Aclarando dudas: Repositorios de LMDE

Como bien publicamos el 21 de Octubre del 2011, hemos decidido crear una sección llamada: Tu opinión cuenta <° Linux, donde publicaremos los correos que algunos usuarios han enviado proponiendo temas de su interés mediante el formulario de contacto.

Pues bien, acaba de nacer otra sección llamada: Aclarando dudas <° Linux, donde le daremos respuesta a algunas de las interrogantes de aquellos usuarios que se acercan a nosotros, con alguna duda en general.

Publicaremos acá las que creamos que deben ser de interés para todos, como es el caso de esta que nos hizo llegar un usuario llamado: Erithrym.

Erithrym escribió:

Hola, he estado siguiendo el blog desde hace unos días, y es muy completo, pero tengo una duda.
Llevo como usuario de LMDE prácticamente desde que salió, pues me parecía mucho más atractivo que Linux Mint, que era la distro que usaba antes. Lo único que no me gusta es que la mayoría de los paquetes están sin actualizar.
Me podrías recomendar una lista de repositorios estable y actualizada?
Es que la última vez que lo intenté con los paquetes de SID, al actualizar el xorg terminé por fastidiar la interfaz gráfica…
Muchas gracias y disculpa por las molestias!
Y ante todo felicidades por este fantástico blog!

<° Linux responde:

Muchas gracias por tus elogios, nos alegra enormemente que nuestro esfuerzo por mantener este blog, sea de utilidad para otros usuarios.

Si bien es una ventaja tener repositorios personalizados en LMDE, al mismo tenemos (como barrera) que depender de las actualizaciones que el equipo de Linux Mint incorpore a los mismos.

Primero que todo, tienes que tener en cuenta que LMDE no usa los repositorios de Sid, sino los de Debian Testing y Debian Squeeze. Se supone, que en los repositorios Incoming, deban estar entrando diariamente paquetes nuevos desde los mirrors de Debian Testing, pero esto no es seguro.

Podrías usar directamente los repositorios de Debian, pero es muy probable que al hacerlo exista algún error de dependencia con los paquetes que incluye LMDE.

Tienes dos opciones: O te arriesgas usando los repositorios de Debian Testing para tener paquetes más actualizados, o esperas pacientemente a que desde los repositorios de LMDE, vayan entrando las actualizaciones. Eres libre de escoger. Te dejo los repositorios de Debian:

deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free


elav

elav: Blog Personal / Twitter / G+ / Usuario de ArchLinux. Informático, melómano, blogger y diseñador web. Administrador y Fundador de DesdeLinux.net.


8 comentarios en “Aclarando dudas: Repositorios de LMDE

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Current ye@r *

  1. Google Chrome 16.0.912.0GNU/Linux x64
    Alejandro Nova

    AFAIK Linux Mint Debian Edition, de acuerdo con su propia documentación, es 100% compatible con Debian Testing. Con lo que no pasa eso es con Ubuntu; LMDE advierte que los repositorios de Ubuntu no funcionarán allí.

    1/8
  2. Gracias por la respuesta! He de decir que pensaba que ya tenía testing, pero al parecer no, ya que después de añadir los repositorios me aparecieron un montón de actualizaciones, aunque me dan ciertos problemas, ya que me obligan a desinstalar paquetes como el mint-meta-common o el mint-meta-debian, que no creo que sea recomendable eliminarlos. Además de esto, antes al actualizar el xorg fastidié la interfaz gráfica, por lo que ahora me da un poco de miedo por si la fastidio de nuevo. No debería darme problemas, no?

    2/8
    • Exacto. Si lo que quieres es mantener tu LMDE funcionando sin problemas, te recomiendo que uses los repositorios de LMDE. Puede que si tengas Testing, pero el de LMDE no el de Debian como tal.

      3/8
      • No me importa tener algún que otro problema mientras tenga solución, de hecho es uno de los motivos por los que me gusta más Linux que Windows, poder enfrentarme a la máquina y aprender a como corregir los errores que pueda tener, pero tampoco quiero causar daños irreversibles y tener que reinstalar el sistema operativo cada dos por tres…
        En el caso de los paquetes que mencioné antes, son relevantes? Porque la actualización de libreoffice también me dice que los elimine…

        4/8
      • Esos paquetes son metapaquetes, que a su vez, pueden (o no) desinstalar otros paquetes. Yo los desinstalé sin problemas mayores.

        5/8
  3. Hola, Elav. Fantástico, me da gusto por las nuevas secciones y por responder a este cuestionamiento en particular: los repositorios de LMDE. Sin embargo (¡y que Courage me perdone!), todavía no soy un usuario experto y no sé qué hacer con los repositorios que aquí pones. Me da miedo tocar eso porque ya he tenido problemas que me obligan a reinsatalar todo desde cero. Bueno, en todo caso, muchas gracias.

    6/8
    • No te preocupes. A ver. Lo repositorios que puse en el post, son los que tienes que usar en caso de que no quieras obtener tus paquetes desde los repos de LMDE y actualizar al ritmo de Debian. O sea, si lo que quieres es que el sistema no se corrompa y siga funcionando como debe (aunque no actualice tan seguido), tienes que usar estos. Si lo que quieres es actualizar constantemente (aunque algún paquete relacionado con LMDE se vaya al diablo) entonces usas los que puse en el post.

      7/8
  4. apt-get -t testing install banshee
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios no han sido creados o han
    sido movidos fuera de Incoming.
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    libc6-dev : Rompe: gcc-4.4 (< 4.4.6-4) pero 4.4.5-8 va a ser instalado
    y me pas con todos los paquetes que quiero instalar de testing.¿Como puedo solucionarlo?,De antemano gracias y saludos

    8/8

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Current ye@r *