Instalar Gimp 2.8 en Debian Testing (Wheezy)

46
10914

Gracias al compa Yoyo podemos instalar Gimp 2.8 guiándonos por el tutorial que podemos encontrar en este enlace. Los pasos son simples:

Instalando las dependencias necesarias:

Abrimos un terminal y ponemos:

$ sudo aptitude install intltool libpng12-dev libglib2.0-dev libatk1.0-dev libpango1.0-dev libfontconfig1-dev libcairo2-dev libgtk2.0-dev libtiff4-dev python-gtk2-dev libatk1.0-dev librsvg2-bin libwebkit-dev librsvg2-2.0-cil-dev libjasper-dev liblcms-dev libexif-dev libwmf-dev python2.7-dev

OJO: Esto nos instalará unas cuantas dependencias de MONO, así que al que no le guste esta tecnología, puede dar por terminado el tutorial 😀

Necesitamos compilar babl y gegl pues la versión que tenemos en los repositorios de Testing es inferior a la que Gimp 2.8 necesita.

Compilando las librerías necesarias:

$ wget ftp://ftp.gtk.org/pub/babl/0.1/babl-0.1.10.tar.bz2
$ tar -xvf babl-0.1.10.tar.bz2
$ cd babl-0.1.10/
$ ./configure
$ make
$ sudo make install

$ wget ftp://ftp.gimp.org/pub/gegl/0.2/gegl-0.2.0.tar.bz2
$ tar -xvf gegl-0.2.0.tar.bz2
$ cd gegl-0.2.0/
$ ./configure
$ make
$ sudo make install

Desinstalamos Gimp 2.6

$ sudo aptitude purge libgimp2.0 gimp gimp-help-en gimp-help-common gimp-data libgimp2.0

Compilamos e instalamos Gimp 2.8

$ wget ftp://ftp.gimp.org/pub/gimp/v2.8/gimp-2.8.0.tar.bz2
$ tar -xvf gimp-2.8.0.tar.bz2
$ cd gimp-2.8.0
$ ./configure
$ make
$ sudo make install

Listo. Debe funcionar, aunque si no inicia Gimp mediante el icono en el menú, podemos solucionarlo de esta forma:

Añadimos en nuestro fichero ~/.bashrc las siguientes líneas:

LD_LIBRARY_PATH=/usr/local/lib
env LD_LIBRARY_PATH="/usr/local/lib" gimp
export LD_LIBRARY_PATH

Aunque honestamente no he probado. La solución me la dio el compa Yoyo y la pueden ver acá.

46 COMENTARIOS

    • ok… creo que ya miro que pasa, cuando hago el paso del gegl-0.2.0 al hacer “make” me tira muchos errores y muchos “saliendo de la carepta fulana” o sea… no sé qué ocurre que no puedo instalar el gegl-0.2.0, dice algo así de que no se puede crear el archivo make o algo muy similar ;^;

  1. elva te recomiendo encarecidamente crear paquetes y no usar el método make && make install porque apt no puede gestionar estas instalaciones, eso de LD_LIBRARY_PATH puedes terminar mareando a tu administrador de paquetes.

    saludos

  2. pandev92, a mi me interesa lo de compilarlo sin las X11, cuando lo tengas te agradecería lo comunicaras , gracias
    y respecto a lo de Courage, no le eches cuentas, sera la envidia de no poder tener un mac ,o me equivoco?

  3. O sea gente, Gimp 2.8 depende en algo de MONO ¿. O se puede entender eso, quizas solo pase esto para compilarlo en testing…

  4. La última vez que intenté instalar una versión de GIMP distinta a la que me ofrecían los repositorios oficiales, me quede sin GIMP. No hubo manera de volver atrás, ni purgar ni nada de nada…. Me quedé sin GIMP hasta mi siguiente reinstalación. En mi LTS no tocaré nada…. que ahí tiene que estar hasta la siguiente LTS. Eso si no tarda demasiado en aparecer como actualización.

      • Técnicamente creo que sí se puede, de hecho creo que elav había logrado instalarlo así … pero, prefiero no hacerlo. Intento mantener mi sistema 100% limpio, sin meteduras de pata o cualquier tipo de bugs o algo así jajaja.

        Para lo que uso Gimp, no me molesta esperar 1 mes más hasta que el 2.8 entre en los repos testing de Debian 🙂

        Saludos

Dejar una respuesta