Solución al problema de instalar aplicaciones de 32 bits en Linux Mint 14 RC 64 bits

Acabo de publicar la noticia de que ya se encuentra disponible Linux Mint 14 RC, y Clem acaba de anunciar que en la versión de 64 bits hay un problema que no permite instalar aplicaciones como Skype, Google Earth o cualquier otro paquete de 32 bits.

La posibilidad de instalar 32-bit aplicaciones en un entorno de 64-bit se denomina comúnmente como “Multiarch”. Al parecer, se produjo un cambio con dpkg en Debian, que hizo que la configuración Multiarch quedara obsoleto en Ubuntu. Pueden ver más información sobre este problema acá: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294

Solución

Para habilitar Multiarch, abra una terminal y escriba los siguientes comandos:

sudo dpkg --add-arquitectura i386
apt update



Este problema se solucionará de forma manual en la versión estable de Linux Mint 14.

12 COMENTARIOS

  1. elav te lo dije, no por eso estaba en Debian sid 😛

    de hecho este problema que presenta mint, Debian sid ya lo presentaba hace como 2 meses, incluso en synaptic dice ahí que antes de instalar ia32-libs y ia32-libs-gtk, recomienda que agregues dpkg –add-architecture:i386 luego correr un update y listo.

  2. @MonitoLinux demasiado trabajo el tuyo. No estoy seguro de encontrarlo en los backports del stable. Pero si te puedo garantizar que en Sid, y muy probablemente a estas alturas en los repos de Wheezy[1] lo encuentres disponible.

    [1] http://www.debian.org/News/2011/20110726b

    El soporte multiarch es algo que viene haciendo ruido hace bastante. Yo choque con el como en Junio y ya venia rodando hacia tiempo.

    • @Willians es que yo vengo de tiempos mas viejos, donde no existian tantos repositorios con las aplicaciones que uno necesitaba, donde uno lo maximo que encontraba era el codigo fuente.

  3. Estoy un poco perdido (vaaale mucho) con esto. Estoy usando Xubuntu 12.10 64Bit (un tiro comparado con ubuntu 12.10 que es leeeento) y mi sorpresa al ir a instalar KompoZer es que no aparecía… al final deduje que como no existía para 64bit no estaba en los repositorios…aunque hasta ahora siempre lo había instalado (con apt-get instal Kompozer) pero en esta ocasión no aparecía. Después de dar muchas vueltas encontré un DeB 64 bit y lo instale. Pero mi duda y por fin llego al asunto. Si instalo esto que comentáis en esta entrada. ¿ aparecerán los paquetes de 32bit en el repositorio para instalar programas de 32bit si no están disponibles los de 64 bit? ¿hubiera aparecido el Kompozer de 32 bit para que lo instalara en los repositorios? ¿es bueno que lo haga para futuros programas que necesite?

Dejar una respuesta