Hoe om Brother-laserdrukkers op Linux op te stel

Die meeste van die huidige GNU / Linux-verspreidings het baie ondersteuning vir die modernste hardeware, maar daar is nog steeds hardewarevervaardigers wat op die een of ander manier verhinder dat ons geliefde bedryfstelsel versoenbaar is met hul oplossing. Gelukkig vir baie is dit nie die geval vir diegene onder ons wat Brother-drukkers gebruik nie, omdat hulle plaaslike bestuurders vir Linux het.

Ek het tans die Brother DCP-L2550DN laserdrukkerDit is nie dat dit 'n wonderlike drukker is nie, maar as ek vinnig afdrukke van goeie gehalte kan maak en voldoen aan die verwagtinge van uitgawes, is dit ook baie maklik om goedkoop Brother TN2410- en TN2420-patrone te koop, dit is die wat hierdie toerusting gebruik. In Linux Mint werk dit redelik goed vir my, hoewel ek 'n bietjie meer as normaal gely het om dit te laat werk, daarom is dit goed om die prosedure te verduidelik wat gebruikers met soortgelyke toerusting moet doen.

Die eerste ding wat gebruikers wat drukkers van hierdie handelsmerk het, moet doen, is om na die broer Linux bestuurders bladsy en die bestuurders vir die spesifieke drukkermodel aflaai, word dit versprei deur die verskeidenheid hardeware wat deur die onderneming versprei word (onder andere CUPS, LPR, Scanner, ADS, laserprinters). Elke kategorie drywers bied ons 'n oplossing vir die produkte wat daarmee verband hou, daarom kan dieselfde bestuurder byvoorbeeld werk vir die Brother DCP-L2510D, Brother HL-L2310D en Brother MFC-L2710DN-drukkers.

Brother bied ons op die bestuurder-bladsy 'n spesifieke handleiding vir gebruik volgens die verspreiding wat ons het, die hardewaremodel en sy argitektuur, op dieselfde manier, dit gee ons die moontlikheid om die korrekte werking van die drukker, die konfigurasie te kan nagaan. die tipe papier of selfs die status van u patrone.

Die proses is oor die algemeen eenvoudig. Ons gaan na die Brother-bestuurdersblad, laai die bestuurder af wat met ons hardeware en ons distro versoenbaar is, en installeer die basispakkette met die volgende opdrag:

sudo apt install brother-cups-wrapper-extrabrother-lpr-drivers-extra

Dan begin ons ons rekenaar weer en installeer die bestuurders, aangesien dit nie op die Brother-ondersteuningsblad aangedui word nie. In sommige gevalle moet ons na die afdeling Stelsels / administrasie / drukkers gaan (soos toepaslik in u distro) en die drukker kies wat u pas geïnstalleer het, op hierdie manier sal ons ons drukker van nature kan gebruik.


Die inhoud van die artikel voldoen aan ons beginsels van redaksionele etiek. Klik op om 'n fout te rapporteer hier.

17 kommentaar, los joune

Laat u kommentaar

Jou e-posadres sal nie gepubliseer word nie. Verpligte velde gemerk met *

*

*

  1. Verantwoordelik vir die data: Miguel Ángel Gatón
  2. Doel van die data: Beheer SPAM, bestuur van kommentaar.
  3. Wettiging: U toestemming
  4. Kommunikasie van die data: Die data sal nie aan derde partye oorgedra word nie, behalwe deur wettige verpligtinge.
  5. Datastoor: databasis aangebied deur Occentus Networks (EU)
  6. Regte: U kan u inligting te alle tye beperk, herstel en verwyder.

  1.   anoniem dijo

    Hi
    Ek gebruik 'n broer DCP 7065dn in manjaro kabouter en die bestuurders is in AUR.
    Hierdie drukkers het gewoonlik drywers in rpm en deb vir archlinux en afgeleides is gewoonlik in AUR en vir gentoo is daar 'n broer-oortrek.
    Groete.

    1.    Akkedis dijo

      effektief

  2.   DKK dijo

    Is die bestuurders gratis sagteware - oopbron?

    1.    Akkedis dijo

      In hierdie geval is dit drywers vir Linux, maar die bronne is ongelukkig nie beskikbaar nie (dit is nie open source nie)

  3.   Barbara dijo

    Volgens wat hulle sê, het Brother ten minste meer steun as Ricoh. Ek het 'n Ricoh multifunksionele SP310spnw wat uitstekend is, maar as u dit op Linux gebruik, gee dit baie hoofpyn, en u kan slegs die drukstuk gebruik. Ondersteuning van Ricoh bestaan ​​feitlik nie, en alhoewel dit kwansuis bestuurders vir Linux het, gee dit 'n fout as u dit wil installeer, want ... CUPS loop !!! Ek het dit al amper 'n jaar gehad, en hoewel ek dadelik 'n e-pos aan Ricoh gestuur het om hulle te vra om 'n manier te vind om geskikte bestuurders te skep, het hulle tot dusver nog nie eens die ontvangs van die e-pos erken nie. Ek moet 'n ander bedryfstelsel gebruik om te kan skandeer.

  4.   alberto dijo

    Ek gebruik 'n baie goedkoop Brother-laser HL-2135W wifi en dit is al jare lank wonderlik op Linux. Baie gelukkig.

  5.   Puigdemont 64 bits dijo

    Die 1210w is geïnstalleer met behulp van die verouderde pkgbuild en verander dit, dit ontbreek 'n paar aanhalings, maar dit werk goed.

  6.   Guille dijo

    Moenie Brother koop nie, koop HP, en ek sal verduidelik waarom: Ja, hulle het bestuurders vir GNU / Linux, maar dit is eie. As hulle na X jaar ophou om hul bestuurders vir die nuwe pitte op te dateer en hulle ophou werk, sal hulle u laat lê en niemand sal die kode kan wysig nie omdat ons dit nie het nie. Op die werk gebruik ons ​​die Brother DCP7065dn.
    Wees ook versigtig met HP, want dit het ook drukkers sonder gratis bestuurders, soos HP LaserJet Pro CP1025nw. Koop slegs diegene wat gratis bestuurders het om toekomstige afpersing te voorkom, om 'n nuwe drukker of 'n nuwe Windows- of Mac OS-lisensie te koop (waarvoor hulle altyd bestuurders het).
    Koop onder geen omstandighede 'n SHARP-drukker nie; ons het die MX 2310U kopieër / drukker: eers die bestuurder-installeerder vir Linux (http://www.sharp.es/cps/rde/xchg/es/hs.xsl/-/html/centro-de-descargas.htm?p=&q=MX-2310U&lang=ES&cat=0&type=1214&type=1215&os=&emu=) het verskillende lêerhernoemingsfoute wat ons dwing om die script aan te raak om dit goed te laat werk, tweedens het ons dit in 'n netwerk wat is ingestel met 'n gebruikerskode vir elke werknemer en dit blyk dat die Linux-bestuurder nêrens die kode kan plaas nie in Windows ja in Job Management - User Authentication - User). Daarom kan ek dit nie van GNU / Linux gebruik nie, en ek het truuks probeer om die PPD-lêer te verander (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/) en probeer selfs die bestuurder wat omgekeerde konstruksie vir kodering gebruik (https://github.com/benzea/cups-sharp).
    Orde van voorkeur: HP met gratis bestuurder, HP met eie bestuurder, broer met eie bestuurder, geensins Sharp nie.

  7.   fernan dijo

    Hi
    Hulle benodig 'n binêre om te werk, byvoorbeeld in die geval van die broer dcp 7065dn, gebruik ek 'n deel van die bestuurder as dit gratis sagteware is, maar 'n broer-binêre wat nie gratis is nie, benodig.
    Groete.

  8.   Guille dijo

    Vermy die koop van drukkers sonder gratis drywers, anders is dit in die hande van die vervaardigingsonderneming dat dit u sal dwing om 'n ander stelsel of 'n ander drukker te koop as dit nie die bestuurder op dieselfde tyd as die bedryfstelsels opdateer nie.
    'N HP met gratis bestuurders is beter, pasop dat daar HP met eie drywers soos die HP LaserJet CP 1025nw is, by Brother het hulle almal 'n eie bestuurder, maar dit bestaan ​​ten minste. Erger nog is die SHARP-kopieër-drukkers waarvan die bestuurder vir GNU / Linux nie opsies het nie, soos om die kode wat aan u toegewys is om op die netwerk af te druk, te plaas, wat die gebruik daarvan van Linux voorkom as die maatskappy die kopieë wat deur elkeen gemaak is, wil beheer. byvoorbeeld die Sharp MX 2310U dat ek nie eers daarin geslaag het om die drukker te laat werk deur die PPD daarvan te wysig nie (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/) of met 'n tru-bestuurder (https://github.com/benzea/cups-sharp).

  9.   Koopa dijo

    Goeie middag. (Dag, nag, ens.) Kan iemand my lei in die installering en instelling van 'n skandeerder vir hierdie netwerkdrukkers? of vertel my waar ek vooraf verteerde inligting kan kry. Waar ek werk, word verskeie multifunksionele modelle gebruik, en die konfigurasie van die drukker is sodra die bestuurders geïnstalleer is eenvoudig, maar soms kan die stelsel (meestal zorin os 9 lite) outomaties sommige skandeerders op die netwerk opspoor, maar ander kere nie. Ek wil graag hê dat iemand my moet vertel hoe ek daardie skandeerder handmatig kan byvoeg (hoe daar opdrag gegee word om die multifunksieskandeerder met 'n sekere IP te herken). Ek het gesoek en die beste wat bereik is, is dat 'n naam van die skandeerder met die ip in die eenvoudige scanlys verskyn, maar niks word geskandeer nie. Dieselfde gebeur my ook met multifunksies van samsung, maar dit verskyn meer gereeld in die enkelvoudige lys as die broers. Dit gebeur met my dat 'n rekenaar die skandeerder opspoor en die een daarna nie; dat hulle in dieselfde netwerk is.

  10.   Nasher_87 (ARG) dijo

    Een vraag, dit is simpel omdat ek dit al uitgevind het, maar ek sal dit vra, weet u of Lexmark-drukkers (Z11 LPT en X75 alles-in-een) korrek in Linux werk? Waarna ek gesoek het, is daar glad niks nie; in Ubuntu 9.10 het die Z11 gewerk, sal dit 'n ou pit sit?
    Groete mense

    PS: hulle kan beledig, ek verdien dit 😉

    1.    Guille dijo

      Probeer dit: installeer Ubuntu 9.10 in virtualbox en probeer van daar af na u drukker te druk. As dit werk, kan u dit op die netwerk van die linux na u linux deel om van u af te druk of saam met u in pdf te druk en die pdfs in 'n gedeelde vouer tussen albei stelsels te druk om dit vanaf Ubuntu 9.10 te kan neem.
      Dit is die probleem met eie drywers, dit gebeur dieselfde in Windows, u het 15 jaar gelede iets gekoop met Windows XP en daar is geen driver vir win7 of 10 nie.
      Moet nooit iets koop met eie bestuurders as daar iets met gratis bestuurders meeding nie, kies goed.

  11.   anoniem dijo

    Dankie vir die inligting, ek wil graag later 'n handleiding maak oor hoe u die broer-drukker via wifi kan verbind ... in my geval is dit die MFC9330CDW. Dankie by voorbaat

  12.   Meneer Paquito dijo

    Ek het 'n Brother HL-L2340DW en verbind dit via WiFi. Daar was geen probleem om die drukker via USB aan te sluit nie, maar dit kon nie deur Wifi werk nie.

    Brother bied u, ten minste vir Ubuntu, iets genaamd Driver Install Tool, wat veronderstel dat die gebruiker alleen (of amper iets moet doen) die nodige drywers is. Die probleem is dat u moet weet hoe om dit te doen. In my geval, nadat ek 'n bietjie by Google rondgeloop het, het ek gesien dat Brother dit hier aan u verduidelik:

    http://support.brother.com/g/b/downloadhowtobranchprint.aspx?c=es&dlid=dlf006893_000&flang=4&lang=es&os=127&prod=dcpj315w_eu_as&type3=625&printable=true

    Die probleem is om te weet wat die hel in die URI moet plaas ... Ek het dus voortgegaan met die soektog in 'n opmerking deur 'n sekere jose1080i in hierdie artikel:

    https://www.pedrocarrasco.org/como-configurar-una-impresora-wifi-en-linux/

    Dit kan nie beter verklaar word nie.

    Groete.

  13.   Wifisme dijo

    Dit werk nie op alle Brother-modelle nie, of hoe? Ek het 'n swart en wit laser en daar is geen manier nie

  14.   Enrique Gallegos dijo

    Ek gebruik Linux Mint 19 Cinnamon 64 bits, ek het die Brother HL-1110 kompakte monochroom laserdrukker gekoop en nadat ek my hart verhit het (dit gaan via USB) in plaas van WiFi, verskyn dit in administrasie en skuif dit selfs, maar dit kom leeg uit, want wat ek moet hê om die «windols» te hê om afdrukke te maak, waar dit goed gaan.