Atraci: Un reproductor de música que usa Youtube

Estaba buscando (solo por curiosidad, aclaro para que no me linchen) alguna aplicación similar a Invenio Carmen para GNU/Linux, cuando en el buscador me aparece un link sobre un reproductor llamado Atraci.

¿Qué es Atraci?

Lo curioso es que el resultado me salta porque Atraci promete ser todo lo contrario a Invenio Carmen, o sea, nada de descargar música en mp3 de forma ilegal ni mucho menos.

Atraci nos ofrece (según su sitio web) más de 60 millones de canciones, y cuando realizamos alguna búsqueda, pues usa iTunes, Last.fm y SoundCloud para devolvernos las portadas de los discos, el título de la canción o los artistas. Una vez que encuentra la canción, el álbum o el artista, Atraci trata de encontrar la mejor combinación en Youtube y transmitir el vídeo con la mayor calidad posible.

Interfaz de Atraci

La apariencia de Atraci es muy simple y bonita. Tiene justo lo necesario, pero de tan minimalista que es carece de opciones para personalizarlo. No uso el decorador de ventanas por defecto (en mi caso KWin) por lo tanto al principio me perdí un poco. Los tres círculos que se encuentran en la parte superior derecha, son los botones de Minimizar/Maximizar/Cerrar.

Como ven en la captura, en el momento de tomar la instantánea no me había cargado ningún elemento en la lista de reproducción. Pero la culpa no es de la aplicación, sino de mi ISP. Al intentar seleccionar un resultado en la búsqueda me salía este error:

Así que evidentemente algo estoy haciendo mal. Atraci necesita Node.js (porque ahora a todo el mundo le ha dado por usarlo), Ruby, Grunt y Compass, por lo que literalmente podemos decir que es un reproductor que funciona con tecnología web.

Cómo instalar Atraci en ArchLinux

El concepto detrás de la aplicación me encanta, y me parece muy inteligente usar YouTube para proveer el banco de canciones disponibles, por lo tanto, solo me queda hacer que funcione Atraci. Por cierto, en ArchLinux se puede instalar de AUR:

$ yaourt -S atraci-bin

Y como no podía ser de otra forma, es multiplataforma, por lo que se puede usar en Windows, Mac y GNU/Linux, en este último con versiones para 32 y 64 bits.


24 comentarios

  1.   Citux dijo

    Llevo usándolo un par de días y va muy bien, en Debian Wheezy. Saludos elav.

    1.    elav dijo

      See, pero ya para Debian no vuelvo por un reproductor 😛

    2.    truenhero dijo

      como lo hago, porque me pide
      $ ./Atraci
      ./Atraci: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15′ not found (required by ./Atraci)

  2.   cris dijo

    solo quisiera un reproductor de jamendo dedicado, que me permitiera descubrir nuevos artistas. Estoy tan enganchado a jamendo que les dedico esto:

    http://www.jamendo.com/es/list/a69922/fiesta-de-la-musica-barranquilla-2009

    1.    elav dijo

      Clementine, Amarok y muchos otros soportan Jamendo.

  3.   XTickXIvanX dijo

    Psss, hater de Ghost y Node.JS (-_-“)
    Buena alternativa a Spotify 😀 (Aunque Spotify nadie me lo quita :3)
    PD: El plugin de Spam es troll con mis comentarios (-.-“) (Revisa los “supuestos” comentarios de spam)

    1.    elav dijo

      Jajaja, que no, que no, que no odio a NodeJS, ni a Ghost XDD

  4.   nano dijo

    Calla calvo, odias todo lo que no sea wordpress, no lo niegues

    1.    elav dijo

      Solo odio a Joomla y a Drupal.

  5.   cnicolas dijo

    Sinceramente creo que un reproductor que necesite Node.js, Ruby, etc para su uso no es una buena idea , soy mas de buscar la musica que me interesa y bajrmela y reproducirla con algo sencillo como puede ser mocp. Sinceramente creo que lo que hace este tipo de reproductores se puede hacer directamente desde el navegador.
    Si, ya se que voy contracorriente.

  6.   AdrianArroyoCalle dijo

    Es imposible odiar a Node.js, simplemente es genial

  7.   Tina Toledo dijo

    Ya la tengo instalada y funcionando en Windows 8.1, ya la tengo instalada y funcionando en MacOSX. Eso fue pan comido… pero aun no puedo instalarla adecuadamente en Linux Mint Qiana. ¿Por qué demonios siempre es más fácil hacerlo en Windows y MacOS y es tan complicado en GNU/Linux? ¿Por qué…? ¡¿Por qué?!

  8.   pandev92 dijo

    Pues a mi en Windows no me reproduce nada :S

  9.   Tina Toledo dijo

    A mí me funciona perfectamente bien en Windows 8.1
    http://i232.photobucket.com/albums/ee1/daytrippergirl/Captura-2.jpg

    Pero no he podido instalarlo en Linux Mint Qiana… 🙁

    1.    neysonv dijo

      falta de costumbre supongo. no hacia falta instalar nada… yo solo descargue, descomprimi y ejecute. ejecutalo por terminal a ver que error te sale y ya te ayudaremos.
      saludos

  10.   mmm dijo

    Hola.
    Probá… esto:

    sudo add-apt-repository ppa:webupd8team/atraci
    sudo apt-get update
    sudo apt-get install atraci

    Saludos

  11.   mmm dijo

    Y no me acuerdo cuál es Qiana pero también encontré esto:

    I’m not able to install it on Mint; “Unable to locate package atraci”

    Most probably because you’re running a Mint version which reached end of life. Only Mint 17 and Mint 13 are still supported.

  12.   eliotime3000 dijo

    @Tina, como @mmm lo describe, eso se deba a un mal enlace de dependencias del programa en sí.

    En caso no te guste la versión de los PPA’s, puedes seguir las instrucciones para terminar de compilar la versión estable de GitHub (es duro, lo sé).

  13.   Citux dijo

    @Tina @mmm pueden bajar la versión que les corresponda, (32-bit,64-bit), descomprimir el paquete, ir al directorio de descompresión y ejecutar Atraci. O en una consola ir al directorio de descompresión y ejecutar ./Atraci si falta alguna dependencia indicará cual.

  14.   Jonas Trinidad dijo

    Atraci es un programa que promete, pero si tienes data limitada como yo, es un problema serio además tiene otros asuntos como la falta de playlist generales algo que spotify si existe, compartir la música, descubrir nueva, ver los que tus amigos están escuchando etc.

    Por ahora me quedo con Spotify y próximamente subiré a premiun son solo 6 dolares, de esta forma contribuir para que otras app lleguen a LINUX y no salga corriendo.

  15.   tester dijo

    Me sale este error en manjaro

    atraci: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory

    1.    Azureus dijo

      Que raro, a mi también me sale lo mismo. Pensé que sería el único. Voy a googlear un poco y te cuento más adelante.

    2.    Azureus dijo

      Hola tester, según lo que leí, se debe a que hay unas cuantas librerías sin instalar, prueba instalando libudev1 y nodejs, en archlinux es de la siguiente forma:
      sudo pacman -S nodejs; yaourt -S libudev1 –noconfirm

      es en una sóla linea y lo más probable es que ya tengas el nodejs instalado, pero es por si las dudas.

    3.    Azureus dijo

      Perdón, me equivoqué, esta es la correcta:
      sudo pacman -S nodejs; yaourt -S libudev.so.0 –noconfirm

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.