Як усталяваць апошні драйвер Radeon у Ubuntu / Mint

Для тых з вас, хто сачыў за апошнімі навінамі Форанікса, напэўна, вы ўжо чулі пра гэта Версія 12.4 вадзіцеляў Каталізатар ад AMD, з'яўляецца апошняя версія што даступна для ўладальнікаў картак Radeon 2000/3000/4000 а як можа быць менш, гэтая версія не падтрымлівае X.org 1.12.

Ubuntu y Мята Па змаўчанні яны пастаўляюцца з бясплатнымі драйверамі, напэўна больш, чым той, хто мае ноўтбук, заўважыў, што тэмпература вышэйшая за ўласны драйвер, а ў некаторых выпадках, як у мяне, ад 15 да 20 градусаў вышэй. Пошук у Phoronix Я выявіў, што гэта сапраўды так, і я не адзін пакутаваў ад гэтай праблемы, таму пачаў даследаваць і вырашыў знайсці рашэнне.

Спачатку мы ўсталёўваем праз гэты PPA, зроблены a Карыстальнік Phoronix, апошняя git xorg-сервер-radeon і ati, апошняя табліца і г.д.

Мы выконваем наступныя дзеянні:

Мы дадаем ppa:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get dist-upgrade

Вэб-сайт PPA: https://launchpad.net/~oibaf/+archive/graphics-drivers

Крок вышэй зроблены ў тым выпадку, калі ў нас ужо ёсць драйверы, якія па змаўчанні пастаўляюцца Ubuntu / Mint, у адваротным выпадку нам прыйдзецца выдаліць драйвер fglrx праз Synaptic.

Пасля гэтага мы ўсталюем пакет vdpau

sudo apt-get install vdpau-va-driver

Каб гэта спрацавала, мы ўсталёўваем пакет libg3dvl-табліца

sudo apt-get install libg3dvl-mesa

Тады мы можам усталяваць плэер

sudo apt-get install mplayer

Мы правяраем паскарэнне mpeg2, хоць у будучыні здаецца, што можна будзе паскорыць больш тыпаў кодэкаў.

Mplayer -vo vdpau archivodevideo

Цяпер змагацца з праблемай перагрэву. Мала хто разглядаў прычыну гэтага і проста скардзіўся на праблему, але ёсць рашэнне, якое можа яе палегчыць, яно называецца профільным, і мы можам выбіраць паміж аўтаматычным, нізкім, сярэднім і высокім, з дапамогай гэтага мы можам кантраляваць энергію нашага GPU. У маім выпадку я пакінуў гэта нізкім.

Sudo echo "low" > /sys/class/drm/card0/device/power_profile

Паколькі змяненне будзе толькі часовым, мы робім наступнае, каб сістэма заўсёды запускалася з нізкай ступені:

sudo nano /etc/rc.local

а ўнутры пішам:

echo "low" > /sys/class/drm/card0/device/power_profile

Зроблена гэта, мы эканомім.

Мы перазагрузіліся, і наша сістэма павінна быць абноўленай і працаваць ідэальна.

Гэта не тое ж самае, што з выкарыстаннем афіцыйнага драйвера ATI, але, па меншай меры, гэты бясплатны драйвер удасканальваецца, і, несумненна, у самы бліжэйшы час мы зможам атрымліваць асалоду ад поўнага паскарэння відэа, адзінае, што сапраўды ідзе не так, гэта ўспышка, я пра яе дрэнна ведаю. таму што, але эй, я буду чакаць паляпшэнняў.


Змест артыкула адпавядае нашым прынцыпам рэдакцыйная этыка. Каб паведаміць пра памылку, націсніце тут.

12 каментарыяў, пакіньце свой

Пакіньце свой каментар

Ваш электронны адрас не будзе апублікаваны.

*

*

  1. Адказны за дадзеныя: Мігель Анхель Гатон
  2. Прызначэнне дадзеных: Кантроль спаму, кіраванне каментарыямі.
  3. Легітымнасць: ваша згода
  4. Перадача дадзеных: Дадзеныя не будуць перададзены трэцім асобам, за выключэннем юрыдычных абавязкаў.
  5. Захоўванне дадзеных: База дадзеных, размешчаная Occentus Networks (ЕС)
  6. Правы: у любы час вы можаце абмежаваць, аднавіць і выдаліць сваю інфармацыю.

  1.   нана сказаў

    Я кідаю гэта, мы эканомім.

    Так, гэта зроблена.

    Ва ўсякім разе, рашэнне даволі добрае, але ў Phoronix таксама кажуць, што драйверы AMD паступова ўдасканальваюцца, што я не лічу прымальным, паколькі астатняя частка спаборніцтваў ужо мае падтрымку OpenCL, OpenGL зусім няшмат, але даволі прасунутую і падтрымку X. org без праблем. Іншае - прыезд Wayland, які будзе падтрымлівацца толькі драйверамі Noveau і іншымі бясплатнымі, што было б добра, калі б Nvidia, AMD і Intel атрымалі задачу падтрымаць Wayland, якую Nvidia катэгарычна адхіліла, але ў доўгатэрміновай перспектыве яна дасць уверх.

    1.    Франчэска сказаў

      Я пакідаю вам граматыку, якая з'яўляецца вашай спецыяльнасцю. Бясплатныя драйверы amd падтрымліваюць ужо шмат што, а іншыя распрацоўваюцца, прымаючы пад увагу, што закрытая падтрымка драйвераў для opencl жудасная, вы не можаце чакаць значна большага ў бясплатным, мы ўбачым, для атрымання дадатковай інфармацыі тут:

      http://www.x.org/wiki/RadeonFeature#VSYNC

    2.    Філон сказаў

      407 дзён без фіксацыі ўдару па слоўніку ... Выпраўце "Рэха" і дайце яму гадзіну ... Гатова.

  2.   рогертукс сказаў

    Ці вы можаце выкарыстоўваць бэта-версію, 12.6.

    1.    Франчэска сказаў

      Бэта-версія 12.6 не падтрымлівае карты да серыі 5000, прынамсі мой Radeon 4650, яны не працуюць.

      1.    вас зразумеў сказаў

        Якая ганьба ... 🙁 Усё менш застаецца адкласці тую, якая ёсць у мяне, з серыі 5000.

        1.    pandev92 сказаў

          Ёсць 5000, якія на самай справе маюць 4000 ядра, я спадзяюся, вы не выпусцілі ніводнага з іх ... xD, я мяркую, у вашага 5000 яшчэ засталося як мінімум два гады.

  3.   Родольфа Алехандра сказаў

    Наколькі я разумею, яны кажуць, што гэты рэліз толькі адзін раз, згодна з тым, што я прачытаў, калі выйдзе новае ядро ​​альбо xorg, гэтыя драйверы не будуць дзейнічаць наогул, здаецца, сорамна, але добра памяняць карту.

  4.   Крыстафер сказаў

    Sudo echo "low"> / sys / class / drm / card0 / device / power_profile

    Ці падыходзіць ён для ўсіх картак і з любым кіроўцам?

    1.    pandev92 сказаў

      Так, для ўсіх, акрамя серыі 7000, памятайце, што пры перазапуску канфігурацыі, калі вы не захаваеце яе ў rc.local

  5.   Жордзі Вердуга сказаў

    Вялікі дзякуй за гэты артыкул, ён дапамог мне атрымаць апошні бясплатны драйвер для майго ATi HD4330. У мяне ўзнікла праблема: відэа на YouTube бачылі няправільныя колеры. У рэшце рэшт, рашэнне было такім жа простым, як выдаленне пакетаў, звязаных з VDPAU, так як здаецца, што ўспышка Youtube прымусіла яго працаваць. Самае смешнае, што іншыя сайты з флэш-відэа, такія як Vimeo, калі колеры выглядалі добра, таму я выказаў здагадку, што гэта не працуе.
    Ну, вось пакеты, якія я выдаліў: vdpau-va-driver і libg3dvl-mesa.
    Цяпер усё ідэальна.

  6.   Кугар сказаў

    Flash дрэнны, таму што версія ubuntu 12.04 мае праблемы з пакетам libvdpau1 на картах Nvidia, і я не здзіўлюся, калі здарыцца нешта падобнае да таго, пра што вы каментуеце ў гэтым пасце: vdpau-va-driver.

    У гэтай спасылцы ўся інфармацыя: http://askubuntu.com/questions/117127/flash-video-appears-blue