Blurtooth una vulnerabilidad de BT que permite a los hackers conectarse a dispositivos cercanos

Blutooth-attack

Una vulnerabilidad recientemente revelada en el estándar inalámbrico Bluetooth podría permitir a los hackers conectarse a dispositivos de forma remota en un área determinada y acceder a las aplicaciones de los usuarios.

La vulnerabilidad, denominada Blurtooth, fue detallada hace pocos días por el organismo de la industria Bluetooth SIG que supervisa el desarrollo del estándar. Y es que bluetooth se encuentra en miles de millones de dispositivos en todo el mundo, desde teléfonos inteligentes hasta dispositivos IoT «Internet de las cosas».

La vulnerabilidad de Blurtooth fue descubierta por investigadores de la EPFL École Polytechnique Fédérale de Lausanne y la Universidad Purdue de Suiza.

En el mundo de la tecnología de consumo, se usa comúnmente para alimentar conexiones de corto alcance para tareas como emparejar auriculares inalámbricos con un teléfono.

Pero Bluetooth también admite la transferencia de datos de mayor alcance a distancias de hasta varios cientos de pies, un alcance que los hackers podrían explotar utilizando Blurtooth para lanzar ataques.

La vulnerabilidad aprovecha una debilidad en la forma en que Bluetooth verifica la seguridad de las conexiones.

Normalmente, un usuario debe aprobar manualmente una solicitud de conexión antes de que su dispositivo se vincule a otro sistema, pero Blurtooth permite eludir esta defensa.

Ya que un hacker o alguna persona con los conocimientos suficientes para explotar la vulnerabilidad  puede configurar un sistema malicioso para hacerse pasar por un dispositivo Bluetooth que el usuario ya había aprobado, como lo pueden ser sus auriculares inalámbricos y obtener acceso a las aplicaciones habilitadas para Bluetooth en la máquina del usuario.

Los ataques de Blurtooth se basan en una función de seguridad Bluetooth incorporada conocida como CTKD. Normalmente, esta función se utiliza para ayudar a cifrar conexiones. Pero un hacker podría explotarlo para poder obtener la clave de autenticación de un dispositivo previamente aprobado, que es lo que hace posible suplantar puntos finales legítimos y, por lo tanto, eludir la necesidad de que el usuario apruebe las conexiones entrantes.

El alcance inalámbrico limitado de Bluetooth reduce la amenaza que representa la vulnerabilidad. Las dos ediciones de la tecnología afectadas, Low Energy y Basic Rate, solo admiten conexiones a distancias de hasta 300 pies aproximadamente. Pero el soporte generalizado para esas dos ediciones de Bluetooth en dispositivos de consumo significa que una gran cantidad de terminales podrían ser potencialmente vulnerables.

El organismo de la industria de Bluetooth SIG declaró que algunos de los dispositivos que utilizan las versiones 4.0 a 5.0 de Bluetooth se ven afectados. La versión 5.2 más reciente, que aún no se ha adoptado ampliamente, aparentemente no es vulnerable, mientras que la versión 5.1 tiene ciertas características integradas que los fabricantes de dispositivos pueden activar para bloquear los ataques de Blurtooth.

En el aviso de seguridad, Bluetooth SIG dijo que está «comunicando ampliamente» los detalles de la vulnerabilidad con los fabricantes de dispositivos para acelerar la respuesta de la industria. El grupo los «anima a integrar rápidamente los parches necesarios». Aún no está claro cuándo estarán disponibles los parches o qué dispositivos los necesitarán.

El Bluetooth SIG publicó el siguiente comunicado el viernes:

Nos gustaría proporcionar algunas aclaraciones sobre la vulnerabilidad BLURtooth. La declaración pública inicial de Bluetooth SIG indicó que la vulnerabilidad podría afectar a los dispositivos que utilizan las versiones 4.0 a 5.0 de la especificación principal de Bluetooth.

Sin embargo, eso ahora se ha corregido para indicar solo las versiones 4.2 y 5.0. Además, la vulnerabilidad BLURtooth no afecta a todos los dispositivos que utilizan estas versiones.

Para estar potencialmente abierto a un ataque, un dispositivo debe admitir tanto BR / EDR como LE simultáneamente, admitir la derivación de claves de transporte cruzado y aprovechar el emparejamiento y las claves derivadas de una manera específica. La solución para este problema se describe en la Especificación básica de Bluetooth 5.1 y posteriores, y Bluetooth SIG ha recomendado a los miembros con productos vulnerables que incorporen este cambio en diseños más antiguos, cuando sea posible.

Finalmente se menciona que los usuarios pueden realizar un seguimiento sobre si su dispositivo ha recibido un parche para los ataques BLURtooth comprobando las notas de la versión del firmware y del sistema operativo para  CVE-2020-15802.


Sé el primero en comentar

Deja tu comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.