Kako instalirati najnoviji Radeon upravljački program u Ubuntu / Mint

Za one koji ste pratili najnovije vijesti u Phoronixu, sigurno ste to već čuli 12.4 verzija vozača katalizator od AMD-a, je najnovija verzija što je dostupno vlasnicima kartica Radeon 2000/3000/4000 a kako bi moglo biti i manje, ova verzija ne podržava X.org 1.12.

Ubuntu y menta Po defaultu dolaze sa besplatnim upravljačkim programima, sigurno je više od onoga koji ima laptop primijetio temperaturu višu od vlasničkog, a u nekim slučajevima poput moje, između 15 i 20 stepeni. Pretraživanje u Phoronix Otkrio sam da je ovo zaista istina i nisam bio jedini koji pati od ovog problema, pa sam počeo istraživati ​​i odlučio pronaći rješenje.

Prvo instaliramo putem ovog AJN-a kojeg je izradio a Korisnik Phoronixa, najnoviji git xorg-server-radeon i ati, najnovija tablica itd.

Slijedimo ove korake:

Dodamo ppa:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get dist-upgrade

Web lokacija AJN: https://launchpad.net/~oibaf/+archive/graphics-drivers

Gornji korak je izveden u slučaju da već imamo upravljačke programe koji dolaze po defaultu Ubuntu / Mint, u suprotnom ćemo morati ukloniti upravljački program fglrx kroz Synaptic.

Nakon toga instalirat ćemo vdpau paket

sudo apt-get install vdpau-va-driver

Da bismo uspjeli, instaliramo paket libg3dvl-table

sudo apt-get install libg3dvl-mesa

Tada možemo instalirati mplayer

sudo apt-get install mplayer

Testiramo ubrzanje za mpeg2, iako se u budućnosti čini da će biti moguće ubrzati više vrsta kodeka.

Mplayer -vo vdpau archivodevideo

Sada da se borimo s problemom pregrijavanja. Rijetki su pogledali razlog za to i jednostavno su se požalili na problem, ali postoji rješenje koje ga može ublažiti, zove se profil, a mi možemo birati između automatskog, niskog, srednjeg i visokog, s tim možemo kontrolirati energiju svog GPU-a. U mom slučaju sam to ostavio nisko.

Sudo echo "low" > /sys/class/drm/card0/device/power_profile

Kako bi promjena bila samo privremena, radimo sljedeće kako bi sistem uvijek počeo sa slabim radom:

sudo nano /etc/rc.local

a unutra pišemo:

echo "low" > /sys/class/drm/card0/device/power_profile

Učinjeno ovo, mi štedimo.

Ponovo smo se pokrenuli i trebali bismo imati svoj sistem ažurnim i koji savršeno funkcionira.

To nije isto kao i korištenje službenog ATI upravljačkog programa, ali barem se ovaj besplatni upravljački program poboljšava i sigurno ćemo u vrlo bliskoj budućnosti moći uživati ​​u potpunom video ubrzanju, jedino što stvarno pođe po zlu je bljesak, ne znam ' Ne znam dobro o tome, jer, ali hej, nastavit ću čekati poboljšanja.


Sadržaj članka pridržava se naših principa urednička etika. Da biste prijavili grešku, kliknite ovdje.

12 komentara, ostavi svoj

Ostavite komentar

Vaša e-mail adresa neće biti objavljena.

*

*

  1. Za podatke odgovoran: Miguel Ángel Gatón
  2. Svrha podataka: Kontrola neželjene pošte, upravljanje komentarima.
  3. Legitimacija: Vaš pristanak
  4. Komunikacija podataka: Podaci se neće dostavljati trećim stranama, osim po zakonskoj obavezi.
  5. Pohrana podataka: Baza podataka koju hostuje Occentus Networks (EU)
  6. Prava: U bilo kojem trenutku možete ograničiti, oporaviti i izbrisati svoje podatke.

  1.   nano rekao je

    Ako bacim ovo, mi štedimo.

    Da dobro, gotovo je.

    U svakom slučaju, rješenje je prilično dobro, ali u Phoronixu također kažu da se AMD upravljački programi postepeno poboljšavaju, što mislim da nije prihvatljivo, jer ostatak konkurencije već ima OpenCL podršku, OpenGL prilično, ali prilično naprednu i podršku X. org bez problema. Druga je kada Wayland stigne, što će podržati samo vozači Noveau i drugi besplatni, što bi bilo dobro kada bi Nvidia, AMD i Intel dobili zadatak da podržavaju Wayland, što je Nvidia kategorički odbila, ali dugoročno će dati gore.

    1.    Francesco rekao je

      Gramatiku prepuštam vama, što je vaša specijalnost. Besplatni upravljački programi za amd već podržavaju mnoge stvari, a druge se razvijaju, uzimajući u obzir da je podrška za zatvoreni upravljački program za opencl užasna, nećemo moći očekivati ​​mnogo više u besplatnom, vidjet ćemo, za više informacija ovdje:

      http://www.x.org/wiki/RadeonFeature#VSYNC

    2.    Flota rekao je

      407 dana bez fiksiranja udarca u rječnik ... Ispravi "Odjek" i daj mu h ... Gotovo.

  2.   rogertux rekao je

    Ili možete koristiti beta verziju, 12.6.

    1.    Francesco rekao je

      Beta 12.6 dolazi bez podrške za kartice prije serije 5000, barem moj Radeon 4650, ne radi.

      1.    sve je u redu rekao je

        Kakva sramota ... 🙁 Sve je manje preostalo da odvojim ovaj koji imam, iz serije 5000.

        1.    pandev92 rekao je

          Postoji nekih 5000 koji zapravo imaju 4000 jezgri, nadam se da niste ispustili nijedno od tih ... xD, pretpostavljam da je vašem 5000 ostalo još najmanje dvije godine.

  3.   rudolph alexander rekao je

    Koliko razumijem, kažu da je ovo izdanje samo jednom, prema onome što sam pročitao, ako izađe novi kernel ili xorg, ovi upravljački programi neće uopće trajati, čini se sramotom, ali dobro je promijeniti karticu.

  4.   Christopher rekao je

    Sudo eho "low"> / sys / class / drm / card0 / device / power_profile

    Da li je pogodan za sve kartice i sa bilo kojim vozačem?

    1.    pandev92 rekao je

      Da, za sve osim za seriju 7000, imajte na umu da kada ponovo pokrenete konfiguraciju, osim ako je ne spremite u rc.local

  5.   Jordi Verdugo rekao je

    Hvala vam puno na ovom članku, pomogao mi je da imam najnoviji besplatni upravljački program za moj ATi HD4330. U čemu sam imao problema: videozapisi na YouTubeu viđeni su u pogrešnim bojama. Na kraju, rješenje je bilo jednostavno poput uklanjanja paketa povezanih s VDPAU-om budući da se čini da je Youtube flash to učinio. Smiješno je što su druge web stranice s flash video snimcima, poput Vimea, ako boje izgledaju dobro pa sam pretpostavio da to ne funkcionira.
    Pa, evo paketa koje sam izbrisao: vdpau-va-driver i libg3dvl-mesa.
    Sada je sve savršeno.

  6.   Qugar rekao je

    Flash je loš jer verzija ubuntu 12.04 ima problema s paketom libvdpau1 na Nvidia karticama i ne bih se iznenadio da se dogodi nešto slično onome što komentirate u ovom postu: vdpau-va-driver.

    Na ovom linku sve informacije: http://askubuntu.com/questions/117127/flash-video-appears-blue

bool(tačno)