Alliberada la nova versio de RPM 4.15, que ja està inclosa en la beta de Fedora 31

Després de gairebé dos anys de desenvolupament, va ser anunciat el llançament de la nova versió de l'administrador de paquets RPM 4.15.0. RPM Package Manager (o RPM, originalment anomenat Red Hat Package Manager, però va esdevenir acrònim recursiu) és una eina d'administració de paquets pensada bàsicament per a GNU / Linux. És capaç d'instal·lar, actualitzar, desinstal·lar, verificar i sol·licitar programes.

El projecte RPM4 és desenvolupat per Red Hat i s'utilitza en distribucions com RHEL (Inclosos projectes derivats de CentOS, Scientific Linux, AsiaLinux, Red Flag Linux, Oracle Linux), Fedora, SUSE, openSUSE, ALT Linux, OpenMandriva, Mageia, PCLinuxOS, Tizen i molts altres.

Anteriorment, un equip de desenvolupament independent desenvolupar el projecte RPM5, que no està directament relacionat amb RPM4 i actualment està abandonat (no s'ha actualitzat des de 2010).

Un paquet RPM pot contenir un conjunt arbitrari d'arxius. La majoria de els arxius RPM són «binary RPM» (O BRPM) que contenen la versió compilada d'algun programari.

També hi ha «source RPM» (o SRPM) que contenen el codi font utilitzat per a construir un paquet binari.

Aquests tenen una etiqueta apropiada a la capçalera de l'arxiu que els distingeix dels RPM normals, el que fa que s'extreguin a / usr / src en la instal·lació.

Els SRPM normalment porten l'extensió d'arxiu «.src.rpm» (.spm en sistemes d'arxius limitats a 3 caràcters d'extensió, per exemple, DOS FAT antigues).

Entre les característiques de RPM estan:

  • Els paquets poden ser xifrats i verificats amb GPG i MD5.
  • Els arxius de codi font (per exemple .tar.gz, .tar.bz2) estan inclosos en SRPMs, possibilitant una verificació posterior.
  • PatchRPMs i DeltaRPMs, que són equivalents a fitxers pegat, poden actualitzar incrementalment els paquets RPM instal·lats.
  • Les dependències poden ser resoltes automàticament pel gestor de paquets.

Novetats de RPM 4.15

En aquesta nova versió de RPM 4.15 Rpmbuild afegeix suport per construir dinàmicament dependències amb la seva inclusió en src.rpm. Es va agregar suport per a la secció "% generate_buildrequires» a l'arxiu d'especificacions, el contingut es tracta com una llista de dependències (BuildRequires) que requereix verificació (si no hi ha dependència, es mostrarà un error).

Una altra de les novetats en aquest llançament és que es va afegir el suport experimental per a operacions que depenen de chroot sense requerir root (Per mitjà d'espais de noms d'usuari) amb la qual cosa es podran realitzar compilacions sense privilegis en entorns chroot.

D'altra banda, s'ha implementat suport del conjunt de paquet de paral·lelització en sistemes de múltiples nuclis. El límit en el nombre de subprocessos s'estableix a través de la macro '% _smp_build_ncpus »i la variable $ RPM_.

També s'ha millorat el suport per a l'arquitectura ARM, A més que s'ha afegit el suport per armv8.

Un altre canvi important és l'addició d'un back-end de base de dades fictici per ajudar a RPM a executar-se en sistemes sense RPMDB com Debian.

Dels altres canvis que es destaquen en l'anunci:

  • Es va agregar l'opció «-scm» per habilitar el mode '% autosetup SCM »
  • Es va agregar la macro incorporada '% {expr: ...} »per a calcular expressions arbitràries (el format"% [expr] »també es va proposar fa uns dies)
  • La codificació UTF-8 es fa servir per defecte per a dades de cadena en encapçalats
  • Es van agregar macros globals% build_cflags,% build_cxxflags,% build_fflags i% build_ldflags amb banderes per al compilador i l'enllaçador
  • Es va agregar la macro '% dnl »(Descartar a la línia següent) per inserir comentaris
  • Els enllaços per Python 3 proporcionen retorns de cadena en forma de seqüències blindades UTF-8 en lloc de dades de bytes.
  • Es proporciona un suport continu per Lua 5.2-5.3, que no requereix definicions de compatibilitat en el codi.
  • Es afegit una nova secció «% patchlist» i «% sourcelist», que es pot utilitzar per afegir els pegats i el codi font d'un simple llistat de noms sense especificar els números de registre (per exemple, en lloc de «Patch0: - popt 1,16-pkgconfig.patch »patchlist secció, podeu especificar%« popt-1.16-pkgconfig.patch »);

Finalment, per als que estiguin interessats a provar les millores d'aquesta nova versió de l'gestor de paquets, han de saber que la beta de Fedora 31 és una de les primeres distros en implementar aquesta nova versio de RPM 4.15.

Si vols conèixer més a l'respecte pots consultar el següent enllaç.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

Sigues el primer a comentar

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.