Brackets 1.1 què hi ha de nou després de passar el temps?

¿Es recorden de Suports? en DesdeLinux li dediquem diversos articles a aquest editor de text de codi obert impulsat per Adobe i la seva Comunitat, i que des d'aquell llavors ha anat evolucionant a poc a poc fins arribar a la versió 1.1 amb moltíssimes millores i característiques .. En aquest article repassarem algunes d'elles, però abans, recordem algunes de les opcions que fan de Suports alguna cosa diferent.

Edició en línia amb Brackets

Brackets CSS Editor

Una de les característiques més interessants de Brackets és al que jo anomeno «Edició en línia», que consisteix a editar les propietats CSS d'una etiqueta HTML ja existent, o crear una nova, des del propi fitxer . Html sense haver d'obrir el fitxer del full d'estils. Només hem de posar el cursor sobre l'etiqueta corresponent i oprimir Ctrl + E.

Visualitzar elements, colors i imatges en Brackets

Brackets_Imatge

Brackets ens permet visualitzar les imatges que enllacem al nostre codi html o el color d'una propietat en el fitxer .css com es veu a la imatge anterior. A més, té l'opció de veure els canvis que anem guardant en el nostre fitxer html en Google Chrome de forma automàtica, sense recarregar la pàgina.

Aquestes van ser algunes de les característiques més interessants de Brackets per aquell temps, però ara arriben de noves.

Vista dividida en Brackets

Suports

Ara podem treballar de forma més còmoda amb dos fitxers a el mateix temps dividint la vista de l'editor tant en forma vertical com horitzontal. Inclou suport per Temes per defecte i ens permet seleccionar la tipografia que fem servir i la mida de la mateixa.

Extensions, moltes extensions en Brackets

Si hi ha alguna cosa en el que ha millorat moltíssim Brackets (gràcies a la Comunitat) és en el llistat d'extensions disponibles, moltes d'elles amb excel·lent qualitat.

Brackets_Extensions

Jo ús algunes molt interessants com són:

  • Embellir: Per embellir el codi JS, CSS i HTML
  • Bootstrap 3 Skeleton: Per crear un html a punt per boostrap.
  • brackets Compari: Una eina DIFF.
  • Llista de tasques: Per tenir una llista de tasques a la mà
  • brackets Git: Una de les meves preferides, em permet gestionar el meu projecte i el seu repositori GIT. Els deixo una captura en la següent imatge.
  • D'altres, moltes altres ..

Brackets_GIT

Brackets i Extract

Amb la versió 1.1 de Brackets tenim l'opció de baixar una variant que inclou Extract, que bàsicament incluye una nueva experiencia de instalación inicial y una característica que le permite colaborar con un diseñador (que use .PSD) y que utilice la nube de Adobe. Realment no puc dir-los com funciona per raons òbvies, però sembla ser una opció bastant interessant.

Conclusions de Brackets

En resum puc dir que en el poc temps que porta de desenvolupament, Brackets està prenent per a mi un important lloc entre les alternatives que tenim a la mà. No és perfecte, encara li falta molt camí per davant (i tant de bo s'executés tan ràpid com Sublim Text), però gràcies a les noves funcionalitats i extensions que es van afegint, resulta ser una excel·lent opció per als frontends.

Potser es em quedin més cosetes per esmentar, però el millor és que ho provin i jutgin vostès mateixos. Brackets està disponible des del seu lloc web amb paquets compilats per a Debian / Ubuntu, o les seves fonts. Si ets usuari de ArchLinux el pots instal·lar directament des AUR.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

23 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   sergio va dir

    Ús brackets des de la versió 0.27 i ah crescut moltíssim tot aquest temps 🙂
    És una roca !! Titan!

  2.   kik1n va dir

    Nadamas ho estic esperant per a Debian Testing 😀

  3.   Tanrax va dir

    Meravellós article.
    És possible moure't amb dreceres vaig veure / vim?

  4.   Rafael Mardojai va dir

    Actualment l'editor amb el qual desenvolupament, des que el vaig trobar és la meva alternativa per defecte xD

  5.   cooper15 va dir

    Realment és un editor impressionant, a mi em té captivat des que ho vaig provar per primera vegada. El recomano. Espero que d'aquí a poc li tregui l'hegemonia a SublimeText.

    1.    Tanrax va dir

      Jo espero que Sublim Text aprengui un parell de coses. Té idees molt interessants.

      1.    ILAV va dir

        Tots dos han d'aprendre ..

  6.   corb291286 va dir

    jo ho estat utilitzant i on pressiones les tecles «Ctrl + I» no m'apareix res, només em diu que el fitxer no existeix que si vull fer un.

  7.   Ariel va dir

    He intentat instal·lar-lo en Antergos (yaourt -S brackets), però lamentablement mai puc acabar la instal·lació de manera correcta. Sempre obtinc el següent error:

    «Running« curl-dir: node-linux64 »(curl-dir) segons les tasques
    Files «downloads / node-v0.10.24-linux-x64.tar.gz» created.

    Running «node-clean» segons les tasques

    Running «node-mac» segons les tasques

    Running «create-project» segons les tasques
    Building project files

    Done, without errors.
    CXX (target) out / Release / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o
    make: g ++: No s'ha trobat el programa
    libcef_dll_wrapper.target.mk:212: fallada en les instruccions per a l'objectiu 'out / Release / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o'
    make: *** [out / Release / obj.target / libcef_dll_wrapper / libcef_dll / transfer_util.o] Error 127
    ==> ERROR: No s'ha pogut a build ().
    Cancel·lant ...
    ==> ERROR: makepkg no ha pogut compilar brackets.
    ==> Reiniciar la compilació de brackets? [S / N]
    ==> ---------------
    ==> »

    Algú sap què pot ser o com puc arreglar per utilitzar Brackets?

    1.    Tanrax va dir

      Si veus que no pots, instal·la a partir d'un deb.
      Sort!

    2.    ILAV va dir

      Jo des AUR sempre instal brackets-bin

      1.    Ariel va dir

        Brackets-bin va funcionar. Gràcies!

    3.    Alejandro va dir

      make: g ++: No s'ha trobat el programa

  8.   Gonzalo va dir

    He provat diversos editors però a al final sempre acabo tornant a Kate. L'edició en línia de l'CSS, la vista prèvia d'imatges o colors són molt pràctiques i sens dubte estalvien temps, però creus que són motius suficients per a passar-se de Kate, que a la fi acaba incorporant gairebé totes les funcions útils que apareixen en altres editors, a Brackets? Sé que la millor resposta la obtindré a l'provar jo mateix, però la veritat és que estic una mica avorrit de provar tal o quin programa per a al final acabar tornant als que porten anys donant-me bons resultats.

    Salutacions.

    1.    ILAV va dir

      L'únic problema que li veig a KATE és que no té autocompletat de codi, etiquetes i altres 🙁

      1.    firefox-user-88 va dir

        Sembla que autocompletat té: http://kate-editor.org/about-kate/

        1.    ILAV va dir

          Doncs per a HTML i CSS mai ho he vist ..

      2.    clow_eriol va dir

        El autocompletat aquest no fa el que demana ILAV. Tan sols et autocompleta si hi ha una paraula que comença igual al llarg de el document.

  9.   Martin va dir

    La primera opció en la qual faig clic 'Vista prèvia dinàmica', només està disponible amb Google Chrome .... -> Desinstal·lant ....

    Que potser hi ha una mania amb Google Chrome ?? se'ls oblida que això és Linux? Netflix, Whatsapp i ara Brackets ...

    1.    ILAV va dir

      Si, així és. El que passa és que aquesta opció és útil només si treballes amb .html, que per a la composició està bé, però quan crees un tema per a WordPress, a l'treballar amb fitxers .php ja no serveix per a res 😀

    2.    blonfu va dir

      En aquesta última versió hi ha suport multinavegador per a la vista en viu però per defecte està desactivada. A l'arxiu de preferències poses això «livedev.multibrowser»: true, jo el faig servir amb firefox i funciona.

      1.    Pepe va dir

        Hola, i com ho afegeixes, perquè jo afegeixo aquest codi i cada vegada que obro el programa em salta un error que: l'arxiu de preferències no té un format JSON vàlid.

  10.   heckctor va dir

    Hola, com és el theme que aquestes usant? aquesta genial 🙂