Com actualitzar Chrome a Ubuntu, Debian i derivats

Divendres passat, vaig topar amb la ingrata sorpresa a la que a l'hora d'actualitzar Google Chrome, el sistema d'actualització m'indicava que li feia falta el repositori per a 32 bits, el qual ja s'havia anunciat des de desembre de l'any passat. No obstant això, aquesta mesura es va fer efectiva el dimarts 3 de març, el qual es va eliminar completament el repositori per a la versió de 32 bits de Google Chrome.

Probablement els hagi aparegut un missatge com aquest:

W: Fallo al obtener http://dl.google.com/linux/chrome/deb/dists/stable/Release No se pudo encontrar la entrada esperada «main/binary-i386/Packages» en el archivo «Release» (entrada incorrecta en «sources.list» o fichero mal formado)

Ara, per als que estiguin usant les versions de 64 bits d'Ubuntu (exactament, des Trusty) i Debian Jessie, d'executar la següent línia d'ordres (si no té configurat el va suar, li suggereixo que l'executi sota ROOT):

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

No obstant això, per a aquelles persones que segueixin fent servir Ubuntu 12.04 (Precise Pangolin) i Debian 7 (Wheezy) independentment de si estan fent servir les versions de 32 i 64 bits, el suport de Google Chrome ha estat completament acabat, de manera que l'única opció que els queda és simplement desinstal·lar el navegador i usar res més ni res menys que la versió de Chromium que hi ha en aquests repositoris, fer servir un altre navegador o simplement actualitzar la distribució respectiva, a més de treure el repositori de Google Chrome.

sudo rm /etc/apt/sources.list.d/google-chrome.list
sudo apt-get remove google-chrome

No obstant això, per a aquells usuaris que encara fan servir la versió de 32 bits de Google Chrome, encara es troba disponible el codi font per compilar i executar al seu distro, o també poder descarregar des del repo de la distro en la qual ha de treballar. Això també inclou les compilacions de 32 bits de Google Chrome US i Google Chrome per a ARM, a més dels derivats de Chroium com Opera.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa aquí.

14 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà.

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   Fulano Mengano va dir

    «No obstant això, per a aquelles persones que segueixin fent servir Ubuntu 12.04 (Precise Pangolin) i Debian 7 (Wheezy) independentment de si estan fent servir les versions de 32 i 64 bits, el suport de Google Chrome ha estat completament acabat»

    No sé Ubuntu. A Debian 7 64 bits si pot seguir usant el repo de google per obtenir les ultimes versions.

    1.    eliotime3000 va dir

      Fe d'errates.

      He oblidat que aquesta advertència era per a la versió de 32 bits de Ubuntu Precise i Debian Wheezy.

    2.    Yomi va dir

      Doncs jo tinc instal·lat Debian Wheezy 64 bits i m'apareix un missatge que diu que Chrome no rebrà més actualitzacions. La versió instal·lada és 49.0.2623.87 (i a el parer és l'última).

  2.   uber Florez va dir

    Gràcias

    Funciono en Ubuntu 15.10 - 64 bits

  3.   enees_e va dir

    Gràcies! Va funcionar a la perfecció en Xubuntu 14.04 de 64.

  4.   José Acosta va dir

    Gràcies !! em va funcionar en Ubuntu 14.04LTS de 64

  5.   José Acosta va dir

    Gràcies !! em va funcionar en Ubuntu 14.04LTS

  6.   Tobias va dir

    Tant me fa, que Google es quedi amb el seu navegadorcillo no em cal, jo ús en Lubuntu 14.04 de 64 bits Firefox i Chomium que són lliures de Spyware ...

    1.    taulell va dir

      Ni tan lliures però estic d'acord, que facin el que vulguin, igual hi ha més opcions.

  7.   Xavi va dir

    Moltes gràcies, estava buscant la solució i no la trobava, quan deixo de buscar-la ... la trobada de casualitat al blog que llegeixo sempre ... aquest! Gràcies.

  8.   NASARA va dir

    Moltes gràcies, crack!
    Va solucionar el problema en Ubuntu Mate 15.10 x64

  9.   Jesús va dir

    Moltes gràcies, corregit en Ubuntu 14.04 x64

  10.   Edgar va dir

    no hi ha esment sobre Ubuntu 16?

  11.   Edgar va dir

    Aquest és el resultat de el test de Phoronix.
    Entenc que estic fent servir una actualització d'Ubuntu per a 64 bits, però si no recordo malament tenia instal·lat el Ubuntu 14-32 bits.
    Com sospiteu són MOLT principiant.
    És possible que s'hagi instal·lat una actualització incorrecta?
    Gràcias