Com actualitzar gstreamer0.10-plugins-bad a LMDE RC 201108

en manteniment

Després de la instal·lació d'LMDE RC 201108 hi va haver un sol paquet que em va donar error a l'hora d'actualitzar-: gstreamer0.10-plugins-bad.

Per sort la solució per a aquest problema és molt senzilla i bastant ràpida. Obrim un terminal i ens logueamos com root o fem servir suo, Com és el cas de LMDE, Amb la següent comanda.

$ Sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

I ens ha de sortir alguna cosa com això:

(Reading database ... 158926 files and directories currently installed.) Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using ... / gstreamer0.10-plugins-bad_0.10.22-3_i386.deb). .. Unpacking replacement gstreamer0.10-plugins-bad ... dpkg: warning: overriding problem because --force enabled: trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10 .0.10.22-plugins-really-bad 0.1-0.10 Setting up gstreamer0.10.22-plugins-bad (3-2.0) ... Processing triggers for libglib0-XNUMX ...

Fet. ja tenim Gstreamer instal·lat i actualitzat 😀

 


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

5 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   Dario Freije va dir

    Moltes gràcies! Va funcionar de 10.
    Es em travava en aquest paquet a l'voler actualitzar i no seguia amb les altres 418 actualitzacions.

    1.    ILAV <° Linux va dir

      M'alegro que t'hagi servit 😀

  2.   aciguembre va dir

    Doncs a mi m'apareix això ....

    (Leyendo la base de datos ... 152219 ficheros o directorios instalados actualmente.)
    Preparando para reemplazar gstreamer0.10-plugins-bad 0.10.22-2 (usando .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
    Desempaquetando el reemplazo de gstreamer0.10-plugins-bad ...
    dpkg-deb (subproceso): datos: error interno de lectura de gzip `: data error'
    dpkg-deb: error: el subproceso devolvió el código de salida de error 2
    dpkg: error al procesar /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--install):
    el subproceso dpkg-deb --fsys-tarfile devolvió el código de salida de error 2
    Procesando disparadores para libglib2.0-0 ...
    Se encontraron errores al procesar:
    /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
    portatil@portatil ~ $

    ¿Puc fer alguna cosa per corregir-ho?
    Gràcies pel vostre bloc. Espero aprendre molt de vosaltres !!

  3.   gat va dir

    Jo instal LMDE 201109 i quan vaig fer la primera actualització em marc un error per paquets trencats llavors actualitzi des terminal amb sudo apt-get update i sudo apt-get dist-upgrade i tot em va anar a la perfecció a la fin usi sudo apt-get - f install després d'uns dies vaig tenir problemes (això va ser culpa meva) i em vaig veure obligat a reinstal·lar quan tracti de fer de nou l'actualizacion em maracaba error amb gstreamer i tracti d'arreglar de moltes maneres i no vaig poder usi suo dpkg -i -force -overwrite i tot i així no em deixo, ja desesperat vaig fer una cosa molt ximple però 'Funciono !, actualitzi desmarcant gstreamer a l'acabar instal el gstreamer i ja no marc error tot i així des de terminal faci servir sudo pat-get -f install, espero això ajudi

  4.   OlimasterX va dir

    Moltes gràcies !!