Com instal·lar els nostres paquets de LMDE en 3 segons

aprofitant el recent article que vaig publicar sobre MintBackup, Els vull mostrar tres formes senzilles de tornar a instal·lar els paquets que utilitzem quan reinstalemos nostre LMDE.

En realitat, menys la primera forma, les altres pots ser utilitzades tant en Debian, Com en Ubuntu.

Instal·lació en 3 segons

De manera gràfica.

Aquesta és la forma que a la majoria li agrada, tot gràfic i sense haver de tocar un terminal. en LMDE y Linux Mint, Hi ha una fabulosa eina anomenada MintBackup, La qual entre altres coses, la podem utilitzar per salvar els nostres paquets i posteriorment, tornar-los a instal·lar.

En el cas de LMDE, Si actualitzem el paquet python-apt a la versió 0.8.0, no podrem fer servir MintBackup causa d'un problema de dependència. Ens retornarà el següent error:

Traceback (most recent call last):
File "/usr/lib/linuxmint/mintBackup/mintBackup.py", line 87, in <module>
class MessageDialog(apt.FetchProgress):
AttributeError: 'module' object has no attribute 'FetchProgress'

Esperem que els nois de Menta ho arreglin aviat.

Mitjançant el terminal.

Mitjançant la consola podem fer-ho de 2 formes, que a la fi, ve sent el mateix.

En 2 passos.

dpkg --get-selections | awk '$2 ~ /^install$/ {print $1}' > lista_de_paquetes.txt

Un cop tenim accés als repositoris i tot és i actualitzat, només hem de posar això:

cat lista_de_paquetes.txt | xargs sudo aptitude install -y

En 3 passos.

dpkg --get-selections "*" > /home/user/Desktop/lista_de_paquetes.txt

Després de reinstal·lar executem això:

dpkg --set-selections  < /home/user/Desktop/lista_de_paquetes.txt

I després executem:

apt-get -u dselect-upgrade

Crec que és innecessari aclarir que hem de tenir els repositoris configurats correctament .. Senzill veritat?


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

8 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   Valor va dir

    O també t'apuntes en un paper tots els programes que tenies abans i fas

    sudo apt-get -i Insall todoslospaquetesquehasborrado

    Realment no sé si LMDE té el mateix objectiu que el Linux Mint, ser out of the box

    1.    Valor va dir

      * install

  2.   Hokaset va dir

    Encara que sigui una mica «off-topic», volia avisar que han sortit les release candidate a Linux Mint Debian 201108 per a GNOME i XFCE. Espero que s'hagin fet bastants millores ... 🙂

    1.    ILAV <° Linux va dir

      Doncs si, el que passa que quan es va publicar aquesta excel·lent notícia, estàvem fora de línia .. Gràcies.

  3.   mitcoes va dir

    Et acabo de descobrir i GRÀCIES.
    Ahir em vaig instal·lar la LMDE 64 bits, i em vaig apanyant bé, però em falten 2 cosetes per descobrir-

    1- Logearme com a root en mode gràfic

    2.- Posar VLC com reporductor de vídeo per defecte

    Crec que ho aconseguiria des del panell de control aplicacions preferides o obrint amb una altra aplicació / utilitzar aquesta aplicació per defecte. Loguejat com a root.

    He fet sudo nautilus per si de cas i res de res.

    PS1: En 64 bits si que funciona bé el abckup dels paquets.
    PS2: També em falta instal·lar MAME SDL i el recent wine64 de què m'agradaria que existís un ppa, perquè configurant programes després no se't actalizan automàticament.
    PS3: Estic usant el controlador AMD beta AMD_Catalyst_Preview_driver_OpenGL_4.2_beta_support_8.88.8-x86.x86_64.run, Cocoon, https://getcocoon.com/, Per veure sèries geolocalitzades a Firefox, Chrome - que té el seu què instal·lar--, Flash aid de firefox amb el Flash de 64bits, Zindus, Qbittorrent, Opera, l'extensió aletras.oxt i el receinte script per controlar l'excés de RAM memòria cau de el atareao que mereix també un comentari de la teva part.

    Espero amb ansietat la cinquena part de l'tutorial amb aquestes i / o altres suggeriments

  4.   COMECÓ va dir

    ¡Hola!
    Una cosa, caldria canviar el primer enllaç que mana a l'article d'MintBackup per aquest: https://blog.desdelinux.net/mintbackup-realiza-un-respaldo-de-tus-paquetes/
    No sé per què, enllaça a un subdirectori «/ wp-content / themes» ...

    1.    KZKG ^ Gaara va dir

      A punt, corregit 😉

  5.   Nahum va dir

    Hola, des de la versió anterior d'LMDE amd64 he tingut problemes amb paquets trencats i errors a l'carregar repositoris, he provat moltes solucions i cap funciona ... Ja no sé que fer, vaig voler instal·lar Gnome-shell i no em va deixar perquè el paquet està trencat. Vaig veure com resoldre el dels paquets trencats amb ordres com: sudo dpkg -purge -force-remove-reinstreq

    i em surt el següent error:

    dpkg: error: -purge necessita al menys un nom de paquet com a paràmetre

    Escriu dpkg -help per a ajuda sobre instal·lar i desinstal·lar paquets [*];
    Utilitza `dselect 'o` aptitude' per a una gestió més amigable dels paquets;
    Escriu dpkg -Dhelp per a una llista dels valors de depuració de dpkg;
    Escriu dpkg -force-help per a una llista de les opcions per forçar coses;
    Escriu dpkg-deb -help per obtenir ajuda sobre manipulació d'arxius .deb;

    Les opcions marcades amb [*] produeixen una sortida extensa,
    ¡Fíltrela amb `less 'o amb` more'!

    si em pot ajudar algú amb això 🙂