Instal·lar Gimp 2.8 a Debian Testing (Wheezy)

Gràcies a l'compa yoyo podem instal·lar Gimp 2.8 guiant-nos pel tutorial que podem trobar en aquest enllaç. Els passos són simples:

Instal·lant les dependències necessàries:

Obrim un terminal i posem:

$ sudo aptitude install intltool libpng12-dev libglib2.0-dev libatk1.0-dev libpango1.0-dev libfontconfig1-dev libcairo2-dev libgtk2.0-dev libtiff4-dev python-gtk2-dev libatk1.0-dev librsvg2-bin libwebkit-dev librsvg2-2.0-cil-dev libjasper-dev liblcms-dev libexif-dev libwmf-dev python2.7-dev

ULL: Això ens instal·larà unes quantes dependències de MONO, així que a qui no li agradi aquesta tecnologia, pot donar per acabat el tutorial 😀

necessitem compilar babl i GEGL doncs la versió que tenim en els repositoris de Proves és inferior a la que Gimp 2.8 necessita.

Compilant les llibreries necessàries:

$ wget ftp://ftp.gtk.org/pub/babl/0.1/babl-0.1.10.tar.bz2
$ tar -xvf babl-0.1.10.tar.bz2
$ cd babl-0.1.10/
$ ./configure
$ make
$ sudo make install

$ wget ftp://ftp.gimp.org/pub/gegl/0.2/gegl-0.2.0.tar.bz2
$ tar -xvf gegl-0.2.0.tar.bz2
$ cd gegl-0.2.0/
$ ./configure
$ make
$ sudo make install

Desinstalamos Gimp 2.6

$ sudo aptitude purge libgimp2.0 gimp gimp-help-en gimp-help-common gimp-data libgimp2.0

Compilem i instal·lem Gimp 2.8

$ wget ftp://ftp.gimp.org/pub/gimp/v2.8/gimp-2.8.0.tar.bz2
$ tar -xvf gimp-2.8.0.tar.bz2
$ cd gimp-2.8.0
$ ./configure
$ make
$ sudo make install

Fet. Ha de funcionar, tot i que si no inicia Gimp mitjançant la icona al menú, podem solucionar-ho de aquesta forma:

Afegim al nostre fitxer ~ / .bashrc les següents línies:

LD_LIBRARY_PATH=/usr/local/lib
env LD_LIBRARY_PATH="/usr/local/lib" gimp
export LD_LIBRARY_PATH

Encara que honestament no he provat. La solució me la va donar el compa yoyo i la poden veure aquí.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

46 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   leodelacruz va dir

    Ho estic fent servir, amb nou splash i a la fi a la manera finestra única! 😀

  2.   Giskard va dir

    Les millores es veuen espectaculars, però esperaré a l'PPA. A l'igual que el nou XFCE 4.10
    ????

  3.   Alba va dir

    Jo tinc un problema

    «Dimentio gimp-2.8.0 # make
    make: *** No es va especificar cap objectiu i no es va trobar cap makefile. Alt. »

    ; A;

    1.    Alba va dir

      ok ... crec que ja miro que passa, quan faig el pas de l'GEGL-0.2.0 a l'fer «make» em tira molts errors i molts «sortint de la carepta fulana» o sigui ... no sé què passa que no puc instal·lar el GEGL -0.2.0, diu alguna cosa així que no es pot crear el fitxer make o alguna cosa molt semblant; ^;

  4.   correcte va dir

    elva et recomano encaridament crear paquets i no fer servir el mètode make && make install perquè apt no pot gestionar aquestes instal·lacions, això de LD_LIBRARY_PATH pots acabar marejant al teu administrador de paquets.

    salutacions

    1.    Valor va dir

      jajajaja Elva jajajajaja

  5.   rogertux va dir

    Ja està en els repositoris d'Arch !!

    1.    KZKG ^ Gaara va dir

      Déu me forces per evitar la temptació de tornar a Arch .. LOL !!!

      1.    sieg84 va dir

        Una partició a part d'alguns 10-15GB i ja tens fitxers sense treure debian? Perquè no fer-ho?

        1.    pandev92 va dir

          Per instal·lar un paquet em sembla una ximpleria ...

  6.   lucasmatias va dir

    Que alleujament la modalitat de finestra única, en Unity es em re complicava amb la versió 2.6

  7.   yoyo Fernández va dir

    Patinant lliure a full en el meu Debian testing KDE 4.7.4

    Cal comentar que la solució ~ / .bashrc perquè Gimp arrencada des de la seva icona funciona perfectament 😉

    una salutació

  8.   pandev92 va dir

    Estic intentant compilar en osx sense x11, us diré el resultat en unes hores.

      1.    pandev92 va dir

        A vegades crec que ets més gilipolles del que aparentes xd

        1.    Valor va dir

          És que mira que dir coses de Mac per aquí ... Només se t'ocorre a tu.

          1.    pandev92 va dir

            però parlava de gimp xd

        2.    KZKG ^ Gaara va dir

          ¬_¬ ... sense ofendre, no ho repetiré.

          1.    Valor va dir

            No em molesta

  9.   yoyo Fernández va dir

    No entenc aquesta guerra eterna de sistemes ....

    Doncs ara jo vaig a postejar des del meu Mac perquè surti reflectit en el user agent, ala !!!

    Respectem i serem respectats 😉

    1.    pandev92 va dir

      Seeeee xD

      1.    yoyo Fernández va dir

        pandev92

        Jo et suport, compare, els linuxeros Maqueros, que també els havem, hem d'estar units 😉

    2.    sieg84 va dir

      I Have a Dream ...

  10.   keopety va dir

    pandev92, a mi m'interessa el de compilar sense les X11, quan el tinguis et agrairia ho comuniquessis, gràcies
    i pel que fa al de Courage, no li tiris comptes, serà l'enveja de no poder tenir un mac, o m'equivoco?

    1.    pandev92 va dir

      Ok keopety, avui ho he intentat però per una dependència no vaig poder, estic parlant amb els desolladores a veure que em diuen, ja us diré.
      Per gimp 2.6 hi ha el paquet precompiladohttp: //sourceforge.net/projects/gimp-app/files/gimp-app/

      sense x11 naturalment.

      1.    keopety va dir

        Ok, gràcies, estaré atent.
        una salutació

      2.    Valor va dir

        Aquest problema li teniu uns quants, i cal esperar que s'inclogui de forma oficial en algunes distros i en altres espereu una mica

    2.    Valor va dir

      vaig tenir XNUMX

  11.   opensanctux va dir

    Gimp 2.8 Per a què serveix?

    1.    Valor va dir

      Després algú et dirà i passarà com en l'altre post

      1.    opensanctux va dir

        debatre una mica, sanament, només això:)

    2.    keopety va dir

      Aquestes de conya, no?

      1.    opensanctux va dir

        no. òbviament es que és gimp i la pregunta és molt textual, vull saber que aplicacions se li poden donar a gimp.

          1.    opensantux va dir

            ... el més que vaig poder veure va ser, passar de novell a professional usant gimp. Cap que àrea professional cobreix.

            I compilar ??? doncs no, el vaig veure per encimita i renunciï a part que no tinc molt temps lliure, em vaig anar per l'opció fàcil, instal el fedora 17 beta i el descarregueu dels repositores.

            Ara probandolo puc dir amb honestedat que és molt estable, no sé si té suport gpu però maneja molt bé imatges grans. El que té fet aquesta «ben feta» i correctament organitzat millor que krita (que pateix de la tragèdia organitzativa de kde) i van millorar moltíssim el maneig de la color, perquè la 2.6 era molt dolent. I un interessant sistema de selecció de capes que és un dels punts forts de Photoshop.

            Usos amateur i principiant és ampli, retoc de fotografies convencionals, foto-muntatges, disseny gràfic, il·lustració ...

            El professional; Disseny web, mitjans digitals (vídeo, multimèdia) o utilitzant aplicacions externes per a la conversió d'arxius ... Es limita per la manca de suports superiors, la manca de perfils de colors CMYK per a impremta, i paletes de colors per a il·lustració, etc ...

            En resum, encara li falta molt per ser una opció professional.

          2.    opensantux va dir

            ¿Amic meu? jajaja ... NO! Més aviat m'ha vetat alguns comentaris per no estar deacuerdo amb el o per no dir-li que és un amargat ... en fi.

            El que s'ha dit, per a web molt bé, per a impremta no és funcional, ningú va a calibrar una pc per arriscar-se a exportar amb un connector.

            El que Krita és superior, crec jo que això no es discuteix, però té les seves cosetes estranyes.

          3.    Windóusico va dir

            Així que aquest tipus censura comentaris, ... Doncs no m'estranya. Com et vaig contestar l'altre dia, necessita prendre més fibra.

  12.   alunado va dir

    O sigui gent, Gimp 2.8 depèn en alguna cosa de MONO ¿. O es pot entendre això, potser només passi això per compilar a testing ...

  13.   solidus_00 va dir

    ja ho havia instal·lat amb un altre mètode però no va sortir la finestra única, a veure si amb aquest mètode ja hala bé 😀 gràcies

    1.    Litos523 va dir

      Per defecte, s'inicia en la manera tradicional multifinestra.
      Has d'anar a l'menu «Finestres» i activar l'opció de finestra única.

  14.   Jose va dir

    L'última vegada que vaig intentar instal·lar una versió de GIMP diferent de la que m'oferien els repositoris oficials, em quedi sense GIMP. No hi va haver manera de tornar enrere, ni purgar ni res de res .... Em vaig quedar sense GIMP fins al meu següent reinstal·lació. En la meva LTS no tocaré res .... que aquí ha d'estar fins a la següent LTS. Això si no triga gaire a aparèixer com a actualització.

    1.    KZKG ^ Gaara va dir

      JAJAJA similar em passa. Ús Debian (Testing) i ... puc esperar per Gimp 2.8 el que faci falta, no tinc tanta dificultat com per compilar jo mateix 🙂

      1.    comentarista va dir

        Podries utilitzar un ppa per provar?

        1.    KZKG ^ Gaara va dir

          Tècnicament crec que sí es pot, de fet crec que ILAV havia aconseguit instal·lar-lo així ... però, prefereixo no fer-ho. Intento mantenir el meu sistema 100% net, sense ficades de pota o qualsevol tipus de bugs o alguna cosa així jajaja.

          Per al que ús Gimp, no em molesta esperar 1 mes més fins que el 2.8 entri en els repos testing de Debian 🙂

          Salutacions

  15.   David Pineda va dir

    Cal instal·lar les libabl devel per poder compilar bé les GEGL