Solució a el problema d'instal·lar aplicacions de 32 bits a Linux Mint 14 RC 64 bits

Acabo de publicar la notícia que ja es troba disponible Linux Mint 14 RC, I Clem acaba d'anunciar que en la versió de 64 bits hi ha un problema que no permet instal·lar aplicacions com Skype, Google Earth o qualsevol altre paquet de 32 bits.

La possibilitat d'instal·lar 32 bits aplicacions en un entorn de 64 bits s'anomena comunament com «Multiarch». A l'sembla, es va produir un canvi amb dpkg a Debian, Que va fer que la configuració Multiarch quedés obsolet en Ubuntu. Podeu veure més informació sobre aquest problema aquí: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294

Solució

Per habilitar Multiarch, obriu un terminal i escriviu les ordres següents:

sudo dpkg --add-arquitectura i386
apt update

Aquest problema se solucionarà de forma manual a la versió estable de Linux Mint 14.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

12 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   willians va dir

    @MonitoLinux massa feina el teu. No estic segur de trobar en els backports de l'stable. Però si et puc garantir que en Sid, i molt probablement a hores d'ara en els repos de Wheezy [1] el trobis disponible.

    [1] http://www.debian.org/News/2011/20110726b

    El suport multiarch és una cosa que ve fent soroll fa bastant. Jo xoc amb el com al juny i ja venia rodant cap a temps.

    1.    monitolinux va dir

      @Willians és que jo vinc de temps mes vells, on no existien tants repositoris amb les aplicacions que un necessitava, on un ho màxim que trobava era el codi font.

  2.   RafaGCG va dir

    Estic una mica perdut (vaaale molt) amb això. Estic usant Xubuntu 12.10 64 bits (un tret comparat amb ubuntu 12.10 que és leeeento) i la meva sorpresa a l'anar a instal·lar KompoZer és que no apareixia ... a al final vaig deduir que com no existia per 64 bits no estava en els repositoris ... encara que fins ara sempre ho havia instal·lat (amb apt-get instal Kompozer) però en aquesta ocasió no apareixia. Després de donar moltes voltes vaig trobar un DCB 64 bit i l'instal. Però el meu dubte i per fi arribo a l'assumpte. Si instal·lo això que comenteu en aquesta entrada. ¿Apareixeran els paquets de 32bit al repositori per a instal·lar programes de 32bit si no estan disponibles els de 64 bits? ¿Hagués aparegut el Kompozer de 32 bit perquè ho instal·lés en els repositoris? ¿És bo que ho faci per a futurs programes que necessiti?

  3.   Garbage_Killer va dir

    ILAV t'ho vaig dir, no per això era a Debian sid 😛

    de fet aquest problema que presenta mint, Debian sid ja ho presentava fa com 2 mesos, fins i tot en synaptic diu aquí que abans d'instal·lar ia32-libs i ia32-libs-gtk, recomana que hi afegiu dpkg -add-architecture: i386 després córrer una update i llest.

    1.    ILAV va dir

      ¿Quan m'ho vas dir? No em acord 😛

      1.    Garbage_Killer va dir

        precisament fa 2 mesos, quan tenia un problema similar però era perquè el paquet ia32-libs-gtk era l'obsolet, i encara no sortia per completar el ia32-libs nou, fins recordo que vas dir i perquè vaig afegir dpkg -add- architecture: i386 😛

        1.    ILAV va dir

          Jajaja això va ser via IRC no?

  4.   MonitoLinux va dir

    la solucio és descarregar el codigofuente i compilar, després generar el paquet deb i darselo a la comunitat

  5.   Sergio Esaú Arámbula Durán va dir

    genial 🙂

  6.   Fem servir Linux va dir

    Molt bo! Interessant ...
    Esperem que solucionin el problema abans que surti la versió final.
    Salutacions! Pau.

  7.   mfcollf77 va dir

    Jo vaig instal·lar linux mint 14 64 bits i no vaig tenir problema instal·lar a Skype sol que es va instal·lar la versió 4.0

    Veuré en què més tinc problema