Anem a conèixer a Synaptic en LMDE <° Linux

Una de les preguntes més freqüents entre els usuaris que s'inicien en GNU / Linux, És com instal·lar o desinstal·lar programes i quin tipus de paquets es poden instal·lar. Els mostrarem una de les vies més fàcils per fer aquesta tasca, usant Sinàptica, Ia més, li comptarem breument que és i com podem usar-lo.

normalment en Windows, Per a instal·lar un programa s'executa un fitxer amb extensió .exe i només hem de fer servir el Següent »Següent amb un que un altre número de sèrie i per al procés invers (desinstal·lar), anem a l' Panell de Control »Afegir / Treure Programes.

En el cas de GNU / Linux, També hi ha el que podríem anomenar els nostres .exe però clar, tenen un altre nom i estructura. En general, la major part dels paquets en GNU / Linux es troben allotjats en repositoris, i s'utilitzen diverses eines per gestionar-los. Potser els més populars o coneguts siguin els .deb i als .rpm i tots dos poden ser gestionats mitjançant Sinàptica, El qual inicialment era una interfície per APT.

Synaptic: Interfície per APT

El treball amb Sinàptica és ben senzill. La interfície no és complicada i rarament, un usuari nou ha de fer servir o modificar totes les seves opcions. En general, com ve per defecte, es poden realitzar les tasques més comunes.

Sinàptica ve sent com el Afegir / Treure Programes de Windows. Per al seu funcionament, hem de tenir configurats (en el cas de Debian i els seus derivats) les rutes cap als repositoris on es troben els paquets a instal·lar, en el fitxer / Etc / apt / sources.list. D'aquest fitxer, Sinàptica obté la ruta necessària per poder accedir als paquets.

Coneixent la interfície.

És bo afegir que la interfície de Sinàptica en Linux Mint, És diferent de la de Debian. Per algun motiu en Linux Mint, No s'inclou el botó de Marca totes les actualitzacions. Però tornem a la interfície.

A la part superior tenim la Barra de Menús de la qual veurem algunes opcions posteriorment. Una mica més avall, els següents botons:

  • recarregar: Actualitza el llistat de paquets.
  • aplicar: Quan vam marcar algun paquet per instal·lar o desinstal·lar, fem servir aquest botó per aplicar el canvi.
  • propietats: Mostra les característiques de l'paquet, la seva descripció i dependències.
  • Cercar: Ens desplega una diàleg amb diverses opcions per fer cerques de paquets segons certs paràmetres.

Botons d'accés ràpid

Més avall tenim la interfície divideixi en dues columnes. A l'esquerra es mostren les opcions segons la secció que seleccionem. Tant si es diu secció als botons: Seccions, Estat, Origen, Filtres i Resultats de la cerca.

  • seccions: Mostra els paquets organitzats per categories. Si volem buscar un paquet relacionat amb el Entorn d'escriptori GNOME, Per exemple, només hem d'anar a la secció Gnome.
  • Estat: En aquest apartat trobarem quins són els paquets actualitzables, obsolets, instal·lats o residuals.
  • Origen: Mostra l'origen (repositoris) dels paquets. O sigui, d'on provenen.
  • filtres: En aquest apartat es pot aplicar certs filtres per a obtindre diversos tipus d'informació. És important conèixer que els paquets trencats apareixen aqui.
  • Resultats de la cerca: Precisament el que fa és com indica el seu nom, mostrar els resultats de les recerques en Sinàptica.

Seccions de Synaptic

De l'altra banda tenim el llistat de paquets que podem instal·lar mitjançant Synaptic. Si fem seleccionem qualsevol d'ells i fem clic dret, podrem escollir certes opcions com poden ser:

  • Desmarcar: Desmarca el paquet si ho hem seleccionat prèviament.
  • Marcar per instal·lar: Marca el paquet per instal·lar-lo.
  • Marcar per reinstal·lar: Doncs això, selecciona i reinstal·la el paquet.
  • Marcar per actualitzar: Si el paquet disposa d'una actualització, el seleccionem amb aquesta opció.
  • Marcar per eliminar: Elimina només el paquet seleccionat.
  • Marcar per eliminar completament: Elimina el paquet seleccionat amb les seves dependències recomanades. Les depencias suggerides passen a configuració residual.
  • propietats: Fa el mateix que el botó a la part superior.
  • Marcar recomanats per a instal·lació: Selecciona les dependències recomanades de el paquet a instal·lar.
  • Marcar suggerits per a instal·lació: Selecciona les dependències suggerides de el paquet a instal·lar.

Llistat de paquets disponibles

Altres opcions.

Coneixent això ja podem treballar amb Sinàptica, Però podem fer altres coses, com ara canviar les fonts dels repositoris. Una cosa útil si els mirrors que fem servir estan lents o caiguts. Per a això anem a Configuració »Repositori.

A la finestra d'opcions que ens surt només necessitem conèixer 3 pestanyes per poder gestionar els nostres dipòsits. A la primera, ens surten les branques que fem servir en Linux Mint (Main, Upstream, Import, Backport i Romeo). Amb només marcar / desmarcar s'edita el fitxer / Etc / apt / sources.list.

Orígens de l'Programari

En la segona pestanya incloem els repositoris que no són de Menta, És a dir, els Paquets de Tercers com Debian, els PPA de Ubuntu o qualsevol font compatible amb LMDE.

Programari de Tercers

I en la tercera pestanya, podem actives les actualitzacions automàtiques i cada que temps volem que s'executin.

actualitzacions automàtiques

Encara més?

Si ho necessites, Sinàptica també té per establir el Servidor intermediari de la xarxa i les Distribució que volem fer servir per defecte. Per a això anem a Configuració »Preferències.

Per explicar una mica això de la Distribució, Si ens fixem en el fitxer / Etc / apt / sources.list, Tenim dues distribucions per a usar (fixin-se en el text a color):

deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian les proves main contrib non-free
deb http://security.debian.org/ les proves/ Updates main contrib non-free
deb http://www.debian-multimedia.org les proves main non-free

Per defecte, Sinàptica sempre pren la distribució més alta, el que significa que, si entra el paquet Pidgin 2.8 en els repos de Mint (debian) i la versió 2.9 en Debian (les proves), El programa ens va a suggerir instal·lar la versió 2.9.

És clar, això es pot canviar si escollim manualment la distribució que volguem fer servir amb l'opció: Preferir versions de:

escollir distribució
I bé, si fem servir un servidor intermediari per connectar-nos per http, ja que també tenim l'opció de ho manualment:

Servidor intermediari de la xarxa

Hi ha altres eines per manejar els nostres paquets, actualitzar-los i instal·lar-los. Ubuntu per exemple, ara inclou el seu Centre de Programari i LMDE té un de molt similar, però de certa forma Sinàptica és més complet.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

2 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   Jonathan va dir

    Moltes gràcies, la veritat és que estic recent començant amb linux i aquesta eina és vital. És bo conèixer-la millor

  2.   Esborrar va dir

    Necessito saber com evitar que el Linux mint 17 Quiana intenti actualitzar els repo des del seu lloc oficial
    I inclòs en el meu sources.list una nova adreça d'actualizacion ja provada en Ubuntu 14.04 i compatible amb Mint però a l'(apt-get update) es mostra el següent:

    Err http://ubuntu.mes.edu.cu trusty-proposed InRelease

    Err http://packages.linuxmint.com qiana InRelease

    Err http://archive.ubuntu.com trusty InRelease

    Err http://archive.ubuntu.com trusty-updates InRelease

    Err http://security.ubuntu.com trusty-security InRelease

    Err http://ubuntu.mes.edu.cu trusty-security InRelease

    Err http://ubuntu.mes.edu.cu trusty-updates InRelease

    Err http://ubuntu.mes.edu.cu trusty InRelease

    Err http://archive.ubuntu.com trusty Release.gpg
    No s'ha pogut resoldre «archive.ubuntu.com»
    Err http://security.ubuntu.com trusty-security Release.gpg
    No s'ha pogut resoldre «security.ubuntu.com»
    Err http://ubuntu.mes.edu.cu trusty-proposed Release.gpg
    No s'ha pogut resoldre «ubuntu.mes.edu.cu»
    Err http://packages.linuxmint.com qiana Release.gpg
    No s'ha pogut resoldre «packages.linuxmint.com»
    Err http://ubuntu.mes.edu.cu trusty-security Release.gpg
    No s'ha pogut resoldre «ubuntu.mes.edu.cu»
    Err http://ubuntu.mes.edu.cu trusty-updates Release.gpg
    No s'ha pogut resoldre «ubuntu.mes.edu.cu»
    Err http://archive.ubuntu.com trusty-updates Release.gpg
    No s'ha pogut resoldre «archive.ubuntu.com»
    Err http://ubuntu.mes.edu.cu trusty Release.gpg
    No s'ha pogut resoldre «ubuntu.mes.edu.cu»
    Err http://extra.linuxmint.com qiana InRelease

    Err http://extra.linuxmint.com qiana Release.gpg
    No s'ha pogut resoldre «extra.linuxmint.com»
    Err http://archive.canonical.com trusty InRelease

    Err http://archive.canonical.com trusty Release.gpg
    No s'ha pogut resoldre «archive.canonical.com»
    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/InRelease

    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/InRelease

    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/InRelease

    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/InRelease

    W: No es pot obtenir http://packages.linuxmint.com/dists/qiana/InRelease

    W: No es pot obtenir http://extra.linuxmint.com/dists/qiana/InRelease

    W: No es pot obtenir http://archive.ubuntu.com/ubuntu/dists/trusty/InRelease

    W: No es pot obtenir http://archive.ubuntu.com/ubuntu/dists/trusty-updates/InRelease

    W: No es pot obtenir http://security.ubuntu.com/ubuntu/dists/trusty-security/InRelease

    W: No es pot obtenir http://archive.canonical.com/ubuntu/dists/trusty/InRelease

    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/Release.gpg No s'ha pogut resoldre «ubuntu.mes.edu.cu»

    W: No es pot obtenir http://packages.linuxmint.com/dists/qiana/Release.gpg No s'ha pogut resoldre «packages.linuxmint.com»

    W: No es pot obtenir http://archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg No s'ha pogut resoldre «archive.ubuntu.com»

    W: No es pot obtenir http://archive.ubuntu.com/ubuntu/dists/trusty-updates/Release.gpg No s'ha pogut resoldre «archive.ubuntu.com»

    W: No es pot obtenir http://security.ubuntu.com/ubuntu/dists/trusty-security/Release.gpg No s'ha pogut resoldre «security.ubuntu.com»

    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/Release.gpg No s'ha pogut resoldre «ubuntu.mes.edu.cu»

    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/Release.gpg No s'ha pogut resoldre «ubuntu.mes.edu.cu»

    W: No es pot obtenir http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/Release.gpg No s'ha pogut resoldre «ubuntu.mes.edu.cu»

    W: No es pot obtenir http://extra.linuxmint.com/dists/qiana/Release.gpg No s'ha pogut resoldre «extra.linuxmint.com»

    W: No es pot obtenir http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg No s'ha pogut resoldre «archive.canonical.com»

    W: Some index files failed to download. They have been ignored, or old ons used instead.
    E: No s'ha pogut bloquejar / var / lib / dpkg / lock - open (11: Resource Temporarily unavailable)
    E: No s'ha pogut bloquejar el directori d'administració (/ var / lib / dpkg /), ¿potser hi hagi algun altre procés utilitzant-?

    *************** Com resoldre aquest problema? **************************
    Li prego m'ajudin si us plau