Como actualizar gstreamer0.10-plugins-bad en LMDE RC 201108

Luego de la instalación de LMDE RC 201108 hubo un solo paquete que me dió error a la hora de actualizarlo: gstreamer0.10-plugins-bad.

Por suerte la solución para este problema es muy sencilla y bastante rápida. Abrimos un terminal y nos logueamos como root o usamos sudo, como es el caso de con el siguiente comando.

$ sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

Y nos debe salir algo como esto:

(Reading database ... 158926 files and directories currently installed.)
Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: warning: overriding problem because --force enabled:
trying to overwrite "/usr/lib/gstreamer-0.10/libgstxvid.so", which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
Setting up gstreamer0.10-plugins-bad (0.10.22-3) ...
Processing triggers for libglib2.0-0 ...

Listo. Ya tenemos Gstreamer instalado y actualizado 😀

 


5 comentarios

  1.   Dario Freije dijo

    Muchas gracias! Funcionó de 10.
    Se me trababa en ese paquete al querer actualizar y no seguía con las demás 418 actualizaciones.

    1.    elav <° Linux dijo

      Me alegro que te haya servido 😀

  2.   aciguembre dijo

    Pues a mí me aparece esto….

    (Leyendo la base de datos ... 152219 ficheros o directorios instalados actualmente.)
    Preparando para reemplazar gstreamer0.10-plugins-bad 0.10.22-2 (usando .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
    Desempaquetando el reemplazo de gstreamer0.10-plugins-bad ...
    dpkg-deb (subproceso): datos: error interno de lectura de gzip `: data error'
    dpkg-deb: error: el subproceso devolvió el código de salida de error 2
    dpkg: error al procesar /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--install):
    el subproceso dpkg-deb --fsys-tarfile devolvió el código de salida de error 2
    Procesando disparadores para libglib2.0-0 ...
    Se encontraron errores al procesar:
    /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
    portatil@portatil ~ $

    ¿puedo hacer algo para corregirlo?
    Gracias por vuestro blog. Espero aprender mucho de vosotros!!

  3.   Jack dijo

    Yo instale lmde 201109 y cuando hize la primera actualizacion me marco un error por paquetes rotos entonces actualize desde terminal con sudo apt-get update y sudo apt-get dist-upgrade y todo me fue a la perfeccion al final use sudo apt-get -f install despues de unos dias tuve problemas (eso fue culpa mia) y me vi obligado a reinstalar cuando trate de hacer de nuevo la actualizacion me maracaba error con gstreamer y trate de arreglarlo de muchas maneras y no pude use sudo dpkg -i –force-overwrite y aun asi no me dejo, ya desesperado hize algo muy tonto pero ¡Funciono!, actualize desmarcando gstreamer al terminar instale el gstreamer y ya no marco error aun asi desde terminal use sudo pat-get -f install, espero eso ayude

  4.   OlimasterX dijo

    Muchas gracias!!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.