Como cambiar el User Agent en SRWare Iron

Ya vimos las ventajas de usar SRWare Iron en vez de Chromium/Chrome y como bien decía en dicho artículo, cambiar el de Iron es muy sencillo.

Solo tenemos que abrir un terminal como root, y crear con nuestro editor de texto favorito un fichero en /opt/ con el nombre UA.ini.

$ sudo nano /opt/UA.ini

A este fichero le ponemos adentro:

Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Debian Iron/15.0.900.2 Safari/535.2

Y listo.


71 comentarios

  1.   gadi dijo

    Puedo confirmarlo, funciona.

    1.    gadi dijo

      Vale, en el comentario no aparece el logo de la distro, pero en la cabecera del blog sí. Es Chakra, por cierto.

      1.    elav <° Linux dijo

        No sé por qué sale ese logo jajaja. En mi vida lo había visto. A lo mejor si cambias Iron por SRWare Iron salga el original 😀

  2.   gadi dijo

    Probemos de nuevo. He mirado en otro comentario mío anterior, sin esta modificación, y sí, lo correcto es poner SRWare Iron. Mi línea es:

    Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Chakra SRWare Iron/15.0.900.2 Safari/535.2

    Lo que ocurre es que no aparece el logo de Chakra en los comentarios. Como digo, en la cabecera sí aparece.

    1.    Courage dijo

      Lo mismo no está añadido el logo de Chakra pero por lo menos el del navegador te funciona perfectamente

    2.    KZKG^Gaara <" Linux dijo

      Eso es culpa del plugin de los comentarios, que aún no tiene soporte para Chakra 🙁
      Prometo modificar el plugin cuando tenga un chance, así le agrego soporte para Chakra, Pardus, Tuquito y alguna otra distro 🙂

    3.    Erithrym dijo

      Pues yo tengo esa línea, cambiando Chakra por LMDE, claro está, y me sigue apareciendo el icono raro… :S

      1.    KZKG^Gaara <" Linux dijo

        Y si intentas con “Linux Mint” ?

        1.    Erithrym dijo

          Si pongo Linux Mint me pone lo de ahora

        2.    Erithrym dijo

          Lo que me parece raro es que arriba me sigue poniendo que tengo LMDE :S

          1.    Erithrym dijo

            Vale, ahora ya actualizó XD
            Ya me pone que tengo Mint y en los comentarios también, pero en el símbolo del navegador me sigue apareciendo ese icono raro

          2.    Courage dijo

            Muéstrame la línea completa

          3.    Erithrym dijo

            La línea completa es Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Linux Mint SRWare Iron/15.0.900.2 Safari/535.2

            1.    KZKG^Gaara <" Linux dijo

              Creo que el ícono feo es simplemente porque ese es el ícono que trae el plugin para Iron 🙁 … joder, de veras tengo que hacer un tiempo y modificar el plugin ese ¬¬


          4.    Courage dijo

            ¿Eso de Mozilla no influirá?

          5.    Erithrym dijo

            No sé, yo copie el código tal y como lo puso Elav y le hice las modificaciones para que, supuestamente, mostrara bien el navegador y el sistema operativo… desde Iceweasel no me muestra bien el sistema operativo en los comentarios, pero eso es por el plugin, que no tiene LMDE añadido aún

          6.    Courage dijo

            Pues elav a ver si se pasa porque yo creo que podría ser lo de Mozilla/5.0

            1.    elav <° Linux dijo

              Puede ser, yo copié la línea que venía por defecto en Iron y solo le agregué el Debian. Donde puse Debian decía Chrome/15.xx.x.x.x.x


          7.    Erithrym dijo

            Vale, mi nueva línea es la siguiente:
            Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) LMDE Chrome/15.0.900.2 Safari/535.2
            Estaría bien así, elav?

          8.    Erithrym dijo

            Vale, ahora no me detecta el SO en los comentarios, pero de navegador me pone Chrome… a ver si dejando solo Iron…

  3.   gadi dijo

    Perdonad que os floodee los comentarios. Nueva prueba.

    1.    Courage dijo

      Te lo has cargadooooo

    2.    gadi dijo

      Nada, la única manera de que aparezca el logo del navegador correcto es sin la modificación. Así hice el comentario que ha respondido Courage (no me di cuenta de reiniciar).

    3.    KZKG^Gaara <" Linux dijo

      Nada hombre no te preocupes 😉

      1.    elav <° Linux dijo

        No problem!!!

  4.   isar dijo

    Tengo un problema con donde se muestra el logo de la distro en la cabecera. Se me muestra así:

    1.    isar dijo

      Dish, no ha salido el enlace antes Así

      1.    isar dijo

        Joder, a ver si a la tercera atino xD http://i42.tinypic.com/2lmw175.png

        1.    elav <° Linux dijo

          Estamos en vía de solución a ese problema 😀

  5.   Jhals dijo

    Perdon por el flood, pero probando xD

    1.    Jhals dijo

      Al parecer solo muestra el Iron solo xD, me gustaría ver el código del plugin para ver si se puede arreglar o a ver si ya pudieron arreglar esto 😀

      1.    isar dijo

        Creo que el problema es que no sale la cadena Chrome en el User-Agent, si ahora me sale bien, pongo mi User-Agent

        1.    isar dijo

          Vale, añadid Chrome/15.0.900.2 despues de Iron/15.0.900.2 y os debería funcionar.

  6.   ppsalama dijo

    siguiendo las mismas instrucciones a mi me funciona ¿o no?… enviando…

    1.    ppsalama dijo

      Pues no… perdón por probar comentando…

      1.    ppsalama dijo

        nada?

  7.   ppsalama dijo

    Bueno, no quiero floodear más. He vuelto a modificar mi user agent así (antes ponía solo Iron)

    Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Archlinux SRWare Iron/15.0.900.2 Safari/535.2
    si no sale… ¿hay alguna web donde pueda probar (sin tener que comentar aquí)?
    gracias

  8.   Diazepan dijo

    Probando

    1.    KZKG^Gaara dijo

      Por cierto, Isar también hizo una corrección en el reconocimiento de Iron 😀

      1.    Jamin Samuel dijo

        mi linea de comando es esta:

        Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Linux Mint SRWare Iron/15.0.900.2 Safari/535.2

        1.    Jamin Samuel dijo

          y no pasa nada ajajajaja que locura con esto me voy a volver loquito no he podido dar en el clavo 😀

  9.   Jamin Samuel dijo

    Probando haber que pasa 🙂

    1.    Jamin Samuel dijo

      ajaja bueno no paso nada, sigue todo igual:y la linea del comnando es este:

      Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Debian Iron/15.0.900.2 Chrome/15.0.900.2

      Alguna sugerencia ?

  10.   Diazepan dijo

    Prueba

    1.    Diazepan dijo

      Prueba2

      1.    diazepan dijo

        prueba3

  11.   Wolf dijo

    Prueba1

    1.    Wolf dijo

      Prueba2

  12.   Leproso_Ivan dijo

    Ok, al fin lo he conseguido..

    Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.2 (KHTML, like Gecko) ArchLinux Iron/15.0.900.2 Safari/535.2

    Esa es la linea del UA.ini para ArchLinux..

    1.    Manuel de la Fuente dijo

      Según UserAgentString.com está mal, debería ser así:

      Mozilla/5.0 (X11; Arch Linux x86_64) AppleWebKit/535.2 (KHTML, like Gecko) Iron/15.0.900.2 Chrome/15.0.900.2 Safari/535.2

      Solo de esa manera pone que usas “Arch Linux distribution”. Pero igual te lo reconoce en los comentarios y el logo de la sidebar, así que si gustas quédate con ese.

  13.   Rots87 dijo

    probando

  14.   Rayonant dijo

    Probando UA

    1.    Rayonant dijo

      Probando de nuevo

  15.   Helena dijo

    prueba 1

  16.   Helena dijo

    prueba 2

    1.    Helena dijo

      prueba 3 *que bochornoso*

  17.   Helena dijo

    prueba 4 y no se porque sale el logo de apple :/, estoy usando arch

    1.    Helena dijo

      a ver si esta es la prueba final

  18.   charlie_sunday dijo

    prueba

  19.   charlie_sunday dijo

    excelente funciono gracias! 😀

  20.   descargas dijo

    Probando 1

  21.   descargas dijo

    Probando 2 y 3

  22.   Ferran dijo

    test 1

  23.   Ferran dijo

    test 2

  24.   Ferran dijo

    test 3

  25.   Brizno dijo

    Excelente

    1.    Brizno dijo

      2

      1.    Brizno dijo

        3

        1.    Brizno dijo

          4

          1.    Brizno dijo

            5

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.