Como instalar DraftSight en Ubuntu 64 bit y derivados

Hola, esta es mi primer publicación en blog.desdelinux.net y quería compartirles como instalar DraftSight en Ubuntu y derivados de 64 bit, ya que Dassault Systemes solo lanza paquetes deb de 32 bit.

El la red solo he logrado encontrar un tutorial que explica como solucionar el problema de dependencias que siempre ha existido con DraftSight a la hora de instalarlo en un sistema de 64 bit, dicho tutorial dice que hay que modificar un archivo dentro del paquete deb, yo lo he realizado al pie de la letra sin resultado, entonces me di a la tarea de buscar una solución yo mismo, y a base de ver los mensajes de error o librerías faltantes en consola he llegado a encontrar todas las librerías que faltaban.

el paquete deb descarga algunas librerías 32 bit, pero lo hace asumiendo que lo estamos corriendo en un sistema 32 bit, en pocas palabras las librerías que más adelante les mostraré ya deberian estar instaladas por defecto si tuvieramos un sistema 32 bit.

Ahora hablemos un poco sobre DraftSight:

Para los que no conocen DraftSight, es un software del tipo CAD parecido (por no decir igual)  a AutoCAD, no es open-source pero tiene una versión gratuita que cumple con lo básico para la creación y edición 2D de dibujos, cabe mencionar que la versión gratuita no contiene ningún tipo de publicidad dentro del programa, algo que tiene muy buena aceptación entre los usuario.

DraftSight puede crear, editar y visualizar archivos DWG, DFX entre otros, esta disponible en muchos idiomas entre ellos el español, esta hecho usando librerías Qt, por lo que muchos usuarios de KDE estarán muy contentos y en mi opinión es la mejor opción que hay en GNU/Linux después de BricsCAD.

Ahora a lo que trata el post:

La versión actual al momento de la creación de este post es la V1R5.1, el enlace descargará la versión mas reciente.
Esta solución funciona en ubuntu y derivados 13.10 y 14.04, desconozco si funciona en versiones anteriores, por favor informar si surge algún problema.

Antes de instalar el paquete .deb debemos instalar las siguiente librerías.

sudo apt-get install libstdc++6:i386 libgtk2.0-0:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386

luego procedemos a instalar el paquete .deb de forma grafica o en consolo, para este ultimo ingresar en el directorio donde esta el paquete y ejecutar.

sudo dpkg -i DraftSight.deb

Aceptamos los terminos de licencia, esperamos a que termine de instalar y listo, ya podes acceder a través desde el menú.

Para los que quieran probar DraftSight les proporciono el enlace de descarga.

Descargar DraftSight


Categorías

Aplicaciones

Fanático de los videojuegos y la tecnología, usuario de GNU/Linux desde conocer Ubuntu 7.04, siempre en busca de alternativas al software propietario.

19 comentarios

  1.   eliotime3000 dijo

    No tendré problemas con Debian Wheezy (versión 64 bits), ya que sólo se necesita activarle el modo multiarch y asunto solucionado.

  2.   Radixs dijo

    Yo lo acabo de instalar en Debian Testing (Jessie) 64bit, anteriormente ya tenia configurado mi multiarch (tengo instalado skype) y al momento de instalar no tuve problemas, pero como dice obedlink hay que tener la librerías instaladas. Como dije yo lo logre instalar, pero la aplicaciones no se ejecutaba busque los paquetes instalados y me arrojo que solo me faltaba libglu1-mesa:i386, lo instale y se ejecuto sin problemas.

    Gracias obedlink, funciona de lujo!

  3.   manuti dijo

    En 12.04 y 12.10 de 64bits da problemas al instalarse y hay que forzar la arquitectura. De esa forma se consigue instalar pero en cuando se actualiza el sistema desinstala la aplicación. Aquí hay una guía para estabilizar el asunto:
    http://numeriza.com/informatica/como-instalar-draftsight-v1r3-2-en-ubuntu-64-bits-12-04/
    Y aquí podéis ver el error que aparece si no corregimos según la guía anterior
    http://numeriza.com/informatica/nueva-version-de-daftsight-v1r5-0/

    1.    obedlink dijo

      creo que al instalar un .deb desde consola aun que sea forzando arquitectura este no instala dependencias, por lo que tendrías que hacerlo manualmente.

      las dependencias que vienen dentro de .deb de la versión más reciente son:
      xdg-utils, libaudio2

      si vas a instalarlo por consola forzando arquitectura deberías primero instalar las dependencias que puse en esta guía y las que mencione arriba pero las de 32bit

      sudo apt-get install xdg-utils:i386 libaudio2:i386

  4.   dobyman dijo

    Excelente, gracias a éste TUTO logré instalar el draft en mi ubuntu 13.10!!!! .

  5.   Frank Gamarra dijo

    Estimado Autor:

    No me resultó al tratar de instalarlo en ubuntu 14.04.

    ¿En qué debo fijarme para poder instalarlo sin tener problemas?

    Saludos

  6.   Alan dijo

    ¡Muchas gracias! El procedimiento que propones para instalar Draftsight funciona perfectamente, y es muy sencilo. ¡Enhorabuena por el blog!

    Ahora sólo falta que la beta de Draftsight haya madurado desde la última vez que la probé, en la que aún tenía muchos errores. El aspecto inicial parece bastante bueno. Gracias otra vez.

  7.   Luis Felipe dijo

    Excelente Aporte Brother, al fin pude instalarlo en mi Lap de 64 bits, lo único es que cuando lo instale, me solicito aceptar la licencia y condiciones me envía una vez mas a instalarlo ya que lo hice por medio del Centro de Software de Ubuntu, al final solo cerré la petición y listo me fui a buscar en su equipo y en linea y lo busque por el nombre de Draftsight y listo me esta funcionando al 100%-

    Una vez mas gracias por el tiempo que invertiste en publicar esta solución

    Dios te bendiga!!

    Saludos!!

  8.   NESTOR dijo

    Sos un Genio!!! Te felicito por tu aporte. Gracias, gracias y muchas gracias!!!!

  9.   alescien dijo

    instalado y funcionando, gracias por compartir…

  10.   Rafael dijo

    Hola, esto no generara problemas al futuro con los paquetes de 64? o el sistema quedara instalando solo programas de 32?

    Gracias.

  11.   Pedro dijo

    Amigo gracias a tu aporte lo Pude instalar en Ubuntu 14.04 LTS.

  12.   Thiago Henrique ( BRASIL ) dijo

    Muito obrigado amigo, deu 100% funcionando.

  13.   Lorenzo dijo

    Muchísimas gracias estuve bastante sin poder instalarlo.

  14. Estoy tratando de instalar DrafSight en mi Debian Whezzy 7.7 reciente instalada, segui este procedimiento http://www.espaciolinux.com/foros/software/instalacion-drafsigth-bricscad-debian-wheezy-bits-t51561.html, me aparece el icono en el menu de Gnome 3 y puedo ver que esta el binario en /opt/dassault-systemes/.

    Pero al lanzar la aplicacion no hace nada, la ejecuto por terminal utilizando ./DrafSight y me arroja el siguiente error:

    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by ./DraftSight)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libTD_Db.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libTD_DbRoot.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libTD_Gs.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libTD_Gi.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libTD_Ge.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libTD_Root.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libAecGeometry.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libFXExport.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libFXRenderBase.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libFXCommandsBase.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libFxFileDialogs.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libDDKERNEL.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libDDKERNEL.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libFxImages.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libFXCrashRpt.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libFXLISP.so.1)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5X11Extras.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Widgets.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Xml.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Network.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Network.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Gui.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Core.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Core.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/libTD_SpatialIndex.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/libTD_Dwf7Export.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/libQt5Svg.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/libQt5PrintSupport.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/libQt5OpenGL.so.5)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/libDwfCore.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libicui18n.so.48)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/libicuuc.so.48)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/../Libraries/libDwfToolkit.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/../Libraries/libW3dTk.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/../Libraries/libWhipTk.so)
    ./DraftSight: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14′ not found (required by /opt/dassault-systemes/DraftSight/Linux/../Libraries/../Libraries/libfreetype.so.6)

    Que puedo hacer? Segui este procedimiento https://oscartux.wordpress.com/2014/05/21/como-solucionar-el-problema-de-glibc_2-14-not-found-en-spotify/ para tratar de instalar libc.so.6 desde un repositorio experintal y se me rompio todo el sistema tuve que reinstalar.

  15.   Filo dijo

    Han cambiado de 32 a 64 bits, es decir, 32bits ya no lo mantienen.

  16.   Carloncho dijo

    En ubuntu 14.04 para 64 bits me anduvo sólo instalando con gdebi. Igualmente gracias

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.