Controlar el consumo de ancho de banda en Linux

Hoy día es cada vez más común la contratación de planes de navegación móvil, que normalmente vienen limitadas con una cuota de descarga específica al mes, o sea que si te pasás de esta cuota normalmente te suspenden el servicio o en el mejor de los casos te dejan navegar pero a velocidades irrisorias.

En estos casos, Download Monitor se convierte en nuestro mejor aliado


Download Monitor permite monitorizar en tiempo real la cantidad de datos descargados desde Internet por hora, día o mes a través de su interfaz gráfica, contando con la posibilidad de enviarnos notificaciones al escritorio en cuanto alcanzamos o nos acercamos a la cuota de descarga permitida por nuestro operador para así evitarnos la dolorosa desconexión o baja de velocidad en nuestra conexión a Internet.

Adicionalmente, Download Monitor se integra perfectamente con Unity, permitiendo controlar la aplicación por medio de listas rápidas dinámicas que nos permiten acceder a la información de descarga con solo un clic y mostrando una barra de progreso en el icono del lanzador que muestra la cuota de descarga usada y restante hasta el momento.

Instalación

En Ubuntu y derivados:

sudo add-apt-repository ppa:duncanjdavis/download-monitor-submit
sudo apt-get update && sudo apt-get install download-monitor

Para otras distribuciones Linux, es posible descargar Download Monitor directamente desde su página en Launchpad.

Fuente: EMSLinux & IloveUbuntu


5 comentarios

  1. Gracias por responder!

    Conseguí una aplicación que es perfecta para mis necesidades en cuanto a funcionalidad, pero con otro problema fundamental: no lee el interface ppp0, que casualmente es el que me hace falta, ya que todo esto es para controlar el plan de datos (suma del consumo de Mb/dia/mes) de una conexión 3G desde un modem usb y que opera por dicha interface ppp0.

    Ni que decir que me funciona perfecta a través de wlan0 o eth0 (sic) y sería perfecto conseguir un archivito de configuración donde poder cambiar eso, pero no lo encuentro si es que lo hay…

    Para quien le pueda servir, la aplicación me parece super buena, exceptuando ese pequeño handicap, se llama BitMeter OS, y se encuentra aquí: http://codebox.org.uk/bitmeterOs

    Funciona via navegador, en su web tienen una demo que se explica por si sola: http://codebox.org.uk/pages/bitmeteros/demo
    Sigo buscando, saludos!

  2.   Ferneyp dijo

    Buenas tardes
    Me sale esto al ejecutar la segunda línea de comandos:

    W: Imposible obtener http://ppa.launchpad.net/duncanjdavis/download-monitor-submit/ubuntu/dists/natty/main/source/Sources 404 Not Found

    W: Imposible obtener http://ppa.launchpad.net/duncanjdavis/download-monitor-submit/ubuntu/dists/natty/main/binary-amd64/Packages 404 Not Found

    E: Algunos archivos de índice fallaron al descargar. Se han ignorado, o se han utilizado unos antiguos en su lugar

    Agradezco su respuesta.

  3.   Guest dijo

    David tienes un par de dependencias por resolver y cubrir, las cuales son gir1.2 que tiene relacion con vnstat, no se si andas con los repositorios de testing?
    O andas con los de 6, deberias de darle una mirada primero cumple la dependencia y lo tendras listo.

  4. Gracias por la respuesta, pero como dice Pablo mas abajo, hay (por lo menos) una dependencia que es exclusiva de ubuntu. Probaré otras alternativas, a ver si con un poco de suerte doy con la que me conviene.
    Saludos!

  5. Buenas!! Me hace mucha falta este programa, pero no lo puedo instalar en debian. Añado el ppa, la llave y el correspondiente #aptitude install download-monitor, con este resultado:

    root@manuelita /home/gid# aptitude install download-monitorLos paquetes nuevos siguientes se instalaran: download-monitor{b} gir1.2-dbusmenu-glib-0.4{a} gir1.2-notify-0.7{a} libdbusmenu-glib4{a} 0 paquetes actualitzados, 4 instalados, 0 a suprimir i 166 a no actualizar.Se necesitan obtener 486 kB de archivos. Después del desempaquetado se utilizarán 959 kB.No se han encontrado las dependencias de lo siguientes paquetes: download-monitor : Depende: gir1.2-unity-5.0 que es un paquete virtual. Depende: python-apport que és un paquet virtual. Depende: gir1.2-launchpad-integration-3.0 que es un paquete virtual. Depende: vnstat but it is not going to be installed.Las siguientes acciones resolverán las dependencias:
    Mantén la versión actual de los siguientes paquetes:1) download-monitor [No instalado]

    Accepta la solución [Y/n/q/?] Y

    No se intalará, actualizará o suprimirá ningún paquete.
    0 paquetes actualizados, 0 instalados, 0 a suprimir y 166 a no actualizar.Se necesita obtener 0 B de archivos. Después del desempaquetado se utilizarán 0 B.
    root@manuelita /home/gid#

    Socooorrooo !!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *