Debian 12.4 přichází s vynecháním Debian 12.3 a Linuxu 6.1.0-14

Debian 12 Bookworm: Vydání nové stabilní verze

Před několika dny Vývojáři Debianu oznámili vydání nová verze Debian 12.4, který byl vydán, přeskočil vydání Debianu 12.3 protože v konečné fázi jeho přípravy byla objevena chyba v linuxovém jádře v balíčku s jádrem linux-image-6.1.0-14, která způsobuje poškození dat v souborovém systému Ext4.

Problém se objevuje ve stabilní větvi jádra Linuxu 6.1, který byl podpořen opravou, která byla původně přidána do větve 6.5, aby vyřešila selhání kvůli chybě v kódu pro aktualizaci velikosti souboru, která byla zmenšena po přímé aktualizaci.

Jako takové se poukazuje na to poškození je označeno jako nekritické (není vysvětleno, co to přesně znamená, pravděpodobně ke ztrátě dat dochází ve velmi vzácných případech nebo data nejsou trvale ztracena, ale velikost souboru je větší než skutečná).

V kontextu Debianu 12, chyba byla přesunuta do balíčku jádra 6.1 po jeho synchronizaci s verzí 6.1.64. Během diskuse o chybě vývojáři Debianu zmínili, že problém byl opraven v aktualizaci 6.1.66, ale stále není jasné, která z oprav přidaných k této verzi problém řeší, protože v jádře 6.1.66 nejsou žádné změny. které jasně souvisejí s VFS a Ext4 (s největší pravděpodobností mluví o zastavení problému v deb balíčku s jádrem 6.1.66, kdy ve skutečnosti byla oprava přidána do větve jádra 6.1.65, která obsahuje změny související s Ext4).

Co je nového v Debianu 12.4?

Pro část vylepšení, která jsou součástí v tomto novém vydání Debianu 12.4 (navíc je dodáván s balíčkem jádra linux-image-6.1.0-15, který je založen na jádře verze 6.1.66 a obsahuje opravu tohoto problému), Zavádí kumulativní aktualizace balíčků a přidává opravy do instalačního programu. Vydání obsahuje 94 aktualizací, které řeší problémy se stabilitou a 65 aktualizací, které řeší zranitelnosti.

V Debianu 12.4 můžete také zvýraznit laktualizovat na nejnovější stabilní verze balíčky gnome-shell, minizip, systemd, xen, mezi ostatními. Odstraněn balíček gimp-dds, který již není potřeba, protože jeho funkčnost je nyní zabudována do GIMPu.

Kromě toho se také poznamenává, že přidán balíček llvm-toolchain-16 založený na LLVM/Clang 16, který je nutný k vytvoření nových verzí prohlížeče Chromium, byla také přidána podpora Unicode 15.1 do znaků gnome a fonts-noto-color-emoji. libsolv obsahuje podporu pro kompresní algoritmus zstd.

Z další změny které vyčnívají z této nové verze:

  • eas4tbsync: Nová verze, která obnovuje kompatibilitu s novějšími verzemi Thunderbirdu
  • exfatprogs: Opravuje problémy s přístupem do paměti mimo hranice [CVE-2023-45897]
  • exim4: Opravuje bezpečnostní problémy související s protokolem proxy [CVE-2023-42117] a vyhledáváním DNSDB [CVE-2023-42119]
  • GnomeShell: Nová verze umožňuje kromě klávesy mazání zrušit oznámení pomocí klávesy Backspace, opravuje zobrazení duplicitních zařízení při opětovném připojení k PulseAudio, opravuje možné použití po selhání odemknutí při restartování PulseAudio/Pipewire.
  • libsolv: Podpora komprese Zstd povolena
  • Linuxové jádro: Aktualizujte na stabilní verzi 6.1.66
  • profil: Opravuje problém s přetečením vyrovnávací paměti [CVE-2023-47038]
  • php-phpseclib3: Opravte problém s odmítnutím služby
  • postgresql-15: Nová stabilní verze, kde je vyřešen problém vkládání SQL [CVE-2023-39417]; opravuje MERGE, aby správně uplatňovala zásady zabezpečení řádků [CVE-2023-39418]
  • proftpd-dfsg: opravit velikost vyrovnávacích pamětí pro výměnu klíčů SSH
  • qbittorrent: ve výchozím nastavení v qbittorrent-nox zakázáno UPnP pro webové uživatelské rozhraní
  • qemu: Aktualizace na stabilní verzi 7.2.7

Stáhněte si a získejte Debian 12.4

Pro ty, kteří mají zájem získat novou verzi Debianu 12.4, měli byste vědět, že oficiální stránka projektu již nabízí instalační obrazy, zatímco pro ty, kteří již mají předchozí verzi, stačí provést aktualizaci příkazů a získat tuto novou verzi.

A konečně, pokud máte zájem dozvědět se o tom více, můžete se podívat na podrobnosti v následující odkaz.


Zanechte svůj komentář

Vaše e-mailová adresa nebude zveřejněna. Povinné položky jsou označeny *

*

*

  1. Odpovědný za údaje: Miguel Ángel Gatón
  2. Účel údajů: Ovládací SPAM, správa komentářů.
  3. Legitimace: Váš souhlas
  4. Sdělování údajů: Údaje nebudou sděleny třetím osobám, s výjimkou zákonných povinností.
  5. Úložiště dat: Databáze hostovaná společností Occentus Networks (EU)
  6. Práva: Vaše údaje můžete kdykoli omezit, obnovit a odstranit.