Pakker til support til softwareudvikling på DEBIAN 10

Pakker til support til softwareudvikling på DEBIAN 10

Pakker til support til softwareudvikling på DEBIAN 10

Dette indlæg er fortsættelsen (tredje del) af tutorials dedikeret til DEBIAN GNU / Linux Distro, version 10 (Buster), som tjener som basis for mange andre som f.eks MX-Linux 19 (grim ælling).

I denne tredje del viser vi vigtige pakker (applikationer) anbefales at give det nødvendige støtte grundlæggende til udvikling, test og udførelse af nogle software (applikationer) om vores smukke og store Distros DEBIAN 10 og MX-Linux 19.

Opdater og optimer MX-Linux 19.0 og DEBIAN 10.2 efter installationen

Opdater og optimer MX-Linux 19.0 og DEBIAN 10.2 efter installationen

De to foregående indlæg i denne serie er:

  • Opdater og optimer MX-Linux 19.0 og DEBIAN 10.2 efter installationen (Se post)
  • DEBIAN 10: Hvilke ekstra pakker er nyttige efter installationen? (Se post)
DEBIAN 10: Hvilke ekstra pakker er nyttige efter installationen?

DEBIAN 10: Hvilke ekstra pakker er nyttige efter installationen?

Husk og husk at:

"Husk, at de handlinger og pakker, der anbefales her til at køre og installere, er netop det, "pakker anbefalede", og det er op til hver enkelt at køre og installere alle eller nogle af dem, hvorfor er de nødvendige eller nyttige på kort eller mellemlang sigt at kende og bruge dem, ved at lade dem allerede køre eller installere.

Og husk, at disse handlinger og / eller pakker var tidligere testet på begge Distros, og bed ikke om at afinstallere pakker, der er installeret som standard i disse. Yderligere, de øger ikke forbruget af hukommelse eller CPU da de som standard ikke indlæser processer eller dæmoner (tjenester) i hukommelsen. For at vide på forhånd, hvad hver pakke bruges til, skal du klikke på her."

Opdater MX-Linux og DEBIAN: Indhold

Pakker til softwareudvikling support

Understøttelse af Java-applikationer

apt install browser-plugin-freshplayer-pepperflash default-jdk icedtea-netx

Objetivo: Installer grundlæggende support til kompatibilitet med Java-applikationer.

Understøttelse af QT5-applikationer

apt install libqt5core5a qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

Objetivo: Installer grundlæggende support til kompatibilitet med applikationer bygget med QT5.

Støtte til Digital Mining applikationer

apt install autoconf automake autotools-dev build-essential byobu g++ gcc gcc-7 g++-7 git git-core libboost-dev libboost-all-dev libcrypto++-dev libcurl4 libdb-dev libdb++-dev libevent-dev libgmp-dev libgmp3-dev libhwloc-dev libjansson-dev libmicrohttpd-dev libminiupnpc-dev libncurses5-dev libprotobuf-dev libqrencode-dev libqt5gui5 libqtcore4 libqt5dbus5 libstdc++6 libssl-dev libusb-1.0-0-dev libtool libudev-dev make ocl-icd-opencl-dev openssl pkg-config protobuf-compiler qrencode qttools5-dev qttools5-dev-tools

Objetivo: Installer den grundlæggende applikationssupport, drivere og biblioteker, der er nødvendige for installation og styring af Digital Mining-applikationer.

apt install libdb++-dev libdb5.3++ libdb5.3++-dev

Objetivo: Installer grundlæggende biblioteksunderstøttelse til programmer, der bruger Berkeley v5.3-databasebiblioteket, der er meget brugt af moderne Digital Mining-applikationer, der skal kompileres og / eller køres.

Understøttelse af webapplikationer

Apache

apt install apache2

Objetivo: Installer grundlæggende support til webapplikationer optimeret eller kompatibel til Apache2.

Nginx

apt install nginx

Objetivo: Installer grundlæggende support til webapplikationer optimeret eller kompatibel til Nginx.

PostgreSQL

apt install postgresql

Objetivo: Installer grundlæggende kommando- og funktionsunderstøttelse til styring af Postgresql-baserede databaser.

apt install pgadmin3 y phppgadmin

Objetivo: Installer grundlæggende applikationssupport til Postgresql-baseret databasestyring.

MySQL

apt install mysql-server mysql-client

Objetivo: Installer grundlæggende kommando- og funktionssupport til styring af MySQL-baserede databaser.

apt install phpmyadmin y mysql-workbench

Objetivo: Installer grundlæggende applikationssupport til styring af MySQL-baserede databaser.

MariaDB

apt install mariadb-server mariadb-client

Objetivo: Installer den grundlæggende kommando- og funktionsunderstøttelse til styring af databaser baseret på MariaDB.

PHP

apt install php

Objetivo: Installer grundlæggende kommando- og funktionssupport til håndtering af PHP-baserede applikationer.

apt install php-cas php-cgi php-curl php-gd php-json php-mbstring php-mysql php-xml php-apcu php-cli php-dev php-imap php-ldap php-xmlrpc php-intl php-pgsql php-sqlite3 php-zip phpqrcode

Objetivo: Installer den basale support fra native biblioteker til styring af PHP-baserede applikationer.

apt install libmagic-dev libapache2-mod-php libcurl4-gnutls-dev

Objetivo: Installer grundlæggende ikke-indbygget biblioteksupport til håndtering af PHP-baserede applikationer.

PERL

apt install perl

Objetivo: Installer grundlæggende kommando- og funktionssupport til håndtering af PERL-baserede applikationer.

apt install libapache2-mod-perl2 y perlbrew

Objetivo: Installer grundlæggende biblioteksupport til håndtering af PERL-baserede applikationer.

Python

apt install python-all-dev python-pip

Objetivo: Installer grundlæggende kommando- og funktionssupport til styring af Python-baserede applikationer.

apt install python3-setuptools python3-pyqt5 python3-pip

Objetivo: Installer grundlæggende kommando- og funktionssupport til håndtering af Python3-baserede applikationer.

Generisk billede til artikelkonklusioner

Konklusion

Det håber vi dette "nyttigt lille indlæg" om hvilke vigtige pakker der er nødvendige for at yde den nødvendige support til en korrekt  «instalación y gestión» af visse softwareudviklinger, om Distros «DEBIAN y MX-Linux», være af stor interesse og nytte for hele det «Comunidad de Software Libre y Código Abierto» og med stort bidrag til spredningen af ​​det vidunderlige, gigantiske og voksende økosystem af applikationer af og til «GNU/Linux».

Og for mere information, tøv ikke altid med at besøge nogen Online bibliotek som OpenLibra y jedit at læse bøger (PDF-filer) om dette emne eller andre videnområder. For nu, hvis du kunne lide dette «publicación», stop ikke med at dele det med andre, i din Favoritwebsteder, kanaler, grupper eller samfund af sociale netværk, helst gratis og åbent som Mastodon, eller sikker og privat lignende Telegram.

Eller besøg blot vores hjemmeside på Fra Linux eller tilmeld dig den officielle kanal Telegram fra FromLinux at læse og stemme på denne eller andre interessante publikationer om «Software Libre», «Código Abierto», «GNU/Linux» og andre emner relateret til «Informática y la Computación»Og «Actualidad tecnológica».


Indholdet af artiklen overholder vores principper for redaktionel etik. Klik på for at rapportere en fejl her.

2 kommentarer, lad dine

Efterlad din kommentar

Din e-mailadresse vil ikke blive offentliggjort.

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Control SPAM, management af kommentarer.
  3. Legitimering: Dit samtykke
  4. Kommunikation af dataene: Dataene vil ikke blive kommunikeret til tredjemand, undtagen ved juridisk forpligtelse.
  5. Datalagring: Database hostet af Occentus Networks (EU)
  6. Rettigheder: Du kan til enhver tid begrænse, gendanne og slette dine oplysninger.

  1.   Twikzer sagde han

    Ret mig, hvis jeg tager fejl, men .. på debian, fjernede de ikke phpmyadmin fra arkiverne?
    og for at installere php behøver du ikke angive (for eksempel) php7.3 eller php7.3-curl

  2.   Linux Post Installation sagde han

    Hilsen Twikzer! Tak for din kommentar. Bestemt phpmyadmin er ikke i DEBIAN 10 (stabile) repositories, men det er i DEBIAN 11 (Testing) Repositories fra hvad jeg antager, at de på et eller andet tidspunkt vil inkludere det som andre pakker i de stabile, men du kan eller kan udelade det uden Men det var derfor, jeg lod det være der. Med hensyn til det andet er det ikke nødvendigt, da de nuværende versioner i arkivet kaldes med deres generiske navn.