Grundlæggende programmering med pseint (del 3)

Dette er en fortsættelse af vejledningen Grundlæggende programmering med pseint (del 2), denne gang vil jeg forklare, hvad der er nødvendigt at programmere.

OPDRAG

Opgaven er en proces, hvor en variabel oprettes og / eller ændres, idet den henvises til den ved hjælp af dens identifikator, hvormed vi kan få adgang til dens hukommelsesplads.

syntaksen for opgaven er:

[variable]<- [expresion];
[variable]=[expresion];

Hvor [variabel] er den variabel, der modtager værdien af ​​at evaluere [udtryk]. Begge er gyldige, så det betyder ikke noget, hvilken der bruges (hvis de konfigurerede PSeInt korrekt), men efter min mening opretter jeg den første som den rigtige.

Hvis [variabel] ikke eksisterede før tildelingen, blev [variabel] oprettet. Hvis den eksisterede, ødelægges den tidligere værdi, og den nye placeres på plads. Af denne grund betragtes kortlægning som en destruktiv operation.

LÆSNING

Læsning er den proces, hvor brugeren bliver bedt om data eller data til at gemme dataene i en variabel.

dens syntaks er:

Leer variable_1,variable_2,...,variable_n;

hvor [variabel_ {1,2, n}] er den eller de variabler, der modtager den værdi, der er givet af brugeren, hvis der anmodes om mere end en variabel, vil den først bede om den første, derefter for den anden osv. indtil har modtaget alle værdier.

Dette er også en destruktiv funktion.

SKRIVNING

Skrivning er den proces, hvor en streng af tegn og / eller en eller flere variabler skrives på skærmen

syntaksen er:

Escribir expresion_1,expresion_2,...,expresion_n;

hvor [ekspersion_ {1,2, n}] er de tegnstrenge og / eller variabler, der vises.

Skrivning ud over at modtage de data, der skal sættes på skærmen, modtager også instruktionen "Uden at springe over" eller "Uden download", der undgår linjespring.

Skrivning tilføjer ikke mellemrum mellem argumenterne, dvs. hvis du sætter:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

i dette tilfælde vil det vise «olamundo», da der mellem «a» og «b» ikke er nogen tegnstreng, der angiver mellemrummet mellem a og b, så det vises korrekt, det skrives således:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

i dette tilfælde tilføj »», som er en tegnstreng, der har et mellemrum, der er mellemrummet mellem «bølge» og «verden», og så viser det «bølgeverden» med mellemrummet.

HVIS SÅ

Dette er en sætning, der evaluerer en given betingelse og kontrollerer sandheden og / eller falskheden af ​​den nævnte betingelse, det vil sige, hvis betingelsen er opfyldt eller ej.

Dens syntaks er:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Klausulen "Else" er ikke obligatorisk. I dette tilfælde, hvis betingelsen er falsk, skal du ignorere instruktionerne og fortsætte som om sætningen ikke eksisterede, i dette tilfælde ville det være:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Om "Fejl" -klausulen blev placeret eller ej, afhænger af programmets behov.

IFØLGE

Sætningen, da den evaluerer en strengt numerisk variabel, der giver mere end 2 indstillinger som en mulighed, dette er forskelligt fra "Hvis-så", da den forrige kun kan give 2 indstillinger.

Syntaksen er:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Som du kan se efter «nummer1» er der et «:», og derefter placeres instruktionerne, der skal udføres, i det tilfælde, at «numerisk variabel = nummer1», i det andet eksempel er det «nummer2, nummer3», det betyder, at hvis «numerisk variabel = nummer2 eller nummer3" udføres "instruktioner", er dette nyttigt, når to muligheder skal udføre de samme instruktioner.

Der er også klausulen "På en anden måde", der udføres, hvis ingen af ​​mulighederne er opfyldt.

MENS

Det er en gentagen funktion, der først evaluerer en betingelse, og hvis den er opfyldt, udfører den en række instruktioner, så evaluerer den igen betingelsen, og hvis den er sand, udfører den de samme instruktioner igen og fortsætter sådan, indtil betingelsen er falsk.

hvis betingelsen er falsk fra starten, vil den aldrig blive udført, og hvis den altid er sand, vil den blive placeret i en uendelig løkke, for at undgå det sidste i instruktionerne, skal der være noget, der på et tidspunkt forfalsker den betingelse, der skal være i stand til at afslutte sløjfen.

dens syntaks er:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

GENTAG-INDTIL

Dette er en funktion, der ligner den foregående, men i modsætning til den foregående kontrollerer denne tilstanden i slutningen, det vil sige kommandoen vil blive udført mindst 1 gang, også i stedet for at udføre instruktionen, når den er sand, udfører den den mens Hvis betingelsen ikke er opfyldt, men hvis du ønsker, at den skal udføres, mens betingelsen er opfyldt, skal du bruge "mens" i stedet for "indtil".

dens syntaks er:

Repetir
[Instrucciones] hasta que [condicion]

FOR

Denne erklæring udfører en instruktion et afgørende antal gange for en variabel, i modsætning til de foregående, ændrer denne cyklus værdien af ​​den pågældende variabel i sig selv såvel som at have en meget kraftig syntaks.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"Variabel" er den variabel, der modtager "startværdi" og udfører instruktionerne, tilføjer derefter "variabel" plus "trin" og udfører instruktionerne igen, indtil "variabel" er lig med "endelig værdi".

Hvis "med [trin]" fjernes, ved det som standard, at "trin" er lig med 1, også hvis [trin] ikke er angivet, og "startværdi" er større end "slutværdi", vil den gå igennem det i omvendt rækkefølge, dvs. "Trin" er -1

UNDERPROCESS / FUNKTION

En tråd eller funktion er et program inden for et andet, og at dette underprogram modtager en eller flere værdier, betjener dem og returnerer en anden. Dens syntaks er

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

hvor "returvariabel" er den variabel, der indeholder værdien returneret af funktionen "funktionsnavn", der modtog parametrene "arg_1, arg_2, arg_n" for at udføre dette

OTHER

Dette er funktioner, der kun supplerer de andre og ikke har en kompleks syntaks, da de kun er komplementære funktioner.

Ryd skærm

Denne funktion rydder skærmen for ethvert objekt i tolken

Vent nøgle

Denne funktion venter på, at brugeren trykker på en tast for at fortsætte med programmet

forventer x {For det andet Millisekunder}

denne funktion venter en tid i sekunder eller millisekunder på at fortsætte med programmet

PS: undskyld for forsinkelsen, men jeg havde travlt med andre ting, så jeg kunne ikke skrive


Indholdet af artiklen overholder vores principper for redaktionel etik. Klik på for at rapportere en fejl her.

10 kommentarer, lad dine

Efterlad din kommentar

Din e-mailadresse vil ikke blive offentliggjort.

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Control SPAM, management af kommentarer.
  3. Legitimering: Dit samtykke
  4. Kommunikation af dataene: Dataene vil ikke blive kommunikeret til tredjemand, undtagen ved juridisk forpligtelse.
  5. Datalagring: Database hostet af Occentus Networks (EU)
  6. Rettigheder: Du kan til enhver tid begrænse, gendanne og slette dine oplysninger.

  1.   Guille sagde han

    Har du ikke funktioner til at fange nøgler uden at stoppe udførelsen? For at gøre noget med bevægelse, der er mere tiltalende for 9-årige, selvom et hangman-spil også kan være sjovt at programmere.

    Behandl noget_digo
    a <-1;
    lateral <-30;
    ned <-5;
    Mens a = 1 gør
    Ryd skærm;
    c <-1;
    linje <- "";
    gentagelse
    linje <-line + "";
    c <-c + 1;
    Indtil c = lateral
    linje <-line + "X";
    c <-1;
    gentagelse
    At skrive " ";
    c <-c + 1;
    Indtil c = ned-1
    Skriv linje;
    gentagelse
    At skrive " ";
    c 2 Derefter
    ned <-ned-1;
    Afslut ja
    "s":
    Hvis under <15 Så
    ned 2 Så
    lateral <-lateral-1;
    Afslut ja
    "d":
    Hvis lateral <50 Så
    lateral <-lateral + 1;
    Afslut ja
    "0":
    a <-2;
    Afslut sekunder
    Afslut mens
    Afslut proces

  2.   Guille sagde han

    Nå, mislykkedes, hvis du går op, skift bedre linje 23 og 28
    -23 Indtil c = 15
    +23 Indtil c = 18
    y
    -28 Hvis ned> 2 Så
    +28 Hvis ned> 3 Så

    1.    xnmm sagde han

      Tak for bidraget, men det har nogle problemer som at du åbner en sætning i en anden, men den skal ende inden for sætningen, hvor den begyndte, jeg mener, den kan ikke sættes

      Behandl noget
      a <- 0;
      læse til;
      hvis a ikke er lig med 25, så
      mens a ikke er lig med 0 do
      læse til;
      Afslut ja
      slut mens

      når du ser sløjfen, mens du starter inde i "hvis så" udsagnet, men slutter uden for det, er noget lignende ikke muligt.

      Jeg sætter stadig pris på bidraget
      Afslut proces

      1.    Guille sagde han

        Tak, men jeg synes, det er mere et problem at sætte koden her, at jeg ikke ved, hvordan jeg skal sætte den i kodetype, og den kommer ud uden indrykning.

        Programmet fungerer fint. Variablen "a" bruger jeg simpelthen til at afslutte sløjfen, når brugeren skriver et nul. Du kan sætte en exit () eller en pause; i det betingede ser det på det, og jeg gemmer variablen. De er muligheder.

        Greetings.

      2.    Guille sagde han

        Jeg prøver at ændre faner for mellemrum og etiketter por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille sagde han

        Det er fuldt af importfejl fra min kode, jeg prøver igen med faner:
        Dette ville være filen algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille sagde han

        Interessant, kommentaren med kodeetiketter spises, slettes, uanset hvad der går imellem, for eksempel mellem linjer
        gentagelse
        At skrive " ";
        c
        efter c er der en
        og derefter fortsætter det med 3 derefter
        ned
        Samlet set er dette ikke pålideligt at sætte i henhold til hvilke koder.

  3.   Guille sagde han

    Jeg ændrer symbolerne fra at tildele til = for at se, hvordan det er.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille sagde han

      Det bliver ved med at spise en del af koden, kodekoden mislykkes, den skal lade skrivningen være som den er.

      1.    xnmm sagde han

        Hej undskyld for ikke at se dig besvaret før, men godt
        da du ikke kan offentliggøre koden godt, fordi du ikke sender den til mig via mail, så du ikke giver så mange vendinger til sagen.