From Linux it detects which distro you use to visit it

The new theme brought with it many changes, including the friend who programmed the theme (alaintm), it improved the PHP function that I had made to detect the user's distro.

Before we showed the distro that each user used through the banner, now we do it through our sidebar:

This is how it is shown to me, also the image of the logo has a link to the articles related to that distro 😉

For Ubuntu users it would be shown like this:

So with ArchLinux:

And etc etc ... here is the list of distros that we support so far:

  • ArchBang
  • ArchLinux
  • Chakra
  • Crunchbang
  • Debian
  • Fedora
  • Frugalware
  • Gentoo
  • Kubuntu
  • Linux Mint
  • LMDE
  • Mageia
  • Mandriva
  • openSUSE
  • Pardus
  • Pink Linux
  • Sabayon
  • Slackware
  • Slitaz
  • Trisquel
  • Ubuntu

As well as Android (halfway) and Windows Hahaha.

We still can't stand Lubuntu, Xubuntu, Chakra, PardusNot because we don't want to, but because we don't have the .SVG or .PNG of the logo of these distros, I had them but I lost them 🙁… if someone has them, please send them to me kzkggaara [@] from linux [.] net

If you notice that you do not get a logo and a Tux, like here:

It means that we recognize that you use Linux, but we cannot identify the distro.

And ... if you see a worker working:

It means we still have no idea what you use HAHA.

 

What to do to show me the logo of my distro?

SinceLinux is programmed so that if your browser tells it what distro you use, DesdeLinux will show the logo, the problem is that if your browser doesn't say it… we are not fortune-tellers.

For that, you can make a small configuration in your browser and tell it to say what distro you use, here are the links to the tutorials we have done on this:

If you have any questions, suggestions, etc ... let us know 😉

It is almost certain that we will change the way the distro logo is displayed, possibly we will make it more attractive, using the background logo of that widget or something like that, but I did not know how to design that hahahahaha, so I just put the logo and already. When elav come back (he's on vacation these days) I'm sure he does, because he knows more about design and that than me haha.

Anyway, there you have it ... remember that the issue is still in beta phase hahaha.

regards


The content of the article adheres to our principles of editorial ethics. To report an error click here!.

179 comments, leave yours

Leave a Comment

Your email address will not be published. Required fields are marked with *

*

*

  1. Responsible for the data: Miguel Ángel Gatón
  2. Purpose of the data: Control SPAM, comment management.
  3. Legitimation: Your consent
  4. Communication of the data: The data will not be communicated to third parties except by legal obligation.
  5. Data storage: Database hosted by Occentus Networks (EU)
  6. Rights: At any time you can limit, recover and delete your information.

  1.   ubuntero said

    good 😀 they look good, until a few days ago it looked bad and now everything is fine 😀 I liked the new design, it reminds me of Bootstrap: http://twitter.github.com/bootstrap/

    1.    Angel_Le_Blanc said

      do you like Ubuntu?

  2.   ubuntero said

    I correct myself, they are using bootstrap! 🙂

  3.   TheSandman86 said

    Very good design in general and this detail in particular, it looks cleaner and clearer, keep it up !! Cheers!

  4.   Gregorio Espadas said

    Let's see if it already shows me that I write from ArchLinux ...

  5.   Gregorio Espadas said

    … Yes now! 🙂

  6.   Jesus said

    Any ideas on how to get it to work on Fedora 17 and Chrome?

  7.   Rots87 said

    to me if he showed it to me hehehe now to see if it works for me

  8.   Oberost said

    I was here too, xDDD

  9.   Manuel de la Fuente said

    Well, I get Tux's face and of course I have the user agent well configured ...

  10.   Manuel de la Fuente said

    With the previous theme I did get the Arch logo, so it seems they screwed up again, hahaha.

    1.    KZKG ^ Gaara said

      I'll make an adjustment, give me a few minutes 😉

      Edited: Correction ... done the adjustment, tell me if the Arch logo does appear now.

  11.   Rogger Ortega (@ cronos426) said

    I still get the penguin 🙁

    1.    KZKG ^ Gaara said

      What distro do you use?
      Have you already configured the UserAgent in Firefox?

  12.   dwarf said

    It runs fine to me.

  13.   Josue Hernandez Rivas said

    see if it works ...

    1.    KZKG ^ Gaara said

      Configure the UserAgent in Iceweasel, in the post I left a tutorial 😉

  14.   Miguel said

    Sometimes we will enter with Güindous from work ...
    It is painful but it is what it is (at least we have work, for now;))

  15.   elip89 said

    Working great with Arch Linux and Chromium 😀

    regards

    1.    KZKG ^ Gaara said

      Thanks 😉

  16.   Christopher said

    I have a question, why don't they use the same algorithm that they use in the comments to detect the OS.

    1.    KZKG ^ Gaara said

      Actually, we do use the same logic, only that the comments have a lot more distros supported, programmed, because they have been programming that algorithm for longer hahaha, we just need time 😉

  17.   Alejandro Mora said

    Great! Thank you guys very much, I love this site.

    1.    KZKG ^ Gaara said

      Thanks to you friend, a pleasure.

  18.   Manuel de la Fuente said

    It works now. 🙂

    1.    KZKG ^ Gaara said

      lol of course it works, a fix made by me obviously that solves the problem…. LOL.

      1.    Manuel de la Fuente said

        Again I get Tux's face. 🙁

        1.    KZKG ^ Gaara said

          Done, fix again 😉

  19.   SantanAG said

    Testing!

  20.   AurosZx said

    Test message 😉

  21.   armandoplc said

    testing

  22.   armandoplc said

    Noooooooo .. I'm not on windbuntu ... I'm from Chakra ...

    1.    KZKG ^ Gaara said

      Chakra we still do not support it, that is, I have to make the logo and add the lines of code to detect it, do not worry that this week that will just begin, Chakra will already be supported, I will make a post announcing it 😉

  23.   davidlg said

    I'm in Archbang and it tells me Debian

    1.    KZKG ^ Gaara said

      You have to configure the Chromium UserAgent to indicate that you use Archbang, this is not our fault hehe, notice that even in your comments the Debian logo appears 😉

  24.   proper said

    It works out of hair

    1.    KZKG ^ Gaara said

      That means it works fine right? HAHA

  25.   janofx said

    That good, it works very well

    1.    KZKG ^ Gaara said

      Thank you ^ - ^

  26.   Abraham said

    testing

  27.   Abraham said

    Working on shot

    1.    KZKG ^ Gaara said

      Thanks for the notice 😉

  28.   ieje said

    testing

  29.   ieje said

    it does not detect my archlinux, is it due to using iron : s

    1.    KZKG ^ Gaara said

      As much as possible, but the solution is simple.
      Look in the post, there I left the link to a tutorial on how to change the UserAgent in Iron, with that tutorial you can make the small configuration that will show you the logo of the distro 😉

  30.   Jotaele said

    Perfect, Debian already detects me.

    1.    KZKG ^ Gaara said

      Nice 😀

  31.   David De L said

    Testing…

  32.   David De L said

    I am using Ubuntu 12.04 however it only says I use GNU / LInux

  33.   Sys said

    Using Kubuntu, on the main page of desdelinux.net ... I get the Ubuntu symbol

  34.   Sys said

    However, on this same page I see the correct Kubuntu symbol.

    My "general.useragent.override" is:
    general.useragent.override; Mozilla / 5.0 (X11; Kubuntu; Linux x86_64; rv: 14.0) Gecko / 20100101 Firefox / 14.0.1

    I repeat: using Kubuntu, on the main page of desdelinux.net ... I see "To access FromLinux you use" and to its right the Ubuntu symbol

    1.    KZKG ^ Gaara said

      O_O ... damn weird, I'm checking that right now.
      Thanks for the feedback friend 😉

      1.    Sys said

        At this moment when entering https://blog.desdelinux.net I get the Kubuntu symbol. OKAY!

        1.    KZKG ^ Gaara said

          Yep, I did a little fix that must have fixed the error with Kubuntu 😉

      2.    Sys said

        My, my, it turns out that the Kubuntu symbol that appears… is the old one. Ubuntu and Kubuntu changed emblems more than two years ago.

        The good is the one that appears in
        https://upload.wikimedia.org/wikipedia/commons/6/60/KubuntuCoF.svg

        You can see some of its change in: https://en.wikipedia.org/wiki/File:KubuntuCoF.svg

        1.    KZKG ^ Gaara said

          Oops… my mistake 😀
          Ready, right now I corrected the logo and put the one you gave me, thank you again for the help 😉

          You must do [F5] for your browser to load the new .PNG.

          1.    Sys said

            The large Kubuntu symbol, which appears when entering from linux.net, has been updated.

            The one that remains to be updated is the small one, the one seen above this comment 😛, it is https://blog.desdelinux.net/wp-content/plugins/wp-useragent/img/16/os/kubuntu-1.png but it seems like it would have to be https://blog.desdelinux.net/wp-content/plugins/wp-useragent/img/16/os/kubuntu-2.png

  35.   Anonymous said

    =)

  36.   khourt said

    I started using Mageia 2 days ago, and I only see the linux penguin, which is not bad at all, but if I would like the «calderito»

    Interesting the web !!!

    1.    KZKG ^ Gaara said

      Hello, how are you?
      First of all ... WELCOME to the site ^ - ^

      You should change the UserAgent in Chrome to tell the site that you use Linux yes, but specifically Mageia. Above we leave some links to two tutorials on how to do this in Chromium, which is not Chrome specifically, but the principle is the same 😉

      Greetings and thanks for your visit and comment

  37.   Pavloco said

    Three comments nothing more,
    1- The links to the tutorials are poorly arranged
    2- In a moment I'll give you the Xubuntu SVG.
    3- Testing if Xubuntu appears in the comment.

    1.    KZKG ^ Gaara said

      Uff my mistake with the links hehe, I just fixed them, thanks 😀
      Yep, I got the email with the Xubuntu logo, in this week that will begin shortly we will make another update on the theme, there will already be the code for Xubuntu and more distros 😀
      About the logo in the comment, okis too 😉

      Thank you very much for all my friend.

      1.    Manuel de la Fuente said

        They are all still wrong. : S

        1.    KZKG ^ Gaara said

          How all wrong?

          1.    Manuel de la Fuente said

            The links that Pavloco said are all wrong. And I don't know if this blog is haunted or I'm the one who sees visions, but Tux's face keeps popping up, hahaha. o_O

            1.    KZKG ^ Gaara said

              Oops ... my mistake, is that yesterday I fixed this detail, but today when we upload the new update of the site, the fix was not in the update so it returned to the previous state.

              Nothing, which should already be solved, and right now I add the fix for Arch to the ToDo so that it does not happen to us again hahaha.
              Is already showing well right?


          2.    Manuel de la Fuente said

            Now for now. 😛

          3.    Manuel de la Fuente said

            The first two links are still bad.

            1.    KZKG ^ Gaara said

              Done 😀


          4.    Manuel de la Fuente said

            Hell, keep the Tux coming out of his grave. This penguin revives more times than Krillin.

      2.    Rayonant said

        Now it appears, thanks for adding support for Xubuntu, mouse up! xD

        1.    KZKG ^ Gaara said

          Thanks to you for the patience you have with us hehe.

  38.   Pavloco said

    Hahaha if it appears, but the one of the previous versions appears, if you change it for the one I send you it would be cool ... please: D.

  39.   Algabe said

    The new design looks re-good and now if it tells me which distro I am using because I have no idea which one it was using (it's a joke). 🙂

    1.    KZKG ^ Gaara said

      HAHAHAJAJAJAJA !!!!
      Thanks for the comment 😀

  40.   Yoyo Fernandez said

    Well, my Debian does not recognize it (yesterday I installed testing with KDE) using Firefox and without touching the user agent.

    SolusOS which is a Debian based either, from Windows I have not entered yet or from Ubuntu and on Mac it does not recognize me either, does it? I get the worker working with the shovel in the pile of sand.

    Let's see the proof. Commenting from OS X Mountain Lion with Firefox 14.0.1

    1.    KZKG ^ Gaara said

      It is that Debian does not configure any UserAgent in the browser when you install it 🙁
      You have to configure the UA yourself.

      SolusOS does not support it yet, but as soon as I have the logo in PNG or SVG I will 😉

      Mac still doesn't support it, but Ubuntu and Windows do 😀

      1.    Manuel de la Fuente said

        I can't stand Mac either. 😛

  41.   Yoyo Fernandez said

    Confirmed, in the comments if it appears that I am on Mac but above in the banner I get the underpaid worker working from sunrise to sunset: - /

  42.   Stow Kewoto Fume said

    In the list it says that it supports kubuntu, but it appears to me that I use ubuntu.

    1.    KZKG ^ Gaara said

      Yep, I have to check this code because it worked well for me in the testing phase O_O.
      However, have you tried changing Chrome's UserAgent?

  43.   Manuel de la Fuente said

    Well, let's see if you're already "fixing" the comments too, I'm getting tired of not being able to nest any response. ¬¬

  44.   elip89 said

    Here is the link where you can get Lubuntu artwork http://lubuntublog.blogspot.com/p/artwork.html maybe they can find the logo they need

    regards

  45.   davidlg said

    now yes, I did the UserAgent and now it works (before I would do it wrong hehe)

  46.   davidlg said

    here he has not recognized me

    1.    KZKG ^ Gaara said

      What UserAgent are you putting in?

  47.   jamin-samuel said

    well he doesn't recognize me 🙁

    I put this in the user agent:

    / opt / google / chrome / google-chrome –user-agent = »Mozilla / 5.0 (X11; Linux x86_64) AppleWebKit / 535.1 (KHTML, like Gecko) Ubuntu Chrome / 19.0.1084.46 Safari / 535.1 ″% U

  48.   Algabe said

    Try following these steps.

    locate chrome.desktop
    and edit the following.
    sudo nano /usr/local/share/applications/google-chrome.desktop
    Look for the line “Exec = / opt / google / chrome / google-chrome” and leave it as follows.
    Exec = / opt / google / chrome / google-chrome –user-agent = ”Mozilla / 5.0 (X11; Linux x86_64) AppleWebKit / 535.1 (KHTML, like Gecko) Ubuntu Chrome / 19.0.1084.46 Safari / 535.1 ″% U
    Maybe I can help you 🙂

  49.   Pavloco said

    Thanks to you, for having so much attention with the users 🙂.

    1.    KZKG ^ Gaara said

      At this very moment I am adding support for Xubuntu lol

  50.   davidlg said

    Let's see now

  51.   Tent said

    Testing Android and chrome

  52.   JP (@edconocerte) said

    Testing…

  53.   Rogger Ortega (@ cronos426) said

    It still does not detect Chakra 🙁

  54.   Rogger Ortega (@ cronos426) said

    still 🙁

    1.    KZKG ^ Gaara said

      Ready, you should detect it already, a little mistake of mine 😉

  55.   lolopolooza said

    Let's see what comes out to me… .hehehehe

  56.   cronos said

    yes now yes, yupiiiiiiiiiiiii 🙂

  57.   cronos said

    trying again 🙂

  58.   cronos said

    rare thing does not come out again 🙁

  59.   gerno said

    And editing the UA by hand does Xubuntu recognize? I don't know why Ubuntu came out .. 🙁

    1.    KZKG ^ Gaara said

      Yep, without a doubt you will get Xubuntu 😉

  60.   Leper_Ivan said

    Mozilla / 5.0 (X11; Linux x86_64) AppleWebKit / 535.2 (KHTML, like Gecko) ArchLinux Iron / 15.0.900.2 Safari / 535.2

    That's the UA.ini line for Iron and ArchLinux.

  61.   Jotaele said

    Testing Icewasel-Debian

  62.   Rekonq said

    Testing with Rekonq

    1.    Rekonq said

      By the way, the Rekonq icon can be copied from http://en.wikipedia.org/wiki/File:Rekonq-0.3.svg

      1.    KZKG ^ Gaara said

        Yeah I have the icon, I just haven't made any changes yet to the plugin that shows the icons in the comments.

  63.   longinus said

    From my newly installed Arch LInux

  64.   Jotaele said

    Excuse the tests 😀 now it's to check the avatar change.

    1.    KZKG ^ Gaara said

      Nothing to excuse 😉

  65.   Wisp said

    Fantabulous.

  66.   Juancho said

    Oral, if it comes out

    1.    KZKG ^ Gaara said

      😉

  67.   Steve said

    Works great.

  68.   eleefece said

    Testing Rekonq + Kubuntu 12.04

    1.    KZKG ^ Gaara said

      hehe, I just just added the Rekonq icon to the comments

  69.   Wisp said

    I also want to continue playing the user agent

  70.   Rots87 said

    testing with iron

  71.   the pixie said

    Xubuntu

  72.   Alex said

    In Firefox you couldn't use o 'general.useragent.vendor'?

  73.   x11tete11x said

    Gentoo + google chrome does not detect me 🙂

    1.    Manuel de la Fuente said

      You have not configured your user agent. Check the links in the entry on how to change it in Chromium (the method is the same as in Chrome) and check if this works for you:

      Mozilla/5.0 (X11; Linux i686; U;) AppleWebKit/535.7 (KHTML, like Gecko) Gentoo Chrome/22.0.1229.26 Safari/535.7

  74.   Manuel_SAR said

    I am using Midori and Fedora and it does not output = (

  75.   DMoZ said

    And can you tell me which Distro use xD ??? ...

    1.    KZKG ^ Gaara said

      HAHAHA that means that your browser does not tell the sign what you use 😀
      You must configure your UserAgent.

      1.    Anonymous said

        Regarding browsers, do the comments also recognize Icecat?

        1.    KZKG ^ Gaara said

          Yes, if the browser indicates which one it is, it does recognize it 🙂

  76.   @Jlcmux said

    I was looking for this. Very very useful

  77.   @Jlcmux said

    I did it and it effectively changed my icons but now GMAIL and Others tell me that my browser is old and does not load all the components 😛

    1.    KZKG ^ Gaara said

      Add it to the WebKit chain to see 🙂

  78.   Jose Miguel said

    Probannnnndooooo…! (Xubuntu)

  79.   Mandriva said

    Hello

  80.   Old man said

    testing (iron + manjaro)

  81.   Old man said

    testing with SolusOS

    1.    Zironid said

      It works for you? not me 🙁

  82.   federico said

    testing

  83.   federico said

    testing with opera

  84.   Rayonant said

    Testing Arch + Midori + Xfce

  85.   lawliet @ debian said

    Hello, I am using the best distribution of all, I do not want to discuss that here, if you want to discuss that go to another topic or forum.

    1.    Manuel de la Fuente said

      No, the one who is using the best distribution of all is me, but I don't want to discuss that here either, if you want to discuss that, go to another topic or forum.

  86.   Martial del Valle said

    Let's see what appears, I use arch ..

  87.   itachi said

    let's see if it comes out

    1.    itachi said

      another test

  88.   itachi said

    see

  89.   Sasha said

    I get a worker working, it will be because I'm in the psp hehe

  90.   itachi said

    testing debian

  91.   itachi said

    prueba

  92.   Julius Caesar said

    test

  93.   Julius Caesar said

    test fix user agent

  94.   WIDTH said

    Very good

    1.    WIDTH said

      UUUUUUU

  95.   WIDTH said

    sorry

  96.   VulkHead said

    test

  97.   VulkHead said

    test2

    1.    VulkHead said

      test3

      1.    VulkHead said

        test4

        1.    VulkHead said

          now it's cute

          1.    VulkHead said

            XD

  98.   Paul said

    Does anyone know how to configure debian firefox?

  99.   msx said

    Testing, testing, oh! oh, one, two, three, oh! oh, testing, testing
    (Cacho test went well, let's eat something!)

  100.   msx said

    Accessing from Chakra with Chromium.

  101.   itachi said

    testing konqueror

  102.   oscar said

    In my case Ubuntu always appears but I use Xubuntu! 🙂

  103.   oscar said

    Trying to change the user agent ...

  104.   oscar said

    Redios ...

    1.    oscar said

      Putting only Firefox and Xubuntu 12.04

  105.   oscar said

    Okay! Now it is correct. But then it always changes me back to the ubuntu logo.

    Good thank you! 🙂

  106.   Wisp said

    1

  107.   Wisp said

    2

  108.   Percaff_TI99 said

    Testing xfce

  109.   Percaff_TI99 said

    Testing Arch + Kde

  110.   ddavid said

    Very interesting, knowing the distros of each one, I have seen several windows.

    1.    sputnik said

      weeeeeeeeeeee

      1.    sputnik said

        yeah

  111.   Brutico said

    I am unable to do it

  112.   Brutico said

    testing..

  113.   ivan74 said

    testing, should come out manjaro and firefox