DEBIAN 10: Kiaj ekstraj pakoj utilas post instalado?

DEBIAN 10: Kiaj ekstraj pakoj utilas post instalado?

DEBIAN 10: Kiaj ekstraj pakoj utilas post instalado?

Ĉi tiu artikolo estas la daŭrigo (dua parto) de la tutoriales dediĉita al DEBIAN GNU / Linukso Distro, versio 10 (Rompilo), kiu servas kiel bazo por multaj aliaj kiel MX-Linukso 19 (Malbela Anasido).

Ĉi tiun duan parton ni montros tiun alian kromaj aŭ aldonaj pakaĵoj (aplikaĵoj) estas la rekomendita por sekvi optimumigi (kompletigi) niaj belaj kaj bonegaj Distroj DEBIAN 10 kaj MX-Linukso 19.

Ĝisdatigu kaj optimumigu MX-Linukso 19.0 kaj DEBIAN 10.2 post instalado

Ĝisdatigu kaj optimumigu MX-Linukso 19.0 kaj DEBIAN 10.2 post instalado

Ekde, la unua parto de ĉi tiu lernila serio, nomata "Ĝisdatigu kaj optimumigu MX-Linukso 19.0 kaj DEBIAN 10.2 post instalado" estis koncentrita al esencaj bazaj agoj kaj pakoj necesa por a unua ĝisdatigo, personigo kaj optimumigo el ili, tio estas la unuaj post-instalaj paŝoj iam instalitaj.

Kaj citante la antaŭan artikolon, memoru la jenon:

"Memoru, ke la agoj kaj pakaĵoj rekomenditaj ĉi tie por ruliĝi kaj instali estas nur tio, "pakoj rekomendita", kaj dependas de ĉiu funkciigi kaj instali ĉiujn aŭ iujn el ili, kial ili estas necesaj aŭ utilaj, baldaŭ aŭ meze, por koni kaj uzi ilin, havante ilin jam funkciigitaj aŭ instalitaj.

Kaj memoru, ke ĉi tiuj agoj kaj / aŭ pakaĵoj estis antaŭe testita sur ambaŭ Distroj, kaj ili ne petas malinstali pakaĵojn instalitajn defaŭlte en ĉi tiuj. Plue, ili ne pliigas la konsumon de memoro aŭ CPU ĉar ili ne ŝarĝas procezojn aŭ demonojn (servoj) en memoro defaŭlte. Por scii anticipe por kio uzas ĉiu pakaĵo, alklaku Ĉi tie."

Debian 10 Buster

DEBIAN 10: Utilaj ekstraj pakaĵoj por instali

Aplikoj pri Denaskaj Ludoj

apt install games-adventure games-arcade games-board games-card games-chess games-console games-education games-emulator games-fps games-java-dev games-mud games-platform games-programming games-puzzle games-racing games-rogue games-rpg games-shootemup games-simulation games-sport games-strategy games-tasks games-toys games-typing

Objektivo: Instalu specifajn ludpakaĵojn laŭ difinitaj kategorioj

apt install atari800 cen64 cen64-qt desmume dolphin-emu dosbox fs-uae fs-uae-arcade fs-uae-launcher fs-uae-netplay-server games-emulator gbsplay gngb gnome-nds-thumbnailer hatari higan mame mame-data mame-extra mame-tools mednafen mednaffe mess-desktop-entries mgba-common mgba-qt mgba-sdl mupen64plus-audio-all mupen64plus-data mupen64plus-input-all mupen64plus-qt mupen64plus-rsp-all mupen64plus-rsp-hle mupen64plus-rsp-z64 mupen64plus-ui-console mupen64plus-video-all mupen64plus-video-arachnoid mupen64plus-video-glide64 mupen64plus-video-glide64mk2 mupen64plus-video-rice mupen64plus-video-z64 nestopia osmose-emulator pcsxr stella vice virtualjaguar visualboyadvance xmms2-plugin-gme yabause yabause-common yabause-gtk yabause-qt yakuake

Objektivo: Instalu retro-konzolajn emulilojn.

Video-subteno

apt install xserver-xorg-video-all libva-drm2 libva-glx2 libva-wayland2 libva-x11-2 libva2

Objektivo: Instalu bazan video-pelilon, kutime enkonstruitan.

Aŭda subteno

apt install alsa-firmware-loaders alsa-oss alsa-tools alsa-utils alsamixergui volumeicon-alsa paprefs pavumeter pulseaudio-utils ffmpeg2theora sound-icons

apt install lame libdvdnav4 libdvdread4 libfaac0 libmad0 libmp3lame0 libquicktime2 libstdc++5 libxvidcore4 twolame vorbis-tools x264

apt install gstreamer1.0-x gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-alsa gstreamer1.0-pulseaudio gstreamer1.0-tools

Objektivo: Instalu la bazan subtenon de sonaj peliloj, kutime integritaj. Kaj aliaj aplikoj, akcesoraĵoj kaj bibliotekoj necesaj por la mastrumado de sono kaj sono en komputiloj.

Subteno por presado kaj skanado de aparatoj

apt install cups cups-client cups-bsd cups-filters cups-pdf cups-ppdc

apt install foomatic-db-compressed-ppds foomatic-db-engine ghostscript-x ghostscript-cups gocr-tk gutenprint-locales hannah-foo2zjs hpijs-ppds hplip openprinting-ppds printer-driver-all printer-driver-cups-pdf printer-driver-foo2zjs printer-driver-hpcups printer-driver-hpijs

apt install avahi-utils colord flex g++ libtool python-dev sane sane-utils system-config-printer system-config-printer-udev unpaper xsane xsltproc zlibc

Objektivo: Instalu la bazan subtenon de peliloj, programoj, aldonaĵoj kaj bibliotekoj necesaj por administri presajn kaj skanajn aparatojn.

Subteno por oficejaj programoj

apt install fonts-arabeyes fonts-cantarell fonts-freefarsi fonts-liberation fonts-lyx fonts-mathjax fonts-oflb-asana-math fonts-opensymbol fonts-sil-gentium fonts-stix myspell-es ooo-thumbnailer xfonts-intl-arabic xfonts-intl-asian xfonts-intl-chinese xfonts-intl-chinese-big xfonts-intl-european xfonts-intl-japanese xfonts-intl-japanese-big ttf-bitstream-vera ttf-dejavu ttf-summersby

apt install libreoffice libreoffice-base libreoffice-gnome libreoffice-gtk3 libreoffice-help-es libreoffice-java-common libreoffice-l10n-es libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin libreoffice-style-breeze libreoffice-style-elementary libreoffice-style-sifr

apt install pdfarranger pdfshuffler pdftk

Objektivo: Instalu bazan subtenon por oficejaj programoj, aldonaĵoj kaj tiparoj.

Subteno por kongruo de Windows HW kaj SW

apt install cifs-utils disk-manager dosfstools exfat-fuse exfat-utils fuse gvfs-fuse hfsplus hfsutils icoutils ideviceinstaller ipheth-utils libsmbclient mtools mtp-tools ntfs-3g python-smbc smbclient samba-common smbnetfs samba samba-common-bin

apt install cabextract fonts-wine mscompress playonlinux q4wine ttf-mscorefonts-installer winetricks

apt install ndiswrapper

Objektivo: Instalu bazan subtenon por kongruo kun la HW kaj SW de aliaj Operaciumoj, ĉefe MS Windows.

Subteno por Computer HW

apt install acpi acpitool acpi-support fancontrol firmware-linux-free hardinfo hwdata hwinfo irqbalance iucode-tool laptop-detect lm-sensors lshw lsscsi smartmontools xsensors

Objektivo: Instalu la bazan subtenon por kongruo kun la ĝenerala HW de komputiloj.

apt install intel-microcode

apt install amd64-microcode

Objektivo: Instalu bazan CPU-instrukcian subtenon por kongruo kun procesoroj Intel kaj AMD.

sensors-detect
chmod u+s /usr/sbin/hddtemp
hddtemp /dev/sda

Objektivo: Instalu la bazan subtenon de iloj kaj peliloj por la mastrumado de temperaturoj, tensio de la elementoj de la komputilo, inkluzive la mastrumadon de la ventoliloj.

Subteno por sendrataj konektaj aparatoj

apt install wifi-radar wireless-tools wpagui wpasupplicant

Objektivo: Instalu bazan aplikaĵon por administri sendratajn aparatojn en komputilo.

apt install firmware-atheros

apt install firmware-b43-installer firmware-b43legacy-installer firmware-bnx2 firmware-bnx2x firmware-brcm80211

apt install firmware-intelwimax firmware-iwlwifi

apt install firmware-ralink firmware-realtek

Objektivo: Instalu bazan ŝoforan subtenon por administri sendratajn aparatojn (WiFi) en komputilo.

Subteno por bluetooth-ligaj aparatoj

apt install bluetooth bluez bluez-cups bluez-firmware bluez-tools btscanner gnome-bluetooth python-bluez pulseaudio-module-bluetooth

Objektivo: Instalu la bazan ŝoforan subtenon por administrado de sendrataj konektaj aparatoj (bluetooth) de komputilo.

Subteno por USB-retkonektaj aparatoj

apt install mobile-broadband-provider-info ppp pppconfig modemmanager modem-manager-gui modem-manager-gui-help usb-modeswitch usb-modeswitch-data wvdial

Objektivo: Instalu bazan programon kaj ŝoforan subtenon por administri USB-retkonektajn aparatojn konektitajn al komputilo.

Subteno por moveblaj plurmediaj aparatoj

apt install gammu gtkpod libgammu-i18n libgpod-common libgpod-cil libgpod4 libmtp-runtime mtp-tools wammu

Objektivo: Instalu la bazan subtenon de aplikoj kaj bibliotekoj por mastrumi plurmediajn aparatojn konektitajn al komputilo.

Debian 10

konkludo

Ni esperas tion ĉi tiu "utila afiŝeto" pri kio kromaj aplikoj povas esti instalita sur GNU / Linukso-Distroj «DEBIAN y MX-Linux», en siaj plej freŝaj kaj aktualaj versioj por la jaro 2020, atingenda «actualizarlas y optimizarlas», tre interesas kaj utilas, por la tuto «Comunidad de Software Libre y Código Abierto» kaj de granda kontribuo al la disvastigo de la mirinda, giganta kaj kreskanta ekosistemo de aplikoj de kaj por «GNU/Linux».

Kaj por pliaj informoj, ĉiam ne hezitu viziti iun ajn Interreta biblioteko kiel OpenLibra y JedIT legi libroj (PDF-oj) pri ĉi tiu temo aŭ aliaj sciaj areoj. Nuntempe, se vi ŝatis ĉi tion «publicación», ne ĉesu dividi ĝin kun aliaj, en via Plej ŝatataj retejoj, kanaloj, grupoj aŭ komunumoj de sociaj retoj, prefere senpagaj kaj malfermaj kiel Mastodon, aŭ sekura kaj privata kiel Telegramo.

Aŭ simple vizitu nian ĉefpaĝon ĉe De Linukso aŭ aliĝu al la oficiala Kanalo Telegramo de DesdeLinux legi kaj voĉdoni por ĉi tiu aŭ aliaj interesaj eldonaĵoj pri «Software Libre», «Código Abierto», «GNU/Linux» kaj aliaj temoj rilataj al «Informática y la Computación»kaj la «Actualidad tecnológica».


La enhavo de la artikolo aliĝas al niaj principoj de redakcia etiko. Por raporti eraron alklaku Ĉi tie.

10 komentoj, lasu la viajn

Lasu vian komenton

Via retpoŝta adreso ne estos eldonita. Postulita kampojn estas markita per *

*

*

  1. Respondeculo pri la datumoj: Miguel Ángel Gatón
  2. Celo de la datumoj: Kontrola SPAM, administrado de komentoj.
  3. Legitimado: Via konsento
  4. Komunikado de la datumoj: La datumoj ne estos komunikitaj al triaj krom per laŭleĝa devo.
  5. Stokado de datumoj: Datumbazo gastigita de Occentus Networks (EU)
  6. Rajtoj: Iam ajn vi povas limigi, retrovi kaj forigi viajn informojn.

  1.   Alberto Guerra diris

    La pdftk estis tre utila por mi kunligi plurajn pdf-dosierojn en unu dokumenton per la komandlinio.
    Ekzemplo:
    pdftk dosiero_0001.pdf dosiero_0002.pdf dosiero_0003.pdf eliro de kato dosiero_123.pdf

    1.    Linuksa Afiŝinstalo diris

      Dankon Alberto. Por via kontribuo. Mi inkluzivis ĝin en la sekcion Subteno por oficejaj programoj de la artikolo, ĉar mi rimarkis, ke mi ne metis aplikaĵojn (pakojn) por progresinta administrado de PDF-dosieroj.

      Enmetu ĉi tiun linion: apt install pdfarranger pdfshuffler pdftk

      La aliaj 2 estas por la sama sed de la grafika uzantinterfaco (GUI).

  2.   Fran diris

    Dankon, ĝi estas tre grava kontribuo por multaj el ni, kiuj nur volas komenci en la Debiana mondo

    1.    Linuksa Afiŝinstalo diris

      Salutojn, Fran! Dankon pro via pozitiva komento pri la artikolo.

  3.   RubenMTL diris

    Saluton !. Koran dankon pro ĉi tiu afiŝo, ĝi estis tre utila al mi, ĉar mi ĵus ŝanĝis al Debian 10, plasmo KDE. Mi instalis la vastan plimulton senprobleme. kvankam nun mi detaligas la problemojn, kiujn mi havis kun iuj, kiuj ne estis instalitaj.
    Kun la pakaĵo alsa-firmware-loaders mi ricevis:

    E: La pakaĵo alsa-firmware-loaders ne povis troviĝi

    Kaj la samo okazis al mi kun ĉi tiuj aliaj pakoj: libfaac0, amd64-microcode, firmware-atheros, firmware-b43-installer, firmware-b43legacy-installer, firmware-bnx2, firmware-bnx2x, firmware-brcm80211, firmware-intelwimax, firmware- iwlwifi, firmware-ralink, firmware-realtek, bluez-firmware.

    1.    Linuksa Afiŝinstalo diris

      Salutojn RubenMTL! Dankon pro via komento kaj observado. Mi provos instali DEBIAN 10.3 tre baldaŭ por retesti ĉiun pakaĵon kaj revalidigi ĉiun nuntempe ekzistantan pakaĵon.

      1.    RubenMTL diris

        Ne dankinde!. Bonege !!. Dankon al vi pro via tempo, salutojn. !!

  4.   RubenMTL diris

    Alia afiŝo aperinta estis kun la pakaĵo hannah-foo2zjs:

    La pako hannah-foo2zjs ne disponeblas, sed iuj aliaj pakaĵoj aludas ĝin. Ĉi tio povas signifi, ke la pakaĵo mankas, malmoderna aŭ havebla nur de iu alia fonto.

    E: La pako hannah-foo2zjs ne havas kandidaton por instalado.

    Ĉi tio ankaŭ aperas kun la pakaĵoj: ttf-mscorefonts-installer, winetricks, playonlinux, iucode-tool

    Fine, kiam mi volis rekomenci de la terminalo, mi estis markita kaj mi devis malŝalti la kajeron de la butono de ŝaltilo, ĉar ĝi ne respondis. Kaj unufoje komencita la programo revenis, mi provis rekomenci ĝin ĉi-foje de la labortablo kaj ĝi ankaŭ estas kontrolita ... do denove mi devas fari ĝin de la butono sur la kajero. Neniam mi povas rekomenci aŭ fermi min de la labortablo, mi devas fari ĝin se aŭ se mi premas la butonon.

    Mi esperas, ke vi povas helpi min solvi ĉi tiujn problemojn, dankon pro via tempo, salutojn!

    1.    Linuksa Afiŝinstalo diris

      Salutojn RubenMTL! Mi ne povus precize diri al vi. Io devas esti ŝanĝita rilate al Potenca Administrado (ACPI). 🙁

      1.    RubenMTL diris

        Neniu dramo, dankinde ĉiuokaze pro la helpo! Saluton !!