Kiel agordi laserajn presilojn de Brother ĉe linux

Plej multaj GNU / Linukso-nuntempaj distribuoj havas grandan subtenon por la plej moderna aparataro, tamen ekzistas ankoraŭ iuj aparataj fabrikantoj, kiuj malhelpas iumaniere, ke nia amata operaciumo povas esti kongrua kun ilia solvo. Bonŝance por multaj, ĉi tio ne estas la kazo por tiuj el ni, kiuj uzas presilojn de markoj Brother, ĉar ili havas denaskajn pelilojn por Linukso.

Mi nuntempe havas la Lasera printilo Brother DCP-L2550DNNe estas mirinda presilo, sed se ĝi permesas al mi presi rapide, bonkvalite kaj plenumi la kostajn atendojn, estas ankaŭ sufiĉe facile aĉeti malmultekostajn kartoĉojn Brother TN2410 kaj TN2420, kiuj estas tiuj, kiujn uzas ĉi tiu ekipaĵo. En Linukso-Monfarejo mi fartas sufiĉe bonege, kvankam kiam mi havis delikatecon, mi suferis iom pli ol normale por povi igi ĝin funkcii, do estas bone klarigi la procedon, kiun uzantoj kun similaj ekipaĵoj devas fari.

La unua afero, kiun uzantoj havas printilojn de ĉi tiu marko, devas fari estas paĝo de fratoj linux-peliloj kaj elŝutu la ŝoforojn por la specifa presila modelo, ili estas distribuitaj per la diversa aparataro distribuita de la kompanio (CUPS, LPR, Skanilo, ADS, laseraj presiloj, inter aliaj). Ĉiu kategorio da peliloj ofertas al ni solvon por la produktoj asociitaj kun ĝi, tial ekzemple la sama pelilo povas funkcii por la presiloj Brother DCP-L2510D, Brother HL-L2310D kaj Brother MFC-L2710DN.

Brother ofertas al ni en sia paĝo pri instalado de ŝoforo specifan manlibron por uzi laŭ nia distribuo, la aparatara modelo kaj ĝia arkitekturo, same donas al ni la eblon povi kontroli la ĝustan funkciadon de la presilo, la agordon la speco de papero aŭ eĉ la stato de viaj kartoĉoj.

La procezo ĝenerale estas simpla, ni iras al la paĝo de peliloj Brother, elŝutas la pelilon kongruan kun nia aparataro kaj nia distro, kaj instalas la bazajn pakojn per la jena komando:

sudo apt install brother-cups-wrapper-extrabrother-lpr-drivers-extra

Poste ni rekomencas nian komputilon kaj instalas la ŝoforojn, ĉar la subtena paĝo de Brother ne indikas, en iuj kazoj ni devas iri al la sekcio Sistemoj / Administrado / Presiloj (kiel taŭgas en via distro) kaj elekti la presilon, kiun vi ĵus instalis, tiamaniere ni povos uzi nian presilon denaske.


La enhavo de la artikolo aliĝas al niaj principoj de redakcia etiko. Por raporti eraron alklaku Ĉi tie.

17 komentoj, lasu la viajn

Lasu vian komenton

Via retpoŝta adreso ne estos eldonita. Postulita kampojn estas markita per *

*

*

  1. Respondeculo pri la datumoj: Miguel Ángel Gatón
  2. Celo de la datumoj: Kontrola SPAM, administrado de komentoj.
  3. Legitimado: Via konsento
  4. Komunikado de la datumoj: La datumoj ne estos komunikitaj al triaj krom per laŭleĝa devo.
  5. Stokado de datumoj: Datumbazo gastigita de Occentus Networks (EU)
  6. Rajtoj: Iam ajn vi povas limigi, retrovi kaj forigi viajn informojn.

  1.   anonima diris

    Saluton:
    Mi uzas fraton dcp 7065dn en manjaro gnome kaj la ŝoforoj estas en AUR.
    Ĉi tiuj presiloj kutime havas ŝoforojn en rpm kaj deb por archlinux kaj derivaĵoj estas kutime en AUR kaj por gentoo estas frata surmeto.
    Salutojn.

    1.    lacerto diris

      efike

  2.   DAC diris

    Ĉu la ŝoforoj estas libera programaro - malfermfonteco?

    1.    lacerto diris

      Ĉi-kaze ili estas peliloj por Linukso, sed la fontoj ne haveblas (ili ne estas malfermfontaj), bedaŭrinde

  3.   Barbara diris

    Laŭ tio, kion ili diras, almenaŭ Frato havas pli da subteno ol Ricoh. Mi havas Ricoh-multifunkcian SP310spnw, kiu estas bonega, sed se temas pri uzi ĝin en Linukso, ĝi donas multajn kapdolorojn, kaj nur la presan parton uzeblas. Subteno de Ricoh estas preskaŭ neekzistanta, kaj kvankam ĝi supozeble havas pelilojn por Linukso, provante instali ilin ĝi donas eraron, ĉar ... CUPS funkcias !!! Mi havas ĝin de preskaŭ jaro kaj kvankam mi tuj sendis retpoŝton al Ricoh petante ilin trovi manieron krei taŭgajn ŝoforojn, ĝis nun ili eĉ ne konfesis ricevon de la retpoŝto. Mi devas uzi alian OS por povi skani.

  4.   alberto diris

    Mi uzas tre malmultekostan fratan laseron HL-2135W-fraton kaj ĝi estas bonega en Linukso dum jaroj. Tre feliĉa.

  5.   Puigdemont 64 bitoj diris

    La 1210w estas instalitaj uzante la malmodernan pkgbuild kaj modifante ĝin, al ĝi mankas kelkaj citaĵoj, sed ĝi funkcias bone.

  6.   Guille diris

    Ne aĉetu Fraton, aĉetu HP, kaj mi klarigos kial: Jes, ili havas ŝoforojn por GNU / Linukso, sed ili estas proprietaj. Se post X jaroj ili ĉesos ĝisdatigi siajn ŝoforojn por la novaj kernoj kaj ili ĉesos funkcii, ili lasos vin kuŝi kaj neniu povos modifi la kodon ĉar ni ne havas ĝin. En la laboro ni uzas la Brother DCP7065dn.
    Ankaŭ zorgu pri HP, ĉar ĝi ankaŭ havas presilojn sen senpagaj ŝoforoj, kiel HP LaserJet Pro CP1025nw. Aĉetu nur tiujn, kiuj havas senpagajn ŝoforojn por eviti estontan eldevigon aĉeti novan presilon aŭ novan permesilon Vindozo aŭ Mac OS (por kiu ili ĉiam havas ŝoforojn).
    Ne aĉetu iaokaze SHARP-presilon, ni havas la kopiilon / presilon MX 2310U: unue ĝia pelilo-instalilo por linukso (http://www.sharp.es/cps/rde/xchg/es/hs.xsl/-/html/centro-de-descargas.htm?p=&q=MX-2310U&lang=ES&cat=0&type=1214&type=1215&os=&emu=) havas plurajn dosierajn alinomajn erarojn, kiuj devigas nin tuŝi la skripton por ke ĝi bone funkciu, due ni havas ĝin en reto agordita kun uzanta kodo por ĉiu dungito kaj rezultas, ke la Linukso-pelilo ne havas lokon por meti la kodon en Vindozo jes en Laborregado - Uzanto-Aŭtentikigo - Uzanto). Do mi ne povas uzi ĝin de GNU / Linukso, kaj mi provis ruzojn kiel ŝanĝi la PPD-dosieron (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/) kaj eĉ provu la ŝoforon, kiu uzas inversan inĝenieradon por ĉifrado (https://github.com/benzea/cups-sharp).
    Preferordo: HP kun senpaga ŝoforo, HP kun propra ŝoforo, Brother kun propra ŝoforo, tute ne Sharp.

  7.   fernan diris

    Saluton:
    Ili postulas duumaĵon funkcii, ekzemple en la kazo de la frato dcp 7065dn, ke mi uzas parton de la pelilo se ĝi estas libera programaro sed bezonas fraton duuma kiu ne estas senpaga.
    Salutojn.

  8.   Guille diris

    Evitu aĉeti presilojn sen senpagaj ŝoforoj, aŭ ili estos en la manoj de la fabrikanta kompanio, ke se ĝi ne ĝisdatigos sian ŝoforon samtempe kun la operaciumoj, kiujn vi uzas, ĝi devigos vin aĉeti alian sistemon aŭ alian presilon.
    HP kun senpagaj ŝoforoj estas pli bona, atentu, ke ekzistas HP kun posedaj ŝoforoj kiel la HP LaserJet CP 1025nw, ĉe Brother ili ĉiuj havas posedan ŝoforon sed almenaŭ ili ekzistas. Pli malbonaj estas la SHARP-kopiiloj-presiloj, kies pelilo por GNU / Linukso ne havas eblojn kiel meti la kodon asignitan al vi por presi en la reto, kio malebligas ilian uzon de Linukso se la kompanio volas regi la kopiojn faritajn de ĉiu, ekzemple la Sharp MX 2310U, kiun mi eĉ ne sukcesis funkciigi la presilon modifante ĝian PPD (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/) aŭ kun inversa realigita ŝoforo (https://github.com/benzea/cups-sharp).

  9.   Koopa diris

    Bonan posttagmezon. (Tage, nokte, ktp) Ĉu iu povas gvidi min en la instalado kaj agordo de skanilo por ĉi tiuj retaj presiloj? aŭ diru al mi, kie mi povas trovi antaŭdigestitajn informojn. Kie mi laboras, pluraj multifunkciaj modeloj de Brother estas uzataj kaj la agordo de la presilo post la instalado de la peliloj estas simpla, sed kelkfoje la sistemo (ĝenerale zorin os 9 lite) aŭtomate detektas iujn skanilojn en la reto, sed foje ne. Mi ŝatus, ke iu diru al mi kiel aldoni ĉi tiun skanilon permane (kiel estas dirite rekoni la multifunkcian skanilon kun certa IP). Mi serĉis kaj plej multe atingis, ke skanila nomo kun la ip aperas en la simpla skana listo, sed nenio estas skanita. La samo okazas al mi ankaŭ kun samsunaj multifunkcioj, sed ĉi tiuj emas aperi en la simpla skanlisto pli ofte ol la frataj. Okazas al mi, ke komputilo detektas la skanilon kaj tiu apud ĝi ne; ĉar ili estas en la sama reto.

  10.   Nasher_87 (ARG) diris

    Unu demando, ĝi estas stulta ĉar mi jam eksciis, sed bone, mi faros, ĉu vi scias, ĉu Lexmark-presiloj (Z11 LPT kaj X75 ĉiu-en-unu) funkcias ĝuste en Linukso? laŭ tio, kion mi serĉis, estas nenio, en Ubuntu 9.10 la Z11 funkciis, metante malnovan kernon, ĉu ĝi funkcios?
    Salutas homojn

    PS: ili povas insulti, mi meritas ĝin 😉

    1.    Guille diris

      Provu ĉi tion: instalu Ubuntu 9.10 en virtualkesto kaj provu presi de tie al via presilo. Se ĝi funkcius, vi povus provi dividi en la reto de tiu linukso al via linukso por presi de la via aŭ presi kun la via en pdf kaj meti la pdfojn por presi en komuna dosierujo inter ambaŭ sistemoj por povi preni ĝin de Ubuntu 9.10.
      Tio estas la problemo kun proprietaj ŝoforoj, same okazas en Vindozo, vi aĉetis ion antaŭ 15 jaroj per Vindozo XP kaj ne estas ŝoforo por win7 aŭ 10.
      Neniam aĉetu ion per posedaj ŝoforoj, se estas io en la konkurenco kun senpagaj ŝoforoj, elektu bone.

  11.   anonima diris

    Dankon pro la informo, mi ŝatus se poste vi povus fari lernilon pri kiel konekti la fratan presilon per wifi ... en mia kazo ĝi estas la MFC9330CDW. Antaŭdankon

  12.   Sinjoro Paquito diris

    Mi havas Brother HL-L2340DW kaj mi konektas al ĝi per Wifi. Por konekti la presilon per USB ne estis problemo, sed ĝi ne povis funkcii per Wifi.

    Frato ofertas al vi, almenaŭ por Ubuntu, ion nomatan Driver Install Tool, kiu supozas, ke la uzanto sola (aŭ preskaŭ, io devas fari) la necesajn pelilojn. La problemo estas, ke vi devas scii kiel fari ĝin. En mia kazo, post iom ĉirkaŭvagado de Google, mi vidis, ke Frato klarigas ĝin al vi ĉi tie:

    http://support.brother.com/g/b/downloadhowtobranchprint.aspx?c=es&dlid=dlf006893_000&flang=4&lang=es&os=127&prod=dcpj315w_eu_as&type3=625&printable=true

    La problemo estas scii, kion diable meti en la URI ... Do, daŭrigante la serĉadon, mi trovis la respondon en komento de certa jose1080i en ĉi tiu artikolo:

    https://www.pedrocarrasco.org/como-configurar-una-impresora-wifi-en-linux/

    Ĝi ne povas esti pli bone klarigita.

    Salutojn.

  13.   Wifismo diris

    Ĝi ne funkcias ĉe ĉiuj modeloj de Brother, ĉu ne? Mi havas nigran kaj blankan laseron kaj neniel eblas

  14.   Enrique Gallegos diris

    Mi uzas Linuksan Mint 19 Cinamon 64-bitan, mi aĉetis la kompaktan monokroman laseran printilon Brother HL-1110 kaj post varmigado de mia koro (ĝi iras per USB) anstataŭ Wifi, ĝi aperas en administrado kaj eĉ movas la dokumentojn sed ili aperas malplenaj, por kion mi devas havi la «windolojn» por fari presaĵojn, kie ĝi iras bone.