Kiel instali niajn LMDE-pakaĵojn en 3 sekundoj

Utiligante lastatempa artikolo pri kio mi afiŝis mintbackup, Mi volas montri al vi tri facilajn manierojn reinstali la pakaĵojn, kiujn ni uzas kiam ni reinstalas nian LMDE.

Fakte, krom la unua formo, la aliaj povas esti uzataj ambaŭ en Debian, kiel en ubuntu.

Instalado en 3 sekundoj

Grafike.

Tiel plej plaĉas al ĝi, ĉio grafika kaj sen devi tuŝi terminalon. En LMDE y LinuksoMint, ekzistas fabela ilo nomata mintbackup, kiun interalie ni povas uzi por konservi niajn pakojn kaj poste reinstali ilin.

En la kazo de LMDE, se ni ĝisdatigos la pakaĵon python-apt ĝis la versio 0.8.0, ni ne povos uzi mintbackup pro dependeca problemo. Ĝi redonos la sekvan eraron:

Traceback (most recent call last):
File "/usr/lib/linuxmint/mintBackup/mintBackup.py", line 87, in <module>
class MessageDialog(apt.FetchProgress):
AttributeError: 'module' object has no attribute 'FetchProgress'

Espereble la uloj de mento riparu ĝin baldaŭ.

Tra la fina stacio.

Per la konzolo ni povas fari ĝin per 2 manieroj, kio finfine estis la sama.

En 2 paŝoj.

dpkg --get-selections | awk '$2 ~ /^install$/ {print $1}' > lista_de_paquetes.txt

Post kiam ni havos aliron al la deponejoj kaj ĉio estos agordita kaj ĝisdatigita, ni nur devas meti ĉi tion:

cat lista_de_paquetes.txt | xargs sudo aptitude install -y

En 3 paŝoj.

dpkg --get-selections "*" > /home/user/Desktop/lista_de_paquetes.txt

Post reinstali ni ekzekutas ĉi tion:

dpkg --set-selections  < /home/user/Desktop/lista_de_paquetes.txt

Kaj tiam ni kuras:

apt-get -u dselect-upgrade

Mi pensas, ke estas nenecese klarigi, ke ni devas havi la deponejojn ĝuste agorditaj .. Simpla, ĉu ne?


La enhavo de la artikolo aliĝas al niaj principoj de redakcia etiko. Por raporti eraron alklaku Ĉi tie.

8 komentoj, lasu la viajn

Lasu vian komenton

Via retpoŝta adreso ne estos eldonita.

*

*

  1. Respondeculo pri la datumoj: Miguel Ángel Gatón
  2. Celo de la datumoj: Kontrola SPAM, administrado de komentoj.
  3. Legitimado: Via konsento
  4. Komunikado de la datumoj: La datumoj ne estos komunikitaj al triaj krom per laŭleĝa devo.
  5. Stokado de datumoj: Datumbazo gastigita de Occentus Networks (EU)
  6. Rajtoj: Iam ajn vi povas limigi, retrovi kaj forigi viajn informojn.

  1.   kuraĝo diris

    Aŭ vi ankaŭ notas ĉiujn programojn, kiujn vi antaŭe havis kaj faras

    sudo apt-get -y enhavas ĉiujn pakaĵojn forigitajn

    Mi vere ne scias, ĉu LMDE havas la saman celon kiel Linukso MInt, esti ekster la skatolo

    1.    kuraĝo diris

      * instali

  2.   hokasito diris

    Kvankam ĝi estas iom "ekster-temo", mi volis averti, ke la liberigaj kandidatoj aperis en Linukso Mint Debian 201108 por GNOME kaj XFCE. Mi esperas, ke sufiĉe multaj plibonigoj estis faritaj ... 🙂

    1.    elav <° Linukso diris

      Nu, jes, kio okazas kiam ĉi tiu bonega novaĵo estis publikigita, ni estis senretaj ... Dankon.

  3.   mitkoj diris

    Mi ĵus malkovris vin kaj DANKON.
    Hieraŭ mi instalis la 64-bitan LMDE, kaj mi fartas bone, sed mi havas 2 etaĵojn por malkovri-

    1– Ensalutu kiel radiko en grafika reĝimo

    2.- Agordu VLC kiel defaŭltan videoludilon

    Mi pensas, ke mi ricevus ĝin de la preferata aplika regpanelo aŭ malfermante kun alia aplikaĵo / uzante ĉi tiun programon defaŭlte. Ensalutinta kiel radiko.

    Mi faris sudan naŭtilon ĉiaokaze kaj tute nenion.

    PS1: En 64 bitoj se la aldono de la pakaĵoj bone funkcias.
    PS2: Mi ankaŭ bezonas instali MAME SDL kaj kies freŝa wine64 mi ŝatus ekzisti ppa, ĉar agordi programojn poste ne aŭtomate ĝisdatigas ilin.
    PS3: Mi uzas la AMD-beta-pelilon AMD_Catalyst_Preview_driver_OpenGL_4.2_beta_support_8.88.8-x86.x86_64.run, Cocoon, https://getcocoon.com/, por vidi geolokigitajn seriojn en Fajrovulpo, Chrome - kiu devas esti instalita -, Firefox Flash helpas per 64-bita Flash, Zindus, Qbittorrent, Opera, la etendaĵo aletras.oxt kaj la riceva skripto por kontroli la troan RAM-kaŝmemoron de la tasko. tio ankaŭ meritas komenton de vi.

    Mi antaŭĝojas pri la kvina parto de la lernilo kun ĉi tiuj kaj / aŭ aliaj sugestoj

  4.   MANĜU KUN diris

    ¡Hola!
    Unu afero, ni devas ŝanĝi la unuan ligon, kiu sendas la artikolon MintBackup al ĉi tiu: https://blog.desdelinux.net/mintbackup-realiza-un-respaldo-de-tus-paquetes/
    Mi ne scias kial, ĝi ligas al subdosierujo "/ wp-content / themes" ...

    1.    KZKG ^ Gaara diris

      Finita, korektita 😉

  5.   Nahum diris

    Saluton, ekde la antaŭa versio de LMDE amd64 mi havis problemojn kun rompitaj pakoj kaj eraroj dum ŝarĝo de deponejoj, mi provis multajn solvojn kaj neniu el ili funkcias ... Mi ne plu scias kion fari, mi volis instali Gnome-shell kaj ĝi ne lasis min, ĉar la pakaĵo estas rompita. Mi vidis kiel solvi la rompitajn pakaĵojn per ordonoj kiel: sudo dpkg –purge –force-remove-reinstreq

    kaj mi ricevas la jenan eraron:

    dpkg: eraro: –purge postulas almenaŭ unu pakaĵan nomon kiel parametron

    Tajpu dpkg –help por helpo instali kaj malinstali pakaĵojn [*];
    Uzu 'dselect' aŭ 'aptitude' por pli amika paka administrado;
    Tajpu dpkg -Dhelp por listo de dpkg-elpurigaj agordoj;
    Tajpu dpkg –force-help por listo de ebloj devigi aferojn;
    Tajpu dpkg-deb –help por helpo pri manipulado de .deb-dosieroj;

    Opcioj markitaj per [*] produktas ampleksan rezulton,
    Filtru ĝin per 'malpli' aŭ per 'pli'!

    se iu povas helpi min pri ĉi tio 🙂