Pakaĵoj por subteno de Programa Disvolviĝo ĉe DEBIAN 10

Pakaĵoj por subteno de Programa Disvolviĝo ĉe DEBIAN 10

Pakaĵoj por subteno de Programa Disvolviĝo ĉe DEBIAN 10

Ĉi tiu afiŝo estas la daŭrigo (tria parto) de la tutoriales dediĉita al DEBIAN GNU / Linukso Distro, versio 10 (Rompilo), kiu servas kiel bazo por multaj aliaj kiel MX-Linukso 19 (Malbela Anasido).

En ĉi tiu tria parto ni montros la esencaj pakoj (aplikaĵoj) rekomendita provizi la necesan subteno baza por disvolviĝo, testado kaj ekzekuto de iuj programaro (programoj) pri niaj belaj kaj grandaj Distroj DEBIAN 10 kaj MX-Linukso 19.

Ĝisdatigu kaj optimumigu MX-Linukso 19.0 kaj DEBIAN 10.2 post instalado

Ĝisdatigu kaj optimumigu MX-Linukso 19.0 kaj DEBIAN 10.2 post instalado

La antaŭaj 2 afiŝoj en ĉi tiu serio estas:

  • Ĝisdatigu kaj optimumigu MX-Linukso 19.0 kaj DEBIAN 10.2 post instalado (Vidu eniron)
  • DEBIAN 10: Kiaj ekstraj pakoj utilas post instalado? (Vidu eniron)
DEBIAN 10: Kiaj ekstraj pakoj utilas post instalado?

DEBIAN 10: Kiaj ekstraj pakoj utilas post instalado?

Memoru kaj memoru, ke:

"Memoru, ke la agoj kaj pakaĵoj rekomenditaj ĉi tie por ruliĝi kaj instali estas nur tio, "pakoj rekomendita", kaj dependas de ĉiu funkciigi kaj instali ĉiujn aŭ iujn el ili, kial ili estas necesaj aŭ utilaj, baldaŭ aŭ meze, por koni kaj uzi ilin, havante ilin jam funkciigitaj aŭ instalitaj.

Kaj memoru, ke ĉi tiuj agoj kaj / aŭ pakaĵoj estis antaŭe testita sur ambaŭ Distroj, kaj ili ne petas malinstali pakaĵojn instalitajn defaŭlte en ĉi tiuj. Plue, ili ne pliigas la konsumon de memoro aŭ CPU ĉar ili ne ŝarĝas procezojn aŭ demonojn (servoj) en memoro defaŭlte. Por scii anticipe por kio uzas ĉiu pakaĵo, alklaku Ĉi tie."

Ĝisdatigu MX-Linukso kaj DEBIAN: Enhavo

Pakoj por subteno de Programara Disvolviĝo

Subteno por Java-aplikaĵoj

apt install browser-plugin-freshplayer-pepperflash default-jdk icedtea-netx

Objektivo: Instalu bazan subtenon por kongruo kun Java-aplikaĵoj.

Subteno por QT5-aplikoj

apt install libqt5core5a qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

Objektivo: Instalu bazan subtenon por kongruo kun programoj konstruitaj per QT5.

Subteno por Ciferecaj Minindustriaj aplikoj

apt install autoconf automake autotools-dev build-essential byobu g++ gcc gcc-7 g++-7 git git-core libboost-dev libboost-all-dev libcrypto++-dev libcurl4 libdb-dev libdb++-dev libevent-dev libgmp-dev libgmp3-dev libhwloc-dev libjansson-dev libmicrohttpd-dev libminiupnpc-dev libncurses5-dev libprotobuf-dev libqrencode-dev libqt5gui5 libqtcore4 libqt5dbus5 libstdc++6 libssl-dev libusb-1.0-0-dev libtool libudev-dev make ocl-icd-opencl-dev openssl pkg-config protobuf-compiler qrencode qttools5-dev qttools5-dev-tools

Objektivo: Instalu la bazan programan subtenon, ŝoforojn kaj bibliotekojn necesajn por la instalado kaj administrado de ciferecaj Minindustriaj aplikoj.

apt install libdb++-dev libdb5.3++ libdb5.3++-dev

Objektivo: Instalu bazan bibliotekan subtenon por programoj, kiuj uzas la datumbazan bibliotekon Berkeley v5.3, vaste uzatan de modernaj programoj de Cifereca Minado por esti kompilitaj kaj / aŭ funkciigotaj.

Subteno de retprogramoj

Apache

apt install apache2

Objektivo: Instalu bazan subtenon por retaj programoj optimumigitaj aŭ kongruaj por Apache2.

Nginx

apt install nginx

Objektivo: Instalu bazan subtenon por retaj programoj optimumigitaj aŭ kongruaj por Nginx.

PostgreSQL

apt install postgresql

Objektivo: Instalu bazan komandon kaj funkcian subtenon por administri Postgresql-bazitajn Datumbazojn.

apt install pgadmin3 y phppgadmin

Objektivo: Instalu la bazan subtenon de aplikoj por administrado de Datumbazoj bazitaj sur Postgresql.

MySQL

apt install mysql-server mysql-client

Objektivo: Instalu bazan komandon kaj funkcian subtenon por administri MySQL-bazitajn datumbazojn.

apt install phpmyadmin y mysql-workbench

Objektivo: Instalu bazan programan subtenon por administrado de MySQL-bazitaj datumbazoj.

MariaDB

apt install mariadb-server mariadb-client

Objektivo: Instalu la bazan komandon kaj funkcian subtenon por administri Datumbazojn bazitajn sur MariaDB.

PHP

apt install php

Objektivo: Instalu bazan komandon kaj funkcian subtenon por trakti PHP-bazitajn programojn.

apt install php-cas php-cgi php-curl php-gd php-json php-mbstring php-mysql php-xml php-apcu php-cli php-dev php-imap php-ldap php-xmlrpc php-intl php-pgsql php-sqlite3 php-zip phpqrcode

Objektivo: Instalu la bazan subtenon de denaskaj bibliotekoj por administri PHP-bazitajn aplikojn.

apt install libmagic-dev libapache2-mod-php libcurl4-gnutls-dev

Objektivo: Instalu bazan nedenaskan bibliotekan subtenon por pritrakti PHP-bazitajn programojn.

PERL

apt install perl

Objektivo: Instalu bazan komandon kaj funkcian subtenon por trakti PERL-bazitajn programojn.

apt install libapache2-mod-perl2 y perlbrew

Objektivo: Instalu bazan bibliotekan subtenon por trakti PERL-bazitajn programojn.

python

apt install python-all-dev python-pip

Objektivo: Instalu bazan komandon kaj funkcian subtenon por administri Python-bazitajn programojn.

apt install python3-setuptools python3-pyqt5 python3-pip

Objektivo: Instalu bazan komandon kaj funkcian subtenon por pritrakti programojn bazitajn sur Python3.

Senmarka bildo por artikolaj konkludoj

konkludo

Ni esperas tion ĉi tiu "utila afiŝeto" pri kiuj esencaj pakaĵoj bezonas por doni la necesan subtenon por korekti  «instalación y gestión» de iuj programaj evoluoj, pri Distroj «DEBIAN y MX-Linux», tre interesas kaj utilas, por la tuto «Comunidad de Software Libre y Código Abierto» kaj de granda kontribuo al la disvastigo de la mirinda, giganta kaj kreskanta ekosistemo de aplikoj de kaj por «GNU/Linux».

Kaj por pliaj informoj, ĉiam ne hezitu viziti iun ajn Interreta biblioteko kiel OpenLibra y JedIT legi libroj (PDF-oj) pri ĉi tiu temo aŭ aliaj sciaj areoj. Nuntempe, se vi ŝatis ĉi tion «publicación», ne ĉesu dividi ĝin kun aliaj, en via Plej ŝatataj retejoj, kanaloj, grupoj aŭ komunumoj de sociaj retoj, prefere senpagaj kaj malfermaj kiel Mastodon, aŭ sekura kaj privata kiel Telegramo.

Aŭ simple vizitu nian ĉefpaĝon ĉe De Linukso aŭ aliĝu al la oficiala Kanalo Telegramo de DesdeLinux legi kaj voĉdoni por ĉi tiu aŭ aliaj interesaj eldonaĵoj pri «Software Libre», «Código Abierto», «GNU/Linux» kaj aliaj temoj rilataj al «Informática y la Computación»kaj la «Actualidad tecnológica».


La enhavo de la artikolo aliĝas al niaj principoj de redakcia etiko. Por raporti eraron alklaku Ĉi tie.

2 komentoj, lasu la viajn

Lasu vian komenton

Via retpoŝta adreso ne estos eldonita. Postulita kampojn estas markita per *

*

*

  1. Respondeculo pri la datumoj: Miguel Ángel Gatón
  2. Celo de la datumoj: Kontrola SPAM, administrado de komentoj.
  3. Legitimado: Via konsento
  4. Komunikado de la datumoj: La datumoj ne estos komunikitaj al triaj krom per laŭleĝa devo.
  5. Stokado de datumoj: Datumbazo gastigita de Occentus Networks (EU)
  6. Rajtoj: Iam ajn vi povas limigi, retrovi kaj forigi viajn informojn.

  1.   Twikzer diris

    Korektu min se mi eraras, sed .. ĉe debian, ili ne forigis phpmyadmin de la deponejoj?
    kaj por instali php, vi ne devas specifi (ekzemple) php7.3 aŭ php7.3-curl

  2.   Linuksa Afiŝinstalo diris

    Salutojn Twikzer! Dankon pro via komento. Certe phpmyadmin ne estas en la deponejoj DEBIAN 10 (Stabilaj) sed ĝi estas en la Deponejoj DEBIAN 11 (Testado) laŭ tio, kion mi supozas, ke iam ili inkluzivos ĝin kiel aliajn pakojn en la stabilaj, sed vi povas aŭ povas preterlasi ĝi, sen Tamen, tial mi lasis ĝin tie. Pri la dua, ĝi ne necesas, ĉar la nunaj versioj ene de la deponejo estas nomataj per sia gentnomo.