بسته هایی برای پشتیبانی از توسعه نرم افزار در DEBIAN 10

بسته هایی برای پشتیبانی از توسعه نرم افزار در DEBIAN 10

بسته هایی برای پشتیبانی از توسعه نرم افزار در DEBIAN 10

این پست ادامه است (بخش سوم) از آموزش اختصاص داده شده به DEBIAN GNU / Linux Distro، نسخه 10 (باستر)، که به عنوان پایه بسیاری از موارد دیگر مانند MX-Linux 19 (جوجه اردک زشت).

در این قسمت سوم ما نمایش خواهیم داد بسته های ضروری (برنامه ها) توصیه می شود برای ارائه مورد نیاز است پشتیبانی اساسی برای توسعه ، آزمایش و اجرا از بعضی نرم افزار (برنامه ها) در مورد Distros زیبا و عالی ما DEBIAN 10 و MX-Linux 19.

پس از نصب MX-Linux 19.0 و DEBIAN 10.2 را به روز و بهینه کنید

پس از نصب MX-Linux 19.0 و DEBIAN 10.2 را به روز و بهینه کنید

2 پست قبلی در این مجموعه عبارتند از:

DEBIAN 10: چه بسته های اضافی پس از نصب مفید هستند؟

DEBIAN 10: چه بسته های اضافی پس از نصب مفید هستند؟

به یاد داشته باشید و به خاطر داشته باشید که:

"به یاد داشته باشید که اقدامات و بسته های توصیه شده در اینجا برای اجرا و نصب فقط همین موارد هستند ، "بسته ها توصیه شده" و نصب و نصب همه یا بعضی از آنها به هر یک بستگی دارد ، چرا اینها هستند در کوتاه مدت یا میان مدت برای دانستن و استفاده از آنها ضروری یا مفید است، با اجرای یا نصب آنها از قبل.

و به خاطر داشته باشید که این اقدامات و / یا بسته ها بوده است قبلاً در هر دو Distros آزمایش شده است، و آنها نمی خواهند بسته های نصب شده به طور پیش فرض را در این موارد حذف نصب کنند. به علاوه، آنها مصرف حافظه یا CPU را افزایش نمی دهند از آنجا که آنها به طور پیش فرض فرآیندها یا daemons (خدمات) را در حافظه بارگیری نمی کنند. برای اینکه بدانید هر بسته برای چه کاری استفاده می شود ، کلیک کنید اینجا."

MX-Linux و DEBIAN را به روز کنید: مطالب

بسته هایی برای پشتیبانی از توسعه نرم افزار

پشتیبانی از برنامه های جاوا

apt install browser-plugin-freshplayer-pepperflash default-jdk icedtea-netx

Objetivo: پشتیبانی اساسی را برای سازگاری با برنامه های جاوا نصب کنید.

پشتیبانی از برنامه های QT5

apt install libqt5core5a qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

Objetivo: پشتیبانی اساسی را برای سازگاری با برنامه های ساخته شده با QT5 نصب کنید.

پشتیبانی از برنامه های کاربردی استخراج دیجیتال

apt install autoconf automake autotools-dev build-essential byobu g++ gcc gcc-7 g++-7 git git-core libboost-dev libboost-all-dev libcrypto++-dev libcurl4 libdb-dev libdb++-dev libevent-dev libgmp-dev libgmp3-dev libhwloc-dev libjansson-dev libmicrohttpd-dev libminiupnpc-dev libncurses5-dev libprotobuf-dev libqrencode-dev libqt5gui5 libqtcore4 libqt5dbus5 libstdc++6 libssl-dev libusb-1.0-0-dev libtool libudev-dev make ocl-icd-opencl-dev openssl pkg-config protobuf-compiler qrencode qttools5-dev qttools5-dev-tools

Objetivo: پشتیبانی اولیه برنامه ، درایورها و کتابخانه های لازم برای نصب و مدیریت برنامه های کاربردی Digital Mining را نصب کنید.

apt install libdb++-dev libdb5.3++ libdb5.3++-dev

Objetivo: پشتیبانی پایه کتابخانه را برای برنامه هایی که از کتابخانه پایگاه داده Berkeley v5.3 استفاده می کنند و به طور گسترده توسط برنامه های مدرن استخراج دیجیتال برای تدوین و / یا اجرا استفاده می شود ، نصب کنید.

پشتیبانی از برنامه وب

آپاچی

apt install apache2

Objetivo: پشتیبانی اساسی را برای برنامه های وب بهینه شده یا سازگار با Apache2 نصب کنید.

Nginx

apt install nginx

Objetivo: پشتیبانی اصلی را برای برنامه های وب بهینه شده یا سازگار با Nginx نصب کنید.

PostgreSQL و

apt install postgresql

Objetivo: برای مدیریت پایگاه داده های مبتنی بر Postgresql ، دستور اساسی و پشتیبانی را نصب کنید.

apt install pgadmin3 y phppgadmin

Objetivo: پشتیبانی برنامه اصلی را برای مدیریت پایگاه داده مبتنی بر Postgresql نصب کنید.

خروجی

apt install mysql-server mysql-client

Objetivo: برای مدیریت پایگاه داده های مبتنی بر MySQL ، پشتیبانی اساسی از دستور و عملکرد را نصب کنید.

apt install phpmyadmin y mysql-workbench

Objetivo: پشتیبانی مدیریت برنامه اصلی را برای مدیریت پایگاه داده های مبتنی بر MySQL نصب کنید.

MariaDB

apt install mariadb-server mariadb-client

Objetivo: برای مدیریت پایگاه داده های مبتنی بر MariaDB ، پشتیبانی اساسی از دستور و عملکرد را نصب کنید.

پی اچ پی

apt install php

Objetivo: پشتیبانی اساسی از دستور و عملکرد را برای مدیریت برنامه های مبتنی بر PHP نصب کنید.

apt install php-cas php-cgi php-curl php-gd php-json php-mbstring php-mysql php-xml php-apcu php-cli php-dev php-imap php-ldap php-xmlrpc php-intl php-pgsql php-sqlite3 php-zip phpqrcode

Objetivo: پشتیبانی اساسی از کتابخانه های بومی را برای مدیریت برنامه های مبتنی بر PHP نصب کنید.

apt install libmagic-dev libapache2-mod-php libcurl4-gnutls-dev

Objetivo: پشتیبانی اساسی کتابخانه غیربومی را برای مدیریت برنامه های مبتنی بر PHP نصب کنید.

PERL

apt install perl

Objetivo: پشتیبانی اساسی از دستور و عملکرد را برای مدیریت برنامه های مبتنی بر PERL نصب کنید.

apt install libapache2-mod-perl2 y perlbrew

Objetivo: پشتیبانی اساسی کتابخانه را برای مدیریت برنامه های مبتنی بر PERL نصب کنید.

پــایتــون

apt install python-all-dev python-pip

Objetivo: پشتیبانی اساسی از دستور و عملکرد را برای مدیریت برنامه های مبتنی بر Python نصب کنید.

apt install python3-setuptools python3-pyqt5 python3-pip

Objetivo: پشتیبانی اساسی از دستور و عملکرد را برای مدیریت برنامه های مبتنی بر Python3 نصب کنید.

تصویر عمومی برای نتیجه گیری مقاله

نتیجه

ما امیدواریم که این "پست کوچک مفید" در مورد کدام بسته های ضروری مورد نیاز است تا پشتیبانی لازم را برای ارائه صحیح انجام دهید  «instalación y gestión» از برخی پیشرفت های نرم افزاری، در مورد Distros «DEBIAN y MX-Linux»، برای کل از علاقه و سودمندی برخوردار باشد «Comunidad de Software Libre y Código Abierto» و سهم بزرگی در انتشار اکوسیستم فوق العاده ، غول پیکر و رو به رشد برنامه های کاربردی برای و «GNU/Linux».

و برای کسب اطلاعات بیشتر ، همیشه در بازدید از هیچ گونه دریغ نکنید کتابخانه آنلاین مانند OpenLibra y JedIT خواندن کتاب (PDF) در مورد این موضوع یا موارد دیگر حوزه های دانش. در حال حاضر ، اگر این را دوست دارید «publicación», اشتراک گذاری آن را متوقف نکنید با دیگران ، در شما وب سایت ها ، کانال ها ، گروه ها یا انجمن های مورد علاقه از شبکه های اجتماعی ، ترجیحا رایگان و آزاد به عنوان مادادون، یا مانند امن و خصوصی تلگراف.

یا به سادگی از صفحه اصلی ما در دیدن کنید از لینوکس یا به کانال رسمی بپیوندید تلگرام از DesdeLinux برای خواندن و رأی دادن به این یا سایر نشریات جالب در «Software Libre», «Código Abierto», «GNU/Linux» و سایر موضوعات مرتبط با «Informática y la Computación»، و «Actualidad tecnológica».


محتوای مقاله به اصول ما پیوست اخلاق تحریریه. برای گزارش یک خطا کلیک کنید اینجا.

2 نظر ، نظر خود را بگذارید

نظر خود را بگذارید

نشانی ایمیل شما منتشر نخواهد شد. بخشهای موردنیاز علامتگذاری شدهاند با *

*

*

  1. مسئول داده ها: میگل آنخل گاتون
  2. هدف از داده ها: کنترل هرزنامه ، مدیریت نظرات.
  3. مشروعیت: رضایت شما
  4. ارتباط داده ها: داده ها به اشخاص ثالث منتقل نمی شوند مگر با تعهد قانونی.
  5. ذخیره سازی داده ها: پایگاه داده به میزبانی شبکه های Occentus (EU)
  6. حقوق: در هر زمان می توانید اطلاعات خود را محدود ، بازیابی و حذف کنید.

  1.   توییکزر dijo

    اگر اشتباه می کنم اصلاح کنید ، اما .. در debian ، آنها phpmyadmin را از مخازن حذف نکردند؟
    و برای نصب php ، لازم نیست (مثلا) php7.3 یا php7.3-curl را مشخص کنید

  2.   نصب لینوکس dijo

    با سلام Twikzer! بابت نظرتان متشکرم. مطمئناً phpmyadmin در مخازن DEBIAN 10 (پایدار) نیست اما از آنچه من تصور می کنم در مخازن DEBIAN 11 (Testing) است ، که در برخی موارد آنها را مانند سایر بسته های موجود در بسته های پایدار قرار می دهد ، اما شما می توانید یا می توانید آن را حذف کنید ، بدون با این حال ، به همین دلیل آن را در آنجا رها کردم. در مورد نسخه دوم ، لازم نیست ، زیرا نسخه های فعلی موجود در مخزن با نام عمومی خود فراخوانی می شوند.