Steam: Asenna se Debian Wheezyyn kuolematta kokeilemassa (päivitetty)

Tämä viesti, jonka luet seuraavaksi, on parannus Edellinen viesti, mikä ilmeisesti oli melko hämmentävä Höyry, ja se oli vaikea monille, jotka ovat halunneet asentaa sen.

Tässä on kuitenkin menetelmä, jonka löysin juuri kokeilemisen jälkeen (se muistuttaa sinua asennustavasta iceweasel repoista Debian-Mozilla, mutta loppujen lopuksi se toimii):

  1. Lisätään moniarkkitoiminto omaan Debian:sudo apt-get install multiarch-support
  2. Lisäämme repon allekirjoituksen asennettavaksi:
    wget -O- -q http://repo.steampowered.com/steam/signature.gpg | gpg --import gpg --check-sigs - sormenjälki - avaimenperä /usr/share/keyrings/debian-keyring.gpg B05498B7 gpg --export -a B05498B7 | sudo apt-key add -

    Lisää / Etc / apt / sources.list seuraava:

    deb http://repo.steampowered.com/steam precise steam

  3. Suorita seuraava:sudo apt-get install -t precise steam steam-launcher
  4. Jos he pyytävät riippuvuuksia:sudo apt-get -f install

Korjaa Libc6-ongelma

Ensin esiin tuleva Steam-ongelma on pohjimmiltaan riippuvuus Libc6-kirjastosta, joka vaatii vähintään version 2.15. Ongelmien välttämiseksi pelastamme vain Libc6-kirjastot Debian Jessie kanssa seuraavan menettelyn mukaisesti (lyhyt, mutta toimiva):

  1. Lisäämme seuraavan rivin / Etc / apt / sources.list:deb http://ftp.us.debian.org/debian/ testing main contrib non-free
  2. Luomme hakemiston, jossa se osoittaa pingissä olevat prioriteetit, jotta vältetään dist-päivitys luomalla tiedosto / etc / apt / preferences nanolla:
    Paketti: * Pin: origin repo.steampowered.com Pin-Priority: 400 Package: * Pin: release a = Testaa Pin-Priority: -10
  3. Suoritamme seuraavan komennon päivitetyn libc6: n asentamiseksi:apt-get -t testing install libc6

Steam toimii siis ongelmitta

Joka tapauksessa olen löytänyt tämän menetelmän sen ansiosta, että olen katsonut tuotteen repohakemistossa SteamOS, joka perustuu debian vinkuva. Ja koska emme voi tuhlata tällaista etua, päätin tehdä tämän opetusohjelman, nyt emme tarvitse enää riippuvuuksia Ubuntu Ei mitään sellaista.

Joka tapauksessa, nauti Steamistä Debian Wheezyssä ja tulevissa versioissa (nyt kyllä).

Höyry

Steam Debian 7.5 "Wheezy" (64-bittinen) -sovelluksessa, joka on asennettu onnellisesti verkkokirjaani.

Debian Jessiellä (ja SID: llä) on repot sivuliikkeessä epävapaa a Höyry, jos haluat luottaa Debianiin, jos käytät mainitun version versioita. Lisäksi tämä opetusohjelma on myös tekstin lopussa liitä sivustolta.

Artikkelin sisältö noudattaa periaatteita toimituksellinen etiikka. Ilmoita virheestä napsauttamalla täällä.

20 kommenttia, jätä omasi

Jätä kommentti

Sähköpostiosoitettasi ei julkaista.

*

*

  1. Vastuussa tiedoista: Miguel Ángel Gatón
  2. Tietojen tarkoitus: Roskapostin hallinta, kommenttien hallinta.
  3. Laillistaminen: Suostumuksesi
  4. Tietojen välittäminen: Tietoja ei luovuteta kolmansille osapuolille muutoin kuin lain nojalla.
  5. Tietojen varastointi: Occentus Networks (EU) isännöi tietokantaa
  6. Oikeudet: Voit milloin tahansa rajoittaa, palauttaa ja poistaa tietojasi.

  1.   @Jlcux dijo

    Mitä tiedät SteamOSista?

    1.    eliotime3000 dijo

      Mikä on jo beetaversiossa ja joka on viime aikoina asetettu samalle tasolle Debian Wheezy 7.5: n kanssa.

    2.    Cristianhcd dijo

      mikä on vika, jos et tee jotain kumppaneiden ja heidän höyrykoneidensa kanssa, käyttöjärjestelmä on yksinkertaisesti keino asentaa sarja paketteja.

      Parannuksia nähdään AMD / Nvidia-ohjainten tuessa, mutta silti kaukana luvatusta, mikä on vakava ongelma, koska tavallinen käyttäjä asentaa höyryn tai höyrykäyttöjärjestelmän tietokoneeseensa eikä höyrykoneeseen, jossa on laitteistosertifikaatti "

  2.   cr0t0 dijo

    Debian 7.4: ssä olin asentanut sen https://github.com/GhostSquad57/Steam-Installer-for-Wheezy mutta left4dead 2: lla oli gammaongelmia, se oli hyvin harvinaista, enkä löytänyt ratkaisua. Napsauta ja pelaa Lubuntu 14.04 -sovelluksessa. Palaan rakas Wheezy.

    1.    eliotime3000 dijo

      Menetelmä, jonka tein Steamin asentamiseen, saadaan suoraan SteamOS-reposta, joka on optimoitu Debian Wheezy -ohjelmaa varten ilman suurempia ongelmia.

  3.   nimettömänä dijo

    höyrypaketti on testattavissa, kuka tahansa on vakaa, se voi vaihtaa repot testaukseen sen asentamiseksi ja palata vakaana ilman muita komplikaatioita

    1.    eliotime3000 dijo

      No, sain sen Steam-version suoraan SteamOS-reposta, koska se on paljon optimoidumpi toimimaan Debian Wheezyn kanssa ja siten sallimaan sinun ajaa lataamiasi pelejä tai sinulla ei ole ongelmia ALSA: n kanssa.

  4.   Alberton huvila dijo

    Onko mahdollista, että he tekevät opetusohjelman kuinka se asennetaan GRUB: lla, jos meillä on oudon nimeltään Win7 EFI: n kanssa laskelmassamme?

    1.    Alberton huvila dijo

      Tarkoitan Steam-käyttöjärjestelmää. Muuten, siistiä .. se näyttää minne lähetän ... (OS) .. mutta se on työtietokone ¬¬

    2.    eliotime3000 dijo

      SteamOS-asennusohjelma, joka tulee sisään Virallinen ISOSen mukana tulee GRUB, joka tukee ylimääräistä käyttöjärjestelmää. Lisäksi SteamOS-asennusohjelma on melkein sama kuin Debianin, joten sen ei pitäisi olla ongelma, jos asennat sen Windowsin rinnalle.

      UEFI-puolella tässä on pari verkkosivustoa, jotka puhuvat UEFI: stä ja asennuksesta Debian Wheezy UEFI: n kanssa (y tässä on toinen menetelmä joka voi auttaa sinua).

  5.   Alfonso dijo

    Olen asentanut Steamin Debian 7: een, ongelmana on, että yritettäessä avata ohjelmaa se pyytää minulta passin, mutta se tuo tietokoneen käyttäjätunnuksen eikä Steam-nimen. Onko jokin {määritettävä tiedosto? Se ei salli minun vaihtaa käyttäjänimeä.

    kiitos

    1.    eliotime3000 dijo

      Kuinka Steam-ikkuna näkyy sinulle? Kuten sisäänkirjautumislomake tai se, jonka pääte (tai konsoli) pyytää käyttäjän läpäisemään?

      1.    Alfonso dijo

        Näyttöön tulee pääte.

  6.   eliotime3000 dijo

    Jos näyttöön tulee pääte, suorita nämä kaksi riviä päätelaitteessasi:

    wget http://dl.dropbox.com/u/29081229/Steam/debian_install.sh

    sh ./debian_install.sh

    Joten käyttäjän salasanan ongelmaa ei enää näy (normaalisti se ilmenee, kun Ubuntu-repoista tulevia Jockey-riippuvuuksia ei ole asennettu).

    1.    Alfonso dijo

      Olen jo tehnyt vaiheet ja olen edelleen niissä. Onko se tarpeen poistaa?

    2.    Alfonso dijo

      Se pyytää minua asentamaan seuraavat ohjelmat:

      libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386

      Mutta kun yritän tehdä sen, saan legendan: "paketeilla on täyttämättömiä riippuvuuksia"

  7.   Vyyhti dijo

    Hei ystäväni, tuhat kiitosta helpimmasta tavasta, jolla löysin höyryn ja toimin täydellisesti Debian Jessiellani

    Kiitos.

  8.   robermgs dijo

    Komennossa apt-get install -t tarkka höyrynkäynnistin, jonka laitat höyrymuokkaukseen, olisi kuin tämä apt-get install -tarkka höyrynlaskijan tervehdys

  9.   Nebus dijo

    Hei, valitettavasti eksyin tässä vaiheessa:

    «Luomme hakemiston, jossa se osoittaa pingissä olevat prioriteetit, jotta vältetään dist-päivitys luomalla tiedosto / etc / apt / preferences nanolla:»

    Sisältö, jonka tiedostolla pitäisi olla, on minulle selvää, mutta onko tiedosto luotava alihakemistoon kansiossa etc / apt / preferences? Kun laitan "Luomme hakemiston ...", epäilen
    Ja mikä nimi tiedostolla pitäisi olla? Ja mikä laajennus?

    ^^ sen lisäksi, että minulla on höyryä, mikä on jo, jos onnistun asentamaan pirun libc6: n hengitykseeni lataamatta mitään, se olisi tehdä sinusta jumalten alttari! xP että onnellinen lib vaaditaan monilta ääni- ja videosovelluksilta, joita haluan kokeilla työhön, mutta toistaiseksi olen lopettanut riskien ottamisen.

    Kiitos etukäteen!

  10.   Aquadrago dijo

    Hei, kun suoritan kantoraketin, saan seuraavan virheen:

    Luetaan pakettiluetteloa ... Valmis
    E: Arvo 'tarkka' on virheellinen APT :: Default-Release-sovelluksessa, koska sellaista julkaisua ei ole saatavana lähteistä

    Kuinka voin ratkaista sen?

bool (tosi)