Kuinka korjata virhe: "pakettijärjestelmä on rikki"

Joskus kun asennat ohjelmaa ja kaikkia riippuvuuksia ei ole asennettu oikein, pakettijärjestelmäsi on vioittunut etkä voi asentaa uusia ohjelmia tai tehdä uusia päivityksiä. Tämä mini-opetusohjelma auttaa sinua pääsemään purista.


Seuraavat vaiheet ovat erittäin helppoja:

1.- Käydä Järjestelmä> Hallinta> Synaptic Package Manager. Valitse painike Muokattavat suodattimet> Roto. Näyttöön tulee ilmestyä ongelmapaketteja, jotka on poistettava.

2.- Valitse kaikki rikki paketit> napsauta hiiren kakkospainikkeella> Poista asennus poistamalla valinta > napsauta painiketta käyttää.


Artikkelin sisältö noudattaa periaatteita toimituksellinen etiikka. Ilmoita virheestä napsauttamalla täällä.

20 kommenttia, jätä omasi

Jätä kommentti

Sähköpostiosoitettasi ei julkaista.

*

*

  1. Vastuussa tiedoista: Miguel Ángel Gatón
  2. Tietojen tarkoitus: Roskapostin hallinta, kommenttien hallinta.
  3. Laillistaminen: Suostumuksesi
  4. Tietojen välittäminen: Tietoja ei luovuteta kolmansille osapuolille muutoin kuin lain nojalla.
  5. Tietojen varastointi: Occentus Networks (EU) isännöi tietokantaa
  6. Oikeudet: Voit milloin tahansa rajoittaa, palauttaa ja poistaa tietojasi.

  1.   Rodolfo Alejandro Ruiz Hurtado dijo

    Hei, teen mitä ehdotat, mutta se kertoo minulle, että paketit ovat välttämättömiä järjestelmälle, ja jos poistan ne, paketit ovat kirjastot libapt-pkg4.12 ja libapt-pkg4.12: i386, mitä voin tehdä?

  2.   Jeesus Diaz dijo

    Paljon kiitoksia!!

  3.   Jimmy Kfeinan kanssa dijo

    Kiitos, autoit minua paljon

  4.   Quique dijo

    hei En voi päivittää tai ladata mitään, koska se antaa minulle Järjestelmäpaketti on rikki eikä minulla ole Synaptic-ohjelmaa. voitko auttaa minua kiitos

  5.   elvis dijo

    Kiitos, pääsen eroon suurella menestyksellä ja kaikki toimii normaalisti

  6.   Juanm dijo

    Tein mitä suosittelette, ja virhe jatkuu, kun menen päivittämään ja kun haluan asentaa ohjelman johtajan toimesta, se on asennettu

    1.    LacMusta¨Jack ' dijo

      sudo apt-get install -f && sudo apt-get clean && sudo apt-get update && sudo apt-get dist-päivitys

      kokeile sitä ystävää terminaalissa

      1.    anonyymi dijo

        kiitos veli, se auttoi minua paljon, mitä etsin

  7.   Daniel Chambers dijo

    Tarvitsen apua paketeissa, joita ei ole asennettu. Siinä sanotaan, että olen rikkonut paketteja, mutta tarkistan ja minulla ei ole mitä sitten

  8.   Yamil dijo

    Entä jos minulla ei ole Synaptic-paketinhallintaa? Minulla on Ubuntu 12.04, minulla ei ole Synaptic-paketinhallintaohjetta, olen uusi enkä ymmärrä chota-ohjelmaa

  9.   acalampuca dijo

    1. paina ctrl alt t -näppäimiä
    2. Pääte avautuu ja kirjoita: sudo apt-get install synaptic
    3. Se pyytää salasanaasi: kirjoita salasanasi (et näe kirjoittamaasi, jos se ei ole oikea, se kysyy sinulta uudelleen)
    4. kun olet syöttänyt sen, synaptic asennetaan
    5. Noudata sitten ohjeita: https://blog.desdelinux.net/como-solucionar-el-error-el-sistema-de-paquetes-esta-roto/

  10.   Anonyymi dijo

    Hei, käytän canaimaa ja haluan sinun tietävän, että virheeni on seuraava: kumpikaan paketinhallinta tai debian ei toimi minulle, minulla on virhe nimeltä canaima-desktop-gnome

  11.   Abel dijo

    Paljon kiitoksia, se palveli minua.

  12.   Ivan Delgado dijo

    Hei ystävä, minulla on ongelma tietokoneessani, miten saan sipnatic-paketinhallinnan avaamaan sen oikein, se kertoo minulle tämän «E: Oracle-java7-installer-paketti on asennettava uudelleen, mutta tiedostoa ei löydy sille
    E: Sisäinen virhe avaamalla välimuisti (1) ilmoita tästä virheestä

  13.   Luigys toro dijo

    sudo apt-get install -f && sudo apt-get clean && sudo apt-get update && sudo apt-get dist-päivitys

    kokeile sitä ystävää terminaalissa

  14.   CD2 dijo

    Hei, minulla on Canaima ja saan seuraavan virheen, kun yritän poistaa paketin kokonaan: E: canaima-desktop-gnome: Paketti on erittäin huonossa ja epäjohdonmukaisessa tilassa - sinun on asennettava se uudelleen ennen kuin yrität poistaa sitä. Asennan sen uudelleen ja se tulee ulos: E : /var/cache/apt/archives/canaima-plymouth_2.0-11_all.deb: uusi poistamisen jälkeinen komentosarjan säie palautti virheen poistumiskoodin 2
    E: /var/cache/apt/archives/canaima-style-visual-gnome_3.1-23_all.deb: yritetään korvata `/usr/share/themes/canaima-metacity/metacity-1/button_prelight.png ', joka on myös canaima-tyylinen-visuaalinen-opettavainen 1.0 + 4 -paketissa
    E: /var/cache/apt/archives/canaima-descritorio-gnome_3.1-37_all.deb: uusi poiston jälkeinen komentosarjan säie palautti virheen poistumiskoodin 1.

  15.   HH dijo

    Tein sen, mutta se ei päde, koska siinä sanotaan, että putki on rikkoutunut, en voi korjata sitä. Mitä teen? Ole hyvä ja olen ollut tämän kanssa noin 7 kuukautta enkä tiedä mitä tehdä, eikä sitä näy Internetissä

  16.   Viki dijo

    Hei, voitko auttaa minua? Se on, että saan epäluotettavia paketteja. Apu, kiitän sitä.

  17.   anonyymi dijo

    Hei, se oli minulle erittäin hyödyllinen, kiitos ja Jumala siunatkoon älyäsi.

  18.   frdg dijo

    Hei, kuinka voit? Olen tehnyt täällä foorumissa näkyvät vaiheet, mutta tulokset ovat silti samat

    Luetaan pakettiluetteloa ... Valmis
    Luodaan riippuvuuspuu
    Tilatietojen lukeminen ... Valmis
    E: Libcups2-paketti on asennettava uudelleen, mutta tiedostoa ei löydy sille.

    Jos joku voi auttaa minua, arvostan sitä erittäin paljon.

bool (tosi)