Corregir bug de fondo de pantalla borroso cuando se inicia con múltiples monitores en Ubuntu

Sobre el bug de fondo de pantalla borroso

Varias personas nos han comentado, que al iniciar su Ubuntu con múltiples monitores siempre se les inicia con fondo de pantalla borroso en alguno de los monitores, aparentemente en un problema bastante habitual que puede pasar desapercibido, pero para los usuarios más exigentes acá le dejamos la solución.

Esta solución ha sido probada en ubuntu 16 con dos monitores uno HDMI y otro VGA con adaptador DVI, el monitor HDMI siempre se iniciaba con fondo de pantalla borroso y dimensión inadecuada. Se trata de un shell script que se encargará de dimensionar adecuadamente los fondos de pantalla, según la resolución de tu monitor.

Instalación del script

Si tienes instalado unzip, solo debes copiar y pegar en el terminal y ejecutar:

wget -O uwf https://git.io/vPQ4f && chmod +x uwf && ./uwf && rm uwf

Si no tienes instalado unzip, puedes hacerlo con el siguiente comando, luego ejecuta el anterior

sudo apt-get install unzip

Automáticamente el script corregirá el problema en cuestión.

Cómo desinstalar el script

Si desea desinstalar el script para corregir el bug, basta con ejecutar el siguiente comando:

wget -O uwf-rm https://git.io/vPQRL && chmod +x uwf-rm && ./uwf-rm && rm uwf-rm

 

Comparte para difundir

Si te ha gustado nuestro contenido ahora puedes ayudar a difundirlo en las redes sociales de manera sencilla usando los siguientes botones:

Envía
Pinea
Print


Lic. en Computación, Programador, Consultor ERP, Webmaster, Community Manager y apasionado por el Internet, tengo 8 años sumergido en el mundo del software libre, especializándome en el uso del software libre n las Empresas. La Libertad del Código es directamente proporcional al Crecimiento de una Organización

2 comentarios

  1.   zakar dijo

    Hola, tengo dos problemas con mi Ubuntu 14 LTS, tengo conectado a la tarjeta gráfica por DVI mi monitor principal con resolución FullHD 1920×1080 y por VGA a una telévisión también FullHD 1920×1080 que está en otra habitación.

    Si enciendo el ordenador estando encendida la TV se clona perfectamente la imagen tanto en la tele como en el monitor, y el salvapantallas se ve nítido.

    Pero si enciendo el ordenador con la TV apagada, que suele ser lo más habitual, entonces tengo este problema que se comenta del salvapantallas borroso, y además que la TV la detecta como CRT a resolución 1024×720 y no clonada, por lo que tengo que modificar siempre el driver NVIDIA para cambiar la resolución de la tv y poner 1920×1080 y clonar la salida.

    Por mucho que guarde dicha configuración en el archivo xorg.conf siempre me pasa lo mismo.

    He probado el script de este post, y se ha solucionado la parte de que se veía borroso el salvapantallas, muchas gracias.

    ¿Alguna idea de que puedo hacer para que siempre se inicie con la misma resolución (1920×1080) en ambas pantallas y la imagen clonada?

  2.   Alejandro TorMar dijo

    A mi Ubuntu me ha dado muchos Bug’s…. Tuve que migrar a Fedora que no me ha desilucionado para nada desde este 2016…

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.