Apper: Gérez vos packages dans KDE

Il y a quelques jours, je regardais les référentiels de Test Debian une application pour KDE cela me servirait à installer / désinstaller des packages et que ce n'était pas Synaptique, car comme beaucoup le savent Kubuntu nous Muon, et est apparu applications.

applications USA ForfaitKit qui selon votre description:

PackageKit vous permet d'effectuer des tâches de gestion logicielle simples via une interface DBus, par exemple la mise à jour du cache, la mise à jour, l'installation et la suppression de progiciels ou la recherche de codecs multimédias et de descripteurs de fichiers.
Le travail est effectué par des backends qui utilisent le gestionnaire de packages envoyé par la distribution correspondante. PackageKit n'est pas destiné à remplacer des outils avancés tels que Synaptic.

Malgré cela, avec applicationsEn plus d'installer et de désinstaller des logiciels de manière simple, nous pouvons rechercher dans nos référentiels en filtrant si les packages de développement sont installés ou non, qu'ils aient ou non une interface graphique, ou qu'ils soient gratuits ou non. Nous pouvons également voir les dépendances et les descriptions de chaque paquet.

Bien sûr, nous pouvons gérer nos miroirs, mettre à jour de temps en temps et même installer automatiquement les packages de sécurité ou toutes les mises à jour disponibles.

Pour l'installer sur Debian rien de plus simple que de courir dans un terminal:

$ sudo aptitude install apper

Prêt..


Le contenu de l'article adhère à nos principes de éthique éditoriale. Pour signaler une erreur, cliquez sur c'est par ici !.

23 commentaires, laissez le vôtre

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

*

*

  1. Responsable des données: Miguel Ángel Gatón
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.

  1.   jony127 dit

    Un problème avec la synaptique ou simplement essayer quelque chose d'autre ???

    1.    animé dit

      Je cherchais autre chose que Gtk ... même si pour le moment je ne sais pas si Apper est QT ou O

      1.    labo de code dit

        Apper est l'interface basée sur la bibliothèque KDE pour PackageKit (alias KPackageKit), en fait, il n'a aucune dépendance sur les bibliothèques Qt.

        Dépendances:

        PackageKit> = 0.8.5
        En-têtes KDELibs de Kde4
        Espace de travail KDE
        KDE> = 4.3

        Salutations.

        labo de code

        1.    animé dit

          Je savais déjà ... Je cherchais plus d'informations sur ce sujet en ce moment ... merci pour la clarification.

          1.    labo de code dit

            De rien.

            Au fait, utilisez-vous la version Nightly de Firefox pour une raison particulière? Comment vas-tu avec elle?

            labo de code

  2.   Percaff_TI99 dit

    Salut, commenter Debian aujourd'hui Debian Installer 7.0 Release Candidate 1 est enfin disponible, cela signifie que la version stable sera sur le point de sortir. Quant à apper, il est écrit en C ++ et comme vous le dites, il utilise l'interface graphique de packagekit, à certains endroits, ils disent packagekit-qt2 mais je ne suis pas sûr. Salutations et faites un excellent blog pour vous et votre partenaire
    KZKG ^ Gaaraaaaaaaa xD avec le reste de l'équipe.

    1.    animé dit

      Oh! Merci de vous avoir transmis des nouvelles aussi intéressantes.

  3.   Pourritures87 dit

    Bonjour les gens, je vous dis que pour archlinux ça marche aussi apper, je l'utilise et c'est super pour moi. Je sais que les fans de bash diront qu'avec pacman on est des services et c'est vrai ... mais parfois pour celui (comme moi) qui s'y habitue encore, il faut avoir ces outils graphiques

    1.    msx dit

      Je pense qu'Apper est une excellente option lorsque nous installons Arch pour les utilisateurs finaux, car ils peuvent ainsi maintenir leur système à jour presque de manière triviale.
      Personnellement, j'utilise toujours Yaourt pour mettre à jour les packages officiels et le reste des 312 packages AUR installés 😛

      (J'avoue que Yaourt est à Cower ce qu'Apper à Yaourt!)

  4.   merlin le debianite dit

    Apper est que je l'ai utilisé depuis que je suis passé à KDE fortement recommandé, vous pouvez même installer un .deb depuis apper.

    Salutations au revoir.

  5.   sieg84 dit

    et pense que c'est la première chose que je désinstalle après avoir installé openSUSE

    1.    tavo dit

      Je pense que la plupart du temps lors de l'installation d'OpenSUSE, je l'ai fait, en fait je l'ai fait. Je pense qu'apper n'a pas de sens dans cette distribution ayant un gestionnaire de paquets / configurateur de système comme YaST. Quoi qu'il en soit, une fois que vous avez pris la meilleure façon de gérer les référentiels et d'installer les paquets est Zypper de la console

      1.    msx dit

        Zypper et Yum sont la bombe, je les aime presque plus que pacman xD

  6.   geek dit

    Je viens d'installer debian testing kde et il est venu avec apper

    1.    animé dit

      Oui, lorsque vous installez le CD Debian que KDE l'inclut, je l'ai découvert récemment .. mais je fais toujours l'installation avec Netinstall 😀

  7.   oai027 dit

    Bonjour, s'il vous plaît quelqu'un qui sait comment mettre à jour Apper de 0.72 du canal sof à la plus récente 0.80? Merci pour votre sympathie. Bonjour !!!

    1.    animé dit

      À votre santé…

      Quelle distribution utilisez-vous?

      1.    oai027 dit

        Elav: J'utilise Kubuntu 12.10 64 bits à la maison, merci de m'avoir guidé.

    2.    labo de code dit

      Good OaiO27.

      Je n'utilise pas K / Ubuntu sur mon bureau mais je pense que la version la plus élevée trouvée dans les dépôts / PPA est 0.7.2-5, donc j'imagine que si vous voulez avoir la dernière version (0.8.0) vous aurez que de compiler à partir des fichiers source.

      TÉLÉCHARGEMENT DES SOURCES

      Téléchargez la dernière version ici: http://download.kde.org/stable/apper/0.8.0/src/apper-0.8.0.tar.bz2

      COMPILADE

      Décompressez le fichier téléchargé où vous le souhaitez.

      Accédez au répertoire dans lequel vous avez décompressé les fichiers source:

      $ cd app-0.8.0

      Créez un répertoire appelé build et entrez-le:

      $ mkdir build && cd build

      Exécutez la commande suivante, INSTALL_PREFIX doit être celui indiqué, sinon KDE ne pourra pas trouver Apper:

      $ cmake .. -DCMAKE_INSTALL_PREFIX = / usr /

      Exécutez ensuite les commandes suivantes dans le terminal:

      Faire $
      $ sudo faire l'installation

      En principe, apper devrait compiler sans problème, à partir de là, vous pouvez utiliser la dernière version de ce package.

      N'oubliez pas de vous connecter pour que les modifications prennent effet. Si je me suis trompé dans quelque chose, excusez-moi, mais comme je l'ai déjà dit, je n'utilise aucune distribution Canonical ou Apper comme gestionnaire de paquets

      Salutations.

      labo de code

  8.   oai027 dit

    codelab: Merci d'avoir répondu, je l'ai mis en pratique et je vous parle de l'expérience, donc cela sert d'autres personnes qui arrivent x la même chose.

    Hug d'Argentine. Osky

  9.   chasseur dit

    Pour debian, je n'ai rien vu qui s'intègre mieux que synaptic, et après avoir installé qtcurve, cela ressemble à une autre application qt.

  10.   rafael dit

    Salut! salut à tous! bon de lire ce type d'informations! la vérité est que je travaille avec Debian depuis un moment et j'adore ça! ce gestionnaire de paquets, j'ai aussi lu du muon qu'il est très bon! J'utilise en fait l'apper qui se trouve dans les dépôts Debian! (Tout est dans les dépôts Debian, c'est le meilleur! Haha)
    Si quelqu'un veut installer des packages .deb avec l'apper, cliquez dessus sans problème, mais il est nécessaire d'avoir les packages gdebi-core et gdebi-kde! afin que nous puissions installer le package!
    Je voulais juste faire un commentaire là-dessus! salut à tous! Merci de partager les connaissances!

  11.   Camilo dit

    Je l'ai déjà utilisé et cela fonctionne très bien mais installer debian kde7.6.0 live cd ne fonctionne pas J'ai une carte pc asus p8b75mlx ram cmv4gx3m1a1600c11 hd toshiba 1tb corei5 2400 si quelqu'un peut m'aider. Merci d'avance.