DEBIAN 10: Quels paquets supplémentaires sont utiles après l'installation?

DEBIAN 10: Quels paquets supplémentaires sont utiles après l'installation?

DEBIAN 10: Quels paquets supplémentaires sont utiles après l'installation?

Cet article est la suite (deuxième partie) des Tutoriales dédié à DEBIAN GNU / Linux Distro, version 10 (Buster), qui sert de base à de nombreux autres tels que MX-Linux 19 (vilain petit canard).

Cette deuxième partie nous montrerons que d'autres packages supplémentaires ou supplémentaires (applications) sont recommandés à suivre optimisation (complémentation) nos beaux et grands Distros DEBIAN 10 et MX-Linux 19.

Mettre à jour et optimiser MX-Linux 19.0 et DEBIAN 10.2 après l'installation

Mettre à jour et optimiser MX-Linux 19.0 et DEBIAN 10.2 après l'installation

Depuis, la première partie de cette série de tutoriels, appelée "Mettre à jour et optimiser MX-Linux 19.0 et DEBIAN 10.2 après l'installation » était concentré sur actions et packages de base essentiels nécessaire pour un première mise à jour, personnalisation et optimisation d'entre eux, c'est-à-dire les premières étapes post-installation une fois installées.

Et en citant l'article précédent, rappelez-vous ce qui suit:

"N'oubliez pas que les actions et les packages recommandés ici pour exécuter et installer ne sont que cela, "paquets recommandés", et c'est à chacun d'exécuter et d'installer tout ou partie d'entre eux, pourquoi sont-ils nécessaire ou utile, à court ou moyen terme, pour les connaître et les utiliser, en les faisant déjà fonctionner ou installés.

Et gardez à l'esprit que ces actions et / ou packages étaient précédemment testé sur les deux Distros, et ils ne demandent pas de désinstaller les packages installés par défaut dans ceux-ci. En outre, ils n'augmentent pas la consommation de mémoire ou de CPU depuis, ils ne chargent pas les processus ou les démons (services) en mémoire par défaut. Pour savoir à l'avance à quoi sert chaque package, cliquez sur c'est par ici !. »

Debian 10 Buster

DEBIAN 10: packages supplémentaires utiles à installer

Applications de jeux natives

apt install games-adventure games-arcade games-board games-card games-chess games-console games-education games-emulator games-fps games-java-dev games-mud games-platform games-programming games-puzzle games-racing games-rogue games-rpg games-shootemup games-simulation games-sport games-strategy games-tasks games-toys games-typing

Objectif: Installer des packages de jeu spécifiques par catégories définies

apt install atari800 cen64 cen64-qt desmume dolphin-emu dosbox fs-uae fs-uae-arcade fs-uae-launcher fs-uae-netplay-server games-emulator gbsplay gngb gnome-nds-thumbnailer hatari higan mame mame-data mame-extra mame-tools mednafen mednaffe mess-desktop-entries mgba-common mgba-qt mgba-sdl mupen64plus-audio-all mupen64plus-data mupen64plus-input-all mupen64plus-qt mupen64plus-rsp-all mupen64plus-rsp-hle mupen64plus-rsp-z64 mupen64plus-ui-console mupen64plus-video-all mupen64plus-video-arachnoid mupen64plus-video-glide64 mupen64plus-video-glide64mk2 mupen64plus-video-rice mupen64plus-video-z64 nestopia osmose-emulator pcsxr stella vice virtualjaguar visualboyadvance xmms2-plugin-gme yabause yabause-common yabause-gtk yabause-qt yakuake

Objectif: Installez des émulateurs de console rétro.

Support vidéo

apt install xserver-xorg-video-all libva-drm2 libva-glx2 libva-wayland2 libva-x11-2 libva2

Objectif: Installez la prise en charge du pilote vidéo de base, généralement intégrée.

Prise en charge audio

apt install alsa-firmware-loaders alsa-oss alsa-tools alsa-utils alsamixergui volumeicon-alsa paprefs pavumeter pulseaudio-utils ffmpeg2theora sound-icons

apt install lame libdvdnav4 libdvdread4 libfaac0 libmad0 libmp3lame0 libquicktime2 libstdc++5 libxvidcore4 twolame vorbis-tools x264

apt install gstreamer1.0-x gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-alsa gstreamer1.0-pulseaudio gstreamer1.0-tools

Objectif: Installez le support de base des pilotes audio, généralement intégrés. Et d'autres applications, accessoires et bibliothèques nécessaires à la gestion de l'audio et du son sur les ordinateurs.

Prise en charge des périphériques d'impression et de numérisation

apt install cups cups-client cups-bsd cups-filters cups-pdf cups-ppdc

apt install foomatic-db-compressed-ppds foomatic-db-engine ghostscript-x ghostscript-cups gocr-tk gutenprint-locales hannah-foo2zjs hpijs-ppds hplip openprinting-ppds printer-driver-all printer-driver-cups-pdf printer-driver-foo2zjs printer-driver-hpcups printer-driver-hpijs

apt install avahi-utils colord flex g++ libtool python-dev sane sane-utils system-config-printer system-config-printer-udev unpaper xsane xsltproc zlibc

Objectif: Installez la prise en charge de base des pilotes, applications, modules complémentaires et bibliothèques nécessaires à la gestion des périphériques d'impression et de numérisation.

Prise en charge des applications bureautiques

apt install fonts-arabeyes fonts-cantarell fonts-freefarsi fonts-liberation fonts-lyx fonts-mathjax fonts-oflb-asana-math fonts-opensymbol fonts-sil-gentium fonts-stix myspell-es ooo-thumbnailer xfonts-intl-arabic xfonts-intl-asian xfonts-intl-chinese xfonts-intl-chinese-big xfonts-intl-european xfonts-intl-japanese xfonts-intl-japanese-big ttf-bitstream-vera ttf-dejavu ttf-summersby

apt install libreoffice libreoffice-base libreoffice-gnome libreoffice-gtk3 libreoffice-help-es libreoffice-java-common libreoffice-l10n-es libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin libreoffice-style-breeze libreoffice-style-elementary libreoffice-style-sifr

apt install pdfarranger pdfshuffler pdftk

Objectif: Installez la prise en charge de base des applications bureautiques, des modules complémentaires et des polices.

Prise en charge de la compatibilité Windows HW et SW

apt install cifs-utils disk-manager dosfstools exfat-fuse exfat-utils fuse gvfs-fuse hfsplus hfsutils icoutils ideviceinstaller ipheth-utils libsmbclient mtools mtp-tools ntfs-3g python-smbc smbclient samba-common smbnetfs samba samba-common-bin

apt install cabextract fonts-wine mscompress playonlinux q4wine ttf-mscorefonts-installer winetricks

apt install ndiswrapper

Objectif: Installez le support de base pour la compatibilité avec le matériel et le logiciel d'autres systèmes d'exploitation, principalement MS Windows.

Prise en charge de l'ordinateur HW

apt install acpi acpitool acpi-support fancontrol firmware-linux-free hardinfo hwdata hwinfo irqbalance iucode-tool laptop-detect lm-sensors lshw lsscsi smartmontools xsensors

Objectif: Installez le support de base pour la compatibilité avec le matériel générique des ordinateurs.

apt install intel-microcode

apt install amd64-microcode

Objectif: Installez la prise en charge du jeu d'instructions CPU de base pour la compatibilité avec les processeurs Intel et AMD.

sensors-detect
chmod u+s /usr/sbin/hddtemp
hddtemp /dev/sda

Objectif: Installer le support de base des outils et drivers pour la gestion des températures, de la tension des éléments de l'ordinateur, y compris la gestion des ventilateurs.

Prise en charge des périphériques de connexion sans fil

apt install wifi-radar wireless-tools wpagui wpasupplicant

Objectif: Installez la prise en charge des applications de base pour la gestion des périphériques sans fil sur un ordinateur.

apt install firmware-atheros

apt install firmware-b43-installer firmware-b43legacy-installer firmware-bnx2 firmware-bnx2x firmware-brcm80211

apt install firmware-intelwimax firmware-iwlwifi

apt install firmware-ralink firmware-realtek

Objectif: Installez la prise en charge de base des pilotes pour la gestion des périphériques sans fil (WiFi) sur un ordinateur.

Prise en charge des périphériques de connexion Bluetooth

apt install bluetooth bluez bluez-cups bluez-firmware bluez-tools btscanner gnome-bluetooth python-bluez pulseaudio-module-bluetooth

Objectif: Installez la prise en charge du pilote de base pour la gestion des périphériques de connexion sans fil (Bluetooth) d'un ordinateur.

Prise en charge des périphériques de connexion Internet USB

apt install mobile-broadband-provider-info ppp pppconfig modemmanager modem-manager-gui modem-manager-gui-help usb-modeswitch usb-modeswitch-data wvdial

Objectif: Installez la prise en charge des applications et des pilotes de base pour la gestion des périphériques de connexion Internet USB connectés à un ordinateur.

Prise en charge des appareils multimédias mobiles

apt install gammu gtkpod libgammu-i18n libgpod-common libgpod-cil libgpod4 libmtp-runtime mtp-tools wammu

Objectif: Installez le support de base des applications et des bibliothèques pour la gestion des périphériques multimédias connectés à un ordinateur.

Debian 10

Conclusion

Attendre cette "petit message utile » sur quoi applications supplémentaires peut être installé sur Distros GNU / Linux «DEBIAN y MX-Linux», dans ses versions les plus récentes et actuelles pour l'année 2020, pour atteindre «actualizarlas y optimizarlas», est d'un grand intérêt et d'une grande utilité, pour l'ensemble «Comunidad de Software Libre y Código Abierto» et d'une grande contribution à la diffusion de l'écosystème merveilleux, gigantesque et croissant d'applications de et pour «GNU/Linux».

Et pour plus d'informations, n'hésitez pas toujours à visiter Bibliothèque en ligne comme OpenLibra y Jedit pour lire livres (PDF) sur ce sujet ou sur d'autres domaines de connaissances. Pour l'instant, si vous avez aimé ça «publicación», n'arrêtez pas de le partager avec les autres, dans votre Sites Web, chaînes, groupes ou communautés favoris des réseaux sociaux, de préférence gratuits et ouverts au Mastodonte, ou sécurisé et privé comme Telegram.

Ou visitez simplement notre page d'accueil à DeLinux ou rejoignez la chaîne officielle Télégramme de FromLinux lire et voter pour cette publication ou d'autres publications intéressantes sur «Software Libre», «Código Abierto», «GNU/Linux» et d'autres sujets liés à «Informática y la Computación»Et l' «Actualidad tecnológica».


Le contenu de l'article adhère à nos principes de éthique éditoriale. Pour signaler une erreur, cliquez sur c'est par ici !.

10 commentaires, laissez le vôtre

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

*

*

  1. Responsable des données: Miguel Ángel Gatón
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.

  1.   guerre albertaine dit

    Le pdftk m'a été très utile pour concaténer plusieurs fichiers pdf dans un seul document via la ligne de commande.
    exemple:
    fichier pdftk_0001.pdf fichier_0002.pdf fichier_0003.pdf fichier de sortie cat_123.pdf

    1.    Post-installation Linux dit

      Merci Alberto. Pour votre contribution. Je l'ai inclus dans la section Support pour les applications bureautiques de l'article, car je me suis rendu compte que je n'avais pas mis d'applications (packages) pour la gestion avancée des fichiers PDF.

      Insérez cette ligne: apt install pdfarranger pdfshuffler pdftk

      Les 2 autres sont pour le même mais de l'interface utilisateur graphique (GUI).

  2.   Fran dit

    Merci est une contribution très importante pour beaucoup d'entre nous qui veulent juste commencer dans le monde Debian

    1.    Post-installation Linux dit

      Salutations, Fran! Merci pour votre commentaire positif sur l'article.

  3.   RubenMTL dit

    Salut!. Merci beaucoup pour ce post, il m'a été très utile puisque je viens de passer à Debian 10, plasma KDE. J'ai installé la grande majorité sans problèmes. bien que maintenant je détaille les problèmes que j'ai eu avec certains qui n'étaient pas installés.
    Avec le package alsa-firmware-loaders, j'ai obtenu:

    E: Le package alsa-firmware-loaders est introuvable

    Et la même chose m'est arrivée avec ces autres packages: libfaac0, amd64-microcode, firmware-atheros, firmware-b43-installer, firmware-b43legacy-installer, firmware-bnx2, firmware-bnx2x, firmware-brcm80211, firmware-intelwimax, firmware- iwlwifi, firmware-ralink, firmware-realtek, bluez-firmware.

    1.    Post-installation Linux dit

      Salutations RubenMTL! Merci pour ton commentaire et observation. J'essaierai d'installer un DEBIAN 10.3 très prochainement pour retester chaque paquet et revalider chaque paquet actuellement existant.

      1.    RubenMTL dit

        De rien!. Génial !!. Merci à vous pour votre temps, salutations. !!

  4.   RubenMTL dit

    Une autre affiche qui est sortie était avec le paquet hannah-foo2zjs:

    Le paquet hannah-foo2zjs n'est pas disponible, mais un autre paquet y fait référence. Cela peut signifier que le package est manquant, obsolète ou uniquement disponible à partir d'une autre source.

    E: Le paquet hannah-foo2zjs n'a aucun candidat pour l'installation.

    Cela vient également avec les packages: ttf-mscorefonts-installer, winetricks, playonlinux, iucode-tool

    Enfin, lorsque j'ai voulu redémarrer depuis le terminal, j'étais coché et j'ai dû éteindre le notebook à partir du bouton d'alimentation, car il ne répondait pas. Et une fois lancé, le programme est revenu, j'ai essayé de le redémarrer cette fois à partir du bureau et il est également vérifié ... donc encore une fois, je dois le faire à partir du bouton sur le portable. A aucun moment je ne peux redémarrer ou arrêter depuis le bureau, je dois le faire si ou si j'appuie sur le bouton.

    J'espère que vous pourrez m'aider à résoudre ces problèmes, merci pour votre temps, salutations!

    1.    Post-installation Linux dit

      Salutations RubenMTL! Je ne pourrais pas vous dire exactement. Quelque chose doit avoir changé concernant la gestion de l'alimentation (ACPI). 🙁

      1.    RubenMTL dit

        Pas de drame, merci quand même pour l'aide! À votre santé!!