Solution au problème de l'installation d'applications 32 bits sur Linux Mint 14 RC 64 bits

Je viens de publier les nouvelles que je connais déjà Linux Mint 14 RC est disponibleet Clem Vient d'être annoncé que dans la version 64 bits il y a un problème qui ne permet pas d'installer des applications telles que Skype, Google Earth ou tout autre package 32 bits.

La possibilité d'installer des applications 32 bits dans un environnement 64 bits est communément appelée «Multiarch». Apparemment, il y a eu un changement avec dpkg dans Debian, qui a fait la configuration Multiarche devenir obsolète en Ubuntu. Vous pouvez voir plus d'informations sur ce problème ici: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294

Solution

Pour activer Multiarch, ouvrez un terminal et saisissez les commandes suivantes:

sudo dpkg --add-arquitectura i386
apt update

Ce problème sera résolu manuellement dans la version stable de Linux Mint 14.


Le contenu de l'article adhère à nos principes de éthique éditoriale. Pour signaler une erreur, cliquez sur c'est par ici !.

12 commentaires, laissez le vôtre

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

*

*

  1. Responsable des données: Miguel Ángel Gatón
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.

  1.   Willian dit

    @MonitoLinux fonctionne trop pour vous. Je ne suis pas sûr de le trouver dans les backports stables. Mais je peux vous garantir que dans Sid, et très probablement maintenant dans les dépôts de Wheezy [1], vous le trouverez disponible.

    [1] http://www.debian.org/News/2011/20110726b

    Le support multiarch est quelque chose qui a fait beaucoup de bruit. Je suis entré en collision avec lui comme en juin et il roulait déjà depuis longtemps.

    1.    monitolinux dit

      @Willians, c'est que je viens d'une époque plus ancienne, où il n'y avait pas autant de référentiels avec les applications dont on avait besoin, où l'un des plus trouvés était le code source.

  2.   RafaGCG dit

    Je suis un peu perdu (vaaale beaucoup) avec ça. J'utilise Xubuntu 12.10 64Bit (un cliché comparé à ubuntu 12.10 qui est leeeento) et ma surprise lorsque je suis allé installer KompoZer est qu'il n'apparaissait pas ... à la fin j'ai déduit que puisqu'il n'existait pas pour 64bit il n'était pas dans les référentiels ... même si jusqu'à présent il l'a toujours eu installé (avec apt-get install Kompozer) mais cette fois il n'apparaît pas. Après beaucoup de réflexion, j'ai trouvé un DeB 64 bits et l'ai installé. Mais mon doute et enfin j'arrive à l'essentiel. Si j'installe ceci que vous commentez ce post. Les packages 32 bits apparaîtront-ils dans le référentiel pour installer des programmes 32 bits si ceux de 64 bits ne sont pas disponibles? Le Kompozer 32 bits serait-il apparu pour que je l'installe dans les référentiels? Est-ce bien que je le fasse pour les programmes futurs dont j'ai besoin?

  3.   Garbage_Killer dit

    elav je vous l'ai dit, ce n'est pas pour ça que j'étais dans Debian Sid 😛

    en fait ce problème que la menthe présente, Debian Sid l'a déjà présenté il y a environ 2 mois, même en synaptique il dit qu'avant d'installer ia32-libs et ia32-libs-gtk, il vous recommande d'ajouter dpkg –add-architecture: i386 puis d'exécuter un mise à jour et prêt.

    1.    elav dit

      Quand m'avez-vous dit? Je ne me souviens pas 😛

      1.    Garbage_Killer dit

        il y a précisément 2 mois, quand j'ai eu un problème similaire, mais c'était parce que le paquet ia32-libs-gtk était obsolète, et il n'est toujours pas sorti pour compléter les nouveaux ia32-libs, jusqu'à ce que je me souvienne de ce que vous avez dit et pourquoi vais-je ajouter dpkg –add- architecture: i386 😛

        1.    elav dit

          Hahaha c'était via IRC, non?

  4.   MonitorLinux dit

    la solution est de télécharger le code source et de le compiler, puis de générer le paquet deb et de le donner à la communauté

  5.   Sergio Esau Arámbula Duran dit

    Génial 🙂

  6.   Utilisons Linux dit

    Très bon! Intéressant…
    Espérons qu'ils résoudront le problème avant la sortie de la version finale.
    À votre santé! Paul.

  7.   mfcollf77 dit

    J'ai installé linux mint 14 64 bits et je n'ai eu aucun problème à installer Skype, seule la version 4.0 a été installée

    Je vais voir avec quoi d'autre j'ai un problème