Fragen nei Xfce 4.10 release

Nick schermer, ien fan 'e liedende ûntwikkelders fan Xfce, hat pleatst op dit blog Buroblêdomjouwing in artikel dat antwurdet op guon fan 'e meast stelde fragen troch brûkers. Ik sil besykje it sa goed mooglik te oersetten, lykwols kinne jo it yn it Ingelsk rieplachtsje op Dizze link.

Fragen nei de frijlitting fan 4,10

este koart post is in antwurd op guon fragen dy't ik haw taret yn 'e opmerkingen oer it parseberjocht fan Xfce 4.10 oer it ynternet As jo ​​mear fragen hawwe, lit my witte yn 'e opmerkingen en ik sil besykje se te beantwurdzjen.

In nije stabile ferzje nei 16 moannen? En it is gjin release 4.8.1 ...

Dit komt om't Xfce hat in ûntwikkelingsmodel oars oan GNOME o KDE as it giet om stabile ferzjes, fanwegen de Beheind team fan ûntwikkelders Se wolle sa min mooglik tiid besteegje oan it frijjaan fan de pakketten. Grutte stabile ferzjes, lykas oare buroblêden dogge, binne tiidslinend, sels mei it lytse oantal kearnpakketten fan Xfce.

Dêrom waard nei ferzje 4.6 it folgjende besletten: dat der mar 4 grutte releases sille wêze (3 foarriedige ferzjes en in stabile ferzje) en dan allinich stabile ferzjes foar de yndividuele pakketten. Dus de buroblêdferzje is 4.10 (let op it ûntbrekken fan mikronûmer), en yndividuele komponinten kinne in grutter getal hawwe 4.10.x.

As foarbyld, de lêste stabile ferzje fan 'e 4.8 ferzje de xfce4-dev-ark is de 4.8.0, itselde as yn fet-tarball. De lêste útjefte fan xfce4-paniel yn it 4.8 ferzje es 4.8.6 (dat binne 6 stabile ferzjes nei 4.8.0, dat wie yn 'e fet-tarball).

Wy wite dat dit lestiger is foar nije brûkers, dy't leaver in komprimearre bestân pakke mei alle lêste ferzjes, mar leaver trochkriuwe moatte / src / xfce en de needsaak om de lêste ferzje te finen. Foar distribúsjes is dit folle makliker: de pakkers binne ynskreaun op 'e ferstjoerlist xfce-oankundigje of se kinne nei sjen identi.ca en op 'e tiid it pakket dat se moatte bywurkje.

Dit is lykwols noch in punt wêr't wy kinne ferbetterje, dus litte wy sjen as wy mear ynformaasje kinne jaan op 'e webside (meidielings en keppelings nei de lêste ferzjes fan it pakket).

De ferzje 4.10 Ik hie mar 2 foarferzjes, om't der gjin krityske bugs ferskynden en de oersettingen goed wiene. Redenen genôch foar my om de pre3 oer te slaan en de frij te meitsjen 4.10 ynstee.

Online dokumintaasje Wiki

Gewoan om hjir dúdlik oer te wêzen: wy begripe dat online dokuminten gjin oplossing binne, mar it wie it bêste dat wy yn in koarte tiid koene dwaan. Wy hoopje dat de op wiki basearre opset mear bydragen lûkt en liedt ta in folsleine set dokumintaasje. As wy tefreden binne oer de ynhâld fan 'e wiki, sille wy in momintopname meitsje en yn xfce4-docs sette.

gtk3

As earste binne d'r 2 dingen: Xfce 4.10 net brûke gtk3, allinich de temamotor gtk-xfce-motor stipet gtk3, Twad sille wy beprate si Xfce 4.12 wurdt oerdroegen oan gtk3, Ik sil it lêste útlizze:

Technysk gtk3 hat neat oars as gtk2 as it giet om programmearjen. De hurde dielen binne yn portearjen fan guon oanpaste widgets (tekenje en grutte), ferfangingen fan guon ferâldere symboalen en keppeling nei biblioteken fan gtk3, Alle dingen a brûker jo sille net fernimme as wy it goed krije

gtk3 it is net flugger dan gtk2, miskien binne d'r guon gebieten wêr't it in bytsje rapper is, mar d'r binne gebieten wêr't prestaasjes in bytsje sakke. Neat ferrassend hjir.

Ik bin my bewust fan 'e problemen by it oanpassen fan tema's fan gtk3, Fan wat ik begryp is dit hinne en wer feroare yn GTK 3.0, 3.2 en 3.4. Dat wy moatte beslute hokker ferzje nedich is om dit konstante wurk te krijen, om't minsken kleie as allinich it probleem fan Raleigh It kin brûkt wurde :).

Ut it eachpunt fan Xfce is net (wer) it probleem fan boarnen om alle plugins te poarte, want as bygelyks it paniel is porteare foar gtk3, moatte ek de plugins wurde porteare. Net allegear goodies se wurde ûnderhâlden, mar normaal wurkje se en kinne wurde kompileare troch distribúsjes.

Yn alle gefallen moatte wy net te optein wurde oer gtk3, it is gewoan gkt 2.26 mei in geweldige api :). As wy ienris beslute hokker ferzje wy brûke yn 4.12, sil ik dizze op it blog pleatse.

LXDE verbruikt noch minder ûnthâld

* Sûchje * Ik sil dit net raze, om't jo as brûker it buroblêd moatte kieze dat jo bliid makket, mar it steurt my dochs in bytsje. Dus om wat ynformaasje te ferliezen:

LXDE y Xfce se binne basearre op deselde toolkit en leverje min of mear deselde set funksjes. Dat makket it as útgongspunt technysk hast ûnmooglik om folle better of minder te wêzen as it giet om ûnthâldgebrûk. Ik tink dat dizze myte it allegear begon troch twa distribúsjes te fergelykjen (hint: strcmp (distro_a + 1, distro_b + 1) == 0).

Dat bin ik wis Xfce it ferbrûkt wat mear ûnthâld, om't it mear prosessen begjint. Benammen as eksterne plugins wurde tafoege oan it paniel: in ûntwerpbeslút om it paniel stabiler te meitsjen.

Ik wit net of kin skele wêr't dizze fergeliking begon, mar as immen it yn 'e takomst nochris docht, ferlykje asjebleaft it werklike ûnthâldgebrûk en net it fergese ûnthâldgebrûk. Of noch better: jo kinne geheugengebrûk hielendal net fergelykje, om't it frij nutteloos is.

Dat wurdt sein: as ik begjin LXDE y Xfce 4.10 as standert buroblêd (mei ArchLinux pakketten) en gebrûk ps_mem.py , Xfce ferbrûkt 2 MiB mear ûnthâld (mei deselde applikaasjes iepen), Doch wat jo wolle mei dizze getallen, salang't jo appels en appels fergelykje.

Net folle prestaasjes yn mear dan 1 jier

Sorry, mar wy wurkje ek de heule wike. Mar ik ferwyt mysels net Xfce it is in leuk projekt foar ús allegear en as minsken nei in oar lân ferhúzje, in dei hawwe op it wurk, in libben, skoalle, eksamens of gewoan gjin sin hawwe om yn te wurkjen Xfce, do kinst net folle mear dwaan.

Ik persoanlik haw it gefoel dat in soad waard dien yn 'e 4.10 ferzje, dat neat wichtich waard brutsen en dat in soad dingen te dwaan foar 4.10 waarden foltôge yn 'e release-syklus. It doel wie poetsen / skjinmeitsje en dat hawwe wy dien!


De ynhâld fan it artikel hâldt him oan ús prinsipes fan redaksje etyk, Om in flater te melden klikje hjir.

11 opmerkingen, lit jo

Lit jo reaksje efter

Jo e-mailadres wurdt net publisearre. Ferplichte fjilden binne markearre mei *

*

*

  1. Ferantwurdlik foar de gegevens: Miguel Ángel Gatón
  2. Doel fan 'e gegevens: Control SPAM, kommentaarbehear.
  3. Legitimaasje: jo tastimming
  4. Kommunikaasje fan 'e gegevens: De gegevens wurde net oan tredden kommunisearre, útsein troch wetlike ferplichting.
  5. Gegevensopslach: Databank hoste troch Occentus Networks (EU)
  6. Rjochten: Op elk momint kinne jo jo ynformaasje beheine, herstelle en wiskje.

  1.   auroszx sei

    Ik bin bliid dat dizze ferzje út is. Meikoarten sil ik wat tiid nimme om it te ynstallearjen 🙂

  2.   Angelo sei

    Alles dat waard bleatsteld liket my nijsgjirrich, mar somtiden krije dizze ûntwikkelders net alle erkenning dy't se moatte, en in protte einigje op kriminele manier. Ik bin bliid oer de nije ferzje fan jo buroblêdomjouwing dy't ik hieltyd mear leuk fyn, lykwols kinne jo "tusken de rigels" lêze dat se mear kollaborateurs nedich binne, of minder hoemannichte "Eksperts" dy't har bekritisearje sûnder te witten.

    PS Ferjou my foar de hurde wurden, ik sis it net foar dit blog dat ik tink it bêste is yn 'e wrâld fan GNU / LINUX, mar foar in protte dy't leauwe dat alles draait om UBUNTU of GNOME en KDE.

    1.    elav <° Linux sei

      Ja, jo hawwe gelyk yn dat in protte kearen brûkers kritisearje op ûntwikkelders sûnder sels ússels op har plak te setten. It is as as wy easkje dat se foar ús moatte wurkje, as sels in protte fan harren it fergees dogge, as hobby. It is ek wier dat in protte fan dizze ûntwikkelders net wurde erkend sa't se moatte wêze.

      Betanke foar it stopjen en kommentaar Angelo.

  3.   Carlos-Xfce sei

    Hoi Elav. Nijsgjirrich. Ik bin heul bliid dat dizze ferzje einlings útkaam. Hooplik sil it Xfce-team der oan trochwurkje.

    Hoi, ik tink dat jo al in tutorial hawwe dien om Debian mei Xfce op netbook te ynstallearjen, of bin ik ferkeard? Is dat op myn netbook haw ik Ubuntu 10.04 en ik wol it feroarje.

    Ik frege my ek ôf oft LMDE Xfce kin ynstalleare wurde op netbook fia USB-kaai, of as gebrûk fan DVD ferplicht is.

    Wat advisearje jo foar myn mini-laptop? Debian Xfce as LMDE Xfce?

    Tank foar jim oandacht.

    1.    elav <° Linux sei

      groetnis Carlos-Xfce:
      Effektyf LMDE Xfce kin ynstalleare wurde fanôf in USB-stick. No, oer de oanbefelling dy't jo my freegje, tink ik dat as jo wolle dat alles wurket en neat hoecht oan te reitsjen, it soe goed wêze foar jo LMDE Xfce of sels Xubuntu, Jo kieze.

      1.    Carlos-Xfce sei

        Hoi Elav. Lykas altyd, tige tank foar reagearjen. Ik sil jo oanbefelling beskôgje. Ik haw no Xubuntu 11.10 op myn buroblêd, mar ik mis de snelheid fan LMDE Xfce.

        Dat ik sil de lêste ferzje fan LMDE Xfce testen op myn mini-laptop en sjoch hoe't it giet. Hooplik sil nei in pear wiken wat tutorial útkomme oer hoe't jo Xfce feilich kinne bywurkje.

    2.    topokrium sei

      Ik haw sels LMDE Xfce ynstalleare en in USB-kaai. 🙂

      1.    Carlos-Xfce sei

        Hoi. Hoe binne jo dwaande west mei it ynstallearjen fan LMDE Xfce op in USB-kaai? Ik besykje UNetbootin en ik kin it net. De .iso aksepteart my net om de bootdisk oan te meitsjen mei de USB-kaai.

  4.   pc-bsd sei

    Dizze ferzje sil wis oanwêzich wêze yn 'e folgjende edysje fan PC-BSD mei XFCE-buroblêdomjouwing.
    Tink derom dat no PC-BSD te krijen is mei ferskate buroblêd-omjouwings (kde, gnome, xfce, lxde flubox) en mooglik letter MATE-buroblêd.

  5.   topokrium sei

    Yn dit berjocht hat Schermer it dúdlik makke wêrom net GTK3. Foar noch in moanne as twa sille se neat planne op 4.12 en dêrom beslute se Xfce wol of net te dragen (en myn weddenskip is net).

    Minsken lykje te ferjitten dat GTK3 in revolúsje is en as sadanich sil it tiid duorje foar it stabilisearjen (bgl. It tema-probleem dat Schermer neamt) en dêrom is d'r in sterker fûnemint om it miljeu fierder te ûntwikkeljen.

    It is ek wier dat 4.10 in ynterne evolúsje hat kulminearre dy't al begon wie yn 4.8 (xfconf om gnome's gconf te ferfangen, bygelyks libxfceui4 om oare komponinten te ferfangen).

    Dêrom sille wy oandachtich moatte wêze om te sjen wat wurdt publisearre op 'e ferstjoerlist fan' e ûntwikkelders ....

    Underwilens in fraach oan wa't de nije ferzje ynstalleare hat, hoe sjogge de gtk3-tema's yn xfce út?

    1.    elav <° Linux sei

      It liket my ta dat de oerstap langer útstelle soe heul ûnferstannich wêze soe. Bytsje by bytsje binne alle applikaasjes al oannaam gtk3, en mei koarte termyn, gtk2 it sil fergetten wurde. Mar ek is d'r wat tsjinstridigs, as lykas Nick seit, op it programmearnivo hast itselde is, wat is it probleem?

      ik brûk Xfce 4.10 en de tema's dy't ik normaal brûke (ZukiTwo, Ambiance) stipe hawwe foar gtk3, dy't hielendal net min sjogge, behalven as ik it ferskil net sjoch, om't dizze problemen wat motor brûke gtk2.

      Ien ding as ik kin fertelle, dizze ferzje fan Xfce It is fierwei it bêste dat se hawwe frijjûn, en ik sis it om't ik dit buroblêd sûnt de ferzje haw brûkt 4.2.