Mar a stàlaicheas tu na pacaidean LMDE againn ann an 3 diogan

A ’gabhail brath air an artaigil o chionn ghoirid dè a phost mi mu dheidhinn MintBackup, Tha mi airson trì dòighean furasta a shealltainn dhut gus na pacaidean a chleachdas sinn ath-shuidheachadh nuair a bhios sinn ag ath-shuidheachadh ar LMDE.

Gu fìrinneach, ach a-mhàin a ’chiad fhoirm, faodar an fheadhainn eile a chleachdadh an dà chuid ann an Debianmar ann an Ubuntu.

Stàladh ann an 3 diogan

Gu grafaigeach.

Is e seo an dòigh as coltaiche ris, uile grafaigeach agus gun a bhith a ’beantainn ri ceann-uidhe. Ann an LMDE y LinuxMint, tha a inneal eireachdail ris an canar MintBackup, a tha, am measg rudan eile, as urrainn dhuinn a chleachdadh gus na pacaidean againn a shàbhaladh agus nas fhaide air adhart, an ath-shuidheachadh.

Ann an cùis LMDE, ma bheir sinn ùrachadh air a ’phacaid python-apt gu dreach 0.8.0, cha bhith e comasach dhuinn a chleachdadh MintBackup mar thoradh air duilgheadas eisimeileachd. Tillidh e am mearachd a leanas:

Traceback (most recent call last):
File "/usr/lib/linuxmint/mintBackup/mintBackup.py", line 87, in <module>
class MessageDialog(apt.FetchProgress):
AttributeError: 'module' object has no attribute 'FetchProgress'

An dòchas na balaich bho Mint càraich e a dh ’aithghearr.

Tron phort-aiseig.

Tron consol is urrainn dhuinn a dhèanamh ann an 2 dhòigh, a tha aig a ’cheann thall air a bhith mar an ceudna.

Ann an 2 cheum.

dpkg --get-selections | awk '$2 ~ /^install$/ {print $1}' > lista_de_paquetes.txt

Cho luath ‘s a gheibh sinn cothrom air na tasgaidhean agus a h-uile càil air a rèiteachadh agus air ùrachadh, feumaidh sinn seo a chuir:

cat lista_de_paquetes.txt | xargs sudo aptitude install -y

Ann an 3 cheum.

dpkg --get-selections "*" > /home/user/Desktop/lista_de_paquetes.txt

An dèidh ath-shuidheachadh bidh sinn a ’coileanadh seo:

dpkg --set-selections  < /home/user/Desktop/lista_de_paquetes.txt

Agus an uairsin ruith sinn:

apt-get -u dselect-upgrade

Tha mi a ’smaoineachadh nach eil feum air soilleireachadh gum feum sinn na tasgaidhean a bhith air an rèiteachadh gu ceart .. Ceart ceart?


Tha susbaint an artaigil a ’cumail ri na prionnsapalan againn de moraltachd deasachaidh. Gus aithris a dhèanamh air mearachd cliog an seo.

8 bheachd, fàg do chuid fhèin

Fàg do bheachd

Seòladh-d cha tèid fhoillseachadh. Feum air achaidhean air an comharrachadh le *

*

*

  1. Uallach airson an dàta: Miguel Ángel Gatón
  2. Adhbhar an dàta: Smachd air SPAM, riaghladh bheachdan.
  3. Dìleab: Do chead
  4. Conaltradh an dàta: Cha tèid an dàta a thoirt do threas phàrtaidhean ach a-mhàin fo dhleastanas laghail.
  5. Stòradh dàta: Stòr-dàta air a chumail le Occentus Networks (EU)
  6. Còraichean: Aig àm sam bith faodaidh tu am fiosrachadh agad a chuingealachadh, fhaighinn air ais agus a dhubhadh às.

  1.   gaisgeachd thuirt

    No bidh thu cuideachd a ’sgrìobhadh sìos a h-uile prògram a bh’ agad roimhe agus a ’dèanamh

    sudo apt-get -y insall a h-uile pasgan a chaidh a dhubhadh às

    Chan eil mi buileach cinnteach a bheil an aon amas aig LMDE ri Linux MInt, a bhith a-mach às a ’bhogsa

    1.    gaisgeachd thuirt

      * stàlaich

  2.   Hokasito thuirt

    Ged a tha e beagan “off-topic”, bha mi airson rabhadh a thoirt gu bheil na tagraichean fuasglaidh air a thighinn a-mach ann an Linux Mint Debian 201108 airson GNOME agus XFCE. Tha mi an dòchas gun deach grunn leasachaidhean a dhèanamh… 🙂

    1.    elav <° Linux thuirt

      Uill, tha, dè thachras nuair a chaidh an naidheachd sàr-mhath seo fhoillseachadh, bha sinn far-loidhne .. Tapadh leibh.

  3.   mitcoes thuirt

    Tha mi dìreach air faighinn a-mach thu agus CHAN EIL SEO.
    An-dè chuir mi a-steach an LMDE 64-bit, agus tha mi a ’dèanamh gu math, ach tha 2 rud beag agam ri lorg-

    1– Log a-steach mar fhreumh ann am modh grafaigeach

    2.- Suidhich VLC mar an cluicheadair bhidio bunaiteach

    Tha mi a ’smaoineachadh gum faighinn e bhon phannal smachd tagraidhean as fheàrr leam no le bhith a’ fosgladh le tagradh eile / a ’cleachdadh an aplacaid seo gu bunaiteach. Log a-steach mar fhreumh.

    Tha mi air sudo nautilus a dhèanamh dìreach gun fhios agus gun dad idir.

    PS1: Ann an 64 buillean ma dh ’obraicheas na pacaidean gu math.
    PS2: Feumaidh mi cuideachd MAME SDL a chuir a-steach agus am fìon64 o chionn ghoirid a bu mhath leam ppa a bhith ann, oir chan eil a bhith a ’rèiteachadh phrògraman nas fhaide air adhart gan ùrachadh gu fèin-ghluasadach.
    PS3: Tha mi a ’cleachdadh an draibhear beta AMD AMD_Catalyst_Preview_driver_OpenGL_4.2_beta_support_8.88.8-x86.x86_64.run, Cocoon, https://getcocoon.com/, gus sreathan geolocated fhaicinn ann am Firefox, Chrome - a dh ’fheumar a chuir a-steach -, cobhair Firefox Flash le Flash 64-bit, Zindus, Qbittorrent, Opera, an leudachadh aletras.oxt agus an sgriobt cuidhteachaidh gus smachd a chumail air cus RAM cache de a ’ghnìomh a tha cuideachd airidh air beachd bhuat.

    Tha mi a ’coimhead air adhart ris a’ chòigeamh pàirt den oideachadh leis na molaidhean sin agus / no eile

  4.   EAT LE thuirt

    Halò!
    Aon rud, bu chòir dhuinn a ’chiad cheangal atharrachadh a chuireas an artaigil MintBackup chun fhear seo: https://blog.desdelinux.net/mintbackup-realiza-un-respaldo-de-tus-paquetes/
    Chan eil fios agam carson, tha e a ’ceangal ri fo-sgrìobhadh" / wp-content / theme "...

    1.    KZKG ^ Gaara thuirt

      Dèanta, air a cheartachadh 😉

  5.   Nahum thuirt

    Halo, leis gu bheil an dreach roimhe seo de LMDE amd64 air duilgheadasan fhaighinn le pacaidean briste agus mearachdan nuair a bha mi a ’luchdachadh stòran, tha mi air mòran fhuasglaidhean fheuchainn agus chan eil gin dhiubh ag obair… chan eil fios agam dè a nì mi tuilleadh, bha mi airson Gnome-shell a chuir a-steach agus cha do leig e orm leis gu bheil am pasgan briste. Chunnaic mi mar a dh ’fhuasglas mi na pacaidean briste le òrdughan mar: sudo dpkg –purge –force-remove-reinstreq

    agus gheibh mi am mearachd a leanas:

    dpkg: mearachd: - Feumaidh co-dhiù aon ainm pacaid mar pharamadair

    Seòrsa dpkg –help airson cuideachadh le bhith a ’stàladh agus a’ dì-stàladh pacaidean [*];
    Cleachd `dselect 'no` aptitude' airson riaghladh pacaid nas càirdeile;
    Type dpkg -Dhelp airson liosta de shuidheachaidhean deasbaid dpkg;
    Type dpkg –force-help airson liosta roghainnean gus rudan a sparradh;
    Taidhp dpkg-deb –help airson cuideachadh le bhith a ’làimhseachadh faidhlichean .deb;

    Bidh roghainnean air an comharrachadh le [*] a ’toirt toradh fada,
    Criathraich e le ‘nas lugha’ no le ‘barrachd’!

    mas urrainn dha cuideigin mo chuideachadh le seo 🙂