Prògramadh bunaiteach le pseint (pàirt 3)

Tha seo a ’leantainn air an oideachadh Prògramadh bunaiteach le pseint (pàirt 2), an turas seo mìnichidh mi na tha riatanach airson prògramadh.

MOLADH

Is e pròiseas a th ’ann an sònrachadh anns a bheil caochladair air a chruthachadh agus / no air atharrachadh, a’ toirt iomradh air tro aithnichear leis am faigh sinn cothrom air an àite cuimhne aige.

is e co-chòrdalachd an t-sònrachaidh:

[variable]<- [expresion];
[variable]=[expresion];

Far a bheil [caochlaideach] an caochladair a tha a ’faighinn luach luachadh [faireachdainn]. Tha an dà chuid dligheach agus mar sin chan eil e gu diofar dè am fear a thèid a chleachdadh (ma rinn iad rèiteachadh PSeInt gu ceart), ach nam bheachd-sa bidh mi a ’cruthachadh a’ chiad fhear mar am fear ceart.

Mura robh [caochlaideach] ann mus deach an sònrachadh, chaidh [caochlaideach] a chruthachadh, ma bha e ann tha an luach roimhe air a sgrios agus tha am fear ùr air a chuir na àite. Air an adhbhar seo, thathas a ’meas mapadh mar obair millteach.

A ’FAIGHINN

Is e leughadh am pròiseas anns an tèid dàta no dàta iarraidh bhon neach-cleachdaidh gus an dàta sin a stòradh ann an caochladair.

tha an co-fhacal:

Leer variable_1,variable_2,...,variable_n;

far a bheil [caochlaideach_ {1,2, n}] nan caochladairean no caochladairean a gheibh an luach a bheir an neach-cleachdaidh seachad, air eagal ’s gum bi barrachd air aon caochladair air iarraidh, iarraidh e an toiseach, an uairsin airson an dàrna fear agus mar sin air adhart gus air na luachan uile fhaighinn.

Tha seo cuideachd na ghnìomh millteach.

SGRÌOBHADH

Is e sgrìobhadh am pròiseas anns a bheil sreath de charactaran agus / no aon no barrachd chaochladairean air an sgrìobhadh air an sgrion

tha an co-fhacal:

Escribir expresion_1,expresion_2,...,expresion_n;

far a bheil [expersion_ {1,2, n}] nan sreangan caractar agus / no caochladairean a thèid a thaisbeanadh.

Bidh sgrìobhadh a bharrachd air a bhith a ’faighinn an dàta a thèid a chuir air an sgrion cuideachd a’ faighinn an stiùireadh "Gun a bhith a’ sgìtheadh ​​"no" Gun luchdachadh sìos "a sheachnadh an leum loidhne.

Cha bhith sgrìobhadh a ’cur beàrnan eadar na h-argamaidean, is e sin, ma chuireas tu:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

anns a ’chùis seo seallaidh e« olamundo »oir eadar« a »agus« b »chan eil sreang de charactaran ann a tha a’ comharrachadh an àite eadar a agus b, gus am bi e air a thaisbeanadh ceart tha e sgrìobhte mar seo:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

anns a ’chùis seo cuir» »a tha ann an sreang caractar aig a bheil àite a tha na àite eadar« tonn »agus« saoghal »agus an uairsin seallaidh e« saoghal nan tonn »leis an àite.

MA THA

Is e seantans a tha seo a tha a ’luachadh suidheachadh sònraichte agus a’ sgrùdadh fìrinneachd agus / no meallta an t-suidheachaidh sin, is e sin, ma tha an cumha air a choileanadh no nach eil.

Is e an co-fhacal:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Chan eil an clàs “eile” èigneachail, anns a ’chùis seo, ma tha an suidheachadh meallta, leig seachad an stiùireadh agus lean air adhart mar nach biodh a’ bhinn ann, sa chùis seo bhiodh e:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Co dhiubh a chaidh an clàs “Fail” a chuir no nach eil, tha e an urra ri feumalachdan a ’phrògraim sin.

ACCORDING

An abairt mar a bhios e a ’dèanamh measadh air caochladair teann àireamhach a bheir barrachd air 2 roghainn mar roghainn, is e seo an eadar-dhealachadh bho“ If-Then ”leis nach urrainn don fhear roimhe ach 2 roghainn a thoirt seachad.

Is e an co-fhacal:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Mar a chì thu às deidh "àireamh1" tha ":" agus às deidh sin tha an stiùireadh a tha ri dhèanamh air a chuir a-steach ma tha "caochlaideach àireamhach = àireamh1", san dàrna eisimpleir tha e "àireamh2, àireamh3" tha seo a ’ciallachadh ma tha àireamhach caochlaideach = àireamh2 no àireamh3 "an uairsin thèid" stiùireadh "a chuir gu bàs, tha seo feumail nuair a dh’ fheumas 2 chomas an aon stiùireadh a choileanadh.

Tha cuideachd an clàs “In Another Way” a thèid a chuir gu bàs mura tèid gin de na cothroman a choileanadh.

WHILE

Is e gnìomh ath-aithriseach a th ’ann an toiseach a’ luachadh suidheachadh agus an uairsin ma thèid a choileanadh bidh e a ’coileanadh sreath de stiùiridhean, an uairsin bidh e ag ath-mheasadh an t-suidheachaidh agus ma tha e fìor bidh e a’ cur an gnìomh an aon stiùireadh a-rithist agus a ’leantainn mar seo gus am bi an suidheachadh meallta .

ma tha an suidheachadh meallta bhon toiseach cha tèid a chuir gu bàs gu bràth agus ma tha e an-còmhnaidh fìor thèid a chuir ann an lùb gun chrìoch, gus an tè mu dheireadh a sheachnadh anns an stiùireadh feumaidh rudeigin a bhith ann a dh ’ainmicheas an suidheachadh aig àm air choreigin gus a bhith comasach air an lùb a thoirt gu crìch.

tha an co-fhacal:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

REPEAT-UNTIL

Is e gnìomh a tha seo glè choltach ris an fhear roimhe, ach eu-coltach ris an fhear roimhe, bidh am fear seo a ’sgrùdadh a’ chumha aig an deireadh, is e sin, thèid an àithne a chuir gu bàs co-dhiù 1 uair, cuideachd an àite an stiùireadh a chuir an gnìomh nuair a tha e fìor, bidh e ga chur an gnìomh fhad ‘s nach eilear a’ coinneachadh ris a ’chumha, ach ma tha thu airson gun tèid a chuir an gnìomh fhad‘ s a thathar a ’coinneachadh ris a’ chumha, cleachd “fhad” an àite “gus”.

tha an co-fhacal:

Repetir
[Instrucciones] hasta que [condicion]

AIRSON

Tha an aithris seo a ’cur an gnìomh stiùireadh a’ dearbhadh grunn thursan airson caochladair, eu-coltach ris an fheadhainn a bh ’ann roimhe, bidh an cearcall seo ag atharrachadh luach an caochladair sin leis fhèin, a bharrachd air co-aonta fìor chumhachdach a bhith aige.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

Is e "caochlaideach" an caochladair a gheibh "luach tùsail" agus a chuireas an gnìomh an stiùireadh agus an uairsin cuir "caochlaideach" a bharrachd air "ceum" agus cuir an gnìomh an stiùireadh a-rithist gus am bi "caochlaideach" co-ionann ri "luach deireannach".

Ma thèid "le [ceum]" a thoirt air falbh an uairsin gu bunaiteach bidh fios aige gu bheil "ceum" co-ionann ri 1, cuideachd mura h-eil [ceum] air a shònrachadh agus gu bheil "luach tùsail" nas motha na "luach deireannach" thèid e troimhe a-steach òrdugh cùl, is e sin "Ceum" is -1

SUBPROCESS / FEUMALACHD

Is e snàithlean no gnìomh prògram taobh a-staigh fear eile agus gu bheil am fo-chlàr seo a ’faighinn aon luach no barrachd, gan obrachadh agus a’ tilleadh fear eile. Tha an co-chòrdadh aige

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

far a bheil "caochlaideach caochlaideach" an caochladair anns a bheil an luach a thill an gnìomh "ainm gnìomh" a fhuair na paramadairean "arg_1, arg_2, arg_n" gus seo a chuir an gnìomh

EILE

Tha iad sin nan gnìomhan nach eil a ’cur taic ris an fheadhainn eile agus aig nach eil co-aonta iom-fhillte seach nach eil annta ach gnìomhan taiceil.

Sgrion soilleir

Bidh an gnìomh seo a ’glanadh scrion de nì sam bith san eadar-theangair

Fuirich iuchair

Tha an gnìomh seo a ’feitheamh ris an neach-cleachdaidh iuchair a bhrùthadh gus leantainn air adhart leis a’ phrògram

Fuirich x {San dàrna àite, Milliseconds}

bidh an gnìomh seo a ’feitheamh ùine ann an diogan no milliseconds gus leantainn air adhart leis a’ phrògram

PS: duilich airson an dàil ach bha mi trang le cùisean eile gus nach b ’urrainn dhomh sgrìobhadh


Tha susbaint an artaigil a ’cumail ri na prionnsapalan againn de moraltachd deasachaidh. Gus aithris a dhèanamh air mearachd cliog an seo.

10 bheachd, fàg do chuid fhèin

Fàg do bheachd

Seòladh-d cha tèid fhoillseachadh. Feum air achaidhean air an comharrachadh le *

*

*

  1. Uallach airson an dàta: Miguel Ángel Gatón
  2. Adhbhar an dàta: Smachd air SPAM, riaghladh bheachdan.
  3. Dìleab: Do chead
  4. Conaltradh an dàta: Cha tèid an dàta a thoirt do threas phàrtaidhean ach a-mhàin fo dhleastanas laghail.
  5. Stòradh dàta: Stòr-dàta air a chumail le Occentus Networks (EU)
  6. Còraichean: Aig àm sam bith faodaidh tu am fiosrachadh agad a chuingealachadh, fhaighinn air ais agus a dhubhadh às.

  1.   Guille thuirt

    Nach eil gnìomhan agad gus iuchraichean a ghlacadh gun stad a chuir gu bàs? Airson rudeigin a dhèanamh le gluasad a tha nas tarraingiche do chlann 9-bliadhna, ged a dh ’fhaodadh geama hangman a bhith spòrsail a bhith a’ prògramadh cuideachd.

    Pròiseas rudeigin_digo
    a <-1;
    fadalach <-30;
    sìos <-5;
    Fhad 's a = 1 Dèan
    Sgrion soilleir;
    c <-1;
    loidhne <- "";
    Dèan aithris a-rithist
    loidhne <-line + "";
    c <-c + 1;
    Gu ruige c = fadalach
    loidhne <-line + "X";
    c <-1;
    Dèan aithris a-rithist
    A sgrìobhadh "";
    c <-c + 1;
    Gu ruige c = sìos-1
    Sgrìobh loidhne;
    Dèan aithris a-rithist
    A sgrìobhadh "";
    c 2 An uairsin
    sìos <-down-1;
    Cuir crìoch air tha
    "s":
    Ma tha e gu h-ìosal <15 An uairsin
    sìos 2 An uairsin
    fadalach <-lateral-1;
    Cuir crìoch air tha
    "d":
    Ma tha taobhach <50 An uairsin
    fadalach <-lateral + 1;
    Cuir crìoch air tha
    "0":
    a <-2;
    Deireadh diogan
    Crìoch Fhad
    EndProcess

  2.   Guille thuirt

    Uill fàilligeadh ma thèid thu suas, atharraich loidhnichean 23 agus 28 nas fheàrr
    -23 Gu ruige c = 15
    +23 Gu ruige c = 18
    y
    -28 Ma tha e sìos> 2 An uairsin
    +28 Ma tha e sìos> 3 An uairsin

    1.    xnmm thuirt

      Taing airson an tabhartas ach tha duilgheadasan aige mar sin gum fosgail thu aon abairt taobh a-staigh seantans eile ach feumaidh e crìochnachadh taobh a-staigh an t-seantans far an do thòisich e, tha mi a ’ciallachadh, chan urrainnear a chuir

      Pròiseas rudeigin
      a <- 0;
      leugh gu;
      mura h-eil co-ionann ri 25 an uairsin
      ged nach eil co-ionann ri 0 dèan
      leugh gu;
      Cuir crìoch air tha
      deireadh fhad

      mar a chì thu an lùb fhad ‘s a tha thu a’ tòiseachadh taobh a-staigh an aithris “ma tha” ach a ’crìochnachadh taobh a-muigh dheth, chan eil rudeigin mar seo comasach.

      Tha mi fhathast a ’cur luach air an tabhartas
      Pròiseas crìochnachaidh

      1.    Guille thuirt

        Taing, ach tha mi a ’smaoineachadh gu bheil e nas motha de dhuilgheadas a bhith a’ cur a ’chòd an seo, nach eil fios agam ciamar a chuireas mi e ann an seòrsa còd agus thig e a-mach às aonais indentation.

        Tha am prògram ag obair gu math. An caochladair “a” Bidh mi dìreach a ’cleachdadh gus an lùb fhàgail nuair a tha an neach-cleachdaidh a’ taipeadh neoni. Dh ’fhaodadh tu fàgail () no briseadh a chuir; anns an t-suidheachadh bidh e a ’coimhead air agus bidh mi a’ sàbhaladh an caochladair. Tha iad nan roghainnean.

        Taing.

      2.    Guille thuirt

        Feuchaidh mi ri tabaichean atharrachadh airson àiteachan agus na bileagan por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille thuirt

        Tha sin làn de mhearachdan in-mhalairt bhon chòd agam, feuchaidh mi a-rithist le tabaichean:
        B ’e seo am faidhle algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille thuirt

        Gu inntinneach, tha an iomradh le bileagan còd air ithe, air a dhubhadh às, ge bith dè a thèid eadar, mar eisimpleir eadar loidhnichean
        Dèan aithris a-rithist
        A sgrìobhadh "";
        c
        às deidh an c tha a
        agus an uairsin leanaidh e le 3 An uairsin
        sìos
        Gu h-iomlan, chan eil seo earbsach airson a chuir a rèir dè na còdan.

  3.   Guille thuirt

    Bidh mi ag atharrachadh nan samhlaidhean bho bhith a ’sònrachadh gu = gus faicinn mar a tha e.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille thuirt

      Bidh e a ’cumail ag ithe pàirt den chòd, bidh an taga còd a’ fàiligeadh, bu chòir dha an sgrìobhadh fhàgail mar a tha.

      1.    xnmm thuirt

        Hi duilich airson nach fhaca thu freagairt roimhe seo ach uill
        leis nach urrainn dhut an còd fhoillseachadh gu math oir cha chuir thu thugam e tron ​​phost gus nach toir thu uimhir de oidhirpean air a ’chùis.