Aclarar dúbidas: repositorios LMDE

Como publicamos o 21 de outubro de 2011, decidimos crear unha sección chamada: A túa opinión conta <° Linux, onde publicaremos os correos electrónicos que algúns usuarios enviaron propoñendo temas de interese o formulario de contacto.

Ben, acaba de nacer outra sección chamada: Aclarar dúbidas <° Linux, onde responderemos algunhas das preguntas dos usuarios que acoden a nós, con calquera dúbida en xeral.

Publicaremos aquí aqueles que cremos que deben interesar a todos, como é o caso deste que un usuario chamou: Eritrimo.

Eritrimo escribiu:

Ola, levo uns días seguindo o blog e é moi completo, pero teño unha pregunta.
Son usuario de LMDE practicamente dende que saíu, porque parecía moito máis atractivo que Linux Mint, que era a distro que empregaba antes. O único que non me gusta é que a maioría dos paquetes están sen actualizar.
¿Podería recomendar unha lista estable e actualizada de repositorios?
É a última vez que tentei cos paquetes SID, ao actualizar o xorg acabei molestando a interface gráfica ...
Moitas grazas e desculpa as molestias.
E antes de nada parabéns por este fantástico blogue!

<° Linux responde de volta:

Moitas grazas polos teus eloxios, estamos moi contentos de que o noso esforzo por manter este blog sexa útil para outros usuarios.

Aínda que é unha vantaxe ter repositorios personalizados LMDE, ao mesmo tempo temos que (como barreira) depender das actualizacións que o equipo de Linux Mint incorporalos.

Primeiro de todo, hai que telo en conta LMDE non usa os repositorios de Sid, pero os de Probas de Debian y Debian Squeeze. Suponse que nos repositorios Entrada, deben estar introducindo paquetes novos a diario desde os espellos de Probas de Debian, pero isto non é seguro.

Podería usar directamente os repositorios de Debian, pero é moi probable que ao facelo haxa algún erro de dependencia cos paquetes que inclúe LMDE.

Ten dúas opcións: Ou se arrisca a usar os repositorios de Debian Testing para ter máis paquetes actualizados, ou agarda pacientemente a que as actualizacións cheguen dos repositorios LMDE. Vostede é libre de escoller. Déixovos os repositorios de Debian:

deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free


O contido do artigo adhírese aos nosos principios de ética editorial. Para informar dun erro faga clic en aquí.

8 comentarios, deixa os teus

Deixa o teu comentario

Enderezo de correo electrónico non será publicado. Os campos obrigatorios están marcados con *

*

*

  1. Responsable dos datos: Miguel Ángel Gatón
  2. Finalidade dos datos: controlar SPAM, xestión de comentarios.
  3. Lexitimación: o seu consentimento
  4. Comunicación dos datos: os datos non serán comunicados a terceiros salvo obrigación legal.
  5. Almacenamento de datos: base de datos aloxada por Occentus Networks (UE)
  6. Dereitos: en calquera momento pode limitar, recuperar e eliminar a súa información.

  1.   Alexander Nova dixo

    AFAIK Linux Mint Debian Edition, segundo a súa propia documentación, é 100% compatible coas probas de Debian. Co que non pasa iso é con Ubuntu; LMDE advirte que os repositorios de Ubuntu non funcionarán alí.

  2.   Esmeralda dixo

    Grazas pola resposta. Teño que dicir que pensei que xa tiña probas, pero aparentemente non, xa que despois de engadir os repositorios apareceron moitas actualizacións, aínda que me dan certos problemas, xa que me obrigan a desinstalar paquetes como mint-meta-common ou o mint-meta-debian, que non creo recomendable para eliminalos. Ademais disto, antes de actualizar o xorg falei a interface gráfica, polo que agora teño un pouco de medo por se o volvo a arruinar. Non me debería dar problemas, non?

    1.    elav <° Linux dixo

      Exacto. Se queres que o teu LMDE funcione sen problemas, recoméndoche que uses os repositorios LMDE. Quizais se tes probas, pero LMDE non é Debian como tal.

      1.    Eritrimo dixo

        Non me importa ter algún outro problema mentres teña unha solución, de feito é unha das razóns polas que me gusta máis Linux que Windows, para poder enfrontarme á máquina e aprender a corrixir os erros que pode ter, pero non quero causar danos irreversible e ter que reinstalar o sistema operativo cada dous ou tres ...
        No caso dos paquetes que mencionei anteriormente, son relevantes? Porque a actualización de libreoffice tamén me di que os elimine ...

        1.    elav <° Linux dixo

          Eses paquetes son meta-paquetes, que á súa vez poden (ou non) desinstalar outros paquetes. Desinstaleinos sen maiores problemas.

  3.   Carlos-Xfce dixo

    Ola Elav. Fantástico, gústanme as novas seccións e responder a esta pregunta en particular: os repositorios LMDE. Non obstante (e que Courage me perdoe), aínda non son un usuario experto e non sei que facer cos repositorios que puxeches aquí. Teño medo de tocalo porque xa tiven problemas que me obrigan a volver instalalo todo desde cero. Ben, en calquera caso, moitas grazas.

    1.    elav <° Linux dixo

      Non te preocupes. Vexamos. Os repositorios que coloquei na publicación son os que tes que usar por se non queres obter os teus paquetes dos repositorios LMDE e actualizar ao ritmo de Debian. É dicir, se o que quere é que o sistema non se corrompa e siga funcionando como debería (aínda que non se actualiza con tanta frecuencia), ten que usa estes. Se o que desexa é actualizar constantemente (aínda que algún paquete está relacionado con LMDE vaia ao carallo) despois usas as que puxen no post.

  4.   David dixo

    apt-get -t probar instalar banshee
    Lectura da lista de paquetes ... Feito
    Creación de árbore de dependencias
    Lectura da información de estado ... Feito
    Non se pode instalar algún paquete. Isto pode significar iso
    pediu unha situación imposible ou, se está a usar a distribución
    inestable, que algúns paquetes necesarios non se crearon nin teñen
    fora de Incoming.
    A seguinte información pode axudar a resolver a situación:

    Os seguintes paquetes teñen dependencias non cumpridas:
    libc6-dev: Breaks: gcc-4.4 (<4.4.6-4) pero 4.4.5-8 instalarase
    e pasoume con todos os paquetes que quero instalar a partir das probas. Como podo resolvelo ?, Grazas de antemán