Consellos: como cambiar o axente de usuario de Chromium?

Xa vimos como cambiar o Axente de usuario de Firefox y Ópera e agora é a quenda de Cromo, que estou a usar regularmente porque Firefox 8 está comendo a miña memoria RAM.

Alí extensións que lle permiten facelo, pero debido ás restricións que impuxo Google (os moi caralludos) a Cuba Non os podo conseguir, así que teño que facelo a man.

Para iso editamos o ficheiro /usr/share/applications/chromium.desktop e buscamos a liña que di:

Exec=/usr/bin/chromium %U

E poñémolo así:

Exec=/usr/bin/chromium --user-agent="Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.1 (KHTML, like Gecko) Debian Chromium/14.0.835.202 Safari/535.1" %U

Se abrimos unha pestana e poñemos:

chrome://version/

Podemos ver o Axente de usuario que máis ou menos no meu caso debería ser así:

--user-agent="Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.202 Safari/535.1"

Se o comparas coa liña que deixei arriba verás que engadín Debian e eu substituín cromo por Cromo.


O contido do artigo adhírese aos nosos principios de ética editorial. Para informar dun erro faga clic en aquí.

117 comentarios, deixa os teus

Deixa o teu comentario

Enderezo de correo electrónico non será publicado. Os campos obrigatorios están marcados con *

*

*

  1. Responsable dos datos: Miguel Ángel Gatón
  2. Finalidade dos datos: controlar SPAM, xestión de comentarios.
  3. Lexitimación: o seu consentimento
  4. Comunicación dos datos: os datos non serán comunicados a terceiros salvo obrigación legal.
  5. Almacenamento de datos: base de datos aloxada por Occentus Networks (UE)
  6. Dereitos: en calquera momento pode limitar, recuperar e eliminar a súa información.

  1.   oscar dixo

    ¿Sabes cal é a extensión de Google, estou de acordo en que son fillos dunha mala nai, para simplificar o traballo, jajajaja, e en que distribución xa tes Firefox 8?

    1.    elav <° Linux dixo

      Agora non recordo o nome da extensión. E Firefox 8 para Debian, co tar.gz

  2.   Tix dixo

    Con ese camiño (/usr/share/applications/chromium.desktop) non atopo nada, parece que só funciona para unha distribución específica, o mesmo funciona en LMDE en Mint 12 non e supoño que tamén para Ubuntu e Kubuntu.

    1.    elav <° Linux dixo

      Quizais en Ubuntu cambie o nome do .desktop, pero xeralmente están todas as aplicacións que aparecen no menú. Busca ben, se cadra chámase cromo ou lago así.

      1.    Alf dixo

        En Ubuntu está no camiño que se especifica na publicación, só que fas clic dereito na icona e abrirase con kwrite (o meu caso), e buscas a liña, modifiqueina e o cromo deixou de funcionar, por que devolvín os valores tal e como os tiña.

  3.   Tix dixo

    Estou en Mint 12 RC.

    120 MB máis 54,9mb máis 46mb máis 41mb máis 33mb fan un total de 294,9mb con só 3 pestanas abertas
    e subindo segundo o monitor do sistema. Así que abandono Chromium e vou probar outro navegador menos vampiro.

    Quedei ben e non atopei nada como chromium.desktop, de todos os xeitos grazas.

    1.    Jamin samuel dixo

      Tampouco atopei nada .. Estou en Linux mint 12

  4.   oscar dixo

    Chromium consume máis memoria RAM que Firefox?

    1.    hypersayan_x dixo

      Consomen o mesmo co mesmo número de lapelas, vendo as mesmas páxinas, con configuracións idénticas e cos mesmos ou polo menos complementos similares.

      1.    oscar dixo

        @hipersayan_x, grazas polo consello.

      2.    Aliana dixo

        En Kubuntu 11.10, con Firefox 14, con 74 (si, setenta e catro) pestanas abertas, consumo a mesma memoria RAM que Chromium con só 20-22 ... E se abro máis de 25 Chromium xa se fai moi lento.

        O mesmo en Mint, Firefox supera a Chromium.

        No meu caso polo menos NON é certo que consuman o mesmo coas mesmas pestanas abertas. Se é necesario, fornezo capturas e datos.

        Noutras palabras, prefiro Firefox e a súa inmensa cantidade de extensións. Para cousas específicas fago uso de Chromium.

        É certo que navego compulsivamente, non coñezo a ninguén que abra tantas pestanas. Se só necesitas 3 ou 4 pestanas, quizais Chromium o faga por ti.

        Pero iso xa o comentamos noutros lugares.

        1.    KZKG ^ Gaara dixo

          74 pestanas, de acordo.

          "Non coñezo a ninguén que abra tantas pestanas"... jejeje, mellor non digo nada, seguro elav (o outro administrador que ata hai pouco traballaba na mesma empresa ca min) dirá algo así como: «Si! este (referíndome a min) abre tantas pestanas que non me deixa ancho de banda »... ou algo así JAJAJA.

          Nada, aínda abro moitas pestanas, porque ao abrirse estou lendo algunhas semiabertas e estou pechando ... mentres moitas outras aínda non rematan de cargar.

        2.    KZKG ^ Gaara dixo

          Por certo (que rudo que son jaja) ... benvido ao blog 🙂
          Espero que atopes cousas interesantes aquí ... aínda que, sendo usuario de KDE, garante que atoparás moitas cousas que che gustarán 😉

          lembranzas

          1.    Aliana dixo

            OK, grazas a ti.

            Pero ollo, eu son un tipo, aliana é un acrónimo.
            (Normalmente cando aclaro isto non sei por que cambian o ton amigable por outro neutral).

            1.    KZKG ^ Gaara dixo

              Vaia hahahaha perdón polo malentendido hahahaha.
              Nada, tamén un pracer te ter aquí amigo, e repito o que dixen ... se che gusta KDE, aquí atoparás moitas cousas interesantes jajaja 🙂

              Un saúdo e benvidos ao blog 😉


  5.   KZKG ^ Gaara <"Linux dixo

    elav aínda tes Chromium v14 ... guau ...

    1.    elav <° Linux dixo

      Si, e? O meu Chromium v14 fai marabillas para min. De feito, non vexo ningunha diferenza con Chrome 15 agás a pestana de inicio.

  6.   sdaf2 dixo

    Se non che funciona, tenta cambiar o axente de usuario en cromo / cromo con este método de xeito rápido e sinxelo. http://buildall.wordpress.com/2011/05/24/changing-google-chrome-user-agent-string-in-ubuntu-11-04/

    1.    Jamin samuel dixo

      Verroo non me funciona ou aínda non sei como facelo: S

      1.    Jamin samuel dixo

        ...

  7.   Jamin samuel dixo

    Isto tamén pode funcionar para Google Chrome?

    1.    KZKG ^ Gaara dixo

      Si 😀

      1.    Jamin samuel dixo

        ahahaa nunca puiden facer xD

  8.   Chinés dixo

    Probas 😀

  9.   Jamin samuel dixo

    Sigo intentándoo

    1.    Jamin samuel dixo

      ....

  10.   Jamin samuel dixo

    Non entendo o que pasa 🙁 poño isto

    /opt/google/chrome/google-chrome %U Exec=/usr/bin/chromium --user-agent="Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Linux Mint 12 Chrome/17.0.963.79 Safari/535.1" %U

    Corrixe se teño algo mal wrong

    1.    KZKG ^ Gaara dixo

      Con iso nin sequera o logotipo de Mint aparece no banner do blog? (Esquina superior dereita)

      1.    Jamin samuel dixo

        non nada 🙁

      2.    Jamin samuel dixo

        é google chrome o que estou a usar. Podería usar un pouco de axuda

        1.    KZKG ^ Gaara dixo

          Uff, acabo de probalo con Chromium (non teño Chrome) e funcionou coma un encanto O_o... déixame investigar un pouco para ver que atopo.

          1.    Jamin samuel dixo

            antes de investigar .. primeiro imos matar a dúbida, para que non estea a facer algo mal ..

            Onde fuches para configurar iso? abriu cromo e logo que fixo?

            1.    KZKG ^ Gaara dixo

              Abrín un terminal e puxen isto:
              chromium --user-agent="Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Linux Mint 12 Chrome/17.0.963.79 Safari/535.1" %U

              Nada máis 🙂

              Proba iso para ver que resultado che dá 😀


          2.    Jamin samuel dixo

            non pasa nada .. púxeno no terminal e logo abriume unha nova xanela de google chrome .. pero aínda non aparece no axente de usuario

            1.    KZKG ^ Gaara dixo

              Carallo con estes de Google ... ¬_¬
              Por iso non uso Chrome e sí Chromium ...


          3.    Jamin samuel dixo

            ajajaj o raro é que fixen o cambio no firefox como o demostra o outro tutorial .. e ten boa pinta, móstrame o logotipo de linux mint e todo menos cromo e cromo nada de nada

          4.    Jamin samuel dixo

            Ei, poño isto no terminal:

            chromium –user-agent = »Mozilla / 5.0 (X11; Linux x86_64) AppleWebKit / 535.1 (KHTML, como Gecko) Linux Mint 12 Chrome / 17.0.963.79 Safari / 535.1 ″% U

            E díxome:
            cromo: orde non atopada

            1.    KZKG ^ Gaara dixo

              En vez de Chromium pon / usr / bin / chromium ... ben, esa Menta ¬_¬ ...


          5.    Jamin samuel dixo

            ahahaha vas rir un pouco ... mira o que me di agora:

            bash: / usr / bin / chromium: o ficheiro ou directorio non existe

            1.    KZKG ^ Gaara dixo

              WTF !!! … Proba / usr / bin / chromium-browser para ver


          6.    Jamin samuel dixo

            Ok, poño como estás como me dixeches:

            / usr / bin / chromium-browser –user-agent = »Mozilla / 5.0 (X11; Linux x86_64) AppleWebKit / 535.1 (KHTML, como Gecko) Linux Mint 12 Chrome / 17.0.963.79 Safari / 535.1 ″%

            E mira como sae o axente de usuario

            1.    KZKG ^ Gaara dixo

              Ubuntu O_O…. agora renuncio ...
              Non sei nin que distro empregas ... JAJ !!
              Quizais poida poñelo en / etc / chromium / default ou algo así ... Estou quedando sen ideas, en Debian funciona moi ben para min 0_0


          7.    Jamin samuel dixo

            ALLELUJA !! \ O / \ Ø / \ O / \ Ø / -> Xa o conseguín 😀 foi que tiña cromo mal escrito ejejeje GRAZAS

          8.    Jamin samuel dixo

            Agora só me falta poñer unha foto no avatar .. así como a que tes.

            1.    KZKG ^ Gaara dixo

              Carallo por fin LOL !!!
              Para a foto do avatar, xa estás rexistrado aquí no sitio?


  11.   Jamin samuel dixo

    agárdame un pouco .. Recibo linux mint pero cando pecho o terminal volveme a buscar coma se fose ubuntu: O

    1.    KZKG ^ Gaara dixo

      Por suposto, non o executes nun terminal pero execútalo usando [Alt] + [F2] e voila 🙂

    2.    Jamin samuel dixo

      mira; (pecha o terminal e pon ubuntu .. e estou usando linux mint

  12.   Jamin samuel dixo

    [Alt] + [F2] entón poño isto:

    / usr / bin / chromium-browser –user-agent = »Mozilla / 5.0 (X11; Linux x86_64) AppleWebKit / 535.1 (KHTML, como Gecko) Linux Mint 12 Chromium / 17.0.963.79 Safari / 535.1 ″%

    ábreme unha nova xanela de cromo .. abro unha pestana e poño isto
    chrome: // versión /

    e mostra que é ubuntu no canto de Linux mint AJAJAJAJA .. o meu navegador está demonizado con xD canónico

    1.    KZKG ^ Gaara dixo

      Pecha todo o Chromium que ten aberto e faga de novo o F2

      1.    Jamin samuel dixo

        o mesmo segue sucedendo .. ábreme co logotipo de linux mint .. pero cando o pecho e o abro de novo, aparece de novo co logotipo de ubuntu

      2.    Jamin samuel dixo

        Que debo facer para solucionar o axente de usuario? Xa que se o abro a través de F2 ou a través do terminal móstrame o sistema que estou a usar pero cando pecho o navegador e o abro de novo móstrame ubuntu

        1.    KZKG ^ Gaara dixo

          Ben, supoño que para editar o ficheiro:
          /usr/share/applications/chromium.desktop

          1.    Jamin samuel dixo

            ok, como o edito .. xa que non fai nada polo terminal, non fai nada por F2

  13.   Algabe dixo

    Por fin conseguín que funcionase coa axuda de Jhalss e coa axuda do axente de usuario 🙂

    1.    KZKG ^ Gaara dixo

      Uff ... carallo ao final, como o fixeches ao final?

      1.    Algabe dixo

        Moi fácil no terminal poño:

        [presuposto] localiza chrome.desktop [/ presuposto]
        e edite o seguinte.
        [cita] sudo nano /usr/local/share/applications/google-chrome.desktop[/quote]
        Busque a liña "Exec = / opt / google / chrome / google-chrome" e déixaa do seguinte xeito.
        [presuposto] Exec = / opt / google / chrome / google-chrome –user-agent = »Mozilla / 5.0 (X11; Linux i686) AppleWebKit / 536.5 (KHTML, como Gecko) Fedora Chrome / 19.0.1084.52 Safari / 536.5 ″% U [/ cita]
        Reinicia Chrome e o axente de usuario funciona 🙂

        1.    KZKG ^ Gaara dixo

          AAHH !! vale ben moitas grazas 😀
          Estou twitteando agora mesmo jajajaja.

  14.   Greenux dixo

    probando

  15.   Greenux dixo

    Tento de novo

  16.   Claudio dixo

    Ola, teño Debian LXDE e a distribución non me recoñece. Lin os comentarios anteriores pero non o podo configurar. No terminal sudo nano /usr/local/share/applications/google-chrome.desktop está baleiro e non sei como configuralo. Unha axuda ou dúas?

  17.   a dixo

    axente de usuario de proba

  18.   Pavloco dixo

    Probando

    1.    Pavloco dixo

      Xa podía, pero fíxeno diferente.

      1.    Pavloco dixo

        Carallo aínda mal, eu uso Chromium

  19.   Alejandro Mora dixo

    Probando…..

    Moitas grazas!

  20.   Daniel Vermellas dixo

    Probando…

  21.   Aliana dixo

    Probando…

  22.   Aliana dixo

    Olá

    Escribindo desde Konqueror, Kubuntu 11.10.

    Despois de seguir este truco, o meu Chromium 18.0.1025.168 non funciona, dime:

    "KDEInit non puido iniciar" usr / bin / chromium ".

    No meu caso tiven que editar o ficheiro

    /usr/share/applications/chromium-browser.desktop

    para seguir o truco.

    Non sei se teño que cambiar algo ademais de "/ usr / bin / chromium-browser".

    E aínda que desfixen o truco, aínda non teño Chromium.

    Espero non ter que reinstalalo, para non perder as sesións que gardara ...

    Algunha axuda para recuperar Chromium?

    1.    KZKG ^ Gaara dixo

      Ola 🙂
      Se podes poñer aquí o contido do ficheiro que modificaches - » http://paste.desdelinux.net
      Para poder revisalo mellor.

      Comparareino co meu aquí e veremos que lle pasa.
      lembranzas ^ - ^

  23.   Aliana dixo

    Ía propoñer iso, que compartisen o ficheiro para ver ...

    O meu agora (esquecín titulalo):

    http://paste.desdelinux.net/4518

    Pero creo que xa o arranxei.

    Cambiei a versión Chromium do truco (Chromium / 14.0.835.202) pola miña (Chromium / 18.0.1025.168), menos mal que tiven a precaución de anotar a miña versión antes ... E parece que xa teño Chromium de novo ... Creo ... espero que cando o abro de novo segue funcionando ...

    Pero o truco non funciona para min, segue dicíndome máis arriba que teño Ubuntu, como antes seguindo o truco.

    Simplemente deixeino estar, para que non o volvese a arruinar.

    Consello a kubunteros, non toques nada.

    Grazas por asistirme, nome estraño administrador administrador

    1.    KZKG ^ Gaara dixo

      HAHAHAHAHAHA como ría con ese final de «nome estraño administrador»…. LOL !!!!
      Tendo en conta que o meu alcume non é tan sinxelo como pensaba jaja ... encantado de coñecerte, chámome Alejandro 🙂

      De feito, cando se escribiu este post, Chromium non deu problemas por indicar que se trata dunha versión diferente, nin idea de por que agora ten ese detalle O_o ...

      Poñiches Kubuntu no UserAgent e diche que usas Ubuntu? Comprobe que, se é así, comprobarei de novo o código para ver algún erro que perdín.

      lembranzas

      1.    Aliana dixo

        Quere dicir cambiar "Debian Chromium /" a "Kubuntu Chromium /"?

        Intentareino, pero teño medo de que reiniciar Chromium volva a parar.

        E como dixen anteriormente, son un tipo, o meu nome tamén comeza con A ...

      2.    elav <° Linux dixo

        HAHAHAHAHAHA como ría con ese final de "nome estraño administrador" ... LOL !!!!
        Tendo en conta que o meu alcume non é tan sinxelo como pensei jaja ... Encantado de coñecerte, chámome Alejandro

        Deixa a "salsa" de que Aliana é un tipo xD xD

        1.    KZKG ^ Gaara dixo

          JAJA xa sabes que trato ben a todos jaja

  24.   Aliana dixo

    Suxiro: quizais debería engadir ao truco que cambien o v. Cromo do código para o que instalaron ...

  25.   Aliana dixo

    Cambiouse "Debian Chromium /" a "Kubuntu Chromium /", e nada. Sigue dicíndome que estou en Ubuntu.

    Eliminado completamente de "Debian Chromium /" e "Kubuntu Chromium /". Nada.

    Agora só podo abrir Chromium dende a consola, aínda que ese é un problema de Kubuntu / KDE que solucionarei cando me apeteza.

    Polo menos sabes que é Chromium, algo é algo.

    Deixámolo agora, tampouco nos imos tolear por un pequeno detalle.

  26.   bitblu3 dixo

    mmmm, son un bo usuario de firefox, pero estou dando unha oportunidade ao cromo, e a verdade é que notei que usa mellor as vantaxes do nouveau que firefox. Graciñas

  27.   Fega dixo

    proba con chakra

  28.   Fega dixo

    Teño Chakra instalado con Google Chrome e non podo facer funcionar o axente de usuario. ¿Pode alguén que o fixera por favor me axude? Agradecido dende agora

  29.   Hyuuga_Neji dixo

    probando Debian + Google Chrome 15

    1.    Hyuuga_Neji dixo

      en / usr / share / application non hai google-chrome.desktop
      realmente ese ficheiro está en /opt/google/chrome/google-chrome.desktop

      1.    Hyuuga_Neji dixo

        o meu problema está en colocar a liña que leva a Debian desde http://www.useragentstring.com/pages/Chrome/ só aparecen liñas para Ubuntu, Windows e Macosx

  30.   sieg84 dixo

    probando.

    1.    sieg84 dixo

      ben, en openSUSE funciona sen moverse a nada, pero eu non uso cromo, é cromo

  31.   Daniel dixo

    prueba

  32.   threadjack dixo

    bo

  33.   izzyvp dixo

    bo

  34.   Asasino_lixo dixo

    probando

  35.   Asasino_lixo dixo

    proba 2

  36.   Doy dixo

    Proba

  37.   Doy dixo

    Test2

  38.   x11tete11x dixo

    proba

  39.   Wisp dixo

    traballo

  40.   Wisp dixo

    Vexamos

  41.   Wisp dixo

    observando

  42.   José dixo

    Probando a Maxton

  43.   Wisp dixo

    qqw

  44.   Wisp dixo

    nnmnm

  45.   Wisp dixo

    mgn mh

  46.   mat1986 dixo

    Probando axente de usuario ...

  47.   mat1986 dixo

    A ver se agora xD

  48.   mat1986 dixo

    Plan de probas B ...

  49.   mat1986 dixo

    Plan de proba C, se recoñece LXQt

  50.   mat1986 dixo

    Probando axente de usuario con maxthon ...

  51.   mat1986 dixo

    Despois da actualización de cromo, modificouse o axente de usuario personalizado, así que estou probando de novo ...

  52.   5ull1v4n dixo

    Probas despois dunha actualización

    1.    5ull1v4n dixo

      Proba 2: v

      1.    5ull1v4n dixo

        outra proba

  53.   mat1986 dixo

    Probando axente de usuario en qupzilla

    1.    mat1986 dixo

      e agora?

      1.    mat1986 dixo

        E agora si?

  54.   mat1986 dixo

    Comprobando a actualización do axente de usuario en qupzilla

  55.   Brutico dixo

    Última oportunidade

  56.   Wisp dixo

    proba do axente de usuario

  57.   Wisp dixo

    Proba de proba Proba de proba de proba

  58.   Wisp dixo

    enésima proba de axente de usuario