Instale Steam en Debian Wheezy sen morrer probando

Un saúdo a todos. Seguramente, moitos xa estarán disfrutando Vapor para a plataforma GNU / Linux. Non obstante, moitos dos que usan Debian Stable (Wheezy)Están rompéndose a cabeza ao intentar instalar tanto Steam.

Vou amosarche como facelo sen ter que morrer intentándoo, aínda que a maioría dos resultados non tiveron éxito, debido a que as dependencias que require están no repos Ubuntu e / ou o soporte de varias arquitecturas non fora implementado.

Para facer esta fazaña, debemos facer o seguinte:

Instala o soporte multi-arquitectura de Debian Wheezy:

apt-get install multiarch-support

Instala as dependencias que Steam nos pide (por desgraza, desde Ubuntu), a través deste procedemento:

wget http://dl.dropbox.com/u/29081229/Steam/debian_install.sh && ./debian_install.sh

Descarga o paquete Steam mediante este procedemento:

wget http://media.steampowered.com/client/installer/steam.deb && sudo dpkg -i steam.deb

Agarde a que o cliente se actualice, iniciamos sesión e xa está.

Se tes tarxetas de vídeo como ATI / AMD ou NVIDIA, suxerímosche que instales os controladores propietarios para que teñan un mellor rendemento nos xogos que descargues de balde ou que compras a través desta plataforma.

Espero que fora útil para aquelas almas que se mataron buscando un xeito de instalar Steam sen morrer no intento.

PD: Aquí está a miña captura de pantalla do meu Steam no meu debian wheezy:

Steam en Debian Wheezy

E non me despido sen agradecer antes o Usuarios de Steam, para o Debian Wiki e Foro oficial de Debian por facer posible esta fazaña.


O contido do artigo adhírese aos nosos principios de ética editorial. Para informar dun erro faga clic en aquí.

47 comentarios, deixa os teus

Deixa o teu comentario

Enderezo de correo electrónico non será publicado.

*

*

  1. Responsable dos datos: Miguel Ángel Gatón
  2. Finalidade dos datos: controlar SPAM, xestión de comentarios.
  3. Lexitimación: o seu consentimento
  4. Comunicación dos datos: os datos non serán comunicados a terceiros salvo obrigación legal.
  5. Almacenamento de datos: base de datos aloxada por Occentus Networks (UE)
  6. Dereitos: en calquera momento pode limitar, recuperar e eliminar a súa información.

  1.   Canles dixo

    Grazas por compartir eliotime3000. A verdade é que Steam é incrible, moi bos xogos nativos en Linux e cada día máis e mellor.

    Ola2!

    1.    eliotime3000 dixo

      Ben, grazas polo eloxio. Ademais, dado que non uso SUDO, esquecín metelo (grazas aos editores por engadirlle o sudo e o "&") e, se non executas o ficheiro .sh, podes facer:

      sh ./debian_installer.sh

      Xa está.

  2.   iFuSiiOnzZ dixo

    Pasou moito tempo dende que lanzaron a versión de 64 bits, agora é necesario que os desenvolvedores lanzan xogos para esa versión.

    1.    eliotime3000 dixo

      Niso estou de acordo contigo. Ademais, xa que uso Debian Wheezy de 32 bits, non debería ser un problema.

      Aínda que o cliente Steam xa ten 64 bits, aínda confía no paquete multi-arco de Debian para executar xogos que aínda non o son.

      Sexa como sexa, probarei xogos como DOTA 2 e Team Fortress (aínda non teño cartos para pagar xogos como Half-Life).

      1.    Edo dixo

        O segredo é aproveitar as promocións, merquei a saga nunha desas. Tamén está a vapor o humilde paquete

  3.   Erick dixo

    Amigo que o teu comentario: (por desgraza, de Ubuntu), non soa algo despectivo, xa que grazas a Ubuntu hai Steam en Linux, xa que grazas a Ubuntu GNU / Linux fíxose popular e viable para que Valve pensara en incorporar Linux no seu mercado de xogos, só tento facer unha crítica construtiva, nada máis, todos teñen a súa opinión e respéctoo, saúdos

    1.    eliotime3000 dixo

      Seino, pero referíame ás dependencias que pide (jockey-common). Na rama Testing (Jessie) e Unstable (Sid) non piden estas dependencias e nin sequera se atopan nos repos principais desas ramas Debian.

    2.    pandev92 dixo

      Naa, o único motivo de Steam en Linux, é o desexo de preparar unha consola propia baseada en Linux.

  4.   Edo dixo

    Como funciona o kernel 3.2? é que actualmente uso o máis recente, pero debido á U e á compatibilidade co controlador propietario herdado penso cambiar a eOS que usa ese núcleo

    1.    eliotime3000 dixo

      Agora estou funcionando sen problemas e sen problemas (e estou a usar o vídeo integrado de Intel co MESA actualizado).

  5.   OtakuLogan dixo

    Non sei se deste xeito ten algunha vantaxe sobre a que fixen, cambie o repositorio principal a jessie, apt-get update, apt-get install steam: i386 e logo cambie o repositorio principal a wheezy.

    1.    eliotime3000 dixo

      Non afecta nada en si mesmo, a non ser que queira sacrificar certa estabilidade para instalar unha versión 100% adaptada para Debian.

      1.    OtakuLogan dixo

        Ok, grazas pola aclaración.

      2.    jorgejhms dixo

        Jessie é bastante estable.

    2.    Canles dixo

      Sería mellor instalalo como di OtakuLogan ou como eliotime3000 propón?

      1.    eliotime3000 dixo

        Se funciona para ti, recoméndalo. Así de sinxelo

  6.   raíz dixo

    Cres que é xenial cambiar a versión de libc6 así? iso non funciona en todos os casos ..!

    1.    eliotime3000 dixo

      Pero iso depende das dependencias que xera ao instalar o paquete oficial .deb.

  7.   Daniel C dixo

    Aaaay os meus ollos co tema predeterminado de Gnome e as fontes Debian !!!

    1.    eliotime3000 dixo

      Xa me acostumei tanto a GNOME que o uso todos os días. A ver se me saio un momento para respirar aire novo.

  8.   johnmnz117 dixo

    : Ou só por steam decidín cambiar a kubuntu, creo que é hora de volver a debian ou crunchbang 😀

  9.   eliotime3000 dixo

    Iso pásache por non crer en Debian GNU / Linux.

    Agora estou contento co meu Steam e agardo a miña confirmación para xogar a DoTA 2 rapidamente.

    1.    johnmnz117 dixo

      Xa o teño 😀 pero iso foi o malo de intentar instalalo cando estaba en versión beta e desistir moi rápido, probe campións de regnum, tamén é un bo xogo, é unha especie de guau.

  10.   James_Che dixo

    Cando intento instalar o .deb obtense isto: /
    Este paquete non se pode instalar
    A dependencia non é satisfactoria: libc6 (> = 2.15)

    1.    Canles dixo

      Creo que o script o que fai é instalar unha versión máis recente de libc6 desde os repositorios de ubuntu, polo que ten dúas opcións: ou usa o script para facelo ou instala o paquete desde os repositorios de probas de debian.

      Salu2

      1.    James_Che dixo

        Grazas, pero usei o guión e non funciona: /

        1.    eliotime3000 dixo

          Se primeiro non tes "sh", entón tes espazo e escribes o nome do script e premes en Intro.

          1.    James_Che dixo

            sae como un erro de dependencia, pero non vexo como solucionalo.

          2.    eliotime3000 dixo

            Próbao executando o script como ROOT. Normalmente non uso SUDO porque me molesta os permisos.

  11.   Cristian dixo

    Boa información. Tamén o instalei cun guión e a verdade é que é peludo.
    https://github.com/GhostSquad57/Steam-Installer-for-Wheezy

    1.    eliotime3000 dixo

      Bo guión, pero non sabía como usar ese guión GitHub, así que fun comprobar os foros de Steam para atopar a solución máis tanxible.

  12.   Pelucrón dixo

    Teño un problema, todo está ben ata a parte que me di

    sudo dpkg -i steam.deb

    é onde me aparece isto.

    root @ NV55S09u: / home / diego-m # sudo dpkg -i steam.deb
    (Lendo a base de datos ... 128696 ficheiros ou directorios instalados actualmente.)
    Preparándose para substituír o lanzador de vapor 1.0.0.42 (usando steam.deb) ...
    Desempaquetando o substituto do lanzador de vapor ...
    dpkg: Os problemas de dependencia impiden a configuración do lanzador de vapor:
    o lanzador de vapor depende de libc6 (> = 2.15); Non obstante:
    A versión de `libc6: amd64 ′ no sistema é 2.13-38.

    dpkg: erro ao procesar o lanzador de vapor (–install):
    problemas de dependencia - deixados sen configurar
    Procesadores desencadeantes para man-db ...
    Procesando desencadeantes para hicolor-icon-theme ...
    Procesando desencadeantes para utilidades de ficheiros de escritorio ...
    Procesadores desencadeantes para menús gnome ...
    Atopáronse erros ao procesar:
    lanzador de vapor
    root @ NV55S09u: / home / diego-m #

    e cando intento poñer esa dependencia, a libc6 dame o mesmo: amd64 e libc6

    root @ NV55S09u: / home / diego-m # apt-get install libc6: amd64
    Lectura da lista de paquetes ... Feito
    Creación de árbore de dependencias
    Lectura da información de estado ... Feito
    libc6 xa está na súa última versión.
    Pode querer executar apt-get -f install para corrixilo:
    Os seguintes paquetes teñen dependencias non cumpridas:
    lanzador de vapor: Depende: libc6 (> = 2.15) pero instalarase 2.13-38
    E: Dependencias non cumpridas. Probe apt-get -f install sen paquetes (ou especifique unha solución alternativa).
    root @ NV55S09u: / home / diego-m # apt-get install libc6
    Lectura da lista de paquetes ... Feito
    Creación de árbore de dependencias
    Lectura da información de estado ... Feito
    libc6 xa está na súa última versión.
    Pode querer executar apt-get -f install para corrixilo:
    Os seguintes paquetes teñen dependencias non cumpridas:
    lanzador de vapor: Depende: libc6 (> = 2.15) pero instalarase 2.13-38
    E: Dependencias non cumpridas. Probe apt-get -f install sen paquetes (ou especifique unha solución alternativa).

    Espero que o meu problema non sexa moi evidente saúdos e grazas

  13.   Virtuskr dixo

    Recomendo aconsellar que se poñan

    chmod + x ./debian_install.sh

  14.   Desexo Mario dixo

    Alguén me pode axudar cal é o meu problema

    root @ debian: / home / wishmario / Descargas # sudo dpkg -i steam.deb
    (Lendo a base de datos ... 161869 ficheiros ou directorios instalados actualmente.)
    Preparándose para substituír o lanzador de vapor 1.0.0.42 (usando steam.deb) ...
    Desempaquetando o substituto do lanzador de vapor ...
    dpkg: problemas de dependencia que impiden a configuración do lanzador de vapor:
    o lanzador de vapor depende de libc6 (> = 2.15); Non obstante:
    A versión de `libc6: amd64 ′ no sistema é 2.13-38.

    dpkg: erro ao procesar o lanzador de vapor (–install):
    problemas de dependencia - deixados sen configurar
    Procesadores desencadeantes para man-db ...
    Procesando desencadeantes para hicolor-icon-theme ...
    Procesando desencadeantes para utilidades de ficheiros de escritorio ...
    Procesadores desencadeantes para menús gnome ...
    Atopáronse erros ao procesar:
    lanzador de vapor

  15.   Javier Madrid dixo

    Esta entrada debe actualizarse ou eliminarse. Xa non funciona.

  16.   dorme dixo

    Teño problemas para instalar vapor

    dpkg: erro ao procesar o lanzador de vapor (–install):
    problemas de dependencia - deixados sen configurar
    Procesando desencadeantes para utilidades de ficheiros de escritorio ...
    Procesadores desencadeantes para menús gnome ...
    Procesando desencadeantes para hicolor-icon-theme ...
    Procesadores desencadeantes para man-db ...
    Atopáronse erros ao procesar:
    lanzador de vapor

  17.   Stephen Laguerre dixo

    Non me serviu de nada

  18.   Stephen Laguerre dixo

    Ola, non o tomes como spam pero atopei a solución definitiva, se o anterior non che axudou, vai a este vídeo http://youtu.be/V5LkpR179WQ e na descrición empregue a segunda ligazón, non preste atención ao vídeo e logo dé unha esquina (despois de premer o enlace) onde di descargar zip, nese ficheiro. Atoparase un ficheiro .deb, instálalo co instalador de software e xa está

  19.   Siracos dixo

    Non sei, probei isto, pero aínda así falla,

    Ben, isto dime todo o tempo; bash: ./debian_install.sh: permiso denegado

    e isto: Atopáronse erros ao procesar:
    lanzador de vapor
    ao parecer dame un erro debido a problemas de dependencia ....

  20.   juangmuriel dixo

    Estupendo !!, teño ao meu neno de 9 anos, que é un xogador e a metade das veces que entra en Windows para un xogo ten problemas, así que teño un Ubuntu instalado e agora quero migrar o PC só a debian para ter estabilidade Poño vapor e uso software libre e xogos de pago na plataforma.

  21.   panita dixo

    Ola, tentei o guión
    co cambio shh

    wget http://dl.dropbox.com/u/29081229/Steam/debian_install.sh sh ./debian_installer.sh

    e teño isto todo o tempo:

    Tentando de novo.

    –2014-06-09 12: 01: 58– (intento: 9) http://sh/
    Conectando con sh (sh) [193.223.78.211]: 80 ... fallou: o tempo de conexión caducou.

    Quero probar a xogar a dota en debian whezzy porque en Windows falla e desconéctame.

    1.    panita dixo

      http://articulos.softonic.com/instalar-steam-en-linux
      Ben, resolvín con este enlace,
      instala PlayOnLinux. e listo

  22.   MetalheadB93 dixo

    non funciona en 64 bits debian wheezy
    errir: non se pode satisfacer a dependencia: libc6 (> + 2.15)

  23.   Andrew dixo

    Despois de actualizalo, recibo un erro coma este:
    Erro grave: non se puido cargar steamui.so

    1.    xeo dixo

      Estou no mesmo, aínda non podo instalar Steam en debian sid

      1.    xeo dixo

        Resolveino ... instalando as bibliotecas i386. Funciona perfectamente agora.

  24.   Daniel dixo

    Non puiden instalalo, conseguín isto bash: ./debian_install.sh: permiso denegado

bool (verdadeiro)