Núcleo Linux 3.1, agora con mellor soporte para as GPU AMD, Intel e Nvidia

Linus Torvalds anuncio a dispoñibilidade de Linux 3.1 (Loxicamente me refiro ao núcleo), e isto ten como punto forte que se mellorou o soporte para as GPU AMD, Intel e Nvidia, así como para o Arquitectura OpenRISC (cando digo AMD, obviamente queremos dicir Ati).

Pero non só isto, esta versión tamén ten soporte para Nintendo wii, entón agora xa sabes ... o que queiras aventurar e instalar Linux na túa Wii, podes 🙂

Na súa declaración menciona que as bases para Linux v3.2 xa están establecidas, xa que normalmente as versións impares (3.1, 2.3, 2.7, etc.) son versións de desenvolvemento, é dicir, versións nas que traballar para a seguinte versión (con pares número) melloraron o novo que se engadiu na versión impar.

Non obstante jeje, isto non fará que as distros se vexan intimidadas e non inclúa esta versión (3.1) para gañar estabilidade e, polo tanto, agardar á versión 3.2, de feito ... Apostaría a que mañá en ArchLinux xa a teño dispoñible, cuestión de un "Pacman -Syu"e listo, Linux Kernel v3.1 instalado ????

Posiblemente Fedora 16, que debería ser lanzado o mes que vén inclúe esta versión do núcleo, pero bueno ... cada distro ten as súas peculiaridades, iso é o xenial deste mundo 😀

En fin, agarda as actualizacións 😉


O contido do artigo adhírese aos nosos principios de ética editorial. Para informar dun erro faga clic en aquí.

32 comentarios, deixa os teus

Deixa o teu comentario

Enderezo de correo electrónico non será publicado. Os campos obrigatorios están marcados con *

*

*

  1. Responsable dos datos: Miguel Ángel Gatón
  2. Finalidade dos datos: controlar SPAM, xestión de comentarios.
  3. Lexitimación: o seu consentimento
  4. Comunicación dos datos: os datos non serán comunicados a terceiros salvo obrigación legal.
  5. Almacenamento de datos: base de datos aloxada por Occentus Networks (UE)
  6. Dereitos: en calquera momento pode limitar, recuperar e eliminar a súa información.

  1.   Coraxe dixo

    Dálle a Elav o desexo de chamar jaja.

    A Wii paréceme interesante, aínda que non son un xogador

    1.    KZKG ^ Gaara <° Linux dixo

      Non HAHA, non se trata de iniciar unha guerra de chamas lonxe dela, ben podería dicir algo así como «Si, terá a última versión do núcleo, pero pode que teña un problema X.«Ou algo así jeje.

      1.    Coraxe dixo

        melloraron o novo que se engadiu na versión par.

        Estás seguro de que non é o estraño?

        1.    KZKG ^ Gaara <° Linux dixo

          OLA listo, corrixín isto e un erro de dixitación que tiven 😉

  2.   fer dixo

    Vai solucionar problemas coa tecnoloxía "optimus" de nvidia?

    1.    KZKG ^ Gaara <° Linux dixo

      Sentímolo, non o sei ... polo xeral cando din "mellora do soporte", refírense aos parches que fan nos controladores, corrixiron erros, quizais melloras no rendemento, pero non sei ... deberías probalo e ver se os teus problemas actuais están resoltos.
      Sinto non poder axudarche máis.

  3.   son Link dixo

    Vexamos como son as novas melloras para NVIDIA.
    En canto á Wii, se a tivese, instalaría Arch con LXDE.
    En canto a pacman -Syu non o necesito, por iso teño o meu [spam] pacsyu [/ spam]: 3

    1.    KZKG ^ Gaara <° Linux dixo

      Primeiro de todo, BENVIDO ao noso sitio 😀
      Un alias non? jaja, adoitaba usar pacmansearch n pacman-ssou mellorar n Pacman -Syu, Xa o escribo todo sen alias, non sei ... preguiza para reconfiguralos HAHA.

      lembranzas

      1.    Coraxe dixo

        Con 21 anos preguiceiro? Carallo, teremos que verte uns anos maior jaja.

        Ben, ese alias paréceme un chorra

      2.    son Link dixo

        Que alias ou que leite?
        Para evitar ser acusado de spam, consulte os Foros da Comunidade Hispánica Arch ou AUR

  4.   pepe dixo

    A ver se con esta versión xa podo cargar, teño que comezar coa 2.6

    1.    KZKG ^ Gaara <° Linux dixo

      Desde 2.6? Carallo !!! Espero que teña sorte nisto ...

      Por certo, benvido ao blog 😉

  5.   pepe dixo

    grazas, fas un gran traballo.

    Ben, é o que veu coa última versión de lmde, o kernel update pack 3, falla.

    1.    KZKG ^ Gaara <° Linux dixo

      Grazas, fas o que podes 🙂
      Non son o máis experimentado nin coñecedor de LMDE, pero creo ... Creo que xa teñen o núcleo 3.0 nos seus repos.

      1.    pepe dixo

        E non arranca 😀

    2.    elav <° Linux dixo

      Que repositorios utilizou para actualizar a última versión de LMDE? Porque funcionou para min sen problemas os repos LMDE e cos de Debian Testing.

      1.    pepe dixo

        Esas esas.
        O núcleo ten certa incompatibilidade coas pontes de area, dedúcoo dende o momento en que está colgado.

        Polo menos, usando o anterior estou ben, que suspender / hibernar non hai xeito e máis do mesmo de configurar o touchpad

  6.   Eduardo 2 dixo

    É modesto e non quería facer spam, porque é o creador da aplicación que fala ou, polo menos, ten o alcume similar.

    Non me importa o spam, o molesto ou o trolling.

    http://www.archlinux-es.org/foros/viewtopic.php?f=9&t=4617

    1.    KZKG ^ Gaara <° Linux dixo

      Ah, ben, desculpade entón que non coñecía esta aplicación ^ _ ^ U

  7.   Eduardo 2 dixo

    Por certo, Son Link, como vai o proxecto? Informe de ver, aínda que vos digo que un pacman -Syy e -Su ou -Syu non se preocupa por nah, pero parece interesante.

    1.    son Link dixo

      Non é similar, É O QUE SON.
      O proxecto vai como se di no foro, aínda que estes días deixeino un pouco de lado para outros asuntos.
      No meu blogue (fai clic no alcume) tamén hai toda a información. Se son modesto, non son dos que se dedican a usar os comentarios dun blog para spam XD

      1.    KZKG ^ Gaara <° Linux dixo

        Amigo ninguén dixo que fas SPAM nin moito menos 😉
        Por Eduardo 2 y Coraxe non te preocupes ... non lles fagas moita atención, son oficialmente os trolls do noso sitio HAHAHA, así que non lles fagas caso, vale 😀

        De todos os xeitos, un verdadeiro pracer telo aquí, intentaremos poñer artigos que sexan interesantes para ti, porque cada lector conta e é importante para nós 😉

        Un saúdo e lemos.

  8.   Eduardo 2 dixo

    Por certo, boas novas sobre o soporte eh, pero poñer algunhas notas de lanzamento tería sido xenial, esta arenosa, está perdendo o seu toque.

    1.    KZKG ^ Gaara <° Linux dixo

      Vaia, tes razón ... Esquecín explicar detalles técnicos que a gran maioría non entenderían ... nah realmente, debería poñer a ligazón a un rexistro de cambios, aquí déixoo: http://kernelnewbies.org/Linux_3.1 Supoño que sabes inglés, se non, este sitio web axudarache moito: http://translate.google.com/
      A

      HAHA en serio, non sabes canto, nin a máis remota idea que tes de canta experiencia teño tratando con trolls, calefactores, usuarios, etc etc jeje.

      1.    Coraxe dixo

        Creo que o tradutor de Google engana máis:

        http://www.guitarristas.info/foros/james-hetfield-nueva-signature-set-emg/150570#post1046206

        Haha sendo o moderador de McAnime, haha, non é un problema contigo para que calquera poida tratar con trolls

        1.    KZKG ^ Gaara <° Linux dixo

          HEH, si, imaxina ser moderador en MCAnime pero de todos os foros relacionados co Anime, tes algunha idea de cantos trolls e quentadores tiven que soportar? LOL !!!

          Fixen un máster con este tema 😀

  9.   Eduardo 2 dixo

    Ben, o máis interesante son estas 2 pequenas cousas cpupowerutils e OpenRISC, pero supoño que aínda é algo que os parvos non entenderían, tes razón nos detalles técnicos 😀

    Por certo use http://translate.google.com/ (Ben, se sabes inglés, non o uses) e mira esta crítica que se está ben feita como din https://www.linux.com/learn/tutorials/498187-a-look-at-linux-31

  10.   Trece dixo

    Pola miña experiencia persoal, cando se trata de tarxetas gráficas (e Wi-Fi, por certo), en Linux, Intel paréceme o que mellor funcionou en Linux (en varias distros e sen axustes posteriores á instalación). E a razón é obvia: as unidades levan anos sendo gratuítas.

    Pero é bo saber que a compatibilidade con Nvidia segue mellorando (como fai Ati).

    E aclaro de antemán que non digo que os chips gráficos Intel sexan mellores, só que en Linux funcionan mellor desde unha instalación limpa en varias distribucións que probei.

    Saúdos.

    1.    KZKG ^ Gaara <° Linux dixo

      O meu portátil é un gráfico Intel, é un 945 polo que ten 128 MB de vídeo incorporado e nunca ... repito, nunca tiven un único problema e estiven usando GNU / Linux desde entón en Ubuntu 7.10 ou quizais antes. Probei varias distros e neste momento a gráfica nunca me fallou nin moito menos.

      Non obstante, na casa teño un ordenador cun Ati Radeon 9250 e uff ... imposible conseguir que funcione bastante ben, nin sequera instalar controladores propietarios.

      Pero non é iso, é que Nvidia funciona ben, teño instalado Linux nas computadoras de dous amigos e teñen gráficos Nvidia, é marabilloso o ben que funcionan, só instalando os controladores do repositorio.

      En fin, que Ati (AMD) debería traballar máis para mellorar a compatibilidade, non?

      1.    Trece dixo

        Iso é exactamente o que quero dicir, e de aí as vantaxes de que os controladores poden ser gratuítos.

        Saúdos.

  11.   VelloAmigo dixo

    Loading Linux 3.1.5
    error: invalid magic number
    Loading initial ramdisk ...
    error: you need to load the kernel first.

    Press any key to continue ...

    make[1]: se ingresa al directorio `/usr/src/zaptel-1.4.12.1'
    make -C /lib/modules/2.6.32-5-486/build ARCH=i386 SUBDIRS=/usr/src/zaptel-1.4.12.1/kernel HOTPLUG_FIRMWARE=yes KBUILD_OBJ_M="pciradio.o tor2.o torisa.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o wcusb.o zaptel.o ztd-eth.o ztd-loc.o ztdummy.o ztdynamic.o zttranscode.o wct4xxp/ wctc4xxp/ xpp/ wctdm24xxp/ wcte12xp/" modules
    make[2]: se ingresa al directorio `/usr/src/linux-headers-2.6.32-5-486'
    CC [M] /usr/src/zaptel-1.4.12.1/kernel/pciradio.o
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c: In function ‘pciradio_start_dma’:
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: implicit declaration of function ‘set_current_state’
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: ‘TASK_INTERRUPTIBLE’ undeclared (first use in this function)
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: (Each undeclared identifier is reported only once
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1701: error: for each function it appears in.)
    /usr/src/zaptel-1.4.12.1/kernel/pciradio.c:1702: error: implicit declaration of function ‘schedule_timeout’
    make[5]: *** [/usr/src/zaptel-1.4.12.1/kernel/pciradio.o] Error 1
    make[4]: *** [_module_/usr/src/zaptel-1.4.12.1/kernel] Error 2
    make[3]: *** [sub-make] Error 2
    make[2]: *** [all] Error 2
    make[2]: se sale del directorio `/usr/src/linux-headers-2.6.32-5-486'
    make[1]: *** [modules] Error 2
    make[1]: se sale del directorio `/usr/src/zaptel-1.4.12.1'
    make: *** [all] Error 2

    grub.cfg

    if [ -s $prefix/grubenv ]; then
    load_env
    fi
    set default="0"
    if [ "${prev_saved_entry}" ]; then
    set saved_entry="${prev_saved_entry}"
    save_env saved_entry
    set prev_saved_entry=
    save_env prev_saved_entry
    set boot_once=true
    fi

    function savedefault {
    if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
    fi
    }

    function load_video {
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
    }

    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 3878592c-fd5d-44d2-8cdb-577de20dbf6b
    if loadfont /usr/share/grub/unicode.pf2 ; then
    set gfxmode=640x480
    load_video
    insmod gfxterm
    fi
    terminal_output gfxterm
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 3878592c-fd5d-44d2-8cdb-577de20dbf6b
    set locale_dir=($root)/boot/grub/locale
    set lang=es
    insmod gettext
    set timeout=5
    ### END /etc/grub.d/00_header ###

    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=cyan/blue
    set menu_color_highlight=white/blue
    ### END /etc/grub.d/05_debian_theme ###

    ### BEGIN /etc/grub.d/10_linux ###
    menuentry 'Debian GNU/Linux, with Linux 3.1.5' --class debian --class gnu-linux --class gnu --class os {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 3878592c-fd5d-44d2-8cdb-577de20dbf6b
    echo 'Loading Linux 3.1.5 ...'
    linux /boot/vmlinux-3.1.5 root=UUID=3878592c-fd5d-44d2-8cdb-577de20dbf6b ro quiet
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-3.1.5
    }

    00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
    00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
    00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
    00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
    00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
    00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
    00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
    00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
    00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
    01:00.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface
    01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

    1.    KZKG ^ Gaara <"Linux dixo

      Ola e benvidos,
      Que distro empregas? ... Como instalou esa versión 3.1.5?
      Ben, eu (que uso Arch) só teño 3.1.3 dispoñible.

      lembranzas