સીસેન્ટ સાથે મૂળભૂત પ્રોગ્રામિંગ (ભાગ 3)

આ ટ્યુટોરિયલનું એક ચાલુ છે સીસેન્ટ સાથે મૂળભૂત પ્રોગ્રામિંગ (ભાગ 2), આ સમયે પ્રોગ્રામ માટે શું જરૂરી છે તે હું સમજાવીશ.

સોંપો

સોંપણી એ એક પ્રક્રિયા છે જેમાં ચલ બનાવવામાં આવે છે અને / અથવા સંશોધિત થાય છે, તેના ઓળખકર્તાના માધ્યમથી તેનો સંદર્ભ બનાવે છે જેની સાથે અમે તેની મેમરી જગ્યાને accessક્સેસ કરી શકીએ છીએ.

સોંપણીનો વાક્યરચના છે:

[variable]<- [expresion];
[variable]=[expresion];

જ્યાં [ચલ] એ ચલ છે જે [અભિવ્યક્તિ] નું મૂલ્યાંકન કરવાનું મૂલ્ય પ્રાપ્ત કરે છે. બંને માન્ય છે તેથી તેનો ઉપયોગ કરવામાં કોઈ વાંધો નથી (જો તેઓ PSeInt યોગ્ય રીતે ગોઠવે છે), પરંતુ મારા મતે હું પ્રથમ એક યોગ્ય તરીકે બનાવું છું.

જો સોંપણી પહેલાં [ચલ] અસ્તિત્વમાં ન હોત, [વેરિયેબલ] બનાવવામાં આવ્યું હતું, જો તે અસ્તિત્વમાં હોત તો અગાઉનું મૂલ્ય નાશ પામ્યું હતું અને નવું તેની જગ્યાએ મૂકવામાં આવ્યું છે. આ કારણોસર, મેપિંગને વિનાશક કામગીરી માનવામાં આવે છે.

વાંચન

વાંચન એ પ્રક્રિયા છે જેમાં કોઈ ચલમાં ડેટા અથવા ડેટાને વપરાશકર્તા દ્વારા કહેવાતા ડેટાને સ્ટોર કરવાની વિનંતી કરવામાં આવે છે.

તેનો વાક્યરચના છે:

Leer variable_1,variable_2,...,variable_n;

જ્યાં [ચલ_ {1,2, n}] એ ચલ અથવા ચલો છે જે વપરાશકર્તા દ્વારા આપવામાં આવેલ મૂલ્ય પ્રાપ્ત કરે છે, જો એક કરતા વધુ ચલની વિનંતી કરવામાં આવે તો, તે પહેલા પ્રથમ પૂછશે, પછી બીજા માટે અને તેથી વધુ બધા મૂલ્યો પ્રાપ્ત થયા છે.

આ એક વિનાશક કાર્ય પણ છે.

લખવું

લેખન એ પ્રક્રિયા છે જેમાં અક્ષરોની એક શબ્દમાળા અને / અથવા એક અથવા વધુ ચલો સ્ક્રીન પર લખાય છે

વાક્યરચના છે:

Escribir expresion_1,expresion_2,...,expresion_n;

જ્યાં [expersion_ {1,2, n}] એ અક્ષર શબ્દમાળાઓ અને / અથવા ચલો છે જે પ્રદર્શિત થશે.

સ્ક્રીન પર મૂકવા માટે ડેટા પ્રાપ્ત કરવા ઉપરાંત લખવું, "અવગણો વિના" અથવા "ડાઉનલોડ કર્યા વિના" સૂચના પણ મેળવે છે જે લીટી કૂદવાનું ટાળે છે.

લેખન દલીલો વચ્ચે જગ્યાઓ ઉમેરતું નથી, એટલે કે, જો તમે લખો:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

આ કિસ્સામાં તે «ઓલામોન્ડો show બતાવશે કારણ કે« એ »અને« બી between વચ્ચે કોઈ પાત્રની તાર નથી જે એ અને બી વચ્ચેની જગ્યા સૂચવે છે, જેથી તે યોગ્ય રીતે પ્રદર્શિત થાય, તે આ રીતે લખાયેલું છે:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

આ સ્થિતિમાં »add ઉમેરો જે એક અક્ષર શબ્દમાળા છે જેમાં એક જગ્યા છે જે« તરંગ »અને« વિશ્વ between વચ્ચેની જગ્યા છે અને તે પછી તે જગ્યા સાથે «તરંગ વિશ્વ world બતાવશે.

તો પછી

આ એક વાક્ય છે જે આપેલ સ્થિતિનું મૂલ્યાંકન કરે છે અને કહેલી શરતની સત્યતા અને / અથવા જૂઠ્ઠાણાને તપાસે છે, એટલે કે, જો શરત પૂરી થાય છે કે નહીં.

તેનું વાક્યરચના છે:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

કલમ "અન્ય" ફરજિયાત નથી, આ કિસ્સામાં જો શરત ખોટી હોય તો સૂચનાઓને અવગણો અને ચાલુ રાખો જાણે કે સજા અસ્તિત્વમાં ન હોય, તો આ કિસ્સામાં તે રહેશે:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

"નિષ્ફળતા" કલમ મૂકવામાં આવી હતી કે નહીં તે તે કાર્યક્રમની જરૂરિયાતો પર આધારિત છે.

મેળવો

વાક્ય તે સખ્તાઇથી આંકડાકીય ચલનું મૂલ્યાંકન કરે છે જે વિકલ્પ તરીકે 2 કરતા વધારે વિકલ્પો આપે છે, આ "જો-તો" થી તફાવત છે કારણ કે અગાઉના એક ફક્ત 2 વિકલ્પો આપી શકે છે.

વાક્યરચના છે:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

જેમ તમે «નંબર 1 see પછી જોઈ શકો છો કે ત્યાં એક«: »છે અને તે પછી જે સૂચનો હાથ ધરવામાં આવે છે તે કિસ્સામાં મૂકવામાં આવે છે કે« આંકડાકીય ચલ = સંખ્યા 1 », બીજા ઉદાહરણમાં તે« નંબર 2, નંબર 3 »એનો અર્થ એ છે કે જો u ન્યુમેરિક વેરિયેબલ = નંબર 2 અથવા નંબર 3 "પછી" સૂચનો "એક્ઝિક્યુટ કરવામાં આવશે, ત્યારે આ ઉપયોગી છે જ્યારે 2 શક્યતાઓએ સમાન સૂચનાઓ ચલાવવી આવશ્યક છે.

એવી સંભાવના પણ છે કે "ઇન વેન વે" એ સંજોગોમાં ચલાવવામાં આવે છે કે શક્યતાઓમાંથી કોઈ પણ પૂર્ણ થતું નથી.

જ્યારે

તે પુનરાવર્તિત કાર્ય છે જે પહેલા કોઈ સ્થિતિનું મૂલ્યાંકન કરે છે અને પછી જો તે પરિપૂર્ણ થાય છે તો તે સૂચનાઓની શ્રેણીને અમલમાં મૂકે છે, પછી તે સ્થિતિનું ફરીથી મૂલ્યાંકન કરે છે અને જો તે સાચું હોય તો તે ફરીથી તે જ સૂચનાઓ ચલાવે છે અને સ્થિતિ ખોટી ન થાય ત્યાં સુધી આ રીતે ચાલુ રહે છે. .

જો શરૂઆતથી શરત ખોટી હોય તો તે ક્યારેય ચલાવવામાં આવશે નહીં અને જો તે હંમેશાં સાચી હોય તો તે અનંત લૂપમાં મૂકવામાં આવશે, સૂચનોમાં છેલ્લાને ટાળવા માટે કંઈક એવું હોવું જોઈએ કે જે અમુક સમયે પરિસ્થિતિને ખોટી રીતે ઠીક કરે. લૂપ સમાપ્ત કરવા માટે.

તેનો વાક્યરચના છે:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

પુનરાવર્તિત - અનંત

આ પહેલાનાં જેવું જ એક ફંક્શન છે, પરંતુ પાછલા એકથી વિપરીત, આ એક કંડિશનને અંતે તપાસ કરે છે, એટલે કે, કમાન્ડ ઓછામાં ઓછી 1 વાર એક્ઝેક્યુટ થવાની છે, જ્યારે સૂચના છે ત્યારે પણ ચલાવવાને બદલે સાચું, જ્યારે તે શરત ન મળે તો તે ચલાવે છે, પરંતુ જો તમે ઇચ્છો કે જ્યારે સ્થિતિ પૂરી થાય ત્યારે તેને ચલાવવામાં આવે, તો "ત્યાં સુધી" ની જગ્યાએ "જ્યારે" નો ઉપયોગ કરો.

તેનો વાક્યરચના છે:

Repetir
[Instrucciones] hasta que [condicion]

દંપતી

આ નિવેદન એક ચલ માટે નિર્ધારિત સમયની સૂચનાનો અમલ કરે છે, અગાઉના મુદ્દાઓથી વિપરીત, આ ચક્ર પ્રશ્નાત્મક ચલનું મૂલ્ય પોતે જ બદલી નાખે છે, સાથે સાથે ખૂબ શક્તિશાળી વાક્યરચના ધરાવે છે.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"વેરીએબલ" એ વેરિયેબલ છે જે "પ્રારંભિક મૂલ્ય" મેળવે છે અને સૂચનાઓ ચલાવે છે પછી "ચલ" વત્તા "પગલું" ઉમેરશે અને "ચલ" બરાબર "અંતિમ મૂલ્ય" ની બરાબર સૂચનાઓ ફરીથી ચલાવે છે.

જો "[પગલું]" ને દૂર કરવામાં આવે છે, તો ડિફ defaultલ્ટ રૂપે તે જાણશે કે "પગલું" 1 ની બરાબર છે, તે પણ જો [પગલું] ઉલ્લેખિત નથી અને "પ્રારંભિક મૂલ્ય" "અંતિમ મૂલ્ય" કરતા વધારે છે તે તેમાંથી પસાર થશે વિપરીત ક્રમ, તે "પગલું" છે -1

સબ્સક્રોસ / ફંક્શન

થ્રેડ અથવા ફંક્શન એ બીજાની અંદરનો પ્રોગ્રામ છે અને તે કે આ પેટાપ્રગ્રામ એક અથવા વધુ મૂલ્યો પ્રાપ્ત કરે છે, તેમને ચલાવે છે અને બીજો પરત આપે છે. તેનું વાક્યરચના છે

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

જ્યાં "રીટર્ન વેરીએબલ" એ વેરિયેબલ છે જેમાં "ફંક્શન નામ" ફંક્શન દ્વારા પાછા ફરવામાં આવતા મૂલ્ય શામેલ છે જે આ ચલાવવા માટે "arg_1, arg_2, arg_n" પરિમાણો મેળવે છે

અન્ય

આ એવા કાર્યો છે જે ફક્ત અન્યને પૂરક છે અને તેમાં ફક્ત પૂરક કાર્યો હોવાથી જટિલ વાક્યરચના હોતી નથી.

સ્ક્રીન સાફ કરો

આ કાર્ય દુભાષિયામાં કોઈપણ anyબ્જેક્ટની સ્ક્રીનને સાફ કરે છે

પ્રતીક્ષા કી

આ ફંક્શન વપરાશકર્તા સાથે પ્રોગ્રામ સાથે ચાલુ રાખવા માટે કી દબાવવા માટે રાહ જુએ છે

પ્રતીક્ષા કરો xબીજું, મિલિસેકંડ્સ}

આ ફંક્શન પ્રોગ્રામ સાથે ચાલુ રાખવા માટે સેકંડ અથવા મિલિસેકંડમાં એક સમયની રાહ જુએ છે

પીએસ: વિલંબ બદલ માફ કરશો પરંતુ હું અન્ય બાબતોમાં વ્યસ્ત હતો તેથી હું લખી શક્યો નહીં


લેખની સામગ્રી અમારા સિદ્ધાંતોનું પાલન કરે છે સંપાદકીય નૈતિકતા. ભૂલની જાણ કરવા માટે ક્લિક કરો અહીં.

10 ટિપ્પણીઓ, તમારી છોડી દો

તમારી ટિપ્પણી મૂકો

તમારું ઇમેઇલ સરનામું પ્રકાશિત કરવામાં આવશે નહીં.

*

*

  1. ડેટા માટે જવાબદાર: મિગ્યુએલ gelંજેલ ગેટóન
  2. ડેટાનો હેતુ: નિયંત્રણ સ્પામ, ટિપ્પણી સંચાલન.
  3. કાયદો: તમારી સંમતિ
  4. ડેટાની વાતચીત: કાયદાકીય જવાબદારી સિવાય ડેટા તૃતીય પક્ષને આપવામાં આવશે નહીં.
  5. ડેટા સ્ટોરેજ: cસેન્ટસ નેટવર્ક્સ (ઇયુ) દ્વારા હોસ્ટ કરેલો ડેટાબેઝ
  6. અધિકાર: કોઈપણ સમયે તમે તમારી માહિતીને મર્યાદિત, પુન recoverપ્રાપ્ત અને કા deleteી શકો છો.

  1.   ગિલ જણાવ્યું હતું કે

    એક્ઝેક્યુશન અટકાવ્યા વિના કીઓ કેપ્ચર કરવાનાં કાર્યો નથી? હલનચલન સાથે કંઈક કરવા માટે જે 9 વર્ષના બાળકોને વધુ આકર્ષક છે, તેમ છતાં હેંગમેન ગેમ પણ પ્રોગ્રામ કરવામાં આનંદદાયક હોઈ શકે છે.

    કંઈક_ ડિગો પ્રક્રિયા કરો
    એક <-1;
    બાજુની <-30;
    નીચે <-5;
    જ્યારે એ = 1 કરો
    સ્પષ્ટ સ્ક્રીન;
    સી <-1;
    વાક્ય <- "";
    પુનરાવર્તન કરો
    વાક્ય <-લાઇન + "";
    c <-c + 1;
    સી = બાજુની સુધી
    લાઇન <-લાઇન + "X";
    સી <-1;
    પુનરાવર્તન કરો
    લખવુ " ";
    c <-c + 1;
    સી = ડાઉન -1 સુધી
    લખાણ લખો;
    પુનરાવર્તન કરો
    લખવુ " ";
    સી 2 પછી
    ડાઉન <-ડાઉન -1;
    હા હા
    "ઓ":
    જો નીચે <15 તો
    નીચે 2 પછી
    બાજુની <-lateral-1;
    હા હા
    "ડી":
    જો બાજુની <50 તો
    બાજુની <-lateral + 1;
    હા હા
    "0":
    એક <-2;
    અંત સેકન્ડ્સ
    જ્યારે અંત
    સમાપ્ત પ્રક્રિયા

  2.   ગિલ જણાવ્યું હતું કે

    ઠીક છે, નિષ્ફળ જાઓ જો તમે ઉપર જાઓ, તો વધુ સારી રીતે 23 અને 28 લાઇન બદલો
    -23 સુધી સી = 15
    +23 સી = 18 સુધી
    y
    -28 જો નીચે> 2 તો
    +28 જો નીચે> 3 તો

    1.    xnmm જણાવ્યું હતું કે

      ફાળો બદલ આભાર પરંતુ તેમાં કેટલીક સમસ્યાઓ છે જેમ કે તમે એક વાક્ય બીજાની અંદર ખોલો છો પણ તે જે વાક્ય શરૂ થયું ત્યાં જ તે અંતમાં હોવું જોઈએ, મારો મતલબ કે તે મૂકી શકાતું નથી

      કંઈક પ્રક્રિયા કરો
      એ <- 0;
      ને વાંચો;
      જો એ 25 ની બરાબર ન હોય
      જ્યારે a 0 do બરાબર નથી
      ને વાંચો;
      હા હા
      અંત જ્યારે

      જેમ કે તમે જો "જો પછી" સ્ટેટમેન્ટની અંદર શરૂ કરો ત્યારે લૂપ જોશો પરંતુ તેની બહાર સમાપ્ત થશો, તો આવું કંઈક શક્ય નથી.

      હું હજી પણ યોગદાનની કદર કરું છું
      સમાપ્ત પ્રક્રિયા

      1.    ગિલ જણાવ્યું હતું કે

        આભાર.

        કાર્યક્રમ દંડ કામ કરે છે. ચલ "એ" જ્યારે યુઝર શૂન્ય ટાઇપ કરે છે ત્યારે હું લૂપમાંથી બહાર નીકળવા માટે ખાલી ઉપયોગ કરું છું. તમે એક્ઝિટ () અથવા વિરામ મૂકી શકો છો; શરતી સ્થિતિમાં તે તેના પર જુએ છે અને હું ચલને સાચવીશ. તેઓ વિકલ્પો છે.

        શુભેચ્છાઓ.

      2.    ગિલ જણાવ્યું હતું કે

        હું જગ્યાઓ અને લેબલ્સ માટેના ટsબ્સ બદલવાનો પ્રયાસ કરીશ por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    ગિલ જણાવ્યું હતું કે

        તે મારા કોડથી આયાત ભૂલોથી ભરેલી છે, હું ફરીથી ટ tabબ્સ સાથે પ્રયાસ કરીશ:
        આ ફાઇલ algo.psc હશે

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    ગિલ જણાવ્યું હતું કે

        રસપ્રદ, કોડ લેબલ્સવાળી ટિપ્પણી ખાય છે, કા deletedી નાખવામાં આવે છે, જે કંઈપણ વચ્ચે જાય છે, ઉદાહરણ તરીકે રેખાઓ વચ્ચે
        પુનરાવર્તન કરો
        લખવુ " ";
        c
        સી પછી એ છે
        અને પછી તે 3 પછી ચાલુ રહે છે
        નીચે
        એકંદરે, કયા કોડ્સ અનુસાર મૂકવા આ વિશ્વસનીય નથી.

  3.   ગિલ જણાવ્યું હતું કે

    હું તે કેવી રીતે છે તે જોવા માટે = ને સોંપવાથી પ્રતીકો બદલું છું.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    ગિલ જણાવ્યું હતું કે

      તે કોડનો ભાગ ખાતો રહે છે, કોડ ટેગ નિષ્ફળ જાય છે, તે લેખનને જેમ જ છોડી દેવું જોઈએ.

      1.    xnmm જણાવ્યું હતું કે

        તમે જવાબ આપ્યો નહીં તે પહેલાં ન જોઈ માફ કરશો, પણ સારું
        તમે કોડને સારી રીતે પ્રકાશિત કરી શકતા નથી કારણ કે તમે મને તે મેઇલ દ્વારા મોકલતા નથી તેથી તમે આ બાબતમાં ઘણા બધા વળાંક ન આપો.