Shirye-shiryen asali tare da layi (sashi na 3)

Wannan ci gaban karatun ne Shirye-shiryen asali tare da layi (sashi na 2), wannan lokacin zan bayyana abin da ya wajaba don shirin.

AIKI

Aikin tsari tsari ne wanda ake kirkirar mai canji da / ko canza shi, yana mai nuni zuwa gare shi ta hanyar gano shi wanda zamu iya samun damar sararin ƙwaƙwalwar ajiyar sa.

mahimmin aikin shine:

[variable]<- [expresion];
[variable]=[expresion];

Inda [canji] shine canjin da yake karɓar ƙimar kimantawa [magana]. Dukansu suna da inganci don haka ba damuwa ko wane ne aka yi amfani da shi (idan sun daidaita PSeInt daidai), amma a ganina na ƙirƙiri na farko azaman daidai.

Idan [canji] baya wanzu kafin aikin, an ƙirƙira [mai canji], idan ya wanzu ƙimar da ta gabata ta lalace kuma sabon aka sanya a wurinsa. Saboda wannan dalili, ana ɗaukar taswira a matsayin aiki mai halakarwa.

KARATU

Karatu tsari ne wanda ake neman mai amfani dashi data ko bayanan da zai adana bayanan a cikin wani canji.

Tsarin gininsa shi ne:

Leer variable_1,variable_2,...,variable_n;

inda [variable_ {1,2, n}] su ne masu canzawa ko masu canji waɗanda ke karɓar ƙimar da mai amfani ya bayar, idan har an nemi sama da sau ɗaya, zai fara tambaya na farko, sannan na biyu da sauransu har sun karbi duk dabi'u.

Wannan ma aiki ne mai halakarwa.

RUBUTA

Rubutawa hanya ce wacce ake rubuta jerin haruffa da / ko ɗaya ko fiye masu canji akan allon

da tsari ne:

Escribir expresion_1,expresion_2,...,expresion_n;

inda [expersion_ {1,2, n}] akwai kalmomin haruffa da / ko masu canji da za'a nuna su.

Rubuta baya ga karɓar bayanan da za'a saka akan allon kuma yana karɓar umarnin "Ba tare da tsallakewa ba" ko "Ba tare da sauke ba" wanda ke guje wa tsallaken layin.

Rubutawa baya ƙara sarari tsakanin takaddama, ma'ana, idan an sanya shi:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

a wannan yanayin zai nuna «olamundo» tunda tsakanin «a» da «b» babu zaren haruffa da ke nuna sarari tsakanin a da b, don haka ana nuna shi daidai an rubuta kamar haka:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

a wannan yanayin sai a kara »» wanda yake shine kirtani na halayya wanda yake da sarari wanda shine sarari tsakanin «kalaman» da «duniya» sannan kuma zai nuna «duniya mai kalami» tare da sararin.

IDAN HAKA

Wannan jumla ce da ke kimanta yanayin da aka bayar kuma yake bincika gaskiya da / ko ƙaryacewar yanayin da aka faɗa, ma'ana, idan yanayin ya cika ko a'a.

Daidaitonsa shine:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Maganar «Baya ga haka» ba tilas ba ce, a wannan yanayin idan sharadin ƙarya ne sai a yi biris da umarnin kuma a ci gaba kamar ba jumlar ba, a wannan yanayin zai kasance:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Ko an sanya sashin "Failure" ko a'a ya dogara da bukatun wannan shirin.

A CEWA

Jumlar kamar yadda take tantance mai canza lamba wanda yake bada zaɓi fiye da 2 azaman zaɓi, wannan shine bambanci daga "Idan-Sannan" tunda wanda ya gabata zai iya bada zaɓi 2 ne kawai.

A tsari ne:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Kamar yadda kake gani bayan "lamba1" akwai ":" kuma bayan haka an sanya umarnin da za'a aiwatar a cikin lamarin "lamba mai lamba = lamba1", a misali na biyu shine "lamba2, lamba3" wannan yana nufin cewa idan " lambar adadi = lamba2 ko lamba 3 "to" umarni "za'a zartar, wannan yana da amfani yayin da damar 2 dole ne suyi umarni iri ɗaya.

Hakanan akwai ma'anar "A Wata Hanyar" wanda aka zartar a yayin da babu ɗayan damar da ya cika.

ALHALI

Maimaitaccen aiki ne da farko yake kimanta wani yanayi sannan kuma idan ya cika sai ya aiwatar da jerin umarni sai ya sake kimanta yanayin kuma idan gaskiya ne sai ya sake yin wannan umarnin kuma zai ci gaba kamar haka har sai yanayin ya zama karya.

idan yanayin karya ne daga farko ba za'a taba kashe shi ba kuma idan ya kasance gaskiya ne koyaushe za'a sanya shi a cikin madauki mara iyaka, don kaucewa na karshe a cikin umarnin dole ne akwai wani abu wanda a wani lokaci ya gurbata yanayin don samun damar kawo karshen madafun.

Tsarin gininsa shi ne:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

MAIMAITA-SAI

Wannan aiki ne mai kamanceceniya da na baya, amma ba kamar na baya ba, wannan yana bincika yanayin a ƙarshen, ma'ana, za a aiwatar da umarnin aƙalla sau 1, haka ma maimakon aiwatar da umarnin lokacin da yake da gaskiya, yana aiwatar da shi yayin Idan yanayin bai cika ba, amma idan kuna son a zartar da shi yayin da aka cika sharaɗin, yi amfani da "yayin" maimakon "har zuwa".

Tsarin gininsa shi ne:

Repetir
[Instrucciones] hasta que [condicion]

DON

Wannan bayanin yana aiwatar da umarni adadin ƙayyadaddun lokuta don mai canzawa, sabanin waɗanda suka gabata, wannan zagaye yana canza darajar mai canjin da ake tambaya kansa da ƙari ƙari da samun tsari mai ƙarfi.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"Mai canzawa" shine mai canzawa wanda ya karɓi "ƙimar farko" kuma ya aiwatar da umarnin sannan ya ƙara "mai sau" tare da "mataki" kuma ya sake aiwatar da umarnin har sai "m" yayi daidai da "ƙimar ƙarshe".

Idan an cire "tare da (mataki)" to ta hanyar tsoho za ta san cewa "mataki" daidai yake da 1, haka nan idan ba a bayyana takamaiman ba kuma "ƙimar farko" ta fi "ƙima ta ƙarshe" za ta bi ta cikin tsarin baya, wato, "Mataki" shine -1

RUFEWA / AIKI

Zare ko aiki shiri ne tsakanin wani kuma wannan ƙaramin tsarin yana karɓar ƙimomi ɗaya ko fiye, yana aiki da su kuma yana dawo da wani. Amfani da shi shine

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

inda "canji mai canzawa" shine canjin da ya ƙunshi ƙimar da aka dawo da ita ta "sunan aiki" wanda ya karɓi sigogin "arg_1, arg_2, arg_n" don aiwatar da wannan

WANNAN

Waɗannan ayyuka ne waɗanda suke dacewa da sauran kawai kuma basu da hadadden haɗin ginin kalmomi tunda kawai ayyuka ne masu dacewa.

Bayyanan allo

Wannan aikin yana share allon kowane abu a cikin mai fassarar

Maɓallin jira

Wannan aikin yana jiran mai amfani don latsa maɓalli don ci gaba da shirin

Dakata x {Na biyu, Miliyoyin sakandare}

wannan aikin yana jiran lokaci a cikin sakan ko milliseconds don ci gaba da shirin

PS: yi haƙuri da jinkiri amma na shagaltu da wasu lamuran don haka ban iya rubutu ba


Abubuwan da ke cikin labarin suna bin ka'idodinmu na ka'idojin edita. Don yin rahoton kuskure danna a nan.

10 comments, bar naka

Bar tsokaci

Your email address ba za a buga. Bukata filayen suna alama da *

*

*

  1. Mai alhakin bayanan: Miguel Ángel Gatón
  2. Dalilin bayanan: Gudanar da SPAM, gudanar da sharhi.
  3. Halacci: Yarda da yarda
  4. Sadarwar bayanan: Ba za a sanar da wasu bayanan ga wasu kamfanoni ba sai ta hanyar wajibcin doka.
  5. Ajiye bayanai: Bayanin yanar gizo wanda Occentus Networks (EU) suka dauki nauyi
  6. Hakkoki: A kowane lokaci zaka iyakance, dawo da share bayanan ka.

  1.   Guille m

    Ba ku da ayyuka don ɗaukar makullin ba tare da dakatar da aiwatarwa ba? Don yin wani abu tare da motsi wanda ya fi dacewa ga yara 'yan shekaru 9, kodayake wasan rataya kuma na iya zama abin farin ciki don shirin.

    Tsari wani abu_digo
    wani <-1;
    a kaikaice <-30;
    ƙasa <-5;
    Yayinda = 1 Yayi
    Bayyanannen allo;
    c <-1;
    layi <- "";
    Maimaita
    layi <-layi + "";
    c <-c + 1;
    Har sai c = a kaikaice
    layi <-layi + "X";
    c <-1;
    Maimaita
    Don rubuta "";
    c <-c + 1;
    Har sai c = ƙasa-1
    Rubuta layi;
    Maimaita
    Don rubuta "";
    c 2 Sannan
    ƙasa <-down-1;
    Karshe a
    "s":
    Idan kasan <15 Sannan
    ƙasa 2 Sannan
    kai tsaye <-lateral-1;
    Karshe a
    "d":
    Idan na gefe <50 To
    kai tsaye <-lateral + 1;
    Karshe a
    "0":
    wani <-2;
    Secondarshen Seconds
    Karshe Yayin
    EndProcess

  2.   Guille m

    Da kyau kasa idan kun hau, mafi kyau canza layin 23 da 28
    -23 Har zuwa c = 15
    +23 Har zuwa c = 18
    y
    -28 Idan kasan> 2 Sannan
    + 28 Idan kasan> 3 Sannan

    1.    xnmm ba m

      Na gode da gudummawar amma tana da wasu matsaloli kamar ka buɗe jumla ɗaya a cikin wani amma dole ne ya ƙare a cikin hukuncin inda ya fara, ina nufin, ba za a iya sanya shi ba

      Tsara wani abu
      wani <- 0;
      karanta zuwa;
      idan a bai kai 25 ba to
      alhali kuwa a bai yi daidai da 0 yi ba
      karanta zuwa;
      Karshe a
      karshen yayin

      kamar yadda kuke ganin madauki yayin farawa a cikin bayanin "idan to" amma ƙarewa a waje da shi, wani abu kamar wannan ba zai yiwu ba.

      Har yanzu ina godiya da gudummawar
      Processarshen tsari

      1.    Guille m

        Na gode, amma ina tsammanin ya fi matsala sanya lambar a nan, cewa ban san yadda ake saka shi a cikin nau'in lambar ba kuma yana fitowa ba tare da izini ba.

        Shirin yana aiki lafiya. Canjin "a" Na kawai amfani dashi don fita daga madauki lokacin da mai amfani ya buga sifili. Kuna iya sanya mafita () ko hutu; a cikin yanayin yana kallon shi kuma na adana mai canzawa. Su ne zaɓuɓɓuka.

        Na gode.

      2.    Guille m

        Zan gwada canza shafuka don sarari da lakabi por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille m

        Hakan yana cike da kurakuran shigowa daga lamba na, zan sake gwadawa da shafuka:
        Wannan zai zama fayil din algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille m

        Abin sha'awa, sharhi tare da alamun lamba an ci shi, an share shi, duk abin da ke tsakanin, misali tsakanin layuka
        Maimaita
        Don rubuta "";
        c
        bayan c akwai
        sannan kuma yana cigaba da 3 Sannan
        kasa
        Gabaɗaya, wannan ba abin dogaro bane don sanya bisa ga waɗanne lambobin.

  3.   Guille m

    Na canza alamomin daga sanyawa zuwa = don ganin yaya.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille m

      Yana ci gaba da cin ɓangaren lambar, lambar lambar ta gaza, yakamata ya bar rubutun kamar yadda yake.

      1.    xnmm ba m

        Barka dai barka da ganin baka amsa ba a da amma da kyau
        tunda baza ku iya buga lambar ba da kyau saboda ba ku aiko mani ta wasiku ba saboda haka ba ku juyo da yawa ga lamarin.