डेबियन 12.4 डेबियन 12.3 और लिनक्स 6.1.0-14 को छोड़कर आता है

डेबियन 12 किताबी कीड़ा: नया स्थिर संस्करण जारी

कुछ दिनों पहले ए डेबियन डेवलपर्स ने रिलीज की घोषणा की का नया संस्करण डेबियन 12.4 जिसे डेबियन 12.3 की रिलीज़ को छोड़कर रिलीज़ किया गया था क्योंकि इसकी तैयारी के अंतिम चरण में लिनक्स कर्नेल में कर्नेल linux-image-6.1.0-14 वाले पैकेज में एक बग खोजा गया था, जो Ext4 फ़ाइल सिस्टम में डेटा भ्रष्टाचार का कारण बनता है।

समस्या Linux 6.1 कर्नेल की स्थिर शाखा में दिखाई देती है, जिसे एक फिक्स द्वारा समर्थित किया गया है जिसे मूल रूप से 6.5 शाखा में जोड़ा गया था ताकि फ़ाइल आकार को अपडेट करने के लिए कोड में एक बग के कारण क्रैश को हल किया जा सके जो कि प्रत्यक्ष अपडेट के बाद कम हो गया था।

ऐसे में यह बताया गया है कि क्षति को गैर-महत्वपूर्ण के रूप में चिह्नित किया गया है (यह स्पष्ट नहीं किया गया है कि वास्तव में इसका क्या मतलब है, संभवतः डेटा हानि बहुत ही दुर्लभ परिस्थितियों में होती है, या डेटा स्थायी रूप से खो नहीं जाता है, लेकिन फ़ाइल का आकार वास्तविक से बड़ा हो जाता है)।

डेबियन 12 के संदर्भ में, संस्करण 6.1 के साथ सिंक्रनाइज़ करने के बाद बग को 6.1.64 कर्नेल पैकेज में ले जाया गया। बग की चर्चा के दौरान, डेबियन डेवलपर्स ने उल्लेख किया कि समस्या को अद्यतन 6.1.66 में ठीक कर दिया गया था, लेकिन यह अभी भी स्पष्ट नहीं है कि इस संस्करण में जोड़े गए कौन से सुधार समस्या का समाधान करते हैं, क्योंकि 6.1.66 कर्नेल में कोई बदलाव नहीं हैं। 4 जो स्पष्ट रूप से VFS और Ext6.1.66 से संबंधित हैं (संभवतः वे 6.1.65 कर्नेल आधारित डिबेट पैकेज में समस्या रुकने के बारे में बात कर रहे हैं, जब वास्तव में फिक्स को 4 कर्नेल शाखा में जोड़ा गया था, जिसमें ExtXNUMX से संबंधित परिवर्तन शामिल हैं)।

डेबियन 12.4 में नया क्या है?

सुधारों के उस भाग के लिए जो शामिल है डेबियन 12.4 की इस नई रिलीज़ में (साथ ही यह लिनक्स-इमेज-6.1.0-15 कर्नेल पैकेज के साथ आता है, जो कर्नेल संस्करण 6.1.66 पर आधारित है और इसमें समस्या का समाधान शामिल है), यह संचयी पैकेज अद्यतन प्रस्तुत करता है और इंस्टॉलर में सुधार जोड़ता है। रिलीज़ में स्थिरता के मुद्दों को संबोधित करने के लिए 94 अपडेट और कमजोरियों को संबोधित करने के लिए 65 अपडेट शामिल हैं।

डेबियन 12.4 में, आप एल को भी हाइलाइट कर सकते हैंके नवीनतम स्थिर संस्करणों में अद्यतन करें संकुल गनोम-शेल, मिनीज़िप, सिस्टमडी, एक्सईएन, दूसरों के बीच में। जिम्प-डीडीएस पैकेज को हटा दिया गया, जिसकी अब आवश्यकता नहीं है क्योंकि इसकी कार्यक्षमता अब जीआईएमपी में निर्मित हो गई है।

इसके अलावा, यह भी नोट किया जाता है कि एलएलवीएम/क्लैंग पर आधारित एलएलवीएम-टूलचेन-16 पैकेज जोड़ा गया 16, क्रोमियम ब्राउज़र के नए संस्करण बनाने के लिए आवश्यक है, यूनिकोड 15.1 समर्थन को गनोम-अक्षर और फ़ॉन्ट-नोटो-रंग-इमोजी में भी जोड़ा गया है। libsolv में zstd संपीड़न एल्गोरिदम के लिए समर्थन शामिल है।

की अन्य परिवर्तन कि इस नए संस्करण से बाहर खड़े हो जाओ:

  • eas4tbsync: नया संस्करण जो थंडरबर्ड के नए संस्करणों के साथ अनुकूलता बहाल करता है
  • एक्सफ़ैटप्रोग्स: आउट-ऑफ़-बाउंड मेमोरी एक्सेस समस्याओं को ठीक करता है [CVE-2023-45897]
  • एक्ज़िम4: प्रॉक्सी प्रोटोकॉल [सीवीई-2023-42117] और डीएनएसडीबी लुकअप [सीवीई-2023-42119] से संबंधित सुरक्षा समस्याओं को ठीक करता है।
  • सूक्ति शैल: नया संस्करण डिलीट कुंजी के अलावा बैकस्पेस कुंजी के साथ सूचनाओं को खारिज करने की अनुमति देता है, पल्सऑडियो से दोबारा कनेक्ट होने पर दिखने वाले डुप्लिकेट डिवाइस को ठीक करता है, पल्सऑडियो/पाइपवायर को पुनरारंभ करने पर अनलॉक क्रैश के बाद संभावित उपयोग को ठीक करता है।
  • libsolv: Zstd संपीड़न समर्थन सक्षम
  • लिनक्स कर्नेल: स्थिर संस्करण 6.1.66 पर अद्यतन करें
  • प्रोफ़ाइल: बफ़र ओवरफ़्लो समस्या को ठीक करता है [CVE-2023-47038]
  • php-phpseclib3: सेवा से इनकार की समस्या को ठीक करें
  • पोस्टग्रेस्क्ल-15: नया स्थिर संस्करण जहां SQL इंजेक्शन समस्या हल हो गई है [CVE-2023-39417]; पंक्ति सुरक्षा नीतियों को सही ढंग से लागू करने के लिए MERGE को ठीक करता है [CVE-2023-39418]
  • proftpd-dfsg: SSH कुंजी एक्सचेंज बफ़र्स का आकार ठीक करें
  • क्यूबिटोरेंट: qbittorrent-nox में डिफ़ॉल्ट रूप से वेब UI के लिए UPnP अक्षम है
  • क्यूमू: स्थिर संस्करण 7.2.7 पर अद्यतन करें

डाउनलोड करें और डेबियन प्राप्त करें 12.4

उन लोगों के लिए जो डेबियन 12.4 का नया संस्करण प्राप्त करने में रुचि रखते हैं, आपको पता होना चाहिए कि परियोजना की आधिकारिक वेबसाइट पहले से ही इंस्टॉलेशन छवियां प्रदान करती है, जबकि जिनके पास पहले से ही पिछला संस्करण है, उन्हें प्राप्त करने के लिए बस कमांड अपडेट निष्पादित करें यह नया संस्करण.

अंत में, यदि आप इसके बारे में अधिक जानने में रुचि रखते हैं, तो आप विवरण में देख सकते हैं निम्नलिखित लिंक।


अपनी टिप्पणी दर्ज करें

आपका ईमेल पता प्रकाशित नहीं किया जाएगा। आवश्यक फ़ील्ड के साथ चिह्नित कर रहे हैं *

*

*

  1. डेटा के लिए जिम्मेदार: मिगुएल elngel Gatón
  2. डेटा का उद्देश्य: नियंत्रण स्पैम, टिप्पणी प्रबंधन।
  3. वैधता: आपकी सहमति
  4. डेटा का संचार: डेटा को कानूनी बाध्यता को छोड़कर तीसरे पक्ष को संचार नहीं किया जाएगा।
  5. डेटा संग्रहण: ऑकेंटस नेटवर्क्स (EU) द्वारा होस्ट किया गया डेटाबेस
  6. अधिकार: किसी भी समय आप अपनी जानकारी को सीमित, पुनर्प्राप्त और हटा सकते हैं।