Megérkezik az OpenRGB 0.8, amely bővíti az eszköztámogatások listáját és még sok mást

OpenRGB

Ez egy nyílt forráskódú RGB világításvezérlő, amely nem függ a gyártó szoftverétől

Csaknem egy év fejlesztés után bejelentették az OpenRGB 0.8 új verziójának megjelenését, egy nyílt forráskódú eszközkészlet a perifériák RGB-világításának vezérléséhez.

A csomag kompatibilis ASUS, Gigabyte, ASRock és MSI alaplapokkal RGB alrendszerrel házvilágításhoz, ASUS, Patriot, Corsair és HyperX háttérvilágítású memóriamodulokkal, ASUS Aura/ROG grafikus kártyákkal, MSI GeForce, Sapphire Nitro és Gigabyte Aorus, több meghajtóval LED szalagok.

Az OpenRGB 0.8 fő újdonságai

Ebben az új verzióban, amely az OpenRGB 0.8-ból származik a kompatibilis eszközök listája feltöltésre került sok videokártyávalvagy ASUS, Gigabyte, EVGA, MSI, Gainward és Palit.

Amellett, hogy számos "klasszikus" perifériát adtak hozzá, a listán NanoLeaf moduláris lámpák is szerepelnek, otthoni eszközökhöz mostantól az SRGBMods Raspberry Pi Pico, az Arduino pedig i2c-n keresztül csatlakoztatható.

Azt is kiemelik hozzáadva az NVIDIA Illumination videokártyák támogatását, de jelenleg a régebbi NVIDIA videokártyákhoz hasonlóan csak Windowson működik, az NVIDIA szabadalmaztatott illesztőprogramján keresztül működő i2c problémái miatt (a probléma a béta illesztőprogram telepítésével megoldódik). Az MSI MysticLight alaplapokkal kapcsolatos híres probléma megoldódott, és most újra támogatottak, a támogatott alaplapok listája pedig bővült.

Az új verzióban bemutatott másik változtatás az Az udev szabályok most automatikusan generálódnak, amellett, hogy az inpout32 könyvtárat, amely bizonyos vírusirtókkal és csalások ellen (Vanguard) párhuzamosan dolgozva problémákat okozott, a WinRing0 váltotta fel.

Annak érdekében, hogy a Windows SMBus-eszközök hivatalos szoftverével párhuzamosan megfelelően működjön, most egy mutex rendszert használnak, amely megoldja a legtöbb problémát.

részéről ismert problémák Ezek a következők:

  • A konfigurációs útvonal még nem tartalmazhat nem ASCII karaktereket. A meglévő bővítményekkel való kompatibilitás fenntartása érdekében egy javítás készült, de a kiadásban nem szerepel, de a kiadás után a tényleges buildekbe belekerül.
  • Kiderült, hogy a billentyűzetgyártó Sinowealth újrahasznosította a Redragon billentyűzetek VID/PID értékeit egy másik protokoll használatával. A lehetséges problémák elkerülése érdekében (akár a méretezést is beleértve), a Sinowealth billentyűzet támogatási kódja le van tiltva, és nem támogatott.
  • A "hullám" effektus nem működik a Redragon M711-en.
  • Egyes Corsair egerek nem rendelkeznek LED-címkékkel.
  • Egyes Razer billentyűzeteken az elrendezések listája nem teljes.
  • Az Asus címezhető csatornáinak száma nem biztos, hogy pontos.

Hogyan lehet az OpenRGB-t Linuxra telepíteni?

Azok számára, akik szeretnék telepíteni az OpenRGB-t a rendszerükre, kövesse az alábbi utasításokat. Az első dolog, amit tennünk kell telepítse a Qt Creator legújabb kiadását. (A Qt Creator telepítésének részleteit itt ellenőrizheti a következő link).

Az Ubuntu és a derivatívák esetében telepítenünk kell néhány függőséget:

sudo apt install qt5-default libusb-1.0-0-dev libhidapi-dev

Most a következő paranccsal fogjuk megszerezni a segédprogramot:

git clone https://gitlab.com/CalcProgrammer1/OpenRGB

Most kész frissítenünk kell az almodulokat:

git submodule update --init –recursive

És itt két dolgot tehetünk, az egyik az, hogy megnyitjuk a projektet a QT alkotóval, vagy lefordítjuk a rendszerben.

A fordításhoz futtassa a következő parancsokat:

cd OpenRGB
qmake OpenRGB.pro
make -j8
./OpenRGB

Az összeállítás végén engedélyeznünk kell az SMBus hozzáférését.

Az Intel-ben a következő paranccsal tehetjük meg:

modprobe i2c-dev i2c-i801

Vagy az AMD esetében először fel kell sorolnunk az SMBus illesztőprogramokat a következőkkel:

sudo i2cdetect -l

A vezérlő azonosítása után engedélyeket kell adnunk a vezérlőnek, például:

sudo chmod 777 /dev/i2c-0

Végül figyelembe kell venni, hogy az összes újraindításnál továbbra is fennállnak bizonyos képességek, de a színek és módok konfigurálásának fő funkciója stabil.

Mint általában, javasolt a meglévő profilok újbóli létrehozása az eszközökhöz a frissítés után, előfordulhat, hogy a régiek nem vagy rosszul működnek, és a verziókról 0.6-ra frissítve ki kell törölni a plugins mappát, mert 0.6 előtt nem volt plugin API verziókezelő rendszer.

Ha többet szeretne tudni róla ellenőrizheti a részleteket A következő linken.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

Legyen Ön az első hozzászóló

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.