Hogyan lehet az AceStream-et Linuxra telepíteni, és nem halni próbálkozni

Azok, akik szeretjük a sportot, és nem férünk hozzá az összes aktuális sportcsatornához, általában azzal a problémával szembesülnek, hogy az élvezethez különféle oldalakat kell használnunk, amelyek továbbítják online mérkőzések, többségük kéri telepítse az AceStream programot, amelyet kissé bonyolultabb telepíteni a Linuxra.

Ebben az útmutatóban megtanítjuk, hogyan telepítse az AceStream szoftvert Linuxra anélkül, hogy belehalna a kísérletbe, megoldásokat kínálva a manapság leggyakoribb problémákra. A felhasználás és a hozzáférett tartalom teljes felelőssége.

Mi az AceStream?

AceStream egy multimédiás platform meglehetősen innovatív, ami magasabb szintre emelte az audiovizuális eszközök interneten történő reprodukcióját. Ehhez a multimédia fájlok betöltésére szolgáló univerzális menedzsert valósított meg, amely a legfejlettebb P2P technológiákat használja, garantálva a hatékony adattárolási és -átviteli folyamatot.

Az Ace Stream szoftver számos előnyt kínál számunkra, amelyekben kiemelhetjük:

  • Online közvetítések (TV, egyedi közvetítések, filmek, rajzfilmek stb.) Megtekintésének lehetősége magas hang- és képminőség mellett.
  • Hallgasson online zenét olyan formátumban, amely nem veszít semmilyen minőségből.
  • Tekintse meg a torrenteket online, anélkül, hogy megvárná a teljes letöltést.
  • Távoli eszközökön (Apple TV, Chromecast stb.) Lévő tartalom megtekintése olyan kommunikációs protokollokon keresztül, mint az AirPlay, a Google Cast és mások.
  • Lehetővé teszi a különféle alkalmazásokkal való integrációt. Telepítse az AceStream szoftvert Linuxra

Az AceStream telepítése Linuxra

Az AceStream Linux rendszerre történő telepítéséhez különféle lépéseket kell végrehajtanunk az Ön által használt disztribúciótól függően, az Arch Linuxra és az Ubuntura fogunk összpontosítani, de reméljük, hogy a jövőben más disztrókra is telepíthetjük.

Telepítse az AceStream alkalmazást Arch Linux rendszerre és annak származékaira

A cikk legfőbb oka az, hogy sokaknak gondjai voltak az AceStream telepítésével az Arch Linux, az Antergos, a Manjaros és a derivatívákra. A fő ok az, hogy a plugin pkgbuild acestream-mozilla-plugin Hiba ad a telepítéskor, a megoldás rendkívül egyszerű.

Telepíteni fogjuk a acestream-mozilla-plugin amely minket is telepíteni fog acestream-motor y acestream-player-data milyen csomagok szükségesek a szaporodáshoz AceStream a Firefoxból.

Először is meg kell nyitnunk egy terminált, és végre kell hajtanunk a következő parancsot:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Megoldja azt az ellenőrzési problémát, amely megakadályozza a telepítéshez szükséges függőség telepítését acestream-mozilla-plugin.

Ezután végrehajtjuk a következő parancsot

yaourt -S acestream-mozilla-plugin

Többször is megkérdezzük, hogy különféle függőségeket akarunk-e telepíteni, mindenkinek igent kell mondanunk.

Telepítse az AceStream szoftvert az Ubuntura és a származékaira

Telepítse az AceStream szoftvert az Ubuntu 14.04-re és a származékokra

Az Ubuntu és a származékai felhasználóknak a 14.04-es verzióig az AceStream telepítése meglehetősen egyszerű lesz, csak a következő parancsokat kell végrehajtaniuk a terminálról:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Telepítse az AceStream szoftvert az Ubuntu 16.04-re és a származékokra

Akiknek még egy kicsit küzdeniük kell, azok az Ubuntu 16.04 és a derivatívák felhasználói, mivel az acestream nem támogatja ezt a verziót, de ennek köszönhetően cikk, Sikerült telepítenem.

Az első dolog, amit meg fogunk tenni, az az, hogy letölt és telepít néhány olyan függőséget, amelyet nem tud majd letölteni a hivatalos adattárakból, feltétlenül telepítse a disztribúció architektúrájához megfelelőt:

64 bites architektúra:

  1. Töltse le és telepítse libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb a következő linkről teheti meg: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Töltse le és telepítse a következő függőségek sorrendjében:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Mindegyiket letöltheti a következő linkről: https://drive.google.com/folderview?id= … e_web#list

32 bites architektúra:

  1. Töltse le és telepítse libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb a következő linkről teheti meg: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Töltse le és telepítse a következő függőségek sorrendjében: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Mindegyiket letöltheti a következő linkről: https://drive.google.com/folderview?id= … e_web#list

Ezután folytatnunk kell az AceStream szokásos telepítését, mint a 14.04-es verziónál, meg kell nyitnunk egy terminált és végre kell hajtanunk:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Bizonyos esetekben el kell indítani a szolgáltatást acestream-engine.service, ehhez a következő parancsokat hajtjuk végre a terminálról:

systemctl indítás acestream-engine.service systemctl engedélyezése acestream-engine.service

Reméljük, hogy ezzel a bemutatóval élvezheti ezt a remek multimédiás átviteli protokollt, amely a P2P technológia teljes kapacitását kihasználja.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

41 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Julio Cesar Campos dijo

    Nos, a poszt, de legalábbis az archlinuxban, és ez volt az esetem, amire szüksége van: "systemctl start acestream-engine.service" és "systemctl enable acestream-engine.service", hogy működjön.

    1.    gyík dijo

      Tesztelted Firefox-ból, vagy másik böngészőt használtál?

  2.   UserDebian dijo

    Tudja valaki, hogyan kell működtetni a Debian 9-en?

  3.   Julio Cesar Campos dijo

    Firefox az archlinuxon

  4.   gecoxx dijo

    Nem tudom, hogy az előző kommentem megjelent-e ... Ismétlem! Nem tudom, hány óra alatt hajtom végre az átkozott parancsot a terminálban, és hogy feltettem a –noconfirm szót, és végül nem működik !!
    újabb haszontalan bejegyzés!

    telepítési kísérlet Manjaróra

    1.    gyík dijo

      Kedves, hogy ez nem működött nálad, nekem tökéletesen működött, különben is próbáld meg végrehajtani ezt a 2 parancsot:
      "Systemctl start acestream-engine.service" és "systemctl enable acestream-engine.service"

  5.   José dijo

    Minden lépést gond nélkül sikerült elvégeznem. De amikor megpróbáltam elindítani a szolgáltatást a terminálról, két hibát okozott;
    systemctl start acestream-engine.szolgáltatás
    Nem sikerült elindítani az acestream-engine.service szolgáltatást: Az acestream-engine.service egység nem található.
    systemctl engedélyezi az acestream-engine.service szolgáltatást
    Nem sikerült végrehajtani a műveletet: Nincs ilyen fájl vagy könyvtár

    1.    Gustavo dijo

      Pontosan ugyanez történt velem. a terminál azokkal a kudarcokkal visszaveti nekem ezeket a parancsokat.

  6.   Juan M. dijo

    Nagyon köszönöm a bejegyzést! Ha 16.10 bites Ubuntu 64-et használ, akkor nem tudja telepíteni az "acestream-player-data_3.0.2-1.1_amd64.deb" fájlt. Először le kell töltenie és telepítenie kell ezeket a csomagokat:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Valószínűleg valamilyen más függőségre van szükség, amely a repókban található.
    Üdvözlet!

  7.   Mérföld dijo

    Jó.
    Az acestream-mozilla-plugin leállt a Firefox 52-ben, mint sok más NPAPI bővítmény.

  8.   Darco dijo

    Egy másik nagyon jó és egyszerű lehetőség a dokkoló használata és az operációs rendszer agnosztikussá válása. Az acceproxy használatával reprodukálhatja

    A végrehajtás megkönnyítése érdekében írtam egy kis oktatóanyagot és egy szkriptet.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   David Martin dijo

    Az Ubuntu 16.04 telepítésének részében, amikor azt mondja, hogy töltse le és telepítse ezeket a fájlokat, hogyan telepítse őket? Amikor letöltöm és kibontom őket, egyesek csak libreoffice típusú fájlok, mások pedig nem tudom, hogyan "telepítsem" őket.
    Előre is köszönöm és üdvözlöm.
    David.

  10.   Azta dijo

    Vagy a kulcsok nem működnek újra, vagy valamilyen hiba van a csomagokban, de az arch és manjaro fájlokban nem lehet telepíteni.
    Ha megpróbál telepíteni egy függőséget (qwebquit) vagy valami hasonlót, akkor hurokba megy, és nincs rá mód.
    Megtalálta valaki a megoldást?
    Köszönöm

    1.    Alexander dijo

      Helló, az arch linux telepítéséhez a következőket kell tennie:
      -Telepítse az 'acestream-launcher' csomagot a yaourt-ból a 'yaourt -S acestream-launcher' programmal (a csomagot, amelyet legközelebb engedélyezni fogunk, automatikusan letöltjük Önnek)
      -Engedélyezze az acestream-engine.service szolgáltatást, belépünk a terminálba, és ROOT módban a következőket tesszük
      -systemctl indítsa el az acestream-engine.szolgáltatást
      -systemctl engedélyezi az acestream-engine.service szolgáltatást
      Ezek után újraindítottam a számítógépet, nem tudom, hogy szükség lesz-e rá, de csak arra az esetre
      -Ennek elégnek kell lennie, de a legutóbbi Arch frissítésekben valamit elcsesztek, és ez nem működik, ezért kerestek egy ideiglenes megoldást, amely egy fájl letöltése, ez a következő:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      forrás: https://aur.archlinux.org/packages/acestream-launcher/ (az észrevételeken)
      letöltés után megyünk a terminálhoz, és megyünk ahhoz a mappához, ahová letöltöttük,
      Telepítjük a következővel: 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz', és ennyi, mennie kell, az első alkalommal soha nem megy, így másodszor kattintok, mindig először hibát ad, ennyi

      PS: tisztázza, hogy a sudo pacman -U és nem -S, mert ez egy makepkg-ból kapott helyi csomag

      1.    Azta dijo

        Nagyon köszönöm az érdeklődését.
        Annyiszor kipróbáltam, hogy a yaourt-tal történő telepítéskor már fejből tudom a függőségeket és a csomagokkal kapcsolatos megjegyzéseket. Kövessem az indítóval adott tanácsodat, és megnézem, van-e szerencsém. Majd szólok.
        Megismétlem köszönetemet

        Felipe

        1.    Azta dijo

          Így vagy úgy nem működik. Kipróbáltam a linket, amit a kommentekbe tettél, de ez nem oldja meg, felismeri a linket, lehetőséget ad a program kiválasztására, én az acestream-launchert választom, de a VLC nem nyílik meg.
          A konzolban a következő választ kapom.

          Fájl «/usr/lib/python3.6/site-packages/psutil/init.py », 1231 sor, _send_signal
          os.kill (self.pid, sig)

          Várnunk kell az új frissítésekre.
          Köszönöm a segítséget.

  11.   Azta dijo

    Az új frissítés után a konzolon a következő válasz adható.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Az Acestream motor jár.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | hiba az indítás során
    Traceback (a legutóbbi hívás utoljára):
    A «core.c» fájl, 1590 sor, in
    A «core.c» fájl, 144 sor, in
    A «core.c» fájl, 2 sor, in
    ImportError: nem importálható a __m2crypto név
    Hiba történt az Acestream hitelesítése során!
    A Media Player nem fut ...

    Fejlődünk, most felismeri az áramlást, de a libcrypto tovább küzd.

    1.    Azta dijo

      Megpróbáltam telepíteni azt a csomagot, amelyet az általam elküldött linken ajánl.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      És hatékonyan megoldja a problémát, a vlc megnyílik és az Acestream működik.
      Nagyon szépen köszönöm a segítséget-

      1.    Alexander dijo

        Helló, sajnálom a késést, nagyon furcsa volt, hogy ez nem működött az Ön számára, amikor működött. Arch plazmában vagyok, örülök, hogy segített Önnek

        A másik disztribúcióm, a Fedora, ami nálam van, az az, hogy a Wine xD acute stream-et emulál, ha másik disztribúcióba vagy ugyanabban az Arch-ba megy, akkor az a meglepetés, hogy még a Debianban sem rendelkeznek ezek a csomagok

      2.    csemegekészítő01 dijo

        Helló és a fájl telepítésének módja még mindig újonc vagyok, üdvözlet

        1.    Azta dijo

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          A fenti megjegyzésbe teszi

  12.   kemabok dijo

    Tegnap egy snap csomagként telepítettem a Kde Neon 5.8-ba, és csodálkoztam, hogy milyen egyszerűen és gyorsan működött nálam. Jó lenne, ha frissítenéd a cikket, mert nincs összehasonlítás, a folyamat sokkal egyszerűbb.

    sudo apt install snapd → telepítse a snap csomagkezelő rendszert (ha még nincs telepítve)
    snap find acestream → annak ellenőrzésére, hogy van-e a program a tárokban (minden ubuntu derivatívának rendelkeznie kell vele)
    sudo snap telepítse az acestreamplayert

    Üdvözlet

    1.    Antonio Manzano dijo

      Igazad van. Most telepítettem a kubuntu 17.10-be, mivel az itt megjelenő módszer teljesen kivitelezhetetlen. Köszönöm szépen

      1.    Apu dijo

        nem érvényes az i386 architektúrára

    2.    sie9k dijo

      Ez volt az egyetlen módja a Lubuntu 16.04.4-re történő telepítésének, de nincs módom a konfigurációs fájl mentésére, és konfigurálnom kell egy paramétert, hogy a Serviio mellett működjön. Van valami ötlet a javításhoz?

  13.   José Antonio dijo

    Nagyon jó bejegyzés. Kötelezően olvasható weboldal a Linux kezdők számára.

  14.   Péter az újonc dijo

    Hogyan telepítené az AntiX 16-hoz (ez egy linux disztribúció)?

    Próbáltam, mint az Arch Linux és a derivatívák, de olyan újonc vagyok, hogy tévednem kell

  15.   Alexander dijo

    Helló, az sna csomagokkal, amelyeket a fenti kolléga kommentben kommentál, nemcsak ezeknek a terjesztéseknek, hanem sokaknak is könnyebbé vált. Az ezen csomagokkal kompatibilis terjesztések itt találhatók:
    https://snapcraft.io/

    A Debianban a következő lenne:
    -sudo apt install snapd
    -sudo snap install mag
    -sudo telepítés acestreamplayer
    Arch és származékai:
    -sudo pacman -S snapd
    -sudo systemctl engedélyezi –most snapd.socket
    -sudo telepítés acestreamplayer

    Az Arch (plasma) alkalmazásban újra kellett indítanom, hogy a telepített csomagok megjelenjenek, ha nem jelenik meg, tudod, mit kell tennem.

    Az ubuntun és a derivatívákon azt hiszem, olyan lesz, mint a partner, aki fentebb telepítette a KDE neonhoz fűzött kommentekben.

    Kíváncsi, hogy a Gnome-ban a Debian-nal elég csúnyán néz ki, és nem integrálódik jól a GTK-val, de az Arch plazmában elég jól integrálódik, a lényeg az, hogy az esztétikán kívül is látható legyen.

    1.    william dijo

      telepíti az Ön acestream-motorját?
      Nem én

      1.    Alexander dijo

        Helló, nem, nem telepíti, és nem is kell, mivel a snap csomagokkal már az összes lefedett függőség bejön, igen vagy igen működnie kell.

    2.    txuber dijo

      Szia Alejandro, hátha tudsz segíteni nekem
      [txuber @ manjaro ~] $ sudo systemctl enable –now snapd.socket
      Nem sikerült engedélyezni az egységet: A (z) \ xe2 \ x80 \ x93now.service egységfájl nem létezik.
      on manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Alexander dijo

        Helló, Manjaro az, hogy nem tiszta Arch, és a dolgok kissé megváltozhatnak, lehet, hogy már engedélyezve vannak, és nem szükséges erre, feltételezem, hogy már megpróbálta kihagyni ezt a lépést ...

  16.   Debian dijo

    Miután telepítette, mit kell tennie? Mivel az ász-lejátszó nincs telepítve, nem tudom, hogyan kell működtetni.
    Segítsen valaki, kérem?

    1.    Azta dijo

      Ha a telepített fájl az acestream-launcher, akkor amikor egy hivatkozásra kattint, az acestream megkérdezi, hogy melyik alkalmazással szeretné megnyitni a linket, ezt elmondja neki a VLC-vel, és ez fogja elvégezni az ász-lejátszó funkcióit

      1.    Debian dijo

        Szia. Először is, nagyon köszönöm a segítséget. Megjegyzem. Telepítettem az acestream snap csomagot a Debian 9-be a gnome segítségével. Amikor az arenavisión van, amire vágyom, rákattintok egy acestream linkre, és megjelenik egy ablak, amely két lehetőséget kínál nekem: az első az acestreamengine, hogy ha erre kattintok, akkor nem csinál semmit, a második pedig egy másik alkalmazást választ, akkor megadom választani, de a telepített alkalmazások nem nyílnak meg, megnyílik az otthoni mappám, így nem tudom, hogyan válasszam ki a vlc-t.

        A köszöntés.

        1.    Alexander dijo

          Az acestream-launcherrel egyáltalán nem megy, jobb, ha a Snap csomaggal együtt telepítjük, amint azt a fenti megjegyzésemben kifejtem.

  17.   Péter az újonc dijo

    Megpróbálom telepíteni a snapd csomagot, de ez nem engedi:

    sudo apt install snapd
    Csomaglista olvasása ... Kész
    Függőségfa létrehozása
    Az állapotinformációk olvasása ... Kész
    E: A snapd csomag nem található

    mit csinálok?

  18.   Alf dijo

    Köszönöm szépen, ez az egyik olyan program, amelyet a Windows-ban használtam, és szerettem volna, ha linuxban van

  19.   Oscar dijo

    Köszönöm Chemabs és Alejandro! Tökéletes az Ubuntu 17.10-hez
    sudo apt install snapd
    pattintás keresés
    sudo snap telepítse az acestreamplayert
    És ez az!
    A hihetetlen dolog az, hogy felkeresi a hivatalos weboldalt, és ők 2014-től posztot küldenek a fórumukra! És amelyben csak az Ubuntu 13.04-ig említenek!

  20.   Marco Barria dijo

    jó, ahogy az előző megjegyzésekben mondják, tökéletesen működik a snapd arch-ban:

    sudo pacman -S snapd
    sudo systemctl engedélyezze a snapd.socket fájlt
    újraindítás
    sudo snap telepítse az acestreamplayert
    újraindítás

    és kész:

  21.   mchavez dijo

    szia, és van-e olyan mód, hogy úgy telepítsük az ászfolyamot, hogy ne kelljen programozónak lennünk ... ahogy a Windows esetében is megteszik