A Brother lézernyomtatók beállítása linuxon

A legtöbb mai GNU / Linux disztribúció nagyban támogatja a legmodernebb hardvereket, azonban még mindig vannak olyan hardvergyártók, amelyek ilyen vagy olyan módon akadályozzák, hogy szeretett operációs rendszerünk kompatibilis legyen a megoldásukkal. Sokunk szerencséjére ez nem vonatkozik azokra, akik Brother márkájú nyomtatókat használunk, mivel rendelkeznek natív illesztőprogramokkal a Linux számára.

Jelenleg megvan a Brother DCP-L2550DN lézernyomtatóNem arról van szó, hogy csodálatos nyomtatóról van szó, de ha ez lehetővé teszi számomra a gyors, jó minőségű és a költség elvárásoknak megfelelő nyomtatást, az is meglehetősen egyszerű, hogy olcsó Brother TN2410 és TN2420 patronokat szerezzek be, amelyeket a berendezés használ. A Linux Mint-ben elég nagyszerűen teljesítek, bár amikor egy finomságom volt, a szokásosnál kicsit többet szenvedtem, hogy működőképessé válhassak, ezért jó elmagyarázni azt az eljárást, amelyet a hasonló felszereléssel rendelkező felhasználóknak meg kell tenniük.

Az első dolog, amit meg kell tennie azoknak a felhasználóknak, akik rendelkeznek ilyen márkájú nyomtatókkal, az a testvér linux illesztőprogramok oldal és töltse le az illesztőprogramokat az adott nyomtatómodellhez, azokat a vállalat által forgalmazott különféle hardverek (többek között CUPS, LPR, Scanner, ADS, lézernyomtatók) terjesztik. Az illesztőprogramok minden kategóriája kínál megoldást a hozzá kapcsolódó termékekre, ezért például ugyanaz az illesztőprogram működhet a Brother DCP-L2510D, Brother HL-L2310D és Brother MFC-L2710DN nyomtatóknál.

A Brother az illesztőprogram telepítési oldalán egy speciális kézikönyvet kínál felénk, amelyet a rendelkezésünkre álló disztribúciónak, a hardver modellnek és az architektúrának megfelelően használhatunk, ugyanúgy, hogy lehetőséget biztosítunk a nyomtató helyes működésének, konfigurációjának ellenőrzésére. a papír típusa vagy akár a patronok állapota.

A folyamat általában egyszerű: elmegyünk a Brother illesztőprogramok oldalára, letöltjük a hardverünkkel és a terjesztésünkkel kompatibilis illesztőprogramot, és telepítjük az alapcsomagokat a következő paranccsal:

sudo apt install brother-cups-wrapper-extrabrother-lpr-drivers-extra

Ezután újraindítjuk a számítógépünket, és telepítjük az illesztőprogramokat, mivel a Brother támogatási oldal nem jelzi, bizonyos esetekben el kell mennünk a Rendszerek / Adminisztráció / Nyomtatók szakaszba (a disztribúciónak megfelelően), és ki kell választanunk a most telepített nyomtatót, így natív módon tudjuk használni a nyomtatónkat.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

17 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Névtelen dijo

    Szia
    A manjaro gnome-ban egy testvér dcp 7065dn-t használok, a sofőrök pedig AUR-ban vannak.
    Ezeknek a nyomtatóknak általában fordulatszámon vannak az illesztőprogramjai, és az archlinux, a derivatívák általában az AUR-ban vannak, a gentoo esetében pedig egy testvérfedvény van.
    Üdvözlet.

    1.    gyík dijo

      hatékonyan

  2.   DAC dijo

    Az illesztőprogramok szabad szoftverek - nyílt forráskódúak?

    1.    gyík dijo

      Ebben az esetben a Linux illesztőprogramjai, de a források nem érhetők el (nem nyílt forráskódúak), sajnos

  3.   Barbara dijo

    Abból, amit mondanak, legalább a Brother támogatottsága nagyobb, mint Ricohé. Van egy Ricoh multifunkciós SP310spnw-m, amely kiváló, de ha Linuxban használom, nagyon sok fejfájást okoz, és csak a nyomtatási részt lehet használni. A Ricoh támogatás gyakorlatilag nem létezik, és bár állítólag rendelkezik Linux-illesztőprogramokkal, telepítésükkor hibát ad, mert ... A CUPS fut !!! Majdnem egy éve megvan, és bár azonnal küldtem egy e-mailt a Ricoh-nak, amelyben arra kértem őket, hogy találják meg a megfelelő illesztőprogramok létrehozásának módját, a mai napig még nem is nyugtázták az e-mail kézhezvételét. Szkenneléshez egy másik operációs rendszert kell használnom.

  4.   alberto dijo

    Nagyon olcsó Brother HL-2135W wifit használok, és ez évek óta kiváló Linux rendszeren. Nagyon boldog.

  5.   Puigdemont 64bit dijo

    Az 1210w telepítése az elavult pkgbuild használatával és annak módosításával történik, hiányzik néhány idézet, de jól működik.

  6.   Guille dijo

    Ne vásároljon Brother-t, vásároljon HP-t, és megmagyarázom, miért: Igen, vannak illesztőprogramjaik a GNU / Linux számára, de saját tulajdonúak. Ha X év után abbahagyják az illesztőprogramok frissítését az új kernelek számára, és leállnak a munka, akkor fekve hagynak és senki nem tudja módosítani a kódot, mert nálunk nincs. Munkahelyen a Brother DCP7065dn-t használjuk.
    Vigyázzon a HP-vel is, mert ingyenes illesztőprogram nélküli nyomtatóival is rendelkezik, például a HP LaserJet Pro CP1025nw. Csak olyanokat vásároljon, amelyeknek ingyenes illesztőprogramjaik vannak a jövőbeni zsarolás elkerülése érdekében, hogy új nyomtatót vagy új Windows vagy Mac OS licencet vásároljanak (amelyekhez mindig vannak illesztőprogramjaik).
    Semmilyen körülmények között ne vásároljon SHARP nyomtatót, nálunk van az MX 2310U másoló / nyomtató: először illesztőprogram-telepítője a linuxhoz (http://www.sharp.es/cps/rde/xchg/es/hs.xsl/-/html/centro-de-descargas.htm?p=&q=MX-2310U&lang=ES&cat=0&type=1214&type=1215&os=&emu=) több fájlátnevezési hibával rendelkezik, amelyek arra kényszerítenek minket, hogy megérintsük a szkriptet, hogy jól működjön, másodszor egy hálózatban van konfigurálva, amely minden alkalmazott számára felhasználói kódot tartalmaz, és kiderül, hogy a Linux illesztőprogramnak nincs hova tenni a kódot ( a Windows-ban igen a Jobkezelés - Felhasználói hitelesítés - Felhasználó között. Ezért nem tudom használni GNU / Linux rendszerről, és megpróbáltam olyan trükköket, mint a PPD fájl megváltoztatása (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/), és még próbálja ki az illesztőprogramot is, amely a fordított technikát használja a titkosításhoz (https://github.com/benzea/cups-sharp).
    Elsőbbségi sorrend: HP ingyenes illesztőprogrammal, HP saját illesztőprogrammal, Brother saját illesztőprogrammal, semmiképpen sem Sharp

  7.   fernan dijo

    Szia
    Bináris működésre van szükségük, például a testvér dcp 7065dn esetében, ha az illesztőprogram egy részét használom, ha az ingyenes szoftver, de egy testvér binárisra van szükségem, amely nem ingyenes.
    Üdvözlet.

  8.   Guille dijo

    Kerülje a nyomtatók vásárlását ingyenes illesztőprogramok nélkül, különben a gyártó cég kezébe kerül, hogy ha nem frissíti az illesztőprogramot a használt operációs rendszerekkel egy időben, akkor arra kényszerít, hogy vásároljon egy másik rendszert vagy más nyomtatót.
    Az ingyenes illesztőprogramokkal rendelkező HP jobb, vigyázzon, hogy vannak olyan HP-k, amelyeknek olyan saját illesztőprogramjaik vannak, mint a HP LaserJet CP 1025nw, a Brothernél mind rendelkeznek saját illesztőprogrammal, de legalábbis léteznek. Rosszabbak azok a SHARP fénymásolók-nyomtatók, amelyeknek a GNU / Linux illesztőprogramjának nincsenek olyan opciói, mint például az Ön számára kiosztott kód nyomtatásra helyezése a hálózatra, ami megakadályozza azok használatát Linuxból, ha a vállalat ellenőrzi az egyes által készített másolatokat, például a Sharp MX 2310U, amelyet még a nyomtató PPD-jének módosításával sem sikerült működtetni (https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/) vagy hátrameneti vezetővel (https://github.com/benzea/cups-sharp).

  9.   koopa dijo

    Jó napot. (Nappali, éjszakai stb.) Tudna valaki segíteni a szkenner telepítésében és konfigurálásában ezekhez a hálózati nyomtatókhoz? vagy mondd meg, hol találok előre megemésztett információkat. Ahol dolgozom, több Brother multifunkciós modellt használnak, és az illesztőprogramok telepítése után a nyomtató konfigurálása egyszerű, de néha a rendszer (általában a zorin os 9 lite) automatikusan észlel néhány szkennert a hálózaton, de néha nem. Szeretném, ha valaki megmondaná, hogyan kell manuálisan hozzáadni azt a szkennert (hogyan kell felismerni a többfunkciós szkennert egy bizonyos IP-vel). Arra kerestem a legtöbbet, hogy az elért eredmény az, hogy egy szkenner neve az ip-vel együtt megjelenik az egyszerű szkennelési listában, de semmi nincs beolvasva. Ugyanez történik velem a samsung multifunkciókkal is, de ezek általában gyakrabban jelennek meg a simplescan listában, mint a testvérek. Velem fordul elő, hogy egy számítógép felismeri a szkennert, a mellette lévő pedig nem; lévén, hogy ugyanabban a hálózatban vannak.

  10.   Nasher_87 (ARG) dijo

    Egy kérdés, butaság, mert már megtudtam, de hát, felteszem, tudod-e, hogy a Lexmark nyomtatók (Z11 LPT és X75 all-in-one) megfelelően működnek-e Linux alatt? abból, amit kerestem, egyáltalán nincs semmi, az Ubuntu 9.10-ben a Z11 működött, egy régi kernelt betéve fog működni?
    Üdvözlet emberek

    PS: sértegethetnek, megérdemlem 😉

    1.    Guille dijo

      Próbálkozzon ezzel: telepítse az Ubuntu 9.10 programot a virtuális dobozba, és próbáljon onnan nyomtatni a nyomtatójára. Ha működött, megpróbálhat megosztani a hálózaton az adott linuxtól a linuxig, hogy nyomtasson a tiédből, vagy nyomtasson a tieddel pdf-ben, és a pdf-eket mindkét rendszer között megosztott mappába helyezze, hogy kinyomtathassa az Ubuntu 9.10-ből.
      Ez a probléma a saját gyártmányú illesztőprogramokkal, ugyanez történik a Windows rendszerben is, 15 évvel ezelőtt vásárolt valamit Windows XP-vel, és nincs illesztőprogram a Win7 vagy 10-hez.
      Soha ne vásároljon semmit saját sofőrökkel, ha van valami a versenyben az ingyenes sofőrökkel, válasszon jól.

  11.   Névtelen dijo

    Köszönöm az információt, szeretném, ha később elkészítené egy oktatóanyagot arról, hogyan lehet a testvér nyomtatót wifi-n keresztül csatlakoztatni ... az én esetemben ez az MFC9330CDW. Előre is köszönöm

  12.   Mr. Paquito dijo

    Van egy Brother HL-L2340DW készülékem, és Wifi-n keresztül csatlakozom hozzá. A nyomtató USB-vel történő csatlakoztatása nem okozott problémát, de Wifi-vel nem működött.

    A Brother legalább az Ubuntu számára kínál egy, a Driver Install Tool nevű szoftvert, amely feltételezi, hogy a felhasználó egyedül (vagy csaknem valaminek kell tennie) a szükséges illesztőprogramokat. A probléma az, hogy tudnia kell, hogyan kell csinálni. Esetemben, miután kicsit körbejártam a Google-t, láttam, hogy a testvér itt elmagyarázza neked:

    http://support.brother.com/g/b/downloadhowtobranchprint.aspx?c=es&dlid=dlf006893_000&flang=4&lang=es&os=127&prod=dcpj315w_eu_as&type3=625&printable=true

    A probléma az, hogy tudjuk, mi a fenét kell tenni az URI-be ... Tehát, folytatva a keresést, a cikkben szereplő jose1080i megjegyzésében találtam a választ:

    https://www.pedrocarrasco.org/como-configurar-una-impresora-wifi-en-linux/

    Nem lehet jobban megmagyarázni.

    Üdvözlet.

  13.   Wifizmus dijo

    Nem működik minden Brother modellen, igaz? Van egy fekete-fehér lézerem, és nincs rá mód

  14.   Enrique Gallegos dijo

    Linux Mint 19 Cinnamon 64 bitet használtam, megvettem a Brother HL-1110 kompakt monokróm lézernyomtatót, és miután a szívemet felmelegítettem (USB-n keresztül megy) Wifi helyett, az adminisztrációban megjelenik, sőt a dokumentumokat is mozgatja, de üresen jönnek amire szükségem van a "windols" -ra a nyomatok készítéséhez, ahol jól megy.