Basic mmemme na pseint (akụkụ 3)

Nke a bụ ịga n'ihu nkuzi Basic mmemme na pseint (akụkụ 2), oge a aga m akọwa ihe dị mkpa maka mmemme.

Ọrụ

Ọrụ ahụ bụ usoro nke etinyere ma gbanwee ma ọ bụ gbanwee ya, na-ezo aka na ya site na njirimara ya nke anyị nwere ike iji nweta ebe nchekwa ya.

syntax nke ọrụ a bụ:

[variable]<- [expresion];
[variable]=[expresion];

Ebe [agbanwe agbanwe] bu ihe agbanwe agbanwe nke na-enweta uru inyocha [okwu]. Ha abụọ bara uru n'ihi ya, ọ baghị uru nke eji (ọ bụrụ na ha ahazi PSeInt n'ụzọ ziri ezi), mana n'echiche m, m mepụtara nke mbụ dị ka nke ziri ezi.

Ọ bụrụ na [agbanwe agbanwe] adịghị tupu ọrụ ahụ, e kere [agbanwe], ọ bụrụ na ọ dị adị, uru gara aga na-emebi ma mekwaa nke ọhụrụ n'ọnọdụ ya. N'ihi nke a, a na-ahụta nkewa dị ka ọrụ na-ebibi ihe.

AGMAG.

Ọgụgụ bụ usoro a na-arịọ data ma ọ bụ data n'aka onye ọrụ iji chekwaa data ahụ na mgbanwe.

ya syntax bụ:

Leer variable_1,variable_2,...,variable_n;

ebe [variable_ {1,2, n}] bụ ndị na-agbanwe agbanwe ma ọ bụ ndị na-agbanwe agbanwe na-enweta uru nke onye ọrụ nyere, ọ bụrụ na a rịọ ihe karịrị otu agbanwe agbanwe, ọ ga-ebu ụzọ jụọ nke mbụ, mesịa nke abụọ wee gabazie ruo mgbe natara ụkpụrụ niile.

Nke a bụkwa ọrụ mbibi.

AKWRKWỌ

Ide ederede bụ usoro nke ederede ederede na / ma ọ bụ otu ma ọ bụ karịa mgbanwe dị na ihuenyo

na syntax ahụ bụ:

Escribir expresion_1,expresion_2,...,expresion_n;

ebe [expersion_ {1,2, n}] bu udiri agwa na / ma obu mgbanwe ndi a ga-egosipụta.

Ide ihe na mgbakwunye ịnata data a ga-etinye na ihuenyo ahụ na-enwetakwa ntuziaka "Na-enweghị awụlikwa elu" ma ọ bụ "Na-agbadaghị ala" nke na-ezere nkwụsị elu ahụ.

Ide ederede anaghị etinye oghere n'etiti arụmụka ahụ, ya bụ, ọ bụrụ na etinye ya:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

na nke a ọ ga - egosi «olamundo» ebe ọ bụ na etiti «a» na «b» enweghị agwa agwa na egosi oghere dị n’etiti na b, nke mere na egosiri ya n’ụzọ ziri ezi edere ya otu a:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

na nke a tinye »» nke bu agwa agwa nke nwere oghere nke di n'etiti “ife” na «uwa» ma o gha egosi “ife uwa” ya na mbara.

Ọ B THER THE NA

Nke a bụ nkwupụta nke na-enyocha ọnọdụ enyere wee chọpụta eziokwu na / ma ọ bụ ụgha nke ọnọdụ a kwuru, ya bụ, ọ bụrụ na emezuru ọnọdụ ahụ ma ọ bụ na ọ zaghị.

Nkọwa ya bụ:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Nkebiahịrị nke ọzọ abụghị iwu, n'okwu a ọ bụrụ na ọnọdụ a bụ ụgha leghara ntuziaka ndị ahụ anya ma gaa n'ihu dị ka a ga - asị na ahịrịokwu ahụ adịghị, na nke a ọ ga - adịgide:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Ma etinyebere akụkụ nke “Ọdịda” ahụ ma ọ bụ na ọ dabere na mkpa mmemme ahụ.

D AC KA

Ahịrịokwu dịka ọ na-enyocha mgbanwe ọnụọgụ ọnụọgụ nke na-enye ihe karịrị nhọrọ 2 dị ka nhọrọ, nke a dị iche na "Ọ bụrụ-Mgbe ahụ" ebe ọ bụ na onye bu ụzọ nwere ike ịnye naanị nhọrọ 2.

The syntax bụ:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Dị ka ị pụrụ ịhụ mgbe «number1» e nwere a «:» na mgbe na ntuziaka ka rụrụ na-etinye na ikpe nke “ọnụọgụ agbanwe = nọmba1», na ihe atụ nke abụọ ọ bụ «nọmba 2, nọmba3» nke a pụtara na ọ bụrụ na «ọnụọgụ ọnụọgụ = nọmba2 ma ọ bụ nọmba3" mgbe ahụ "ntuziaka" ka a ga - egbu, nke a bara uru mgbe ohere 2 ga - eme otu ntuziaka.

E nwekwara nkebi ahịrịokwu ahụ "Anotherzọ ọzọ" a na-egbu ma ọ bụrụ na ọnweghị nke ọ bụla nwere ike mezuo.

MGBE

Ọ bụ ọrụ a na-eme ugboro ugboro na-ebu ụzọ enyocha ọnọdụ ma ọ bụrụ na ọ mezuru ya, ọ ga-eme usoro ntuziaka mgbe ahụ ọ ga-enyocha ọnọdụ ahụ ọzọ ma ọ bụrụ na ọ bụ eziokwu na ọ ga-eme otu ntuziaka ahụ ọzọ wee gaa n'ihu otu a ruo mgbe ọnọdụ a bụ ụgha.

ọ bụrụ na ọnọdụ ahụ bụ ụgha site na mmalite a gaghị egbu ya ma ọ bụrụ na ọ bụ eziokwu mgbe niile ka a ga-etinye ya na akaghị aka, iji zere nke ikpeazụ na ntuziaka ahụ ga-enwerịrị ihe na oge ụfọdụ ghagidere ọnọdụ ahụ ka ọ bụrụ nwee ike ịkwụsị akaghị.

ya syntax bụ:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

Kpegharịa-rue mgbe

Nke a bụ ọrụ dị ka nke gara aga, mana n'adịghị ka nke gara aga, nke a na-enyocha ọnọdụ ahụ na njedebe, ya bụ, a ga-egbu iwu ahụ opekata mpe oge 1, kwa karịa imezu ntuziaka mgbe ọ bụ eziokwu, ọ na-eme ya Ọ bụrụ na ọnọdụ ahụ ezuteghi, mana ọ bụrụ na ịchọrọ ka emee ya ka ọnọdụ ahụ zutere, jiri "oge" kama "rue".

ya syntax bụ:

Repetir
[Instrucciones] hasta que [condicion]

IHE

Nkwupụta a na-eme ntuziaka na-achọpụta ọnụọgụ ugboro maka mgbanwe, n'adịghị ka ndị gara aga, okirikiri a na-agbanwe uru nke agbanwe agbanwe na ajụjụ n'onwe ya, yana inwe syntax dị ike.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"Ngbanwe" bụ ihe ngbanwe nke na-enweta "uru mbụ" wee mezuo ntuziaka wee gbakwunye "agbanwe" tinyere "nzọụkwụ" wee mezue ntuziaka ahụ ruo mgbe "mgbanwe" na "nhata" uru ikpeazụ

Ọ bụrụ na ewepụrụ "na [nzọụkwụ]" mgbe ahụ na ndabara ọ ga-ama na "nzọ ụkwụ" na 1, ọ bụrụ na akọwapụtaghị [nzọụkwụ] na "mbido mbụ" karịrị "uru ikpeazụ" ọ ga-agafe na ya agbara iji, ya bụ, "Nzọụkwụ" bụ -1

MGBE / Ọrụ

Eriri ma ọ bụ ọrụ bụ mmemme n'ime ibe ya na nke a subprogram na-enweta otu ma ọ bụ karịa ụkpụrụ, na-arụ ọrụ ma weghachite ọzọ. Nkọwa ya bụ

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

ebe "ngbanwe agbanwe" bu ihe ngbanwe nke nwere uru eweghachiri site na "aha oru" oru nke natara nkeji "arg_1, arg_2, arg_n" iji mezuo nke a

OTU

Ndị a bụ ọrụ ndị na-akwado ndị ọzọ ma enweghị syntax dị mgbagwoju anya ebe ha bụ naanị ọrụ mmeju.

Ihuenyo doro anya

Ọrụ a na-ekpochapụ ihuenyo nke ihe ọ bụla na onye ntụgharị okwu

Chere Igodo

Ọrụ a na-eche onye ọrụ iji pịa igodo iji nọgide na mmemme ahụ

Chere x {Nke abụọ, Milliseconds}

ọrụ a na-echere oge na sekọnd ma ọ bụ milliseconds iji gaa n'ihu na mmemme

PS: gbaghara maka igbu oge mana ejiri m ihe ndị ọzọ n'aka nke na enweghị m ike ide


Ọdịnaya nke isiokwu agbaso ụkpụrụ anyị nke ụkpụrụ nduzi. Kpesa mmejọ pịa ebe a.

Ihe 10 kwuru, hapụ nke gị

Hapu okwu gi

Adreesị email gị agaghị bipụtara. Chọrọ ubi na-akara na *

*

*

  1. Rụ ọrụ maka data: Miguel Ángel Gatón
  2. Nzube nke data: Nchịkwa SPAM, njikwa okwu.
  3. Ikike: Nkwenye gị
  4. Nkwurịta okwu nke data: Agaghị agwa ndị ọzọ data ahụ ma ọ bụghị site na iwu.
  5. Nchekwa data: Ebe nchekwa data nke Occentus Networks (EU) kwadoro
  6. Ikike: Oge obula inwere ike igbachi, weghachite ma hichapụ ihe omuma gi.

  1.   Guille dijo

    Adịghị arụ ọrụ ijide igodo na-enweghị ịkwụsị igbu ahụ? Maka ime ihe na agagharị nke na-adọrọ mmasị ụmụaka 9 afọ, ọ bụ ezie na egwuregwu hangman nwekwara ike ịtọ ụtọ mmemme.

    Hazie ihe_digo
    a <-1;
    mpụta <-30;
    gbadaa <-5;
    Mgbe a = 1 Na-eme
    Ihuenyo doro anya;
    c <-1;
    akara <- "";
    Tinyegharịa
    akara <-line + "";
    c <-g + 1;
    Ruo mgbe c = mpụta
    akara <-line + "X";
    c <-1;
    Tinyegharịa
    Ide "";
    c <-g + 1;
    Ruo mgbe = c = ala-1
    Dee akara;
    Tinyegharịa
    Ide "";
    c 2 Mgbe ahụ
    ala <-down-1;
    Kwụsị ee
    "s":
    Ọ bụrụ na ọ dị n'okpuru <15 Mgbe ahụ
    ala 2 Mgbe ah
    mpụta <-lateral-1;
    Kwụsị ee
    "d":
    Ọ bụrụ na mpụta <50 Mgbe ahụ
    mpụta <-lateral + 1;
    Kwụsị ee
    "0":
    a <-2;
    Ọgwụgwụ sekọnd
    Mechie Mgbe
    Ọgwụgwụ Usoro

  2.   Guille dijo

    Adala ma ọ bụrụ na ị gbagoo, akara mgbanwe kacha mma 23 na 28
    -23 Ruo mgbe = c = 15
    +23 Ruo mgbe = c = 18
    y
    -28 Ọ bụrụ ala> 2 Mgbe ahụ
    + 28 Ọ bụrụ ala> 3 Mgbe ahụ

    1.    xnmm dijo

      Daalụ maka onyinye ma ọ nwere nsogbu ụfọdụ dịka ị mepee otu ahịrịokwu n'ime ibe ya mana ọ ga-akwụsị n'ime ahịrịokwu ahụ ebe ọ malitere, m na-ekwu, enweghị ike itinye ya

      Hazie ihe
      a <- 0;
      gụa;
      ọ bụrụ na a adịghị ka 25 mgbe ahụ
      ebe a na ahaghị 0 na-eme
      gụa;
      Kwụsị ee
      agwụ mgbe

      ka ị na-ahụ akaghị mgbe ị na-amalite n'ime nkwupụta "ọ bụrụ mgbe ahụ" mana na-akwụsị n'èzí ya, ihe dị ka nke a agaghị ekwe omume.

      Aka m ji onyinye a kpọrọ ihe
      Ọgwụgwụ usoro

      1.    Guille dijo

        Daalụ, mana echere m na ọ bụ nsogbu karịa itinye koodu ahụ ebe a, na amaghị m otu esi etinye ya na ụdị koodu ọ na-apụta n'enweghị mkparịta ụka.

        Usoro ihe omume ahụ na-arụ ọrụ nke ọma. Mgbanwe ahụ "a" M na-eji wepu aka akaghị mgbe onye ọrụ pịnyere efu. I nwere ike itinye ụzọ ọpụpụ () ma ọ bụ ezumike; na ọnọdụ ọ na-ele ya anya na m na-echekwa agbanwe. Ha bụ nhọrọ.

        Ekele.

      2.    Guille dijo

        Aga m anwa ịgbanwe taabụ maka oghere na aha mmado por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille dijo

        Nke ahụ juputara na njehie ibubata na koodu m, Aga m anwale ọzọ na taabụ:
        Nke a ga-abụ faịlụ algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille dijo

        Na-akpali, ndị comment na koodu kpọọ na-eri, ehichapụ, ihe ọ bụla na-aga n'etiti, ihe atụ n'etiti ahịrị
        Tinyegharịa
        Ide "";
        c
        mgbe c enwere a
        ma ọ gara n'ihu na 3 Mgbe ahụ
        gbada
        N'ozuzu, nke a abụghị ihe a pụrụ ịdabere na ya dịka koodu ya.

  3.   Guille dijo

    M na-agbanwe akara si na-ekenye ka = ịhụ otú.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille dijo

      Ọ na-eri otu akụkụ nke koodu ahụ, akara koodu ahụ adaghị, ọ kwesịrị ịhapụ ederede dịka ọ dị.

      1.    xnmm dijo

        Ndewo nụ maka na ị hụghị ị zara na mbụ mana ọfụma
        ebe ọ bụ na ị nweghị ike ibipụta koodu nke ọma n'ihi na ị naghị ezitere m ya site na mail ka ị ghara inye ọtụtụ ntụgharị n'okwu ahụ.