Instalar corrector ortográfico y gramatical en LibreOffice/OpenOffice

33
43707

Corrector ortográfico

En caso de que hayas instalado OpenOffice/Libreoffice y éste no venga con el corrector ortográfico (diccionario + sinónimos) o el separador silábico correspondiente al idioma de tu preferencia simplemente hay que instalarlo a mano. Para ello, hay dos caminos: usar uno de los diccionarios que ya vienen incluidos en los repositorios de la mayor parte de las distribuciones (como myspell, hunspell, etc.) o, en su defecto, buscar un diccionario en el sitio web de Extensiones de OpenOffice/LibreOffice e instalarlo, como si de una extensión se tratara.

a) Instalar un diccionario MySpell


En Ubuntu esto es súper fácil. Por ejemplo, para instalar el paquete Myspell correspondiente al diccionario español tan sólo hay que abrir un terminal e ingresar el siguiente comando:

sudo apt-get install myspell-es

b) Instalar un diccionario como extensión

1.- Buscar y descargar la extensión correspondiente al diccionario de tu preferencia.

2.- Ir a Herramientas > Administración de extensiones > Añadir y seleccionar el archivo OXT descargado en el paso anterior.

Corrector gramatical

LanguageTool es probablemente el mejor corrector gramatical y de estilo para OpenOffice/LibreOffice. Incluye soporte para inglés, español, francés, alemán, polaco, holandés, rumano y muchos otros idiomas. Hace un buen trabajo a la hora de detectar errores que un típico corrector ortográfico pasaría por alto, como por ejemplo repetición de palabras, concordancia de género y número, etc.

LanguageTool no incluye un corrector ortográfico.

Instalación

1.- Descargar la extensión LanguageTool (archivo OXT)

2.- Ir a Herramientas > Administración de extensiones > Añadir y seleccionar el archivo OXT descargado en el paso anterior.

LanguageTool OpenOffice/LibreOffice

Esta extensión requiere Java para funcionar

3.- Asegurarse de tener instalado el paquete de Java de OpenOffice/LibreOffice.

En el caso de Ubuntu + LibreOffice, simplemente hay que instalar el paquete libreoffice-java-common

sudo apt-get install libreoffice-java-common

LanguageTool OpenOffice/LibreOffice

Para más información sobre LanguageTool, sugiero visitar la sitio web oficial del proyecto.

33 COMENTARIOS

  1. LanguageTool me gusta mucho, pero le hace falta varias reglas más en el idioma español. Si alguien sabe dónde encontrar más reglas, sería muy bueno que lo dijera por esta vía. De lo contrario, deberíamos crear, no sé, un hilo en el foro donde todos podamos crear más reglas y mejorarlo.

  2. excelente post. Hace 2 semanas estuve editando un archivo de texto en LibreOffice y me rompí la cabeza viendo de dónde se configuraba el diccionario 😀

  3. gracias a este articulo pude resolver mi problema con la correccion otrografica, muy bueno, con estos pequeños articulos se resuelven un sin fin de problemas que se le presentan a novatos como yo. gracias…

  4. Gracias, venia dejando este asunto para el final, pero me llego la hora. Encima me entero que esta para Argentina puntualmente. Saludos 😀

  5. Estuve tratando de instalar LanguageTool en Debian 7.7 con Libreoffice 3.5 y luego de empezar a instalar la extension me da un error, se abre un cuadro de dialogo emergente que tiene un cirulo de prohibido (circulo rojo con raya banca en el medio) y me indica

    “Extension manager
    (com.sun.star.uno.RuntimeException)…. continua hasta abajo ocupando toda la pantalla”

    Tengo todo el Sistema Operativo en Ingles, solo quiero instalar el diccionario y el corrector de estilo en español…

    • Con tener el myspell y el diccionario basta para que tengas la corrección ortográfica activa, porque realice los pasos y funciono todo. Pero presento el mismo problema que tu al intentar añadir la extensión de LenguageTool a libreoffice y he estado buscando y no encuentro mucha información solo que debe estar activada la casilla de opciones de java (cosa que ya tengo)

    • En lo personal tuve muchos problemas para encontrar la extensión del diccionario en español porque en la página de libreoffice las extensiones de los diccionarios en español no tienen link de descarga, y la que encontre lo tenia pero era un zip y el formato para las extensiones debe ser OTX para hacerlas funcionar. Me sirvio fue una extensión de OpenOffice y pude instalar el diccionario, te dejo el link >> http://extensions.openoffice.org/project/es_ANY-dicts solo descargas y al finalizar le das doble click sobre el archivo y te saldra un aviso donde confirmaras si quieres instalar como extensión en libreoffice o no. También puedes hacerlo por la ruta que indican aquí en el post Herramientas > Administración de extensiones > Añadir y seleccionar el archivo OXT que en este caso seria el diccionario. Espero te sirva como a mi

  6. Tengo problemas con la extensión LanguageTool, este es el error que me presenta cada vez que quiero activar dicha extensión.
    [jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0
    java stack trace:
    java.lang.UnsupportedClassVersionError: org/languagetool/openoffice/Main : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:316)
    at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:615)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
    at com.sun.star.comp.loader.RegistrationClassFinder.find(RegistrationClassFinder.java:52)
    at com.sun.star.comp.loader.JavaLoader.writeRegistryInfo(JavaLoader.java:399)
    ¿Alguna idea para solucionar este problema? tengo activada la casilla que se encuentra en opciones de java y el entorno de ejecución es Sun Microsystem 1.6,0_33

  7. Soy pensionista y tengo un PC portátil con el cual me entretengo bastante ya que

    mi trabajo ha sido de administrador.

    Tengo instalado OpenOffice 4.1, pero tiene muy poco diccionario y casi ningún corrector ortográfico. Por lo cual me gustaría instalar uno, aunque no lo necesito
    materialmente.

    También me gustaría ser DONANTE aunque fuese con poquito..

    Gracias y saludos

  8. Necesito conseguir para instalar,un dicc. ortográfico gramatical. Pues tengo instalado
    OpenOffice.org 4.1l

    Les agradeceré me ayuden a conseguirlo.

    También puedo pensar en alguna DONACIÓN, aunque no sea una gran cosa ,pues
    soy pension ista y como pueden conprender, no me sobra el dinero, pero tengo
    voluntad.

    Como les indico mi correo, pueden mandarme alguna información o detalle sobre
    esrte particular.

    Gracias y saludos. NIETO

    • Estoy entusiassmado con mi OpenOffice.org, pero el Dicc.que tiene es muy c,orrto

      por lo demás me gusta mucho lo poco que conozco de su organización, per estoy

      muy contento.

      Saludos nuevamente.

Dejar una respuesta